]> git.pld-linux.org Git - packages/systemd.git/commitdiff
- partial update to 238; target-pld.patch hostname parsing needs testing; files secti...
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 15 May 2018 12:22:58 +0000 (14:22 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 15 May 2018 12:22:58 +0000 (14:22 +0200)
systemd-glibc.patch
systemd.spec
target-pld.patch
tmpfiles-not-fatal.patch
udevadm-in-sbin.patch
uids_gids.patch

index adcf185ced4786d86023abd09df10922b5f1cea7..92772a2548ab6458bd122177384c2e11e2196f00 100644 (file)
@@ -1,360 +1,3 @@
-commit 0e50bfaefde2a01792f4e4bcad7e0d822c74835b
-Author: Yu Watanabe <watanabe.yu+github@gmail.com>
-Date:   Mon Dec 25 19:42:42 2017 +0900
-
-    meson: define _GNU_SOURCE to detect copy_file_range() (#7734)
-    
-    Follow-up for bad7a0c81f501fbbcc79af9eaa4b8254441c4a1f of git
-    repository for glibc.
-    
-    Recently glibc added `copy_file_range()`, but to use it,
-    `_GNU_SOURCE` needs to be defined. This adds the flag in
-    meson.build to detect the function by meson correctly.
-
-diff --git a/meson.build b/meson.build
-index be8e61045..f3a65b389 100644
---- a/meson.build
-+++ b/meson.build
-@@ -468,7 +468,8 @@ foreach ident : [
-         ['kcmp',              '''#include <linux/kcmp.h>'''],
-         ['keyctl',            '''#include <sys/types.h>
-                                  #include <keyutils.h>'''],
--        ['copy_file_range',   '''#include <sys/syscall.h>
-+        ['copy_file_range',   '''#define _GNU_SOURCE
-+                                 #include <sys/syscall.h>
-                                  #include <unistd.h>'''],
-         ['bpf',               '''#include <sys/syscall.h>
-                                  #include <unistd.h>'''],
-commit 85db59b794d1ca7f16ea816c916bb4472958cc1b
-Author: Lennart Poettering <lennart@poettering.net>
-Date:   Mon Dec 25 12:01:14 2017 +0100
-
-    meson: use "args" for setting _GNU_SOURCE when checking for functions
-    
-    This reworks how we set _GNU_SOURCE when checking for the availability
-    of functions:
-    
-    1. We set it for most of the functions we look for. After all we set it
-    for our entire built anyway, and it's usually how Linux-specific
-    definitions in glibc are protected these days. Given that we usually
-    have checks for such modern stuff only anyway, let's just blanket enable
-    it.
-    
-    2. Use "args" instead of "prefix" to set the macro. This is what is
-    suggested in the meson docs, hence let's do it.
-
-diff --git a/meson.build b/meson.build
-index f3a65b389..eda9e382b 100644
---- a/meson.build
-+++ b/meson.build
-@@ -431,29 +431,26 @@ foreach ident : [
-         ['memfd_create',      '''#include <sys/memfd.h>'''],
-         ['gettid',            '''#include <sys/types.h>'''],
-         ['pivot_root',        '''#include <stdlib.h>'''],     # no known header declares pivot_root
--        ['name_to_handle_at', '''#define _GNU_SOURCE
--                                 #include <sys/types.h>
-+        ['name_to_handle_at', '''#include <sys/types.h>
-                                  #include <sys/stat.h>
-                                  #include <fcntl.h>'''],
--        ['setns',             '''#define _GNU_SOURCE
--                                 #include <sched.h>'''],
-+        ['setns',             '''#include <sched.h>'''],
-         ['renameat2',         '''#include <stdio.h>'''],
-         ['kcmp',              '''#include <linux/kcmp.h>'''],
-         ['keyctl',            '''#include <sys/types.h>
-                                  #include <keyutils.h>'''],
--        ['copy_file_range',   '''#define _GNU_SOURCE
--                                 #include <sys/syscall.h>
-+        ['copy_file_range',   '''#include <sys/syscall.h>
-                                  #include <unistd.h>'''],
-         ['bpf',               '''#include <sys/syscall.h>
-                                  #include <unistd.h>'''],
-         ['explicit_bzero' ,   '''#include <string.h>'''],
- ]
--        have = cc.has_function(ident[0], prefix : ident[1])
-+        have = cc.has_function(ident[0], prefix : ident[1], args : '-D_GNU_SOURCE')
-         conf.set10('HAVE_' + ident[0].to_upper(), have)
- endforeach
--if cc.has_function('getrandom', prefix : '''#include <sys/random.h>''')
-+if cc.has_function('getrandom', prefix : '''#include <sys/random.h>''', args : '-D_GNU_SOURCE')
-         conf.set10('USE_SYS_RANDOM_H', true)
-         conf.set10('HAVE_GETRANDOM', true)
- else
-
-missing_syscall: when adding syscall replacements, use different names (
-
-#8229)
-
-In meson.build we check that functions are available using:
-    meson.get_compiler('c').has_function('foo')
-which checks the following:
-- if __stub_foo or __stub___foo are defined, return false
-- if foo is declared (a pointer to the function can be taken), return true
-- otherwise check for __builtin_memfd_create
-
-_stub is documented by glibc as
-   It defines a symbol '__stub_FUNCTION' for each function
-   in the C library which is a stub, meaning it will fail
-   every time called, usually setting errno to ENOSYS.
-
-So if __stub is defined, we know we don't want to use the glibc version, but
-this doesn't tell us if the name itself is defined or not. If it _is_ defined,
-and we define our replacement as an inline static function, we get an error:
-
-In file included from ../src/basic/missing.h:1358:0,
-                 from ../src/basic/util.h:47,
-                 from ../src/basic/calendarspec.h:29,
-                 from ../src/basic/calendarspec.c:34:
-../src/basic/missing_syscall.h:65:19: error: static declaration of 'memfd_create' follows non-static declaration
- static inline int memfd_create(const char *name, unsigned int flags) {
-                   ^~~~~~~~~~~~
-.../usr/include/bits/mman-shared.h:46:5: note: previous declaration of 'memfd_create' was here
- int memfd_create (const char *__name, unsigned int __flags) __THROW;
-     ^~~~~~~~~~~~
-
-To avoid this problem, call our inline functions different than glibc,
-and use a #define to map the official name to our replacement.
-
-Fixes #8099.
-
-v2:
-- use "missing_" as the prefix instead of "_"
-
-v3:
-- rebase and update for statx()
-
-  Unfortunately "statx" is also present in "struct statx", so the define
-  causes issues. Work around this by using a typedef.
-
-I checked that systemd compiles with current glibc
-(glibc-devel-2.26-24.fc27.x86_64) if HAVE_MEMFD_CREATE, HAVE_GETTID,
-HAVE_PIVOT_ROOT, HAVE_SETNS, HAVE_RENAMEAT2, HAVE_KCMP, HAVE_KEYCTL,
-HAVE_COPY_FILE_RANGE, HAVE_BPF, HAVE_STATX are forced to 0.
-
-Setting HAVE_NAME_TO_HANDLE_AT to 0 causes an issue, but it's not because of
-the define, but because of struct file_handle.
-
-
-backport https://github.com/systemd/systemd/commit/5187dd2c403caf92d09f3491e41f1ceb3f10491f
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-Upstream-Status: Backport [https://github.com/systemd/systemd/issues/8099]
-Index: git/src/basic/missing_syscall.h
-===================================================================
---- git.orig/src/basic/missing_syscall.h
-+++ git/src/basic/missing_syscall.h
-@@ -26,9 +26,11 @@
- #include <sys/types.h>
- #if !HAVE_PIVOT_ROOT
--static inline int pivot_root(const char *new_root, const char *put_old) {
-+static inline int missing_pivot_root(const char *new_root, const char *put_old) {
-         return syscall(SYS_pivot_root, new_root, put_old);
- }
-+
-+#  define pivot_root missing_pivot_root
- #endif
- #if !HAVE_CANONICALIZE_FILE_NAME
-@@ -68,7 +70,7 @@ static inline char *canonicalize_file_na
- #    endif
- #  endif
--static inline int memfd_create(const char *name, unsigned int flags) {
-+static inline int missing_memfd_create(const char *name, unsigned int flags) {
- #  ifdef __NR_memfd_create
-         return syscall(__NR_memfd_create, name, flags);
- #  else
-@@ -76,6 +78,8 @@ static inline int memfd_create(const cha
-         return -1;
- #  endif
- }
-+
-+#  define memfd_create missing_memfd_create
- #endif
- /* ======================================================================= */
-@@ -115,7 +119,7 @@ static inline int memfd_create(const cha
- #    endif
- #  endif
--static inline int getrandom(void *buffer, size_t count, unsigned flags) {
-+static inline int missing_getrandom(void *buffer, size_t count, unsigned flags) {
- #  ifdef __NR_getrandom
-         return syscall(__NR_getrandom, buffer, count, flags);
- #  else
-@@ -123,14 +127,18 @@ static inline int getrandom(void *buffer
-         return -1;
- #  endif
- }
-+
-+#  define getrandom missing_getrandom
- #endif
- /* ======================================================================= */
- #if !HAVE_GETTID
--static inline pid_t gettid(void) {
-+static inline pid_t missing_gettid(void) {
-         return (pid_t) syscall(SYS_gettid);
- }
-+
-+#  define gettid missing_gettid
- #endif
- /* ======================================================================= */
-@@ -158,7 +166,7 @@ struct file_handle {
-         unsigned char f_handle[0];
- };
--static inline int name_to_handle_at(int fd, const char *name, struct file_handle *handle, int *mnt_id, int flags) {
-+static inline int missing_name_to_handle_at(int fd, const char *name, struct file_handle *handle, int *mnt_id, int flags) {
- #  ifdef __NR_name_to_handle_at
-         return syscall(__NR_name_to_handle_at, fd, name, handle, mnt_id, flags);
- #  else
-@@ -166,6 +174,8 @@ static inline int name_to_handle_at(int
-         return -1;
- #  endif
- }
-+
-+#  define name_to_handle_at missing_name_to_handle_at
- #endif
- /* ======================================================================= */
-@@ -183,7 +193,7 @@ static inline int name_to_handle_at(int
- #    endif
- #  endif
--static inline int setns(int fd, int nstype) {
-+static inline int missing_setns(int fd, int nstype) {
- #  ifdef __NR_setns
-         return syscall(__NR_setns, fd, nstype);
- #  else
-@@ -191,6 +201,8 @@ static inline int setns(int fd, int nsty
-         return -1;
- #  endif
- }
-+
-+#  define setns missing_setns
- #endif
- /* ======================================================================= */
-@@ -236,7 +248,7 @@ static inline pid_t raw_getpid(void) {
- #    endif
- #  endif
--static inline int renameat2(int oldfd, const char *oldname, int newfd, const char *newname, unsigned flags) {
-+static inline int missing_renameat2(int oldfd, const char *oldname, int newfd, const char *newname, unsigned flags) {
- #  ifdef __NR_renameat2
-         return syscall(__NR_renameat2, oldfd, oldname, newfd, newname, flags);
- #  else
-@@ -244,12 +256,14 @@ static inline int renameat2(int oldfd, c
-         return -1;
- #  endif
- }
-+
-+#  define renameat2 missing_renameat2
- #endif
- /* ======================================================================= */
- #if !HAVE_KCMP
--static inline int kcmp(pid_t pid1, pid_t pid2, int type, unsigned long idx1, unsigned long idx2) {
-+static inline int missing_kcmp(pid_t pid1, pid_t pid2, int type, unsigned long idx1, unsigned long idx2) {
- #  ifdef __NR_kcmp
-         return syscall(__NR_kcmp, pid1, pid2, type, idx1, idx2);
- #  else
-@@ -257,36 +271,44 @@ static inline int kcmp(pid_t pid1, pid_t
-         return -1;
- #  endif
- }
-+
-+#  define kcmp missing_kcmp
- #endif
- /* ======================================================================= */
- #if !HAVE_KEYCTL
--static inline long keyctl(int cmd, unsigned long arg2, unsigned long arg3, unsigned long arg4,unsigned long arg5) {
-+static inline long missing_keyctl(int cmd, unsigned long arg2, unsigned long arg3, unsigned long arg4,unsigned long arg5) {
- #  ifdef __NR_keyctl
-         return syscall(__NR_keyctl, cmd, arg2, arg3, arg4, arg5);
- #  else
-         errno = ENOSYS;
-         return -1;
- #  endif
-+
-+#  define keyctl missing_keyctl
- }
--static inline key_serial_t add_key(const char *type, const char *description, const void *payload, size_t plen, key_serial_t ringid) {
-+static inline key_serial_t missing_add_key(const char *type, const char *description, const void *payload, size_t plen, key_serial_t ringid) {
- #  ifdef __NR_add_key
-         return syscall(__NR_add_key, type, description, payload, plen, ringid);
- #  else
-         errno = ENOSYS;
-         return -1;
- #  endif
-+
-+#  define add_key missing_add_key
- }
--static inline key_serial_t request_key(const char *type, const char *description, const char * callout_info, key_serial_t destringid) {
-+static inline key_serial_t missing_request_key(const char *type, const char *description, const char * callout_info, key_serial_t destringid) {
- #  ifdef __NR_request_key
-         return syscall(__NR_request_key, type, description, callout_info, destringid);
- #  else
-         errno = ENOSYS;
-         return -1;
- #  endif
-+
-+#  define request_key missing_request_key
- }
- #endif
-@@ -313,10 +335,10 @@ static inline key_serial_t request_key(c
- #    endif
- #  endif
--static inline ssize_t copy_file_range(int fd_in, loff_t *off_in,
--                                      int fd_out, loff_t *off_out,
--                                      size_t len,
--                                      unsigned int flags) {
-+static inline ssize_t missing_copy_file_range(int fd_in, loff_t *off_in,
-+                                              int fd_out, loff_t *off_out,
-+                                              size_t len,
-+                                              unsigned int flags) {
- #  ifdef __NR_copy_file_range
-         return syscall(__NR_copy_file_range, fd_in, off_in, fd_out, off_out, len, flags);
- #  else
-@@ -324,6 +346,8 @@ static inline ssize_t copy_file_range(in
-         return -1;
- #  endif
- }
-+
-+#  define copy_file_range missing_copy_file_range
- #endif
- /* ======================================================================= */
-@@ -351,7 +375,7 @@ static inline ssize_t copy_file_range(in
- union bpf_attr;
--static inline int bpf(int cmd, union bpf_attr *attr, size_t size) {
-+static inline int missing_bpf(int cmd, union bpf_attr *attr, size_t size) {
- #ifdef __NR_bpf
-         return (int) syscall(__NR_bpf, cmd, attr, size);
- #else
-@@ -360,6 +384,7 @@ static inline int bpf(int cmd, union bpf
- #endif
- }
-+#  define bpf missing_bpf
- #endif
- /* ======================================================================= */
 commit 848e863acc51ecfb0f3955c498874588201d9130
 Author: Franck Bui <fbui@suse.com>
 Date:   Thu Mar 15 06:23:46 2018 +0100
index 63ed48459b39daafcc293fa2b8777e2aa76cc9db..ea7785501acf2783e2c6eb043b9caab7d68f5a40 100644 (file)
@@ -25,13 +25,13 @@ Summary:    A System and Service Manager
 Summary(pl.UTF-8):     systemd - zarządca systemu i usług dla Linuksa
 Name:          systemd
 # Verify ChangeLog and NEWS when updating (since there are incompatible/breaking changes very often)
-Version:       235
-Release:       7
+Version:       238
+Release:       0.1
 Epoch:         1
 License:       GPL v2+ (udev), LGPL v2.1+ (the rest)
 Group:         Base
 Source0:       https://github.com/systemd/systemd/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: d53a925f1ca5b2e124de0a8aa65d0db2
+# Source0-md5: 76db8004647283b779234364cd637d3c
 Source1:       %{name}-sysv-convert
 Source2:       %{name}_booted.c
 Source3:       network.service
@@ -655,6 +655,8 @@ cp -p %{SOURCE2} src/systemd_booted.c
        -Dlz4=true \
        -Dmicrohttpd=%{__true_false microhttpd} \
        -Dmount-path=/bin/mount \
+       -Dnobody-user="nobody" \
+       -Dnobody-group="nogroup" \
        -Dntp-servers='0.pool.ntp.org 1.pool.ntp.org 2.pool.ntp.org 3.pool.ntp.org' \
        -Dpam=%{__true_false pam} \
        -Dqrencode=%{__true_false qrencode} \
@@ -667,11 +669,13 @@ cp -p %{SOURCE2} src/systemd_booted.c
        -Drootsbindir=%{_rootsbindir} \
        -Dselinux=%{__true_false selinux} \
        -Dsetfont-path=/bin/setfont \
+       -Dsplit-bin=true \
        -Dsplit-usr=true \
        -Dsulogin-path=/sbin/sulogin \
        -Dsysvinit-path=/etc/rc.d/init.d \
        -Dsysvrcnd-path=/etc/rc.d \
-       -Dumount-path=/bin/umount
+       -Dumount-path=/bin/umount \
+       -Dusers-gid=1000 \
 
 %meson_build -C build
 
@@ -737,17 +741,6 @@ echo ".so man8/udevd.8" >$RPM_BUILD_ROOT%{_mandir}/man8/systemd-udevd.8
 # Main binary has been moved, but we don't want to break existing installs
 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
 
-# Create SysV compatibility symlinks. systemctl/systemd are smart
-# enough to detect the way they were called
-install -d $RPM_BUILD_ROOT/sbin
-ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
-ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
-ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
-ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
-ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
-ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
-ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
-
 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
 
 # disable redundant SYSV services
@@ -1062,7 +1055,7 @@ fi
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc DISTRO_PORTING NEWS README TODO
+%doc doc/DISTRO_PORTING NEWS README TODO
 %{_datadir}/dbus-1/system.d/org.freedesktop.hostname1.conf
 %{_datadir}/dbus-1/system.d/org.freedesktop.import1.conf
 %{_datadir}/dbus-1/system.d/org.freedesktop.locale1.conf
@@ -1594,7 +1587,7 @@ fi
 %{systemdunitdir}/systemd-volatile-root.service
 %{systemdunitdir}/user@.service
 %{systemdunitdir}/machine.slice
-%{systemdunitdir}/system.slice
+#%{systemdunitdir}/system.slice
 %{systemdunitdir}/user.slice
 %exclude %{systemdunitdir}/rc-inetd.service
 %{systemdunitdir}/syslog.socket
@@ -1641,7 +1634,6 @@ fi
 %{systemdunitdir}/remote-fs-pre.target
 %{systemdunitdir}/remote-fs.target
 %if %{with cryptsetup}
-%{systemdunitdir}/remote-cryptsetup-pre.target
 %{systemdunitdir}/remote-cryptsetup.target
 %endif
 %{systemdunitdir}/rescue.target
index 784c3409d7535b8f716bb75da4ba8bf578deba32..e38fa29b5d2f52131e113a54f1d314a0380dfd46 100644 (file)
 ; rest of target-pld.patch logic in systemd.spec
-diff -dur -x '*~' -x '*.orig' systemd-208.orig/src/core/hostname-setup.c systemd-208/src/core/hostname-setup.c
---- systemd-208.orig/src/core/hostname-setup.c 2013-08-13 22:02:46.000000000 +0200
-+++ systemd-208/src/core/hostname-setup.c      2014-01-09 15:15:41.000000000 +0100
-@@ -23,6 +23,7 @@
+--- a/src/basic/hostname-util.h~       2018-03-05 23:16:37.000000000 +0100
++++ b/src/basic/hostname-util.h        2018-05-15 13:46:17.924678801 +0200
+@@ -42,5 +42,6 @@ int sethostname_idempotent(const char *s
  
- #include "alloc-util.h"
- #include "fileio.h"
-+#include "fd-util.h"
- #include "hostname-setup.h"
- #include "hostname-util.h"
- #include "log.h"
-@@ -53,13 +53,84 @@
-         return 0;
+ int shorten_overlong(const char *s, char **ret);
++int read_etc_hostname_distro(const char *path, char **ret);
+ int read_etc_hostname_stream(FILE *f, char **ret);
+ int read_etc_hostname(const char *path, char **ret);
+--- systemd-238/src/basic/hostname-util.c~     2018-03-05 23:16:37.000000000 +0100
++++ systemd-238/src/basic/hostname-util.c      2018-05-15 13:21:08.392017315 +0200
+@@ -290,13 +290,33 @@ int read_etc_hostname_stream(FILE *f, ch
+         }
  }
  
-+static int read_distro_hostname(char **hn) {
++int read_etc_hostname_distro(const char *path, char **ret) {
 +        int r;
-+        _cleanup_fclose_ FILE *f = NULL;
-+
-+        assert(hn);
-+
-+        f = fopen("/etc/sysconfig/network", "re");
-+        if (!f)
-+                return -errno;
-+
-+        for (;;) {
-+                char line[LINE_MAX];
-+                char *s, *k;
-+
-+                if (!fgets(line, sizeof(line), f)) {
-+                        if (feof(f))
-+                                break;
-+
-+                        r = -errno;
-+                        goto finish;
-+                }
-+
-+                s = strstrip(line);
-+
-+                if (!startswith_no_case(s, "HOSTNAME="))
-+                        continue;
-+
-+                k = strdup(s+9);
-+                if (!k) {
-+                        r = -ENOMEM;
-+                        goto finish;
-+                }
-+
-+                hostname_cleanup(k);
-+
-+                if (isempty(k)) {
-+                        free(k);
-+                        r = -ENOENT;
-+                        goto finish;
-+                }
-+
-+                *hn = k;
-+                r = 0;
-+                goto finish;
-+        }
-+
-+        r = -ENOENT;
-+
-+finish:
-+        return r;
-+}
-+
-+static int read_hostname(char **hn) {
-+        int r;
-+
-+        assert(hn);
-+
-+        /* First, try to load the generic hostname configuration file,
-+         * that we support on all distributions */
-+
-+        r = read_hostname_config("/etc/hostname", hn);
-+        if (r < 0) {
-+                if (r == -ENOENT)
-+                        return read_distro_hostname(hn);
-+
++        char *p;
++        r = parse_env_file("/etc/sysconfig/network", NEWLINE, "HOSTNAME", &p, NULL);
++        if (r < 0)
 +                return r;
-+        }
-+
-+        return 0;
++        if (r == 0) /* EOF without any hostname? the file is empty, let's treat that exactly like no file at all: ENOENT */
++                return -ENOENT;
++        hostname_cleanup(p);
++         if (!hostname_is_valid(p, true))
++                 return -EBADMSG;
++         *ret = p;
++         return 0;
 +}
 +
- int hostname_setup(void) {
-         _cleanup_free_ char *b = NULL;
-         bool enoent = false;
-         const char *hn;
-         int r;
+ int read_etc_hostname(const char *path, char **ret) {
+         _cleanup_fclose_ FILE *f = NULL;
+         assert(ret);
+-        if (!path)
++        if (!path) {
++                int r;
+                 path = "/etc/hostname";
++                r = read_etc_hostname_distro(path, ret);
++                if (r > 0)
++                        return r;
++        }
  
--        r = read_hostname_config("/etc/hostname", &b);
-+        r = read_hostname(&b);
-         if (r < 0) {
-                 if (r == -ENOENT)
-                         enoent = true;
+         f = fopen(path, "re");
+         if (!f)
 diff -dur -x '*~' -x '*.orig' systemd-208.orig/src/core/locale-setup.c systemd-208/src/core/locale-setup.c
 --- systemd-208.orig/src/core/locale-setup.c   2013-10-01 00:17:21.000000000 +0200
 +++ systemd-208/src/core/locale-setup.c        2014-01-09 15:15:41.000000000 +0100
index 2d0e43d510efe9bbc3b547175df2ac7dda44132d..a6cf4f804ac0735953151c573e16774fcb0da62a 100644 (file)
@@ -1,17 +1,19 @@
---- systemd-39/units/systemd-tmpfiles-setup.service.in~        2011-12-30 22:27:36.623529054 +0100
-+++ systemd-39/units/systemd-tmpfiles-setup.service.in 2012-01-29 22:55:46.116130563 +0100
-@@ -19,4 +19,4 @@
+--- systemd-238/units/systemd-tmpfiles-setup.service.in~       2018-03-05 23:16:37.000000000 +0100
++++ systemd-238/units/systemd-tmpfiles-setup.service.in        2018-05-15 13:23:51.990328057 +0200
+@@ -19,5 +19,5 @@ RefuseManualStop=yes
  [Service]
  Type=oneshot
  RemainAfterExit=yes
 -ExecStart=@rootbindir@/systemd-tmpfiles --create --remove --boot --exclude-prefix=/dev
 +ExecStart=-@rootbindir@/systemd-tmpfiles --create --remove --boot --exclude-prefix=/dev
---- systemd-39/units/systemd-tmpfiles-clean.service.in~        2011-12-30 22:27:36.520529020 +0100
-+++ systemd-39/units/systemd-tmpfiles-clean.service.in 2012-01-29 22:56:15.626015474 +0100
-@@ -18,5 +18,5 @@
+ SuccessExitStatus=65
+--- systemd-238/units/systemd-tmpfiles-clean.service.in~       2018-03-05 23:16:37.000000000 +0100
++++ systemd-238/units/systemd-tmpfiles-clean.service.in        2018-05-15 13:24:19.297825542 +0200
+@@ -17,6 +17,6 @@ Before=shutdown.target
  
  [Service]
  Type=oneshot
 -ExecStart=@rootbindir@/systemd-tmpfiles --clean
 +ExecStart=-@rootbindir@/systemd-tmpfiles --clean
+ SuccessExitStatus=65
  IOSchedulingClass=idle
index d97fd539da4097d3285b7c81b0d70700151e21fa..7ec5a916ffeadd4486efff3179add061b603589a 100644 (file)
@@ -1,13 +1,5 @@
 --- systemd-235/meson.build~   2017-10-06 10:18:04.000000000 +0200
 +++ systemd-235/meson.build    2017-10-21 15:12:47.202404998 +0200
-@@ -67,6 +67,7 @@ datadir = join_paths(prefixdir, get_opti
- localstatedir = join_paths('/', get_option('localstatedir'))
- rootbindir = join_paths(rootprefixdir, 'bin')
-+rootsbindir = join_paths(rootprefixdir, 'sbin')
- rootlibexecdir = join_paths(rootprefixdir, 'lib/systemd')
- rootlibdir = get_option('rootlibdir')
 @@ -200,6 +201,7 @@ substs.set('includedir',
  substs.set('pkgsysconfdir',                                   pkgsysconfdir)
  substs.set('bindir',                                          bindir)
index 27313f77b553944bc628ac0d81bfe9ab9c452fd6..9629f6b0fbad4c3a6ae280272680854df8038d7e 100644 (file)
@@ -1,7 +1,7 @@
---- a/sysusers.d/basic.conf.in~        2016-11-03 18:16:42.000000000 +0100
-+++ b/sysusers.d/basic.conf.in 2016-11-12 20:05:11.934482095 +0100
-@@ -12,26 +12,26 @@ u root    0     "Super User" /root
- u nobody  65534 "Nobody"     -
+--- systemd-238/sysusers.d/basic.conf.in~      2018-03-05 23:16:37.000000000 +0100
++++ systemd-238/sysusers.d/basic.conf.in       2018-05-15 13:30:41.922818679 +0200
+@@ -12,27 +12,27 @@ u root    0     "Super User" /root
+ u @NOBODY_USER_NAME@  65534 "Nobody"     -
  
  # Administrator group: can *see* more than normal users
 -g adm     -     -            -
@@ -16,7 +16,7 @@
 +g kmem    9     -            -
  g tty     @TTY_GID@     -            -
 -g utmp    -     -            -
-+g utmp    22     -            -
++g utmp    22    -            -
  
  # Hardware access groups
 -g audio   -     -            -
 -g dialout -     -            -
 -g disk    -     -            -
 -g input   -     -            -
--g lp      -     -            -
 -g kvm     -     -            -
--g tape    -     -            -
--g video   -     -            -
+-g lp      -     -            -
 +g audio   23    -            -
 +g cdrom   27    -            -
 +g dialout 16    -            -
 +g disk    6     -            -
 +g input   182   -            -
-+g lp      7     -            -
 +g kvm     160   -            -
++g lp      7     -            -
+ g render  -     -            -
+-g tape    -     -            -
+-g video   -     -            -
 +g tape    68    -            -
 +g video   24    -            -
  
  # Default group for normal users
--g users   -     -            -
-+g users   1000  -            -
---- systemd-235/sysusers.d/systemd-remote.conf.m4~     2017-10-06 10:18:04.000000000 +0200
-+++ systemd-235/sysusers.d/systemd-remote.conf.m4      2017-10-21 15:26:33.951199376 +0200
-@@ -6,8 +6,8 @@
+ g users   @USERS_GID@     -            -
+--- systemd-238/sysusers.d/systemd-remote.conf.m4~     2018-03-05 23:16:37.000000000 +0100
++++ systemd-238/sysusers.d/systemd-remote.conf.m4      2018-05-15 13:33:04.453829878 +0200
+@@ -6,5 +6,5 @@
  #  (at your option) any later version.
  
  m4_ifdef(`HAVE_MICROHTTPD',
 -u systemd-journal-remote  - "systemd Journal Remote"
 +u systemd-journal-remote  319 "systemd Journal Remote"
  )m4_dnl
- m4_ifdef(`HAVE_LIBCURL',
--u systemd-journal-upload  - "systemd Journal Upload"
-+u systemd-journal-upload  320 "systemd Journal Upload"
- )m4_dnl
---- systemd-235/sysusers.d/systemd.conf.m4~    2017-10-06 10:18:04.000000000 +0200
-+++ systemd-235/sysusers.d/systemd.conf.m4     2017-10-21 15:27:49.116545700 +0200
-@@ -5,16 +5,16 @@
+--- systemd-238/sysusers.d/systemd.conf.m4~    2018-03-05 23:16:37.000000000 +0100
++++ systemd-238/sysusers.d/systemd.conf.m4     2018-05-15 13:34:07.479084303 +0200
+@@ -5,13 +5,13 @@
  #  the Free Software Foundation; either version 2.1 of the License, or
  #  (at your option) any later version.
  
  m4_ifdef(`ENABLE_RESOLVE',
 -u systemd-resolve   - "systemd Resolver"
 +u systemd-resolve   317 "systemd Resolver"
- )m4_dnl
- m4_ifdef(`ENABLE_TIMESYNCD',
--u systemd-timesync  - "systemd Time Synchronization"
-+u systemd-timesync  318 "systemd Time Synchronization"
  )m4_dnl
  m4_ifdef(`ENABLE_COREDUMP',
 -u systemd-coredump  - "systemd Core Dumper"
This page took 0.24107 seconds and 4 git commands to generate.