]> git.pld-linux.org Git - packages/systemd.git/commitdiff
up to 249
authorJan Palus <atler@pld-linux.org>
Wed, 7 Jul 2021 21:22:55 +0000 (23:22 +0200)
committerJan Palus <atler@pld-linux.org>
Wed, 7 Jul 2021 22:27:45 +0000 (00:27 +0200)
hostnamed-errno.patch [new file with mode: 0644]
pld-pam-systemd-user.patch
proc-hidepid.patch
systemd-completion.patch
systemd.spec
udev-ploop-rules.patch
uids_gids.patch [deleted file]

diff --git a/hostnamed-errno.patch b/hostnamed-errno.patch
new file mode 100644 (file)
index 0000000..286721d
--- /dev/null
@@ -0,0 +1,53 @@
+From 4b5e7c3eaa0ccf5f438d1793fe07daaf59bc73f6 Mon Sep 17 00:00:00 2001
+From: Jan Palus <jpalus@fastmail.com>
+Date: Thu, 8 Jul 2021 00:23:21 +0200
+Subject: [PATCH] hostnamed: correct variable with errno in fallback_chassis
+
+fixes assertion failure on arm:
+
+systemd-hostnamed[642]: Assertion '(_error) != 0' failed at src/hostname/hostnamed.c:207, function fallback_chassis(). Aborting.
+---
+ src/hostname/hostnamed.c | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/hostname/hostnamed.c b/src/hostname/hostnamed.c
+index bd535ddc4d..36702f2fb0 100644
+--- a/src/hostname/hostnamed.c
++++ b/src/hostname/hostnamed.c
+@@ -204,14 +204,14 @@ static const char* fallback_chassis(void) {
+         r = read_one_line_file("/sys/class/dmi/id/chassis_type", &type);
+         if (r < 0) {
+-                log_debug_errno(v, "Failed to read DMI chassis type, ignoring: %m");
++                log_debug_errno(r, "Failed to read DMI chassis type, ignoring: %m");
+                 goto try_acpi;
+         }
+         r = safe_atou(type, &t);
+         free(type);
+         if (r < 0) {
+-                log_debug_errno(v, "Failed to parse DMI chassis type, ignoring: %m");
++                log_debug_errno(r, "Failed to parse DMI chassis type, ignoring: %m");
+                 goto try_acpi;
+         }
+@@ -260,14 +260,14 @@ static const char* fallback_chassis(void) {
+ try_acpi:
+         r = read_one_line_file("/sys/firmware/acpi/pm_profile", &type);
+         if (r < 0) {
+-                log_debug_errno(v, "Failed read ACPI PM profile, ignoring: %m");
++                log_debug_errno(r, "Failed read ACPI PM profile, ignoring: %m");
+                 return NULL;
+         }
+         r = safe_atou(type, &t);
+         free(type);
+         if (r < 0) {
+-                log_debug_errno(v, "Failed parse ACPI PM profile, ignoring: %m");
++                log_debug_errno(r, "Failed parse ACPI PM profile, ignoring: %m");
+                 return NULL;
+         }
+-- 
+2.32.0
+
index 6e1c2575089c1aa9252358e181d8e51e231d28fc..808375bfa4e720af0d182ae4fb6b64eb8de219b0 100644 (file)
@@ -1,27 +1,27 @@
---- systemd-stable-245.6/src/login/systemd-user.m4.orig        2020-06-11 13:54:19.219560705 +0200
-+++ systemd-stable-245.6/src/login/systemd-user.m4     2020-06-11 13:59:30.489083928 +0200
+--- systemd-stable-249/src/login/systemd-user.in.orig  2021-07-07 19:41:29.000000000 +0200
++++ systemd-stable-249/src/login/systemd-user.in       2021-07-07 22:39:21.502935327 +0200
 @@ -2,19 +2,10 @@
  #
  # Used by systemd --user instances.
  
--m4_ifdef(`ENABLE_HOMED',
+-{% if ENABLE_HOMED %}
 --account sufficient pam_systemd_home.so
--)m4_dnl
--account sufficient pam_unix.so
+-{% endif %}
+-account sufficient pam_unix.so no_pass_expiry
 -account required pam_permit.so
 -
 +account               include         system-auth
- m4_ifdef(`HAVE_SELINUX',
+ {% if HAVE_SELINUX %}
 -session required pam_selinux.so close
 -session required pam_selinux.so nottys open
--)m4_dnl
+-{% endif %}
 -session required pam_loginuid.so
 -session optional pam_keyinit.so force revoke
--m4_ifdef(`ENABLE_HOMED',
+-{% if ENABLE_HOMED %}
 --session optional pam_systemd_home.so
 +session               optional        pam_selinux.so close
 +session               optional        pam_selinux.so nottys open
- )m4_dnl
+ {% endif %}
 -session optional pam_systemd.so
 +session               required        pam_loginuid.so
 +session               include system-auth
index c47484731acfbeb081c176ccf5fc01437796852d..d19fed8a298d3be163194fab482714ddb58326b1 100644 (file)
@@ -3,7 +3,7 @@
 @@ -41,3 +41,7 @@
  # Increase the default a bit in order to allow many simultaneous logins since
  # we keep one fd open per session.
- LimitNOFILE=@HIGH_RLIMIT_NOFILE@
+ LimitNOFILE={{HIGH_RLIMIT_NOFILE}}
 +
 +# Run as group 'proc' to ensure access to /proc when
 +# it is mounted with hidepid=1|2 option
index 3c24beb16a6e7679605e199fdf213810c004daab..67649c36512dde4273f7549363ec3e6eeed938b6 100644 (file)
@@ -2,23 +2,23 @@ diff -urN systemd-241.orig/shell-completion/bash/meson.build systemd-241/shell-c
 --- systemd-241.orig/shell-completion/bash/meson.build 2019-02-14 11:11:58.000000000 +0100
 +++ systemd-241/shell-completion/bash/meson.build      2019-03-07 01:08:55.312337719 +0100
 @@ -30,7 +30,7 @@
-                  ['udevadm',             ''],
-                  ['kernel-install',      ''],
-                  [bash_systemctl,        ''],
--                 ['bootctl',             'ENABLE_EFI'],
-+                 ['bootctl',             ''],
-                  ['coredumpctl',         'ENABLE_COREDUMP'],
-                  ['homectl',             'ENABLE_HOMED'],
-                  ['hostnamectl',         'ENABLE_HOSTNAMED'],
+          ['systemd-run',         ''],
+          ['udevadm',             ''],
+          ['kernel-install',      ''],
+-         ['bootctl',             'ENABLE_EFI'],
++         ['bootctl',             ''],
+          ['coredumpctl',         'ENABLE_COREDUMP'],
+          ['homectl',             'ENABLE_HOMED'],
+          ['hostnamectl',         'ENABLE_HOSTNAMED'],
 diff -urN systemd-241.orig/shell-completion/zsh/meson.build systemd-241/shell-completion/zsh/meson.build
 --- systemd-241.orig/shell-completion/zsh/meson.build  2019-02-14 11:11:58.000000000 +0100
 +++ systemd-241/shell-completion/zsh/meson.build       2019-03-07 01:09:00.655641470 +0100
 @@ -25,7 +25,7 @@
-                  ['_sd_unit_files',            ''],
-                  ['_sd_machines',              ''],
-                  [zsh_systemctl,               ''],
--                 ['_bootctl',                  'ENABLE_EFI'],
-+                 ['_bootctl',                  ''],
-                  ['_coredumpctl',              'ENABLE_COREDUMP'],
-                  ['_hostnamectl',              'ENABLE_HOSTNAMED'],
-                  ['_localectl',                'ENABLE_LOCALED'],
+          ['_sd_outputmodes',           ''],
+          ['_sd_unit_files',            ''],
+          ['_sd_machines',              ''],
+-         ['_bootctl',                  'ENABLE_EFI'],
++         ['_bootctl',                  ''],
+          ['_coredumpctl',              'ENABLE_COREDUMP'],
+          ['_hostnamectl',              'ENABLE_HOSTNAMED'],
+          ['_localectl',                'ENABLE_LOCALED'],
index e0386c391303081f9662a9fba6a9627f3c8427e8..bdd96df77d2087166a9a39fd0849a24177dea637 100644 (file)
@@ -30,14 +30,14 @@ Summary:    A System and Service Manager
 Summary(pl.UTF-8):     systemd - zarządca systemu i usług dla Linuksa
 Name:          systemd
 # Verify ChangeLog and NEWS when updating (since there are incompatible/breaking changes very often)
-Version:       248.3
+Version:       249
 Release:       0.1
 Epoch:         1
 License:       GPL v2+ (udev), LGPL v2.1+ (the rest)
 Group:         Base
 #Source0Download: https://github.com/systemd/systemd/releases
 Source0:       https://github.com/systemd/systemd-stable/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: bb412cc7f9c9c54bcfdb8e7a90f5a8b1
+# Source0-md5: fb0481dfe8f30ea06d270005f1039364
 Source1:       %{name}-sysv-convert
 Source2:       %{name}_booted.c
 Source3:       network.service
@@ -76,7 +76,7 @@ Patch8:               proc-hidepid.patch
 Patch9:                %{name}-configfs.patch
 Patch10:       pld-boot_efi_mount.patch
 Patch11:       optional-tmp-on-tmpfs.patch
-Patch12:       uids_gids.patch
+Patch12:       hostnamed-errno.patch
 Patch13:       sysctl.patch
 Patch14:       pld-pam-%{name}-user.patch
 Patch15:       %{name}-x32.patch
@@ -129,6 +129,7 @@ BuildRequires:      pcre2-8-devel
 BuildRequires: pkgconfig >= 1:0.9.0
 BuildRequires: polkit-devel >= 0.106
 BuildRequires: python3
+BuildRequires: python3-jinja2
 BuildRequires: python3-lxml
 %{?with_qrencode:BuildRequires:        qrencode-devel >= 4}
 BuildRequires: rpmbuild(macros) >= 1.752
@@ -746,6 +747,27 @@ grep -rlZ -0 '#!/usr/bin/env bash' . | xargs -0 sed -i -e 's,#!/usr/bin/env bash
 
 %build
 %meson build \
+       -Dadm-gid=3 \
+       -Daudio-gid=23 \
+       -Dcdrom-gid=27 \
+       -Ddialout-gid=16 \
+       -Ddisk-gid=6 \
+       -Dinput-gid=182 \
+       -Dkmem-gid=9 \
+       -Dkvm-gid=160 \
+       -Dlp-gid=7 \
+       -Dsgx-gid=344 \
+       -Dtape-gid=68 \
+       -Dusers-gid=1000 \
+       -Dutmp-gid=22 \
+       -Dvideo-gid=24 \
+       -Dwheel-gid=10 \
+       -Dsystemd-journal-gid=288 \
+       -Dsystemd-network-uid=316 \
+       -Dsystemd-resolve-uid=317 \
+       -Dsystemd-timesync-uid=318 \
+       -Dnobody-user="nobody" \
+       -Dnobody-group="nogroup" \
        -Daudit=%{__true_false audit} \
        -Ddefault-hierarchy=hybrid \
        -Ddefault-kill-user-processes=false \
@@ -761,8 +783,6 @@ grep -rlZ -0 '#!/usr/bin/env bash' . | xargs -0 sed -i -e 's,#!/usr/bin/env bash
        -Dman=true \
        -Dmicrohttpd=%{__true_false microhttpd} \
        -Dmount-path=/bin/mount \
-       -Dnobody-user="nobody" \
-       -Dnobody-group="nogroup" \
        -Dntp-servers='0.pool.ntp.org 1.pool.ntp.org 2.pool.ntp.org 3.pool.ntp.org' \
        -Dpam=%{__true_false pam} \
        -Dqrencode=%{__true_false qrencode} \
@@ -781,7 +801,6 @@ grep -rlZ -0 '#!/usr/bin/env bash' . | xargs -0 sed -i -e 's,#!/usr/bin/env bash
        -Dsysvrcnd-path=/etc/rc.d \
        -Dtpm2=%{__true_false tpm2} \
        -Dumount-path=/bin/umount \
-       -Dusers-gid=1000 \
 
 %ninja_build -C build
 
@@ -1829,6 +1848,7 @@ fi
 %{systemdunitdir}/initrd-fs.target
 %{systemdunitdir}/initrd-root-fs.target
 %{systemdunitdir}/initrd-switch-root.target
+%{systemdunitdir}/initrd-usr-fs.target
 %{systemdunitdir}/initrd.target
 %{systemdunitdir}/kexec.target
 %{systemdunitdir}/local-fs-pre.target
@@ -2292,11 +2312,13 @@ fi
 /lib/udev/hwdb.d/60-evdev.hwdb
 /lib/udev/hwdb.d/60-input-id.hwdb
 /lib/udev/hwdb.d/60-keyboard.hwdb
+/lib/udev/hwdb.d/60-seat.hwdb
 /lib/udev/hwdb.d/60-sensor.hwdb
 /lib/udev/hwdb.d/70-joystick.hwdb
 /lib/udev/hwdb.d/70-mouse.hwdb
 /lib/udev/hwdb.d/70-pointingstick.hwdb
 /lib/udev/hwdb.d/70-touchpad.hwdb
+/lib/udev/hwdb.d/80-ieee1394-unit-function.hwdb
 
 %attr(755,root,root) %{_rootsbindir}/start_udev
 %attr(755,root,root) %{_rootsbindir}/udevd
@@ -2345,6 +2367,7 @@ fi
 /lib/udev/rules.d/78-sound-card.rules
 /lib/udev/rules.d/80-drivers.rules
 /lib/udev/rules.d/80-net-setup-link.rules
+/lib/udev/rules.d/81-net-dhcp.rules
 /lib/udev/rules.d/90-vconsole.rules
 
 %{_mandir}/man5/udev.conf.5*
index 5c7ef9febcc144a23ab5238f749d2f48643edff7..4c22d725fdb34b69d12c7e87ba479de19865e44b 100644 (file)
@@ -2,7 +2,7 @@ diff -ru udev-182.orig/rules/60-persistent-storage.rules udev-182/rules/60-persi
 --- udev-182.orig/rules.d/60-persistent-storage.rules  2012-02-23 16:26:16.000000000 +0100
 +++ udev-182/rules.d/60-persistent-storage.rules       2012-05-24 11:23:01.000000000 +0200
 @@ -16,6 +16,8 @@
- SUBSYSTEM!="block", GOTO="persistent_storage_end"
+ SUBSYSTEM!="block|ubi", GOTO="persistent_storage_end"
  KERNEL!="loop*|mmcblk*[0-9]|msblk*[0-9]|mspblk*[0-9]|nvme*|sd*|sr*|vd*|xvd*|bcache*|cciss*|dasd*|ubd*|ubi*|scm*|pmem*|nbd*|zd*", GOTO="persistent_storage_end"
  
 +KERNEL=="ploop*", GOTO="persistent_storage_end"
diff --git a/uids_gids.patch b/uids_gids.patch
deleted file mode 100644 (file)
index 5405a87..0000000
+++ /dev/null
@@ -1,63 +0,0 @@
---- systemd-238/sysusers.d/basic.conf.in~      2018-03-05 23:16:37.000000000 +0100
-+++ systemd-238/sysusers.d/basic.conf.in       2018-05-15 13:30:41.922818679 +0200
-@@ -12,28 +12,28 @@ u root    0     "Super User" /root
- u @NOBODY_USER_NAME@  65534 "Nobody"     -
- # Administrator group: can *see* more than normal users
--g adm     -     -            -
-+g adm     3     -            -
- # Administrator group: can *do* more than normal users
--g wheel   -     -            -
-+g wheel   10     -            -
- # Access to certain kernel and userspace facilities
--g kmem    -     -            -
-+g kmem    9     -            -
- g tty     @TTY_GID@     -            -
--g utmp    -     -            -
-+g utmp    22    -            -
- # Hardware access groups
--g audio   -     -            -
--g cdrom   -     -            -
--g dialout -     -            -
--g disk    -     -            -
--g input   -     -            -
--g kvm     -     -            -
--g lp      -     -            -
-+g audio   23    -            -
-+g cdrom   27    -            -
-+g dialout 16    -            -
-+g disk    6     -            -
-+g input   182   -            -
-+g kvm     160   -            -
-+g lp      7     -            -
- g render  -     -            -
--g sgx     -     -            -
--g tape    -     -            -
--g video   -     -            -
-+g sgx     344   -            -
-+g tape    68    -            -
-+g video   24    -            -
- # Default group for normal users
- g users   @USERS_GID@     -            -
---- systemd-238/sysusers.d/systemd-remote.conf.m4~     2018-03-05 23:16:37.000000000 +0100
-+++ systemd-238/sysusers.d/systemd-remote.conf.m4      2018-05-15 13:33:04.453829878 +0200
-@@ -6,5 +6,5 @@
- #  (at your option) any later version.
- m4_ifdef(`HAVE_MICROHTTPD',
--u systemd-journal-remote  - "systemd Journal Remote"
-+u systemd-journal-remote  319 "systemd Journal Remote"
- )m4_dnl
---- systemd-238/sysusers.d/systemd.conf.m4~    2018-03-05 23:16:37.000000000 +0100
-+++ systemd-238/sysusers.d/systemd.conf.m4     2018-05-15 13:34:07.479084303 +0200
-@@ -5,5 +5,5 @@
- u systemd-timesync  - "systemd Time Synchronization"
- )m4_dnl
- m4_ifdef(`ENABLE_COREDUMP',
--u systemd-coredump  - "systemd Core Dumper"
-+u systemd-coredump  333 "systemd Core Dumper"
- )m4_dnl
This page took 0.057743 seconds and 4 git commands to generate.