]> git.pld-linux.org Git - packages/systemd.git/commitdiff
- fix crypt root setup auto/th/systemd-234-2
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 7 Sep 2017 18:30:38 +0000 (20:30 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 7 Sep 2017 18:30:38 +0000 (20:30 +0200)
- rel 2

cryptsetup-fix-infinite-timeout-6486.patch [new file with mode: 0644]
systemd.spec

diff --git a/cryptsetup-fix-infinite-timeout-6486.patch b/cryptsetup-fix-infinite-timeout-6486.patch
new file mode 100644 (file)
index 0000000..860d816
--- /dev/null
@@ -0,0 +1,42 @@
+From c64c6a8b259abfbff5ce202d5d5982b120cf928f Mon Sep 17 00:00:00 2001
+From: Andrew Soutar <andrew@andrewsoutar.com>
+Date: Mon, 31 Jul 2017 02:19:16 -0400
+Subject: [PATCH] cryptsetup: fix infinite timeout (#6486)
+
+0004f698d causes `arg_timeout` to be infinity instead of 0 when timeout=0. The
+logic here now matches this change.
+
+Fixes #6381
+
+(cherry picked from commit 0864d311766498563331f486909a0d950ba7de87)
+---
+ src/cryptsetup/cryptsetup.c | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/cryptsetup/cryptsetup.c b/src/cryptsetup/cryptsetup.c
+index 3b4c086162..08ed7e53ba 100644
+--- a/src/cryptsetup/cryptsetup.c
++++ b/src/cryptsetup/cryptsetup.c
+@@ -56,7 +56,7 @@ static bool arg_tcrypt_veracrypt = false;
+ static char **arg_tcrypt_keyfiles = NULL;
+ static uint64_t arg_offset = 0;
+ static uint64_t arg_skip = 0;
+-static usec_t arg_timeout = 0;
++static usec_t arg_timeout = USEC_INFINITY;
+ /* Options Debian's crypttab knows we don't:
+@@ -670,10 +670,10 @@ int main(int argc, char *argv[]) {
+                 if (arg_discards)
+                         flags |= CRYPT_ACTIVATE_ALLOW_DISCARDS;
+-                if (arg_timeout > 0)
+-                        until = now(CLOCK_MONOTONIC) + arg_timeout;
+-                else
++                if (arg_timeout == USEC_INFINITY)
+                         until = 0;
++                else
++                        until = now(CLOCK_MONOTONIC) + arg_timeout;
+                 arg_key_size = (arg_key_size > 0 ? arg_key_size : (256 / 8));
index 889f10b8d5ffc872026862efad05173a8591ff93..07f5d2e613446b7b8cbb520075424046e3a15062 100644 (file)
@@ -26,7 +26,7 @@ Summary(pl.UTF-8):    systemd - zarządca systemu i usług dla Linuksa
 Name:          systemd
 # Verify ChangeLog and NEWS when updating (since there are incompatible/breaking changes very often)
 Version:       234
-Release:       1
+Release:       2
 Epoch:         1
 License:       GPL v2+ (udev), LGPL v2.1+ (the rest)
 Group:         Base
@@ -74,6 +74,7 @@ Patch13:      sysctl.patch
 Patch14:       pld-pam-%{name}-user.patch
 Patch15:       %{name}-seccomp_disable_on_i386.patch
 Patch16:       %{name}-path.patch
+Patch17:       cryptsetup-fix-infinite-timeout-6486.patch
 URL:           http://www.freedesktop.org/wiki/Software/systemd
 BuildRequires: acl-devel
 %{?with_audit:BuildRequires:   audit-libs-devel}
@@ -640,6 +641,7 @@ Uzupełnianie parametrów w zsh dla poleceń udev.
 %patch14 -p1
 %patch15 -p1
 %patch16 -p1
+%patch17 -p1
 
 cp -p %{SOURCE2} src/systemd_booted.c
 
This page took 0.255774 seconds and 4 git commands to generate.