]> git.pld-linux.org Git - packages/systemd.git/blobdiff - target-pld.patch
Give users access to /dev/uinput
[packages/systemd.git] / target-pld.patch
index bdef12c2bdf8e9bccf07287d16ad5c812403f7f1..ca3ba69e3ca0e611f4fdefd9e9516882d148692b 100644 (file)
@@ -1,32 +1,30 @@
-diff --git a/Makefile.am b/Makefile.am
-index 170465a..bce467d 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -196,6 +196,8 @@
- SYSINIT_TARGET_WANTS =
- SOCKETS_TARGET_WANTS =
+diff -dur -x '*~' -x '*.orig' systemd-208.orig/Makefile.am systemd-208/Makefile.am
+--- systemd-208.orig/Makefile.am       2013-10-02 04:57:09.000000000 +0200
++++ systemd-208/Makefile.am    2014-01-09 15:15:41.000000000 +0100
+@@ -211,6 +211,8 @@
  TIMERS_TARGET_WANTS =
+ USER_SOCKETS_TARGET_WANTS =
+ USER_BUSNAMES_TARGET_WANTS =
 +FINAL_TARGET_WANTS =
 +GRAPHICAL_TARGET_WANTS =
  
  SYSTEM_UNIT_ALIASES =
  USER_UNIT_ALIASES =
-@@ -214,6 +216,8 @@
-       what="$(SYSINIT_TARGET_WANTS)" && wants=sysinit.target && $(add-wants)
-       what="$(SOCKETS_TARGET_WANTS)" && wants=sockets.target && $(add-wants)
-       what="$(TIMERS_TARGET_WANTS)" && wants=timers.target && $(add-wants)
-+      what="$(FINAL_TARGET_WANTS)" && wants=final.target && $(add-wants)
-+      what="$(GRAPHICAL_TARGET_WANTS)" && wants=graphical.target && $(add-wants)
+@@ -230,6 +232,8 @@
+       what="$(SLICES_TARGET_WANTS)" && wants=slices.target && $(add-wants)
+       what="$(USER_SOCKETS_TARGET_WANTS)" && wants=sockets.target && dir=$(userunitdir) && $(add-wants)
+       what="$(USER_BUSNAMES_TARGET_WANTS)" && wants=busnames.target && dir=$(userunitdir) && $(add-wants)
++      what="$(FINAL_TARGET_WANTS)" && wants=final.target && dir=$(systemunitdir) && $(add-wants)
++      what="$(GRAPHICAL_TARGET_WANTS)" && wants=graphical.target && dir=$(systemunitdir) && $(add-wants)
  
  define add-wants
        [ -z "$$what" ] || ( \
-@@ -3388,9 +3392,16 @@
+@@ -4001,8 +4005,15 @@
        $(systemdstatedir)
  
  MULTI_USER_TARGET_WANTS += \
 +      rc-local.service \
-       systemd-logind.service \
-       systemd-user-sessions.service
+       systemd-logind.service
  
 +FINAL_TARGET_WANTS += \
 +      halt-local.service
@@ -37,7 +35,7 @@ index 170465a..bce467d 100644
  SYSTEM_UNIT_ALIASES += \
        systemd-logind.service dbus-org.freedesktop.login1.service
  
-@@ -3790,6 +3801,10 @@
+@@ -4493,6 +4504,10 @@
  uninstall-hook: $(UNINSTALL_DATA_HOOKS) $(UNINSTALL_EXEC_HOOKS)
  
  install-data-hook: $(INSTALL_DATA_HOOKS)
@@ -48,11 +46,10 @@ index 170465a..bce467d 100644
  
  distclean-local: $(DISTCLEAN_LOCAL_HOOKS)
  
-diff --git a/src/core/hostname-setup.c b/src/core/hostname-setup.c
-index 2c2f10c..754f0c7 100644
---- a/src/core/hostname-setup.c
-+++ b/src/core/hostname-setup.c
-@@ -64,13 +64,84 @@ static int read_and_strip_hostname(const char *path, char **hn) {
+diff -dur -x '*~' -x '*.orig' systemd-208.orig/src/core/hostname-setup.c systemd-208/src/core/hostname-setup.c
+--- systemd-208.orig/src/core/hostname-setup.c 2013-08-13 22:02:46.000000000 +0200
++++ systemd-208/src/core/hostname-setup.c      2014-01-09 15:15:41.000000000 +0100
+@@ -53,13 +53,84 @@
          return 0;
  }
  
@@ -116,7 +113,7 @@ index 2c2f10c..754f0c7 100644
 +        /* First, try to load the generic hostname configuration file,
 +         * that we support on all distributions */
 +
-+        r = read_and_strip_hostname("/etc/hostname", hn);
++        r = read_hostname_config("/etc/hostname", hn);
 +        if (r < 0) {
 +                if (r == -ENOENT)
 +                        return read_distro_hostname(hn);
@@ -133,16 +130,15 @@ index 2c2f10c..754f0c7 100644
          const char *hn;
          bool enoent = false;
  
--        r = read_and_strip_hostname("/etc/hostname", &b);
+-        r = read_hostname_config("/etc/hostname", &b);
 +        r = read_hostname(&b);
          if (r < 0) {
                  if (r == -ENOENT)
                          enoent = true;
-diff --git a/src/core/locale-setup.c b/src/core/locale-setup.c
-index 7f692e9..0a45854 100644
---- a/src/core/locale-setup.c
-+++ b/src/core/locale-setup.c
-@@ -74,6 +74,7 @@ int locale_setup(void) {
+diff -dur -x '*~' -x '*.orig' systemd-208.orig/src/core/locale-setup.c systemd-208/src/core/locale-setup.c
+--- systemd-208.orig/src/core/locale-setup.c   2013-10-01 00:17:21.000000000 +0200
++++ systemd-208/src/core/locale-setup.c        2014-01-09 15:15:41.000000000 +0100
+@@ -76,6 +76,7 @@
  
          if (detect_container(NULL) <= 0) {
                  r = parse_env_file("/proc/cmdline", WHITESPACE,
@@ -150,7 +146,7 @@ index 7f692e9..0a45854 100644
                                     "locale.LANG",              &variables[VARIABLE_LANG],
                                     "locale.LANGUAGE",          &variables[VARIABLE_LANGUAGE],
                                     "locale.LC_CTYPE",          &variables[VARIABLE_LC_CTYPE],
-@@ -121,6 +121,15 @@ int locale_setup(void) {
+@@ -120,6 +121,15 @@
                          log_warning("Failed to read /etc/locale.conf: %s", strerror(-r));
          }
  
@@ -163,44 +159,50 @@ index 7f692e9..0a45854 100644
 +                        log_warning("Failed to read /etc/sysconfig/i18n: %s", strerror(-r));
 +        }
 +
-         if (!variables[VARIABLE_LANG]) {
-                 variables[VARIABLE_LANG] = strdup("C");
-                 if (!variables[VARIABLE_LANG]) {
---- systemd-196/src/timedate/timedated.c~      2012-10-16 23:35:40.589269718 +0200
-+++ systemd-196/src/timedate/timedated.c       2012-12-21 11:46:13.545086335 +0100
-@@ -175,6 +175,13 @@
+         add = NULL;
+         for (i = 0; i < _VARIABLE_MAX; i++) {
+                 char *s;
+diff -dur -x '*~' -x '*.orig' systemd-208.orig/src/timedate/timedated.c systemd-208/src/timedate/timedated.c
+--- systemd-208.orig/src/timedate/timedated.c  2013-08-13 22:02:47.000000000 +0200
++++ systemd-208/src/timedate/timedated.c       2014-01-09 15:15:41.000000000 +0100
+@@ -183,9 +183,19 @@
+                         c->zone = strdup(e);
+                         if (!c->zone)
+                                 return log_oom();
++                        goto have_timezone;
                  }
          }
  
 +      r = parse_env_file("/etc/sysconfig/timezone", NEWLINE,
-+                         "TIMEZONE", &tz.zone,
++                         "TIMEZONE", &c->zone,
 +                         NULL);
 +      if (r < 0) {
 +              if (r != -ENOENT)
 +                      log_warning("Failed to read /etc/sysconfig/timezone: %s", strerror(-r));
 +      }
- have_timezone:
-         if (isempty(tz.zone)) {
-                 free(tz.zone);
-diff --git a/src/vconsole/vconsole-setup.c b/src/vconsole/vconsole-setup.c
-index 9196789..1d1a916 100644
---- a/src/vconsole/vconsole-setup.c
-+++ b/src/vconsole/vconsole-setup.c
-@@ -358,6 +358,17 @@
-                 if (r < 0 && r != -ENOENT)
-                         log_warning("Failed to read /etc/vconsole.conf: %s", strerror(-r));
-         }
-+
-+        if (r <= 0) {
-+                r = parse_env_file("/etc/sysconfig/console", NEWLINE,
-+                                   "CONSOLEFONT", &vc_font,
-+                                   "CONSOLEMAP", &vc_font_map,
-+                                   "CONSOLESCREENFONTMAP", &vc_font_unimap,
-+                                   "KEYTABLE", &vc_keymap,
-+                                   NULL);
-+                if (r < 0 && r != -ENOENT)
-+                        log_warning("Failed to read /etc/sysconfig/console: %s", strerror(-r));
-+        }
++ 
++have_timezone:
+         if (isempty(c->zone)) {
+                 free(c->zone);
+                 c->zone = NULL;
+diff -dur -x '*~' -x '*.orig' systemd-208.orig/src/vconsole/vconsole-setup.c systemd-208/src/vconsole/vconsole-setup.c
+--- systemd-208.orig/src/vconsole/vconsole-setup.c     2013-08-13 22:02:47.000000000 +0200
++++ systemd-208/src/vconsole/vconsole-setup.c  2014-01-09 15:17:49.000000000 +0100
+@@ -284,6 +284,17 @@ int main(int argc, char **argv) {
+         if (r < 0 && r != -ENOENT)
+                 log_warning("Failed to read /etc/vconsole.conf: %s", strerror(-r));
  
-         if (utf8)
-                 enable_utf8(fd);
++        if (r <= 0) {
++                int r1 = parse_env_file("/etc/sysconfig/console", NEWLINE,
++                                "CONSOLEFONT", &vc_font,
++                                "CONSOLEMAP", &vc_font_map,
++                                "CONSOLESCREENFONTMAP", &vc_font_unimap,
++                                "KEYTABLE", &vc_keymap,
++                                NULL);
++                if (r1 < 0 && r1 != -ENOENT)
++                        log_warning("Failed to read /etc/sysconfig/console: %s", strerror(-r1));
++        } 
++
+         /* Let the kernel command line override /etc/vconsole.conf */
+         if (detect_container(NULL) <= 0) {
+                 r = parse_env_file("/proc/cmdline", WHITESPACE,
This page took 0.048789 seconds and 4 git commands to generate.