]> git.pld-linux.org Git - packages/systemd.git/blobdiff - systemd.spec
- R selinux >= 2.6 because of https://github.com/systemd/systemd/issues/3962
[packages/systemd.git] / systemd.spec
index e9eb2091e2596ea682d09c1072873d02d416e44f..f73945a3c89e1324bcc1ceec9377295705f11516 100644 (file)
@@ -26,21 +26,17 @@ Summary(pl.UTF-8):  systemd - zarządca systemu i usług dla Linuksa
 Name:          systemd
 # Verify ChangeLog and NEWS when updating (since there are incompatible/breaking changes very often)
 Version:       232
-Release:       0.1
+Release:       0.4
 Epoch:         1
 License:       GPL v2+ (udev), LGPL v2.1+ (the rest)
 Group:         Base
-Source0:       https://github.com/systemd/systemd/archive/v%{version}.tar.gz
+Source0:       https://github.com/systemd/systemd/archive/v%{version}/%{name}-%{version}.tar.gz
 # Source0-md5: 3e3a0b14050eff62e68be72142181730
 Source1:       %{name}-sysv-convert
 Source2:       %{name}_booted.c
 Source3:       network.service
 Source4:       var-lock.mount
 Source5:       var-run.mount
-Source10:      pld-storage-init-late.service
-Source11:      pld-storage-init.service
-Source12:      pld-wait-storage.service
-Source13:      pld-storage-init.sh
 Source14:      pld-clean-tmp.service
 Source15:      pld-clean-tmp.sh
 Source16:      pld-rc-inetd-generator.sh
@@ -75,6 +71,7 @@ Patch10:      pld-boot_efi_mount.patch
 Patch11:       optional-tmp-on-tmpfs.patch
 Patch12:       uids_gids.patch
 Patch13:       sysctl.patch
+Patch14:       pld-pam-systemd-user.patch
 URL:           http://www.freedesktop.org/wiki/Software/systemd
 BuildRequires: acl-devel
 %{?with_audit:BuildRequires:   audit-libs-devel}
@@ -102,7 +99,7 @@ BuildRequires:       libgcrypt-devel >= 1.4.5
 %{?with_microhttpd:BuildRequires:      libmicrohttpd-devel >= 0.9.33}
 BuildRequires: libmount-devel >= 2.28.2-2
 BuildRequires: libseccomp-devel >= 1.0.0
-%{?with_selinux:BuildRequires: libselinux-devel >= 2.1.9}
+%{?with_selinux:BuildRequires: libselinux-devel >= 2.6}
 BuildRequires: libtool >= 2:2.2
 BuildRequires: libxslt-progs
 BuildRequires: lz4-devel >= r119
@@ -122,6 +119,7 @@ BuildRequires:      xz-devel
 BuildRequires: zlib-devel
 Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
 Requires:      %{name}-units = %{epoch}:%{version}-%{release}
+Requires(post,postun): %{name}-units = %{epoch}:%{version}-%{release}
 Requires(postun):      /usr/sbin/groupdel
 Requires(postun):      /usr/sbin/userdel
 Requires(post):        /bin/setfacl
@@ -167,6 +165,9 @@ Provides:   user(systemd-timesync)
 #Obsoletes:    ConsoleKit-x11
 Obsoletes:     systemd-no-compat-tmpfiles
 Obsoletes:     udev-systemd
+# for storage detection / activation services
+Conflicts:     dmraid < 1.0.0-0.rc16.3.3
+Conflicts:     mdadm < 4.0-2
 # sytemd wants pam with pam_systemd.so in system-auth...
 Conflicts:     pam < 1:1.1.5-5
 # ...and sudo hates it
@@ -174,8 +175,8 @@ Conflicts:  sudo < 1:1.7.8p2-4
 # for prefdm script
 Conflicts:     xinitrc-ng < 1.0
 # systemd scripts use options not present in older versions
-Conflicts:     kpartx < 0.4.9-7
-Conflicts:     multipath-tools < 0.4.9-7
+Conflicts:     kpartx < 0.6.1-1
+Conflicts:     multipath-tools < 0.6.1-1
 # no tmpfs on /media, use /run/media/$USER for mounting
 Conflicts:     udisks2 < 1.92.0
 # packages that have dirs under /var/run and/or /var/lock must provide tmpfiles configs
@@ -442,7 +443,7 @@ Summary:    Shared systemd libraries
 Summary(pl.UTF-8):     Biblioteki współdzielone systemd
 Group:         Libraries
 Requires:      libgcrypt >= 1.4.5
-%{?with_selinux:Requires:      libselinux >= 2.1.9}
+%{?with_selinux:Requires:      libselinux >= 2.6}
 Obsoletes:     nss_myhostname
 
 %description libs
@@ -529,7 +530,7 @@ Requires:   coreutils
 Requires:      filesystem >= 3.0-45
 Requires:      kmod >= 15
 Requires:      libblkid >= 2.24
-%{?with_selinux:Requires:      libselinux >= 2.1.9}
+%{?with_selinux:Requires:      libselinux >= 2.6}
 Requires:      setup >= 2.9.0-3
 Requires:      udev-libs = %{epoch}:%{version}-%{release}
 Requires:      uname(release) >= 3.12
@@ -620,6 +621,7 @@ Uzupełnianie parametrów w zsh dla poleceń udev.
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
+%patch14 -p1
 
 cp -p %{SOURCE2} src/systemd_booted.c
 
@@ -663,7 +665,8 @@ cp -p %{SOURCE2} src/systemd_booted.c
        --with-rootprefix="" \
        --with-rootlibdir=/%{_lib} \
        --with-sysvinit-path=/etc/rc.d/init.d \
-       --with-sysvrcnd-path=/etc/rc.d
+       --with-sysvrcnd-path=/etc/rc.d \
+       --without-kill-user-processes
 
 %{__make}
 
@@ -756,16 +759,9 @@ ln -s ../var-run.mount $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
 # and remove mounting tmp on tmpfs by default
 %{__rm} $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/tmp.mount
 
-# Install and enable storage subsystems support services (RAID, LVM, etc.)
-cp -p %{SOURCE10} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init-late.service
-cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init.service
-cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/pld-wait-storage.service
+# add /tmp cleanup service
 cp -p %{SOURCE14} $RPM_BUILD_ROOT%{systemdunitdir}/pld-clean-tmp.service
-install -p %{SOURCE13} $RPM_BUILD_ROOT/lib/systemd/pld-storage-init
 install -p %{SOURCE15} $RPM_BUILD_ROOT/lib/systemd/pld-clean-tmp
-
-ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
-ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
 ln -s ../pld-clean-tmp.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
 
 # Add inside container only SIGPWR handler which is used by lxc-stop
@@ -820,6 +816,7 @@ install -d $RPM_BUILD_ROOT/var/log
 
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la \
+       $RPM_BUILD_ROOT/lib/systemd/*.la \
        $RPM_BUILD_ROOT/%{_lib}/*.la
 
 %find_lang %{name}
@@ -864,7 +861,7 @@ chmod g+s /var/log/journal
 # https://bugs.freedesktop.org/show_bug.cgi?id=89202
 /bin/getfacl -p /var/log/journal/$(cat /etc/machine-id) | grep -v '^#' | sort -u | /bin/setfacl -R --set-file=- /var/log/journal/$(cat /etc/machine-id) || :
 
-%post   libs -p /sbin/ldconfig
+%post libs -p /sbin/ldconfig
 %postun libs -p /sbin/ldconfig
 
 %post units
@@ -1109,7 +1106,6 @@ fi
 /lib/systemd/resolv.conf
 %attr(755,root,root) /lib/systemd/libsystemd-shared*.so
 %attr(755,root,root) /lib/systemd/pld-clean-tmp
-%attr(755,root,root) /lib/systemd/pld-storage-init
 %attr(755,root,root) /lib/systemd/systemd-ac-power
 %attr(755,root,root) /lib/systemd/systemd-backlight
 %attr(755,root,root) /lib/systemd/systemd-binfmt
@@ -1498,9 +1494,6 @@ fi
 %{systemdunitdir}/netfs.service
 %{systemdunitdir}/network.service
 %{systemdunitdir}/pld-clean-tmp.service
-%{systemdunitdir}/pld-storage-init-late.service
-%{systemdunitdir}/pld-storage-init.service
-%{systemdunitdir}/pld-wait-storage.service
 %{systemdunitdir}/prefdm.service
 %{systemdunitdir}/quotaon.service
 %{systemdunitdir}/random.service
@@ -1664,8 +1657,6 @@ fi
 %{systemdunitdir}/graphical.target.wants/display-manager.service
 %{systemdunitdir}/graphical.target.wants/systemd-update-utmp-runlevel.service
 %{systemdunitdir}/local-fs.target.wants/pld-clean-tmp.service
-%{systemdunitdir}/local-fs.target.wants/pld-storage-init-late.service
-%{systemdunitdir}/local-fs.target.wants/pld-storage-init.service
 %{systemdunitdir}/local-fs.target.wants/systemd-remount-fs.service
 %{systemdunitdir}/local-fs.target.wants/var-lib-machines.mount
 %{systemdunitdir}/local-fs.target.wants/var-lock.mount
This page took 0.09055 seconds and 4 git commands to generate.