]> git.pld-linux.org Git - packages/systemd.git/blobdiff - systemd.spec
- partial update to 245; TODO: files + reading ChangeLog and NEWS
[packages/systemd.git] / systemd.spec
index 531bdafa9812b1d87d63a862e003e034e95f6538..d0a61892bba2fc14b14645e70d23d955041de11f 100644 (file)
@@ -28,14 +28,14 @@ Summary:    A System and Service Manager
 Summary(pl.UTF-8):     systemd - zarządca systemu i usług dla Linuksa
 Name:          systemd
 # Verify ChangeLog and NEWS when updating (since there are incompatible/breaking changes very often)
-Version:       243
-Release:       2
+Version:       245
+Release:       0.1
 Epoch:         1
 License:       GPL v2+ (udev), LGPL v2.1+ (the rest)
 Group:         Base
 #Source0Download: https://github.com/systemd/systemd/releases
 Source0:       https://github.com/systemd/systemd/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: ca2403fa7dff73afd2e896b4cb25021b
+# Source0-md5: 04f02d9841ea5992a16f6b03c873da28
 Source1:       %{name}-sysv-convert
 Source2:       %{name}_booted.c
 Source3:       network.service
@@ -66,7 +66,7 @@ Patch1:               config-pld.patch
 Patch2:                pld-sysv-network.patch
 Patch3:                tmpfiles-not-fatal.patch
 Patch4:                udev-ploop-rules.patch
-Patch5:                udevadm-in-sbin.patch
+
 Patch6:                net-rename-revert.patch
 Patch7:                %{name}-completion.patch
 Patch8:                proc-hidepid.patch
@@ -76,6 +76,7 @@ Patch11:      optional-tmp-on-tmpfs.patch
 Patch12:       uids_gids.patch
 Patch13:       sysctl.patch
 Patch14:       pld-pam-%{name}-user.patch
+Patch15:       %{name}-x32.patch
 URL:           https://www.freedesktop.org/wiki/Software/systemd/
 BuildRequires: acl-devel
 %{?with_audit:BuildRequires:   audit-libs-devel}
@@ -660,7 +661,7 @@ Uzupełnianie parametrów w zsh dla poleceń udev.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
+
 # rejected upstream (do not disable!)
 %patch6 -p1
 %patch7 -p1
@@ -671,9 +672,12 @@ Uzupełnianie parametrów w zsh dla poleceń udev.
 %patch12 -p1
 %patch13 -p1
 %patch14 -p1
+%patch15 -p1
 
 cp -p %{SOURCE2} src/systemd_booted.c
 
+grep -rlZ -0 '#!/usr/bin/env bash' . | xargs -0 sed -i -e 's,#!/usr/bin/env bash,#!/bin/bash,g'
+
 %build
 %meson build \
        -Daudit=%{__true_false audit} \
@@ -681,9 +685,7 @@ cp -p %{SOURCE2} src/systemd_booted.c
        -Ddefault-kill-user-processes=false \
        %{?debug:--buildtype=debug} \
        -Defi=%{__true_false efi} \
-       -Dhalt-local=/sbin/halt.local \
        -Dkexec-path=/sbin/kexec \
-       -Dkill-path=/bin/kill \
        -Dkmod-path=/sbin/kmod \
        -Dlibcryptsetup=%{__true_false cryptsetup} \
        -Dlibidn2=true \
@@ -703,7 +705,6 @@ cp -p %{SOURCE2} src/systemd_booted.c
        -Drc-local=/etc/rc.d/rc.local \
        -Drootlibdir=/%{_lib} \
        -Drootprefix="" \
-       -Drootsbindir=%{_rootsbindir} \
        -Dselinux=%{__true_false selinux} \
        -Dsetfont-path=/bin/setfont \
        -Dsplit-bin=true \
@@ -726,7 +727,8 @@ install -d $RPM_BUILD_ROOT/var/lib/{%{name}/{catalog,coredump},machines} \
        $RPM_BUILD_ROOT%{_rootsbindir} \
        $RPM_BUILD_ROOT%{_sysconfdir}/{modprobe.d,systemd/system-preset} \
        $RPM_BUILD_ROOT%{systemduserunitdir}/sockets.target.wants \
-       $RPM_BUILD_ROOT%{systemdunitdir}/{final,sound,system-update}.target.wants
+       $RPM_BUILD_ROOT%{systemdunitdir}/{final,sound,system-update}.target.wants \
+       $RPM_BUILD_ROOT%{_prefix}/lib/systemd/system-environment-generators
 
 %meson_install -C build
 
@@ -747,7 +749,7 @@ ln -s /lib/udev/udevd $RPM_BUILD_ROOT/lib/systemd/systemd-udevd
 ln -s /lib/udev/udevd $RPM_BUILD_ROOT%{_rootsbindir}/udevd
 
 # compat symlinks for "/ merged into /usr" programs
-ln -s %{_rootsbindir}/udevadm $RPM_BUILD_ROOT/bin
+ln -s ../bin/udevadm $RPM_BUILD_ROOT%{_rootsbindir}
 ln -s /lib/udev $RPM_BUILD_ROOT%{_prefix}/lib
 
 # install custom udev rules from pld package
@@ -1067,14 +1069,14 @@ fi
 %endif
 
 %triggerpostun -n udev-core -- udev < 165
-/sbin/udevadm info --convert-db
+/bin/udevadm info --convert-db
 
 %post -n udev-core
-/sbin/udevadm hwdb --update || :
+/bin/udevadm hwdb --update || :
 if [ $1 -gt 1 ]; then
        if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
                if grep -qs devtmpfs /proc/mounts && [ -n "$(pidof udevd)" ]; then
-                       /sbin/udevadm control --exit
+                       /bin/udevadm control --exit
                        /lib/udev/udevd --daemon
                fi
        else
@@ -1159,6 +1161,7 @@ fi
 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
 %attr(755,root,root) %{_bindir}/systemd-umount
 %attr(755,root,root) %{_bindir}/timedatectl
+%attr(755,root,root) %{_bindir}/userdbctl
 /lib/modprobe.d/systemd.conf
 /lib/systemd/import-pubring.gpg
 /lib/systemd/resolv.conf
@@ -1343,6 +1346,7 @@ fi
 %{_mandir}/man1/systemd-tty-ask-password-agent.1*
 %{_mandir}/man1/systemd-umount.1*
 %{_mandir}/man1/timedatectl.1*
+%{_mandir}/man1/userdbctl.1*
 %{_mandir}/man5/binfmt.d.5*
 %{_mandir}/man5/coredump.conf.5*
 %{_mandir}/man5/coredump.conf.d.5*
@@ -1429,7 +1433,7 @@ fi
 %{_mandir}/man8/systemd-machine-id-commit.service.8*
 %{_mandir}/man8/systemd-makefs.8*
 %{_mandir}/man8/systemd-makefs@.service.8*
-%{_mandir}/man8/systemd-makeswap@.service.8*
+%{_mandir}/man8/systemd-mkswap@.service.8*
 %{_mandir}/man8/systemd-modules-load.8*
 %{_mandir}/man8/systemd-pstore.8*
 %{_mandir}/man8/systemd-pstore.service.8*
@@ -1536,6 +1540,7 @@ fi
 %attr(755,root,root) %{_prefix}/lib/systemd/user-environment-generators/30-systemd-environment-d-generator
 %dir %{_prefix}/lib/systemd/user-preset
 %{_prefix}/lib/systemd/user-preset/90-systemd.preset
+%dir %{_prefix}/lib/systemd/system-environment-generators
 %dir /lib/systemd/ntp-units.d
 /lib/systemd/ntp-units.d/80-systemd-timesync.list
 %dir /lib/systemd/pld-helpers.d
@@ -1907,6 +1912,7 @@ fi
 /lib/systemd/network/80-container-host0.network
 /lib/systemd/network/80-container-ve.network
 /lib/systemd/network/80-container-vz.network
+/lib/systemd/network/80-wifi-adhoc.network
 %{systemdunitdir}/systemd-network-generator.service
 %{systemdunitdir}/systemd-networkd-wait-online.service
 %{systemdunitdir}/systemd-networkd.service
@@ -2069,6 +2075,7 @@ fi
 
 %attr(755,root,root) /lib/udev/ata_id
 %attr(755,root,root) /lib/udev/cdrom_id
+%attr(755,root,root) /lib/udev/fido_id
 %attr(755,root,root) /lib/udev/mtd_probe
 %attr(755,root,root) /lib/udev/scsi_id
 %attr(755,root,root) /lib/udev/v4l_id
@@ -2087,6 +2094,7 @@ fi
 /lib/udev/hwdb.d/20-usb-vendor-model.hwdb
 /lib/udev/hwdb.d/20-vmbus-class.hwdb
 /lib/udev/hwdb.d/60-evdev.hwdb
+/lib/udev/hwdb.d/60-input-id.hwdb
 /lib/udev/hwdb.d/60-keyboard.hwdb
 /lib/udev/hwdb.d/60-sensor.hwdb
 /lib/udev/hwdb.d/70-joystick.hwdb
@@ -2118,16 +2126,19 @@ fi
 
 # rules below are NOT supposed to be changed by users
 /lib/udev/rules.d/50-udev-default.rules
+/lib/udev/rules.d/60-autosuspend-chromiumos.rules
 /lib/udev/rules.d/60-block.rules
 /lib/udev/rules.d/60-cdrom_id.rules
 /lib/udev/rules.d/60-drm.rules
 /lib/udev/rules.d/60-evdev.rules
+/lib/udev/rules.d/60-fido-id.rules
 /lib/udev/rules.d/60-persistent-alsa.rules
 /lib/udev/rules.d/60-persistent-input.rules
 /lib/udev/rules.d/60-persistent-storage.rules
 /lib/udev/rules.d/60-persistent-storage-tape.rules
 /lib/udev/rules.d/60-persistent-v4l.rules
 /lib/udev/rules.d/60-serial.rules
+/lib/udev/rules.d/61-autosuspend-manual.rules
 /lib/udev/rules.d/64-btrfs.rules
 /lib/udev/rules.d/70-mouse.rules
 /lib/udev/rules.d/70-power-switch.rules
This page took 0.037817 seconds and 4 git commands to generate.