]> git.pld-linux.org Git - packages/systemd.git/blobdiff - systemd.spec
- this version is broken in an interesting way, rebooted during upgrade
[packages/systemd.git] / systemd.spec
index feae58e130c6db506373641faef38304e39cd134..bb0363eb1604821da35e2592601afddbf84579f8 100644 (file)
@@ -28,14 +28,14 @@ Summary:    A System and Service Manager
 Summary(pl.UTF-8):     systemd - zarządca systemu i usług dla Linuksa
 Name:          systemd
 # Verify ChangeLog and NEWS when updating (since there are incompatible/breaking changes very often)
-Version:       244
-Release:       0.1
+Version:       245
+Release:       1.1
 Epoch:         1
 License:       GPL v2+ (udev), LGPL v2.1+ (the rest)
 Group:         Base
 #Source0Download: https://github.com/systemd/systemd/releases
 Source0:       https://github.com/systemd/systemd/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 413121fe918b252ae62310f6fc7c4b32
+# Source0-md5: 04f02d9841ea5992a16f6b03c873da28
 Source1:       %{name}-sysv-convert
 Source2:       %{name}_booted.c
 Source3:       network.service
@@ -66,7 +66,7 @@ Patch1:               config-pld.patch
 Patch2:                pld-sysv-network.patch
 Patch3:                tmpfiles-not-fatal.patch
 Patch4:                udev-ploop-rules.patch
-Patch5:                udevadm-in-sbin.patch
+
 Patch6:                net-rename-revert.patch
 Patch7:                %{name}-completion.patch
 Patch8:                proc-hidepid.patch
@@ -440,6 +440,23 @@ responder LLMNR.
 Generuje także dla zgodności plik /run/systemd/resolve/resolv.conf,
 który można użyć do dowiązania symbolicznego z /etc/resolv.conf.
 
+%package userdb
+Summary:       systemd userdb service and client tool
+Group:         Base
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description userdb
+userdb component is a framework which allows defining rich user and
+group records in a JSON format, extending on the classic "struct
+passwd" and "struct group" structures. Various components in systemd
+have been updated to process records in this format, including
+systemd-logind and pam-systemd. The user records are intended to be
+extensible, and allow setting various resource management, security
+and runtime parameters that shall be applied to processes and sessions
+of the user as they log in. This facility is intended to allow
+associating such metadata directly with user/group records so that
+they can be produced, extended and consumed in unified form.
+
 %package inetd
 Summary:       Native inet service support for systemd via socket activation
 Summary(pl.UTF-8):     Natywna obsługa usług inet dla systemd
@@ -661,7 +678,7 @@ Uzupełnianie parametrów w zsh dla poleceń udev.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
+
 # rejected upstream (do not disable!)
 %patch6 -p1
 %patch7 -p1
@@ -676,6 +693,8 @@ Uzupełnianie parametrów w zsh dla poleceń udev.
 
 cp -p %{SOURCE2} src/systemd_booted.c
 
+grep -rlZ -0 '#!/usr/bin/env bash' . | xargs -0 sed -i -e 's,#!/usr/bin/env bash,#!/bin/bash,g'
+
 %build
 %meson build \
        -Daudit=%{__true_false audit} \
@@ -683,9 +702,7 @@ cp -p %{SOURCE2} src/systemd_booted.c
        -Ddefault-kill-user-processes=false \
        %{?debug:--buildtype=debug} \
        -Defi=%{__true_false efi} \
-       -Dhalt-local=/sbin/halt.local \
        -Dkexec-path=/sbin/kexec \
-       -Dkill-path=/bin/kill \
        -Dkmod-path=/sbin/kmod \
        -Dlibcryptsetup=%{__true_false cryptsetup} \
        -Dlibidn2=true \
@@ -705,7 +722,6 @@ cp -p %{SOURCE2} src/systemd_booted.c
        -Drc-local=/etc/rc.d/rc.local \
        -Drootlibdir=/%{_lib} \
        -Drootprefix="" \
-       -Drootsbindir=%{_rootsbindir} \
        -Dselinux=%{__true_false selinux} \
        -Dsetfont-path=/bin/setfont \
        -Dsplit-bin=true \
@@ -718,7 +734,7 @@ cp -p %{SOURCE2} src/systemd_booted.c
 
 %meson_build -C build
 
-%{__cc} %{rpmcppflags} %{rpmcflags} -o build/systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd
+%{__cc} %{rpmcppflags} %{rpmcflags} -o build/systemd_booted %{rpmldflags} src/systemd_booted.c -Lbuild -lsystemd
 
 %{?with_tests:%meson_test -C build}
 
@@ -728,7 +744,9 @@ install -d $RPM_BUILD_ROOT/var/lib/{%{name}/{catalog,coredump},machines} \
        $RPM_BUILD_ROOT%{_rootsbindir} \
        $RPM_BUILD_ROOT%{_sysconfdir}/{modprobe.d,systemd/system-preset} \
        $RPM_BUILD_ROOT%{systemduserunitdir}/sockets.target.wants \
-       $RPM_BUILD_ROOT%{systemdunitdir}/{final,sound,system-update}.target.wants
+       $RPM_BUILD_ROOT%{systemdunitdir}/{final,sound,system-update}.target.wants \
+       $RPM_BUILD_ROOT%{systemdunitdir}/systemd-udevd.service.d \
+       $RPM_BUILD_ROOT%{_prefix}/lib/systemd/system-environment-generators
 
 %meson_install -C build
 
@@ -749,7 +767,7 @@ ln -s /lib/udev/udevd $RPM_BUILD_ROOT/lib/systemd/systemd-udevd
 ln -s /lib/udev/udevd $RPM_BUILD_ROOT%{_rootsbindir}/udevd
 
 # compat symlinks for "/ merged into /usr" programs
-ln -s %{_rootsbindir}/udevadm $RPM_BUILD_ROOT/bin
+ln -s ../bin/udevadm $RPM_BUILD_ROOT%{_rootsbindir}
 ln -s /lib/udev $RPM_BUILD_ROOT%{_prefix}/lib
 
 # install custom udev rules from pld package
@@ -1069,14 +1087,14 @@ fi
 %endif
 
 %triggerpostun -n udev-core -- udev < 165
-/sbin/udevadm info --convert-db
+/bin/udevadm info --convert-db
 
 %post -n udev-core
-/sbin/udevadm hwdb --update || :
+/bin/udevadm hwdb --update || :
 if [ $1 -gt 1 ]; then
        if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
                if grep -qs devtmpfs /proc/mounts && [ -n "$(pidof udevd)" ]; then
-                       /sbin/udevadm control --exit
+                       /bin/udevadm control --exit
                        /lib/udev/udevd --daemon
                fi
        else
@@ -1294,11 +1312,13 @@ fi
 %ifarch %{x8664}
 %{_prefix}/lib/sysctl.d/50-pid-max.conf
 %endif
+%{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
 %{_datadir}/dbus-1/system-services/org.freedesktop.import1.service
 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
 %{_datadir}/dbus-1/system-services/org.freedesktop.machine1.service
+%{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
 %{_datadir}/dbus-1/system-services/org.freedesktop.timesync1.service
 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
@@ -1350,6 +1370,7 @@ fi
 %{_mandir}/man5/coredump.conf.d.5*
 %{_mandir}/man5/dnssec-trust-anchors.d.5*
 %{_mandir}/man5/hostname.5*
+%{_mandir}/man5/journald@.conf.5*
 %{?with_efi:%{_mandir}/man5/loader.conf.5*}
 %if %{with microhttpd}
 %{_mandir}/man5/journal-remote.conf.5*
@@ -1403,7 +1424,11 @@ fi
 %{_mandir}/man8/nss-mymachines.8*
 %{_mandir}/man8/systemd-backlight.8*
 %{_mandir}/man8/systemd-binfmt.8*
-%{?with_efi:%{_mandir}/man8/systemd-bless-boot-generator.8*}
+%if %{with efi}
+%{_mandir}/man8/systemd-bless-boot.8*
+%{_mandir}/man8/systemd-bless-boot-generator.8*
+%endif
+%{_mandir}/man8/systemd-boot-check-no-failures.8*
 %{_mandir}/man8/systemd-coredump.8*
 %{?with_cryptsetup:%{_mandir}/man8/systemd-cryptsetup-generator.8*}
 %{_mandir}/man8/systemd-debug-generator.8*
@@ -1420,7 +1445,10 @@ fi
 %{_mandir}/man8/systemd-importd.8*
 %{_mandir}/man8/systemd-initctl.8*
 %{_mandir}/man8/systemd-journald-dev-log.socket.8*
+%{_mandir}/man8/systemd-journald-varlink@.socket.8*
 %{_mandir}/man8/systemd-journald.8*
+%{_mandir}/man8/systemd-journald@.service.8*
+%{_mandir}/man8/systemd-journald@.socket.8*
 %if %{with microhttpd}
 %{_mandir}/man8/systemd-journal-remote.8*
 %{_mandir}/man8/systemd-journal-upload.8*
@@ -1538,6 +1566,7 @@ fi
 %attr(755,root,root) %{_prefix}/lib/systemd/user-environment-generators/30-systemd-environment-d-generator
 %dir %{_prefix}/lib/systemd/user-preset
 %{_prefix}/lib/systemd/user-preset/90-systemd.preset
+%dir %{_prefix}/lib/systemd/system-environment-generators
 %dir /lib/systemd/ntp-units.d
 /lib/systemd/ntp-units.d/80-systemd-timesync.list
 %dir /lib/systemd/pld-helpers.d
@@ -1564,6 +1593,7 @@ fi
 %{systemdunitdir}/sys-fs-fuse-connections.mount
 %{systemdunitdir}/sys-kernel-config.mount
 %{systemdunitdir}/sys-kernel-debug.mount
+%{systemdunitdir}/sys-kernel-tracing.mount
 %{systemdunitdir}/systemd-coredump@.service
 %{systemdunitdir}/systemd-coredump.socket
 %{systemdunitdir}/systemd-exit.service
@@ -1598,6 +1628,7 @@ fi
 %{systemdunitdir}/killall.service
 %{systemdunitdir}/kmod-static-nodes.service
 %{systemdunitdir}/ldconfig.service
+%{systemdunitdir}/modprobe@.service
 %{systemdunitdir}/netfs.service
 %{systemdunitdir}/network.service
 %{systemdunitdir}/pld-clean-tmp.service
@@ -1636,6 +1667,7 @@ fi
 %{systemdunitdir}/systemd-journal-remote.service
 %{systemdunitdir}/systemd-journal-upload.service
 %{systemdunitdir}/systemd-journald.service
+%{systemdunitdir}/systemd-journald@.service
 %{systemdunitdir}/systemd-kexec.service
 %{systemdunitdir}/systemd-localed.service
 %{systemdunitdir}/systemd-logind.service
@@ -1662,6 +1694,7 @@ fi
 %{systemdunitdir}/systemd-udev-settle.service
 %{systemdunitdir}/systemd-udev-trigger.service
 %{systemdunitdir}/systemd-udevd.service
+%dir %{systemdunitdir}/systemd-udevd.service.d
 %{systemdunitdir}/systemd-update-done.service
 %{systemdunitdir}/systemd-update-utmp-runlevel.service
 %{systemdunitdir}/systemd-update-utmp.service
@@ -1671,6 +1704,7 @@ fi
 %{systemdunitdir}/user@.service
 %{systemdunitdir}/machine.slice
 #%{systemdunitdir}/system.slice
+%{?with_cryptsetup:%{systemdunitdir}/system-systemd\x2dcryptsetup.slice}
 %dir %{systemdunitdir}/user-.slice.d
 %{systemdunitdir}/user-.slice.d/10-defaults.conf
 %{systemdunitdir}/user-runtime-dir@.service
@@ -1681,10 +1715,13 @@ fi
 %{systemdunitdir}/systemd-journal-remote.socket
 %{systemdunitdir}/systemd-journald-audit.socket
 %{systemdunitdir}/systemd-journald-dev-log.socket
+%{systemdunitdir}/systemd-journald-varlink@.socket
 %{systemdunitdir}/systemd-journald.socket
+%{systemdunitdir}/systemd-journald@.socket
 %{systemdunitdir}/systemd-udevd-control.socket
 %{systemdunitdir}/systemd-udevd-kernel.socket
 %{systemdunitdir}/basic.target
+%{systemdunitdir}/blockdev@.target
 %{systemdunitdir}/bluetooth.target
 %{systemdunitdir}/boot-complete.target
 %{?with_cryptsetup:%{systemdunitdir}/cryptsetup-pre.target}
@@ -1800,6 +1837,7 @@ fi
 %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
 %{systemdunitdir}/sysinit.target.wants/sys-fs-fuse-connections.mount
 %{systemdunitdir}/sysinit.target.wants/sys-kernel-debug.mount
+%{systemdunitdir}/sysinit.target.wants/sys-kernel-tracing.mount
 %{systemdunitdir}/sysinit.target.wants/systemd-ask-password-console.path
 %{systemdunitdir}/sysinit.target.wants/systemd-binfmt.service
 %{?with_efi:%{systemdunitdir}/sysinit.target.wants/systemd-boot-system-token.service}
@@ -1924,6 +1962,8 @@ fi
 %{_mandir}/man5/networkd.conf.5*
 %{_mandir}/man5/networkd.conf.d.5*
 %{_mandir}/man7/systemd.net-naming-scheme.7*
+%{_mandir}/man8/systemd-network-generator.8*
+%{_mandir}/man8/systemd-network-generator.service.8*
 %{_mandir}/man8/systemd-networkd-wait-online.8*
 %{_mandir}/man8/systemd-networkd-wait-online.service.8*
 %{_mandir}/man8/systemd-networkd.8*
@@ -1971,6 +2011,19 @@ fi
 %{_mandir}/man8/systemd-resolved.8*
 %{_mandir}/man8/systemd-resolved.service.8*
 
+%files userdb
+%defattr(644,root,root,755)
+%doc docs/GROUP_RECORD.md docs/USER_GROUP_API.md docs/USER_RECORD.md
+%attr(755,root,root) /bin/userdbctl
+%attr(755,root,root) /lib/systemd/systemd-userdbd
+%attr(755,root,root) /lib/systemd/systemd-userwork
+%{systemdunitdir}/sockets.target.wants/systemd-userdbd.socket
+%{systemdunitdir}/systemd-userdbd.service
+%{systemdunitdir}/systemd-userdbd.socket
+%{_mandir}/man8/systemd-userdbd.8*
+%{_mandir}/man8/systemd-userdbd.service.8*
+%{_mandir}/man1/userdbctl.1*
+
 %files inetd
 %defattr(644,root,root,755)
 %attr(755,root,root) %{systemdunitdir}-generators/pld-rc-inetd-generator
@@ -2091,6 +2144,7 @@ fi
 /lib/udev/hwdb.d/20-usb-vendor-model.hwdb
 /lib/udev/hwdb.d/20-vmbus-class.hwdb
 /lib/udev/hwdb.d/60-evdev.hwdb
+/lib/udev/hwdb.d/60-input-id.hwdb
 /lib/udev/hwdb.d/60-keyboard.hwdb
 /lib/udev/hwdb.d/60-sensor.hwdb
 /lib/udev/hwdb.d/70-joystick.hwdb
This page took 0.050136 seconds and 4 git commands to generate.