]> git.pld-linux.org Git - packages/systemd.git/blobdiff - systemd.spec
Added upstream patch to disable runlevel hacks
[packages/systemd.git] / systemd.spec
index 7c55f2c8aad4bc3f7dfb49b4db3ac3ad44e35cc3..a74a94fa81997b0c112cce56ab015cb362031572 100644 (file)
@@ -6,10 +6,14 @@
 # - dev->udev upgrade:
 #   - /dev/urandom remains missing, not created with start_udev anymore
 #
+#      /usr/share/factory/etc/nsswitch.conf
+#      /usr/share/factory/etc/pam.d/other
+#      /usr/share/factory/etc/pam.d/system-auth
+#
 # Conditional build:
 %bcond_without audit           # without audit support
 %bcond_without cryptsetup      # without cryptsetup support
-%bcond_without microhttpd      # microhttpd support
+%bcond_without microhttpd      # use microhttpd for network journal access
 %bcond_without pam             # PAM authentication support
 %bcond_without qrencode        # QRencode support
 %bcond_without selinux         # without SELinux support
@@ -20,13 +24,13 @@ Summary:    A System and Service Manager
 Summary(pl.UTF-8):     systemd - zarządca systemu i usług dla Linuksa
 Name:          systemd
 # Verify ChangeLog and NEWS when updating (since there are incompatible/breaking changes very often)
-Version:       218
-Release:       0.1
+Version:       219
+Release:       1.2
 Epoch:         1
 License:       GPL v2+ (udev), LGPL v2.1+ (the rest)
 Group:         Base
 Source0:       http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
-# Source0-md5: 4e2c511b0a7932d7fc9d79822273aac6
+# Source0-md5: e0d6c9a4b4f69f66932d2230298c9a34
 Source1:       %{name}-sysv-convert
 Source2:       %{name}_booted.c
 Source3:       network.service
@@ -57,7 +61,6 @@ Patch1:               config-pld.patch
 Patch2:                shut-sysv-up.patch
 Patch3:                pld-sysv-network.patch
 Patch4:                tmpfiles-not-fatal.patch
-Patch5:                ignore-sysv-if-native-exists.patch
 Patch8:                udev-ploop-rules.patch
 Patch9:                udevadm-in-sbin.patch
 Patch10:       net-rename-revert.patch
@@ -67,6 +70,9 @@ Patch14:      dont-hash-null-keys.patch
 Patch16:       systemd-configfs.patch
 Patch17:       pld-boot_efi_mount.patch
 Patch18:       optional-tmp-on-tmpfs.patch
+Patch19:       uids_gids.patch
+Patch20:       sysv-symlinks-warning.patch
+Patch21:       no-configurable-runlevels.patch
 URL:           http://www.freedesktop.org/wiki/Software/systemd
 BuildRequires: acl-devel
 BuildRequires: attr-devel
@@ -140,7 +146,19 @@ Suggests:  ConsoleKit
 Suggests:      fsck >= 2.25.0
 Suggests:      service(klogd)
 Suggests:      service(syslog)
+Provides:      group(systemd-bus-proxy)
+Provides:      group(systemd-network)
+Provides:      group(systemd-resolve)
+Provides:      group(systemd-timesync)
 Provides:      group(systemd-journal)
+Provides:      group(systemd-journal-remote)
+Provides:      group(systemd-journal-upload)
+Provides:      user(systemd-bus-proxy)
+Provides:      user(systemd-network)
+Provides:      user(systemd-resolve)
+Provides:      user(systemd-timesync)
+Provides:      user(systemd-journal-remote)
+Provides:      user(systemd-journal-upload)
 Provides:      udev-acl = %{epoch}:%{version}-%{release}
 Obsoletes:     systemd-no-compat-tmpfiles
 Obsoletes:     udev-systemd
@@ -327,6 +345,45 @@ HTTP.
 systemd-journal-gatewayd serwuje zdarzenia dziennika po sieci poprzez
 HTTP.
 
+%package networkd
+Summary:       systemd network manager
+Summary(pl.UTF-8):     Zarządca sieci systemd
+Group:         Base
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Suggests:      %{name}-resolved = %{epoch}:%{version}-%{release}
+
+%description networkd
+systemd-networkd is a system service that manages networks. It detects
+and configures network devices as they appear, as well as creating
+virtual network devices.
+
+%description networkd -l pl.UTF-8
+systemd-networkd to usługa systemowa zarządzająca siecią. Wykrywa
+i konfiguruje interfejsy sieciowe gdy się pojawiają, a także tworzy
+wirtualne urządzenia sieciowe.
+
+%package resolved
+Summary:       systemd network name resolution manager
+Summary(pl.UTF-8):     Zarządca rozwiązywania nazw sieciowych systemd
+Group:         Base
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description resolved
+systemd-resolved is a system service that manages network name
+resolution. It implements a caching DNS stub resolver and an LLMNR
+resolver and responder.
+
+It also generates /run/systemd/resolve/resolv.conf for compatibility
+which may be symlinked from /etc/resolv.conf.
+
+%description resolved -l pl.UTF-8
+systemd-resolved to usługa systemowa zarządzająca rozwiązywaniem nazw
+sieciowych. Implementuje keszujący resolver DNS oraz resolver i
+responder LLMNR.
+
+Generuje także dla zgodności plik /run/systemd/resolve/resolv.conf,
+który można użyć do dowiązania symbolicznego z /etc/resolv.conf.
+
 %package inetd
 Summary:       Native inet service support for systemd via socket activation
 Summary(pl.UTF-8):     Natywna obsługa usług inet dla systemd
@@ -479,7 +536,7 @@ Requires:   filesystem >= 3.0-45
 Requires:      kmod >= 14
 Requires:      libblkid >= 2.20
 %{?with_selinux:Requires:      libselinux >= 2.1.9}
-Requires:      setup >= 2.6.1-1
+Requires:      setup >= 2.9.0-3
 Requires:      udev-libs = %{epoch}:%{version}-%{release}
 Requires:      uname(release) >= 2.6.32
 #Suggests:     uname(release) >= 3.7
@@ -617,7 +674,6 @@ Uzupełnianie parametrów w zsh dla poleceń udev.
 #patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
 %patch8 -p1
 %patch9 -p1
 # rejected upstream
@@ -629,6 +685,9 @@ Uzupełnianie parametrów w zsh dla poleceń udev.
 %patch16 -p1
 %patch17 -p1
 %patch18 -p1
+%patch19 -p1
+%patch20 -p1
+%patch21 -p1
 cp -p %{SOURCE2} src/systemd_booted.c
 
 %build
@@ -678,7 +737,7 @@ cp -p %{SOURCE2} src/systemd_booted.c
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/var/lib/%{name}/coredump \
+install -d $RPM_BUILD_ROOT/var/lib/{%{name}/coredump,machines} \
        $RPM_BUILD_ROOT{%{_sysconfdir}/{modprobe.d,systemd/system-preset},%{_sbindir}}
 
 %{__make} install \
@@ -805,6 +864,11 @@ install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
 # Create directory for service helper scripts
 install -d $RPM_BUILD_ROOT/lib/systemd/pld-helpers.d
 
+# to be enabled only when the packages are installed
+%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants/systemd-networkd.service
+%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants/systemd-networkd.socket
+%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants/systemd-resolved.service
+
 install -d $RPM_BUILD_ROOT/var/log
 :> $RPM_BUILD_ROOT/var/log/btmp
 :> $RPM_BUILD_ROOT/var/log/wtmp
@@ -823,6 +887,18 @@ rm -rf $RPM_BUILD_ROOT
 
 %pre
 %groupadd -g 288 systemd-journal
+%groupadd -g 315 systemd-bus-proxy
+%useradd -u 315 -g 315 -d /var/log/journal -s /bin/false -c "Systemd Bus Proxy" systemd-bus-proxy
+%groupadd -g 316 systemd-network
+%useradd -u 316 -g 316 -d /var/log/journal -s /bin/false -c "Systemd Network Management" systemd-network
+%groupadd -g 317 systemd-resolve
+%useradd -u 317 -g 317 -d /var/log/journal -s /bin/false -c "Systemd Resolver" systemd-resolve
+%groupadd -g 318 systemd-timesync
+%useradd -u 318 -g 318 -d /var/log/journal -s /bin/false -c "Systemd Time Synchronization" systemd-timesync
+%groupadd -g 319 systemd-journal-remote
+%useradd -u 319 -g 319 -d /var/log/journal -s /bin/false -c "Systemd Journal Remote" systemd-journal-remote
+%groupadd -g 320 systemd-journal-upload
+%useradd -u 320 -g 320 -d /var/log/journal -s /bin/false -c "Systemd Journal Upload" systemd-journal-upload
 
 %post
 /bin/systemd-machine-id-setup || :
@@ -955,6 +1031,24 @@ if [ "$1" = "0" ]; then
        %groupremove systemd-journal-gateway
 fi
 
+%post networkd
+%systemd_post systemd-networkd.socket systemd-networkd.service
+
+%preun networkd
+%systemd_preun systemd-networkd.socket systemd-networkd.service
+
+%postun networkd
+%systemd_reload
+
+%post resolved
+%systemd_post systemd-resolved.service
+
+%preun resolved
+%systemd_preun systemd-resolved.service
+
+%postun resolved
+%systemd_reload
+
 %triggerpostun -n udev-core -- dev
 if [ "$2" = 0 ]; then
        # need to kill and restart udevd as after obsoleting dev package the
@@ -1003,10 +1097,10 @@ fi
 %defattr(644,root,root,755)
 %doc DISTRO_PORTING NEWS README TODO
 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
+/etc/dbus-1/system.d/org.freedesktop.import1.conf
 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
 /etc/dbus-1/system.d/org.freedesktop.login1.conf
 /etc/dbus-1/system.d/org.freedesktop.machine1.conf
-/etc/dbus-1/system.d/org.freedesktop.resolve1.conf
 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
 %ghost %config(noreplace) %{_sysconfdir}/machine-id
@@ -1017,24 +1111,28 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/bootchart.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/coredump.conf
+%if %{with microhttpd}
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/journal-remote.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/journal-upload.conf
+%endif
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/journald.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/logind.conf
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/resolved.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/timesyncd.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/user.conf
 %dir %{_sysconfdir}/systemd/user
-%dir %{_sysconfdir}/systemd/system/*.target.wants
-%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.service
-%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.target
+%dir %{_sysconfdir}/systemd/system/getty.target.wants
+%dir %{_sysconfdir}/systemd/system/multi-user.target.wants
+%dir %{_sysconfdir}/systemd/system/sockets.target.wants
+%dir %{_sysconfdir}/systemd/system/sysinit.target.wants
+%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/getty.target.wants/getty@tty1.service
+%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/sysinit.target.wants/systemd-timesyncd.service
+%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/multi-user.target.wants/remote-fs.target
 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/systemd-user
 /etc/xdg/systemd
 %attr(755,root,root) /bin/journalctl
 %attr(755,root,root) /bin/loginctl
 %attr(755,root,root) /bin/machinectl
-%attr(755,root,root) /bin/networkctl
 %attr(755,root,root) /bin/systemd
 %attr(755,root,root) /bin/systemd-ask-password
 %attr(755,root,root) /bin/systemd-escape
@@ -1061,6 +1159,7 @@ fi
 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
 %attr(755,root,root) %{_bindir}/timedatectl
+/lib/systemd/import-pubring.gpg
 %attr(755,root,root) /lib/systemd/pld-clean-tmp
 %attr(755,root,root) /lib/systemd/pld-storage-init
 %attr(755,root,root) /lib/systemd/systemd-ac-power
@@ -1075,23 +1174,24 @@ fi
 %attr(755,root,root) /lib/systemd/systemd-fsck
 %attr(755,root,root) /lib/systemd/systemd-hibernate-resume
 %attr(755,root,root) /lib/systemd/systemd-hostnamed
+%attr(755,root,root) /lib/systemd/systemd-importd
 %attr(755,root,root) /lib/systemd/systemd-initctl
 %attr(755,root,root) /lib/systemd/systemd-journald
+%if %{with microhttpd}
 %attr(755,root,root) /lib/systemd/systemd-journal-remote
 %attr(755,root,root) /lib/systemd/systemd-journal-upload
+%endif
 %attr(755,root,root) /lib/systemd/systemd-localed
 %attr(755,root,root) /lib/systemd/systemd-logind
 %attr(755,root,root) /lib/systemd/systemd-machined
 %attr(755,root,root) /lib/systemd/systemd-machine-id-commit
 %attr(755,root,root) /lib/systemd/systemd-modules-load
-%attr(755,root,root) /lib/systemd/systemd-networkd
-%attr(755,root,root) /lib/systemd/systemd-networkd-wait-online
+%attr(755,root,root) /lib/systemd/systemd-pull
 %attr(755,root,root) /lib/systemd/systemd-quotacheck
 %attr(755,root,root) /lib/systemd/systemd-random-seed
 %attr(755,root,root) /lib/systemd/systemd-remount-fs
 %attr(755,root,root) /lib/systemd/systemd-reply-password
 %attr(755,root,root) /lib/systemd/systemd-resolve-host
-%attr(755,root,root) /lib/systemd/systemd-resolved
 %attr(755,root,root) /lib/systemd/systemd-rfkill
 %attr(755,root,root) /lib/systemd/systemd-shutdown
 %attr(755,root,root) /lib/systemd/systemd-shutdownd
@@ -1106,7 +1206,15 @@ fi
 %attr(755,root,root) /lib/systemd/systemd-user-sessions
 %attr(755,root,root) /lib/systemd/systemd-vconsole-setup
 %attr(755,root,root) /lib/systemd/systemd
-%attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
+%{?with_cryptsetup:%attr(755,root,root) /lib/systemd/system-generators/systemd-cryptsetup-generator}
+%attr(755,root,root) /lib/systemd/system-generators/systemd-debug-generator
+%attr(755,root,root) /lib/systemd/system-generators/systemd-efi-boot-generator
+%attr(755,root,root) /lib/systemd/system-generators/systemd-fstab-generator
+%attr(755,root,root) /lib/systemd/system-generators/systemd-getty-generator
+%attr(755,root,root) /lib/systemd/system-generators/systemd-gpt-auto-generator
+%attr(755,root,root) /lib/systemd/system-generators/systemd-hibernate-resume-generator
+%attr(755,root,root) /lib/systemd/system-generators/systemd-system-update-generator
+%attr(755,root,root) /lib/systemd/system-generators/systemd-sysv-generator
 /lib/udev/rules.d/70-uaccess.rules
 /lib/udev/rules.d/71-seat.rules
 /lib/udev/rules.d/73-seat-late.rules
@@ -1120,36 +1228,44 @@ fi
 %lang(fr) %{_libexecdir}/systemd/catalog/systemd.fr.catalog
 %lang(it) %{_libexecdir}/systemd/catalog/systemd.it.catalog
 %lang(pl) %{_libexecdir}/systemd/catalog/systemd.pl.catalog
+%lang(pt_BR) %{_libexecdir}/systemd/catalog/systemd.pt_BR.catalog
 %lang(ru) %{_libexecdir}/systemd/catalog/systemd.ru.catalog
 %dir %{_libexecdir}/sysusers.d
 %{_libexecdir}/sysusers.d/basic.conf
 %{_libexecdir}/sysusers.d/systemd.conf
+%if %{with microhttpd}
 %{_libexecdir}/sysusers.d/systemd-remote.conf
+%endif
 %{_libexecdir}/tmpfiles.d/etc.conf
 %{_libexecdir}/tmpfiles.d/legacy.conf
 %{_libexecdir}/tmpfiles.d/systemd.conf
 %{_libexecdir}/tmpfiles.d/systemd-nologin.conf
+%if %{with microhttpd}
 %{_libexecdir}/tmpfiles.d/systemd-remote.conf
+%endif
 %{_libexecdir}/tmpfiles.d/tmp.conf
 %{_libexecdir}/tmpfiles.d/var.conf
 %{_libexecdir}/tmpfiles.d/x11.conf
 %{_libexecdir}/sysctl.d/50-coredump.conf
 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
+%{_datadir}/dbus-1/system-services/org.freedesktop.import1.service
 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
 %{_datadir}/dbus-1/system-services/org.freedesktop.machine1.service
-%{_datadir}/dbus-1/system-services/org.freedesktop.resolve1.service
 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
+%{_datadir}/polkit-1/actions/org.freedesktop.import1.policy
 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
+%{_datadir}/polkit-1/actions/org.freedesktop.machine1.policy
 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
 %dir %{_datadir}/systemd
 %{?with_microhttpd:%{_datadir}/systemd/gatewayd}
 %{_datadir}/systemd/kbd-model-map
+%{_datadir}/systemd/language-fallback-map
 %{_mandir}/man1/bootctl.1*
 %{_mandir}/man1/busctl.1*
 %{_mandir}/man1/coredumpctl.1*
@@ -1194,8 +1310,6 @@ fi
 %{_mandir}/man5/machine-info.5*
 %{_mandir}/man5/modules-load.d.5*
 %{_mandir}/man5/os-release.5*
-%{_mandir}/man5/resolved.conf.5*
-%{_mandir}/man5/resolved.conf.d.5*
 %{_mandir}/man5/sleep.conf.d.5*
 %{_mandir}/man5/sysctl.d.5*
 %{_mandir}/man5/system.conf.d.5*
@@ -1213,18 +1327,22 @@ fi
 %{_mandir}/man7/file-hierarchy.7*
 %{_mandir}/man7/kernel-command-line.7*
 %{_mandir}/man7/systemd.directives.7*
+%{_mandir}/man7/systemd.generator.7*
 %{_mandir}/man7/systemd.index.7*
 %{_mandir}/man7/systemd.journal-fields.7*
 %{_mandir}/man7/systemd.special.7*
 %{_mandir}/man7/systemd.time.7*
 %{_mandir}/man8/kernel-install.8*
+%{_mandir}/man8/libnss_myhostname.so.2.8*
+%{_mandir}/man8/libnss_mymachines.so.2.8*
 %{_mandir}/man8/nss-myhostname.8*
+%{_mandir}/man8/nss-mymachines.8*
 %{_mandir}/man8/systemd-activate.8*
 %{_mandir}/man8/systemd-backlight.8*
 %{_mandir}/man8/systemd-binfmt.8*
 %{_mandir}/man8/systemd-coredump.8*
 %{?with_cryptsetup:%{_mandir}/man8/systemd-cryptsetup-generator.8*}
-%{_mandir}/man8/systemd-debug-generator.8.gz
+%{_mandir}/man8/systemd-debug-generator.8*
 %{_mandir}/man8/systemd-fsck.8*
 %{_mandir}/man8/systemd-efi-boot-generator.8*
 %{_mandir}/man8/systemd-gpt-auto-generator.8*
@@ -1235,44 +1353,41 @@ fi
 %{_mandir}/man8/systemd-hibernate-resume@.service.8*
 %{_mandir}/man8/systemd-hostnamed.8*
 %{_mandir}/man8/systemd-initctl.8*
-%{_mandir}/man8/systemd-journald-dev-log.socket.8
+%{_mandir}/man8/systemd-journald-dev-log.socket.8*
 %{_mandir}/man8/systemd-journald.8*
+%if %{with microhttpd}
 %{_mandir}/man8/systemd-journal-remote.8.*
 %{_mandir}/man8/systemd-journal-upload.8.*
+%endif
 %{_mandir}/man8/systemd-localed.8*
 %{_mandir}/man8/systemd-logind.8*
 %{_mandir}/man8/systemd-machined.8*
 %{_mandir}/man8/systemd-machine-id-commit.service.8*
 %{_mandir}/man8/systemd-modules-load.8*
-%{_mandir}/man8/systemd-networkd-wait-online.8
-%{_mandir}/man8/systemd-networkd-wait-online.service.8.*
-%{_mandir}/man8/systemd-networkd.8
-%{_mandir}/man8/systemd-networkd.service.8.gz
 %{_mandir}/man8/systemd-quotacheck.8*
 %{_mandir}/man8/systemd-random-seed.8*
 %{_mandir}/man8/systemd-remount-fs.8*
-%{_mandir}/man8/systemd-resolved.8
-%{_mandir}/man8/systemd-resolved.service.8.gz
-%{_mandir}/man8/systemd-rfkill.8
-%{_mandir}/man8/systemd-rfkill@.service.8.gz
+%{_mandir}/man8/systemd-rfkill.8*
+%{_mandir}/man8/systemd-rfkill@.service.8*
 %{_mandir}/man8/systemd-shutdown.8*
 %{_mandir}/man8/systemd-shutdownd.8*
 %{_mandir}/man8/systemd-sleep.8*
-%{_mandir}/man8/systemd-socket-proxyd.8.gz
+%{_mandir}/man8/systemd-socket-proxyd.8*
 %{_mandir}/man8/systemd-sysctl.8*
 %{_mandir}/man8/systemd-system-update-generator.8*
 %{_mandir}/man8/systemd-sysv-generator.8*
-%{_mandir}/man8/systemd-sysusers.8.gz
-%{_mandir}/man8/systemd-sysusers.service.8
+%{_mandir}/man8/systemd-sysusers.8*
+%{_mandir}/man8/systemd-sysusers.service.8*
 %{_mandir}/man8/systemd-timedated.8*
-%{_mandir}/man8/systemd-timesyncd.8
-%{_mandir}/man8/systemd-timesyncd.service.8.gz
+%{_mandir}/man8/systemd-timesyncd.8*
+%{_mandir}/man8/systemd-timesyncd.service.8*
 %{_mandir}/man8/systemd-udevd.8*
-%{_mandir}/man8/systemd-update-done.8
-%{_mandir}/man8/systemd-update-done.service.8.gz
+%{_mandir}/man8/systemd-update-done.8*
+%{_mandir}/man8/systemd-update-done.service.8*
 %{_mandir}/man8/systemd-update-utmp.8*
 %{_mandir}/man8/systemd-user-sessions.8*
 %{_mandir}/man8/systemd-vconsole-setup.8*
+%dir /var/lib/machines
 %dir /var/lib/%{name}
 %dir /var/lib/%{name}/coredump
 %attr(640,root,root) %ghost /var/log/btmp
@@ -1322,13 +1437,19 @@ fi
 %dir %{_libexecdir}/systemd/system-shutdown
 %dir %{_libexecdir}/systemd/system-sleep
 %dir %{_libexecdir}/systemd/user
-%{_libexecdir}/systemd/user/*.target
+%{_libexecdir}/systemd/user/basic.target
+%{_libexecdir}/systemd/user/bluetooth.target
+%{_libexecdir}/systemd/user/default.target
+%{_libexecdir}/systemd/user/exit.target
+%{_libexecdir}/systemd/user/paths.target
+%{_libexecdir}/systemd/user/printer.target
+%{_libexecdir}/systemd/user/shutdown.target
+%{_libexecdir}/systemd/user/smartcard.target
+%{_libexecdir}/systemd/user/sockets.target
+%{_libexecdir}/systemd/user/sound.target
+%{_libexecdir}/systemd/user/timers.target
 %{_libexecdir}/systemd/user/systemd-exit.service
 %dir %{_libexecdir}/systemd/user-generators
-%dir /lib/systemd/network
-/lib/systemd/network/80-container-host0.network
-/lib/systemd/network/80-container-ve.network
-/lib/systemd/network/99-default.link
 %dir /lib/systemd/pld-helpers.d
 %dir /lib/systemd/system-generators
 %dir /lib/systemd/system-preset
 %{_mandir}/man1/systemctl.1*
 %{_mandir}/man5/tmpfiles.d.5*
 %{_mandir}/man8/systemd-tmpfiles.8*
-%{_npkgconfigdir}/systemd.pc
-
-%{systemdunitdir}/*.automount
-%{systemdunitdir}/*.mount
-%{systemdunitdir}/*.path
-%{systemdunitdir}/*.service
-%{systemdunitdir}/*.slice
+%{_pkgconfigdir}/systemd.pc
+
+%{systemdunitdir}/proc-sys-fs-binfmt_misc.automount
+%{systemdunitdir}/dev-hugepages.mount
+%{systemdunitdir}/dev-mqueue.mount
+%{systemdunitdir}/proc-sys-fs-binfmt_misc.mount
+%{systemdunitdir}/sys-fs-fuse-connections.mount
+%{systemdunitdir}/sys-kernel-config.mount
+%{systemdunitdir}/sys-kernel-debug.mount
+%{systemdunitdir}/tmp.mount
+%{systemdunitdir}/var-lock.mount
+%{systemdunitdir}/var-run.mount
+%{systemdunitdir}/systemd-ask-password-console.path
+%{systemdunitdir}/systemd-ask-password-wall.path
+%{systemdunitdir}/allowlogin.service
+%{systemdunitdir}/autovt@.service
+%{systemdunitdir}/console-getty.service
+%{systemdunitdir}/console-shell.service
+%{systemdunitdir}/console.service
+%{systemdunitdir}/container-getty@.service
+%{systemdunitdir}/cpusets.service
+%{systemdunitdir}/dbus-org.freedesktop.hostname1.service
+%{systemdunitdir}/dbus-org.freedesktop.import1.service
+%{systemdunitdir}/dbus-org.freedesktop.locale1.service
+%{systemdunitdir}/dbus-org.freedesktop.login1.service
+%{systemdunitdir}/dbus-org.freedesktop.machine1.service
+%{systemdunitdir}/dbus-org.freedesktop.timedate1.service
+%{systemdunitdir}/debug-shell.service
+%{systemdunitdir}/display-manager.service
+%{systemdunitdir}/emergency.service
+%{systemdunitdir}/getty@.service
+%{systemdunitdir}/halt-local.service
+%{systemdunitdir}/initrd-cleanup.service
+%{systemdunitdir}/initrd-parse-etc.service
+%{systemdunitdir}/initrd-switch-root.service
+%{systemdunitdir}/initrd-udevadm-cleanup-db.service
+%{systemdunitdir}/killall.service
+%{systemdunitdir}/kmod-static-nodes.service
+%{systemdunitdir}/ldconfig.service
+%{systemdunitdir}/netfs.service
+%{systemdunitdir}/network.service
+%{systemdunitdir}/pld-clean-tmp.service
+%{systemdunitdir}/pld-storage-init-late.service
+%{systemdunitdir}/pld-storage-init.service
+%{systemdunitdir}/pld-wait-storage.service
+%{systemdunitdir}/prefdm.service
+%{systemdunitdir}/quotaon.service
+%{systemdunitdir}/random.service
+%{systemdunitdir}/rescue.service
+%{systemdunitdir}/serial-getty@.service
+%{systemdunitdir}/single.service
+%{systemdunitdir}/sys-kernel-config.service
+%{systemdunitdir}/systemd-ask-password-console.service
+%{systemdunitdir}/systemd-ask-password-wall.service
+%{systemdunitdir}/systemd-backlight@.service
+%{systemdunitdir}/systemd-binfmt.service
+%{systemdunitdir}/systemd-bootchart.service
+%{systemdunitdir}/systemd-firstboot.service
+%{systemdunitdir}/systemd-fsck-root.service
+%{systemdunitdir}/systemd-fsck@.service
+%{systemdunitdir}/systemd-halt.service
+%{systemdunitdir}/systemd-hibernate-resume@.service
+%{systemdunitdir}/systemd-hibernate.service
+%{systemdunitdir}/systemd-hostnamed.service
+%{systemdunitdir}/systemd-hwdb-update.service
+%{systemdunitdir}/systemd-hybrid-sleep.service
+%{systemdunitdir}/systemd-importd.service
+%{systemdunitdir}/systemd-initctl.service
+%{systemdunitdir}/systemd-journal-catalog-update.service
+%{systemdunitdir}/systemd-journal-flush.service
+%{systemdunitdir}/systemd-journal-gatewayd.service
+%{systemdunitdir}/systemd-journal-remote.service
+%{systemdunitdir}/systemd-journal-upload.service
+%{systemdunitdir}/systemd-journald.service
+%{systemdunitdir}/systemd-kexec.service
+%{systemdunitdir}/systemd-localed.service
+%{systemdunitdir}/systemd-logind.service
+%{systemdunitdir}/systemd-machine-id-commit.service
+%{systemdunitdir}/systemd-machined.service
+%{systemdunitdir}/systemd-modules-load.service
+%{systemdunitdir}/systemd-nspawn@.service
+%{systemdunitdir}/systemd-poweroff.service
+%{systemdunitdir}/systemd-quotacheck.service
+%{systemdunitdir}/systemd-random-seed.service
+%{systemdunitdir}/systemd-reboot.service
+%{systemdunitdir}/systemd-remount-fs.service
+%{systemdunitdir}/systemd-rfkill@.service
+%{systemdunitdir}/systemd-shutdownd.service
+%{systemdunitdir}/systemd-suspend.service
+%{systemdunitdir}/systemd-sysctl.service
+%{systemdunitdir}/systemd-sysusers.service
+%{systemdunitdir}/systemd-timedated.service
+%{systemdunitdir}/systemd-timesyncd.service
+%{systemdunitdir}/systemd-tmpfiles-clean.service
+%{systemdunitdir}/systemd-tmpfiles-setup-dev.service
+%{systemdunitdir}/systemd-tmpfiles-setup.service
+%{systemdunitdir}/systemd-udev-settle.service
+%{systemdunitdir}/systemd-udev-trigger.service
+%{systemdunitdir}/systemd-udevd.service
+%{systemdunitdir}/systemd-update-done.service
+%{systemdunitdir}/systemd-update-utmp-runlevel.service
+%{systemdunitdir}/systemd-update-utmp.service
+%{systemdunitdir}/systemd-user-sessions.service
+%{systemdunitdir}/systemd-vconsole-setup.service
+%{systemdunitdir}/user@.service
+%{systemdunitdir}/-.slice
+%{systemdunitdir}/machine.slice
+%{systemdunitdir}/system.slice
+%{systemdunitdir}/user.slice
 %exclude %{systemdunitdir}/rc-inetd.service
-%{systemdunitdir}/*.socket
-%{systemdunitdir}/*.target
-%{systemdunitdir}/*.timer
+%{systemdunitdir}/syslog.socket
+%{systemdunitdir}/systemd-initctl.socket
+%{systemdunitdir}/systemd-journal-remote.socket
+%{systemdunitdir}/systemd-journald-audit.socket
+%{systemdunitdir}/systemd-journald-dev-log.socket
+%{systemdunitdir}/systemd-journald.socket
+%{systemdunitdir}/systemd-shutdownd.socket
+%{systemdunitdir}/systemd-udevd-control.socket
+%{systemdunitdir}/systemd-udevd-kernel.socket
+%{systemdunitdir}/basic.target
+%{systemdunitdir}/bluetooth.target
+%{?with_cryptsetup:%{systemdunitdir}/cryptsetup-pre.target}
+%{?with_cryptsetup:%{systemdunitdir}/cryptsetup.target}
+%{systemdunitdir}/ctrl-alt-del.target
+%{systemdunitdir}/default.target
+%{systemdunitdir}/emergency.target
+%{systemdunitdir}/final.target
+%{systemdunitdir}/getty.target
+%{systemdunitdir}/graphical.target
+%{systemdunitdir}/halt.target
+%{systemdunitdir}/hibernate.target
+%{systemdunitdir}/hybrid-sleep.target
+%{systemdunitdir}/initrd-fs.target
+%{systemdunitdir}/initrd-root-fs.target
+%{systemdunitdir}/initrd-switch-root.target
+%{systemdunitdir}/initrd.target
+%{systemdunitdir}/kexec.target
+%{systemdunitdir}/local-fs-pre.target
+%{systemdunitdir}/local-fs.target
+%{systemdunitdir}/machines.target
+%{systemdunitdir}/multi-user.target
+%{systemdunitdir}/network-online.target
+%{systemdunitdir}/network-pre.target
+%{systemdunitdir}/network.target
+%{systemdunitdir}/nss-lookup.target
+%{systemdunitdir}/nss-user-lookup.target
+%{systemdunitdir}/paths.target
+%{systemdunitdir}/poweroff.target
+%{systemdunitdir}/printer.target
+%{systemdunitdir}/reboot.target
+%{systemdunitdir}/remote-fs-pre.target
+%{systemdunitdir}/remote-fs.target
+%{systemdunitdir}/rescue.target
+%{systemdunitdir}/rpcbind.target
+%{systemdunitdir}/runlevel0.target
+%{systemdunitdir}/runlevel1.target
+%{systemdunitdir}/runlevel2.target
+%{systemdunitdir}/runlevel3.target
+%{systemdunitdir}/runlevel4.target
+%{systemdunitdir}/runlevel5.target
+%{systemdunitdir}/runlevel6.target
+%{systemdunitdir}/shutdown.target
+%{systemdunitdir}/sigpwr.target
+%{systemdunitdir}/sleep.target
+%{systemdunitdir}/slices.target
+%{systemdunitdir}/smartcard.target
+%{systemdunitdir}/sockets.target
+%{systemdunitdir}/sound.target
+%{systemdunitdir}/suspend.target
+%{systemdunitdir}/swap.target
+%{systemdunitdir}/sysinit.target
+%{systemdunitdir}/system-update.target
+%{systemdunitdir}/time-sync.target
+%{systemdunitdir}/timers.target
+%{systemdunitdir}/umount.target
+%{systemdunitdir}/systemd-tmpfiles-clean.timer
 %dir %{systemdunitdir}/basic.target.wants
 %dir %{systemdunitdir}/dbus.target.wants
 %dir %{systemdunitdir}/halt.target.wants
@@ -1367,23 +1653,52 @@ fi
 %dir %{systemdunitdir}/sysinit.target.wants
 %dir %{systemdunitdir}/syslog.target.wants
 %dir %{systemdunitdir}/timers.target.wants
-%{systemdunitdir}/local-fs.target.wants/*
+%{systemdunitdir}/local-fs.target.wants/pld-clean-tmp.service
+%{systemdunitdir}/local-fs.target.wants/pld-storage-init-late.service
+%{systemdunitdir}/local-fs.target.wants/pld-storage-init.service
+%{systemdunitdir}/local-fs.target.wants/systemd-remount-fs.service
+%{systemdunitdir}/local-fs.target.wants/var-lock.mount
+%{systemdunitdir}/local-fs.target.wants/var-run.mount
 %{systemdunitdir}/multi-user.target.wants/getty.target
 %{systemdunitdir}/multi-user.target.wants/rc-local.service
 %{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
 %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
 %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
-%{systemdunitdir}/runlevel[12345].target.wants/*
-%{systemdunitdir}/sockets.target.wants/*
+%{systemdunitdir}/sockets.target.wants/systemd-initctl.socket
+%{systemdunitdir}/sockets.target.wants/systemd-journald-audit.socket
+%{systemdunitdir}/sockets.target.wants/systemd-journald-dev-log.socket
+%{systemdunitdir}/sockets.target.wants/systemd-journald.socket
+%{systemdunitdir}/sockets.target.wants/systemd-shutdownd.socket
+%{systemdunitdir}/sockets.target.wants/systemd-udevd-control.socket
+%{systemdunitdir}/sockets.target.wants/systemd-udevd-kernel.socket
 %{?with_cryptsetup:%{systemdunitdir}/sysinit.target.wants/cryptsetup.target}
 %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
 %{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
 %{systemdunitdir}/sysinit.target.wants/kmod-static-nodes.service
 %{systemdunitdir}/sysinit.target.wants/ldconfig.service
 %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
-%{systemdunitdir}/sysinit.target.wants/sys-*.mount
-%{systemdunitdir}/sysinit.target.wants/systemd-*
-%{systemdunitdir}/timers.target.wants/*.timer
+%{systemdunitdir}/sysinit.target.wants/sys-fs-fuse-connections.mount
+%{systemdunitdir}/sysinit.target.wants/sys-kernel-debug.mount
+%{systemdunitdir}/sysinit.target.wants/systemd-ask-password-console.path
+%{systemdunitdir}/sysinit.target.wants/systemd-binfmt.service
+%{systemdunitdir}/sysinit.target.wants/systemd-firstboot.service
+%{systemdunitdir}/sysinit.target.wants/systemd-hwdb-update.service
+%{systemdunitdir}/sysinit.target.wants/systemd-journal-catalog-update.service
+%{systemdunitdir}/sysinit.target.wants/systemd-journald.service
+%{systemdunitdir}/sysinit.target.wants/systemd-journal-flush.service
+%{systemdunitdir}/sysinit.target.wants/systemd-machine-id-commit.service
+%{systemdunitdir}/sysinit.target.wants/systemd-modules-load.service
+%{systemdunitdir}/sysinit.target.wants/systemd-random-seed.service
+%{systemdunitdir}/sysinit.target.wants/systemd-sysctl.service
+%{systemdunitdir}/sysinit.target.wants/systemd-sysusers.service
+%{systemdunitdir}/sysinit.target.wants/systemd-tmpfiles-setup-dev.service
+%{systemdunitdir}/sysinit.target.wants/systemd-tmpfiles-setup.service
+%{systemdunitdir}/sysinit.target.wants/systemd-udevd.service
+%{systemdunitdir}/sysinit.target.wants/systemd-udev-trigger.service
+%{systemdunitdir}/sysinit.target.wants/systemd-update-done.service
+%{systemdunitdir}/sysinit.target.wants/systemd-update-utmp.service
+%{systemdunitdir}/sysinit.target.wants/systemd-vconsole-setup.service
+%{systemdunitdir}/timers.target.wants/systemd-tmpfiles-clean.timer
 %{_mandir}/man8/systemd-ask-password-console.path.8*
 %{_mandir}/man8/systemd-ask-password-console.service.8*
 %{_mandir}/man8/systemd-ask-password-wall.path.8*
@@ -1432,12 +1747,50 @@ fi
 %if %{with microhttpd}
 %files journal-gateway
 %defattr(644,root,root,755)
+%{systemdunitdir}/systemd-journal-gatewayd.socket
 %attr(755,root,root) /lib/systemd/systemd-journal-gatewayd
 %{_mandir}/man8/systemd-journal-gatewayd.8*
 %{_mandir}/man8/systemd-journal-gatewayd.service.8*
 %{_mandir}/man8/systemd-journal-gatewayd.socket.8*
 %endif
 
+%files networkd
+%defattr(644,root,root,755)
+/etc/dbus-1/system.d/org.freedesktop.network1.conf
+%dir %{_sysconfdir}/systemd/network
+%dir %{_sysconfdir}/systemd/system/network-online.target.wants
+%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/network-online.target.wants/systemd-networkd-wait-online.service
+%dir /lib/systemd/network
+/lib/systemd/network/80-container-host0.network
+/lib/systemd/network/80-container-ve.network
+/lib/systemd/network/99-default.link
+%{systemdunitdir}/dbus-org.freedesktop.network1.service
+%{systemdunitdir}/systemd-networkd-wait-online.service
+%{systemdunitdir}/systemd-networkd.service
+%{systemdunitdir}/systemd-networkd.socket
+%{_datadir}/dbus-1/system-services/org.freedesktop.network1.service
+%attr(755,root,root) /bin/networkctl
+%attr(755,root,root) /lib/systemd/systemd-networkd
+%attr(755,root,root) /lib/systemd/systemd-networkd-wait-online
+%{_mandir}/man1/networkctl.1*
+%{_mandir}/man8/systemd-networkd-wait-online.8*
+%{_mandir}/man8/systemd-networkd-wait-online.service.8*
+%{_mandir}/man8/systemd-networkd.8*
+%{_mandir}/man8/systemd-networkd.service.8*
+
+%files resolved
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/resolved.conf
+/etc/dbus-1/system.d/org.freedesktop.resolve1.conf
+%{_datadir}/dbus-1/system-services/org.freedesktop.resolve1.service
+%{systemdunitdir}/dbus-org.freedesktop.resolve1.service
+%{systemdunitdir}/systemd-resolved.service
+%attr(755,root,root) /lib/systemd/systemd-resolved
+%{_mandir}/man5/resolved.conf.5*
+%{_mandir}/man5/resolved.conf.d.5*
+%{_mandir}/man8/systemd-resolved.8*
+%{_mandir}/man8/systemd-resolved.service.8*
+
 %files inetd
 %defattr(644,root,root,755)
 %attr(755,root,root) %{systemdunitdir}-generators/pld-rc-inetd-generator
@@ -1464,7 +1817,6 @@ fi
 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
 
-
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libsystemd.so
@@ -1575,10 +1927,12 @@ fi
 /lib/udev/hwdb.d/20-usb-vendor-model.hwdb
 /lib/udev/hwdb.d/60-keyboard.hwdb
 /lib/udev/hwdb.d/70-mouse.hwdb
+/lib/udev/hwdb.d/70-touchpad.hwdb
 
 %attr(755,root,root) %{_sbindir}/start_udev
 %attr(755,root,root) %{_sbindir}/udevd
 %attr(755,root,root) %{_sbindir}/udevadm
+%attr(755,root,root) /bin/systemd-hwdb
 %attr(755,root,root) /bin/udevadm
 
 %dir %{_sysconfdir}/udev
@@ -1611,6 +1965,7 @@ fi
 /lib/udev/rules.d/64-btrfs.rules
 /lib/udev/rules.d/70-mouse.rules
 /lib/udev/rules.d/70-power-switch.rules
+/lib/udev/rules.d/70-touchpad.rules
 /lib/udev/rules.d/75-net-description.rules
 /lib/udev/rules.d/75-probe_mtd.rules
 /lib/udev/rules.d/75-tty-description.rules
@@ -1622,6 +1977,8 @@ fi
 
 %{_mandir}/man5/udev.conf.5*
 %{_mandir}/man7/udev.7*
+%{_mandir}/man7/hwdb.7*
+%{_mandir}/man8/systemd-hwdb.8*
 %{_mandir}/man8/udevadm.8*
 %{_mandir}/man8/udevd.8*
 
This page took 0.097435 seconds and 4 git commands to generate.