]> git.pld-linux.org Git - packages/systemd.git/blobdiff - systemd.spec
- obsolete static packages
[packages/systemd.git] / systemd.spec
index d2daac7e42ea654baeb09dcce46e5b8fa295b40f..95ea1b1dba79b265d7be0b5e8c3ac4bafd6db770 100644 (file)
@@ -1,9 +1,4 @@
 # TODO:
-# - restore sysconfig/timezone support in target-pld patch
-#   [now systemd expects /etc/localtime to be symlink to /usr/share/zoneinfo/... unconditionally]
-# - pldize vconsole setup:
-#      http://cgit.freedesktop.org/systemd/systemd/tree/src/vconsole/vconsole-setup.c
-# - initrd needs love (does not build and is probably completly unusable in current form)
 # - merge rpm macros provided by systemd with ours
 #
 # Conditional build:
 %bcond_without qrencode        # QRencode support
 %bcond_without selinux         # without SELinux support
 %bcond_without tcpd            # libwrap (tcp_wrappers) support
-
-%bcond_with    initrd          # build without udev-initrd
-%bcond_with    uClibc          # link initrd version with static uClibc
-%bcond_with    klibc           # link initrd version with static klibc
-%bcond_with    dietlibc        # link initrd version with static dietlibc (currently broken and unsupported)
-%bcond_without glibc           # link initrd version with static glibc
-
-%ifarch sparc sparc64
-%define                with_glibc 1
-%endif
-
-# if one of the *libc is enabled disable default uClibc
-%if %{with dietlibc} && %{with uClibc}
-%undefine      with_uClibc
-%endif
-
-%if %{with glibc} && %{with uClibc}
-%undefine      with_uClibc
-%endif
-
-%if %{with klibc} && %{with uClibc}
-%undefine      with_uClibc
-%endif
+%bcond_with    tests           # "make check" (requires systemd already installed)
 
 Summary:       A System and Service Manager
 Summary(pl.UTF-8):     systemd - zarządca systemu i usług dla Linuksa
 Name:          systemd
 # Verify ChangeLog and NEWS when updating (since there are incompatible/breaking changes very often)
-Version:       196
-Release:       2
+Version:       205
+Release:       1
 Epoch:         1
-License:       GPL v2+
+License:       GPL v2+ (udev), LGPL v2.1+ (the rest)
 Group:         Base
 Source0:       http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
-# Source0-md5: 05ebd7f108e420e2b4e4810ea4b3c810
+# Source0-md5: 3afc38170371929cf6ab056bf6a52fc6
 Source1:       %{name}-sysv-convert
 Source2:       %{name}_booted.c
 Source3:       network.service
@@ -63,6 +36,7 @@ Source15:     pld-clean-tmp.sh
 Source16:      pld-rc-inetd-generator.sh
 Source17:      rc-inetd.service
 Source18:      default.preset
+Source19:      prefdm.service
 # rules
 Source101:     udev-alsa.rules
 Source102:     udev.rules
@@ -79,14 +53,15 @@ Patch2:             shut-sysv-up.patch
 Patch3:                pld-sysv-network.patch
 Patch4:                tmpfiles-not-fatal.patch
 Patch6:                udev-so.patch
-Patch7:                udev-uClibc.patch
 Patch8:                udev-ploop-rules.patch
 Patch9:                udevadm-in-sbin.patch
 Patch10:       net-rename-revert.patch
-# hack set to allow static udev build
-Patch100:      static-udev.patch
+Patch11:       nss-in-rootlib.patch
+Patch12:       proc-hidepid.patch
+Patch13:       nss-myhostname-link.patch
 URL:           http://www.freedesktop.org/wiki/Software/systemd
 BuildRequires: acl-devel
+BuildRequires: attr-devel
 %{?with_audit:BuildRequires:   audit-libs-devel}
 BuildRequires: autoconf >= 2.64
 BuildRequires: automake >= 1:1.11
@@ -118,28 +93,18 @@ BuildRequires:     python-modules
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.628
 BuildRequires: sed >= 4.0
+%{?with_tests:BuildRequires:   systemd}
 BuildRequires: usbutils >= 0.82
 BuildRequires: xz-devel
 BuildRequires: zlib-devel
-%if %{with initrd}
-BuildRequires: acl-static
-BuildRequires: attr-static
-%{?with_dietlibc:BuildRequires:        dietlibc-static}
-BuildRequires: glib2-static >= 1:2.22.0
-%{?with_glibc:BuildRequires:   glibc-static}
-%{?with_klibc:BuildRequires:   klibc-static}
-BuildRequires: kmod-libs-static >= 5
-BuildRequires: libblkid-static >= 2.20
-%{?with_glibc:BuildRequires:   libselinux-static >= 2.1.9}
-%{?with_glibc:BuildRequires:   libsepol-static}
-%{?with_klibc:BuildRequires:   linux-libc-headers}
-BuildRequires: pcre-static
-%{?with_uClibc:BuildRequires:  uClibc-static >= 4:0.9.30.3}
-BuildRequires: xz-static
-BuildRequires: zlib-static
-%endif
 Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
 Requires:      %{name}-units = %{epoch}:%{version}-%{release}
+Requires(postun):      /usr/sbin/groupdel
+Requires(postun):      /usr/sbin/userdel
+Requires(pre): /bin/id
+Requires(pre): /usr/bin/getgid
+Requires(pre): /usr/sbin/groupadd
+Requires(pre): /usr/sbin/useradd
 Requires:      /etc/os-release
 Requires:      SysVinit-tools
 Requires:      agetty
@@ -147,6 +112,7 @@ Requires:   agetty
 Requires:      dbus >= 1.4.16-6
 Requires:      filesystem >= 4.0-3
 Requires:      libutempter
+Requires:      polkit
 Requires:      rc-scripts >= 0.4.5.3-7
 Requires:      setup >= 2.8.0-2
 Requires:      udev-core = %{epoch}:%{version}-%{release}
@@ -155,10 +121,12 @@ Requires: virtual(module-tools)
 Suggests:      ConsoleKit
 Suggests:      fsck >= 2.20
 Suggests:      kmod >= 5
-Suggests:      nss_myhostname
 Suggests:      service(klogd)
 Suggests:      service(syslog)
+Provides:      group(systemd-journal)
+Provides:      group(systemd-journal-gateway)
 Provides:      udev-acl = %{epoch}:%{version}-%{release}
+Provides:      user(systemd-journal-gateway)
 Obsoletes:     systemd-no-compat-tmpfiles
 Obsoletes:     udev-systemd
 # systemd takes care of that and causes problems
@@ -289,6 +257,7 @@ Provides:   virtual(init-daemon)
 Obsoletes:     SysVinit
 Obsoletes:     readahead < 1:1.5.7-3
 Obsoletes:     virtual(init-daemon)
+Conflicts:     rc-scripts < 0.4.5.5-2
 Conflicts:     upstart
 
 %description init
@@ -333,9 +302,9 @@ Obsoletes:  xinetd
 %description inetd
 Native inet service support for systemd via socket activation.
 
-This package contains inet service generator that provides
-the functionality of rc-inetd service and replaces a separate
-inet daemon with systemd socket activation feature.
+This package contains inet service generator that provides the
+functionality of rc-inetd service and replaces a separate inet daemon
+with systemd socket activation feature.
 
 %description inetd -l pl.UTF-8
 Natywna obsługa usług inet dla systemd.
@@ -371,6 +340,7 @@ Summary(pl.UTF-8):  Biblioteki współdzielone systemd
 Group:         Libraries
 Requires:      libgcrypt >= 1.4.5
 %{?with_selinux:Requires:      libselinux >= 2.1.9}
+Obsoletes:     nss_myhostname
 
 %description libs
 Shared systemd libraries.
@@ -383,6 +353,7 @@ Summary:    Header files for systemd libraries
 Summary(pl.UTF-8):     Pliki nagłówkowe bibliotek systemd
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
+Obsoletes:     systemd-static
 
 %description devel
 Header files for systemd libraries.
@@ -395,7 +366,7 @@ Summary:    bash-completion for systemd
 Summary(pl.UTF-8):     Bashowe dopełnianie składni dla systemd
 Group:         Applications/Shells
 Requires:      %{name} = %{epoch}:%{version}
-Requires:      bash-completion
+Requires:      bash-completion >= 2.0
 
 %description -n bash-completion-systemd
 bash-completion for systemd.
@@ -432,18 +403,20 @@ hotpluga.
 Summary:       A userspace implementation of devfs - core part of udev
 Summary(pl.UTF-8):     Implementacja devfs w przestrzeni użytkownika - główna część udev
 Group:         Base
-Requires:      udev-libs = %{epoch}:%{version}-%{release}
 Requires:      coreutils
 Requires:      filesystem >= 3.0-45
 Requires:      kmod-libs >= 5
 Requires:      libblkid >= 2.20
 %{?with_selinux:Requires:      libselinux >= 2.1.9}
 Requires:      setup >= 2.6.1-1
+Requires:      udev-libs = %{epoch}:%{version}-%{release}
 Requires:      uname(release) >= 2.6.32
+Obsoletes:     udev-compat
+Obsoletes:     udev-initrd < %{epoch}:%{version}-%{release}}
+Conflicts:     geninitrd < 12639
 Conflicts:     rc-scripts < 0.4.5.3-1
 Conflicts:     systemd-units < 1:183
 Conflicts:     udev < 1:118-1
-Obsoletes:     udev-compat
 
 %description -n udev-core
 A userspace implementation of devfs - core part of udev.
@@ -468,6 +441,7 @@ Summary:    Header file for libudev library
 Summary(pl.UTF-8):     Plik nagłówkowy biblioteki libudev
 Group:         Development/Libraries
 Requires:      udev-libs = %{epoch}:%{version}-%{release}
+Obsoletes:     udev-static
 
 %description -n udev-devel
 Header file for libudev library.
@@ -475,18 +449,6 @@ Header file for libudev library.
 %description -n udev-devel -l pl.UTF-8
 Plik nagłówkowy biblioteki libudev.
 
-%package -n udev-static
-Summary:       Static libudev library
-Summary(pl.UTF-8):     Biblioteka statyczna libudev
-Group:         Development/Libraries
-Requires:      udev-devel = %{epoch}:%{version}-%{release}
-
-%description -n udev-static
-Static libudev library.
-
-%description -n udev-static -l pl.UTF-8
-Biblioteka statyczna libudev.
-
 %package -n udev-apidocs
 Summary:       libudev API documentation
 Summary(pl.UTF-8):     Dokumentacja API libudev
@@ -503,8 +465,8 @@ Dokumentacja API libudev.
 Summary:       Shared libgudev library - GObject bindings for libudev
 Summary(pl.UTF-8):     Biblioteka współdzielona libgudev - wiązania GObject do libudev
 Group:         Libraries
-Requires:      udev-libs = %{epoch}:%{version}-%{release}
 Requires:      glib2 >= 1:2.22.0
+Requires:      udev-libs = %{epoch}:%{version}-%{release}
 
 %description -n udev-glib
 Shared libgudev library - GObject bindings for libudev.
@@ -516,9 +478,10 @@ Biblioteka współdzielona libgudev - wiązania GObject do libudev.
 Summary:       Header file for libgudev library
 Summary(pl.UTF-8):     Plik nagłówkowy biblioteki libgudev
 Group:         Development/Libraries
+Requires:      glib2-devel >= 1:2.22.0
 Requires:      udev-devel = %{epoch}:%{version}-%{release}
 Requires:      udev-glib = %{epoch}:%{version}-%{release}
-Requires:      glib2-devel >= 1:2.22.0
+Obsoletes:     udev-glib-static
 
 %description -n udev-glib-devel
 Header file for libgudev library.
@@ -526,18 +489,6 @@ Header file for libgudev library.
 %description -n udev-glib-devel -l pl.UTF-8
 Plik nagłówkowy biblioteki libgudev.
 
-%package -n udev-glib-static
-Summary:       Static libgudev library
-Summary(pl.UTF-8):     Biblioteka statyczna libgudev
-Group:         Development/Libraries
-Requires:      udev-glib-devel = %{epoch}:%{version}-%{release}
-
-%description -n udev-glib-static
-Static libgudev library.
-
-%description -n udev-glib-static -l pl.UTF-8
-Biblioteka statyczna libgudev.
-
 %package -n udev-glib-apidocs
 Summary:       libgudev API documentation
 Summary(pl.UTF-8):     Dokumentacja API libgudev
@@ -550,26 +501,26 @@ libgudev API documentation.
 %description -n udev-glib-apidocs -l pl.UTF-8
 Dokumentacja API libgudev.
 
-%package -n udev-initrd
-Summary:       A userspace implementation of devfs - static binary for initrd
-Summary(pl.UTF-8):     Implementacja devfs w przestrzeni użytkownika - statyczna binarka dla initrd
-Group:         Base
-Requires:      udev-core = %{epoch}:%{version}-%{release}
-Conflicts:     geninitrd < 10000.10
+%package -n bash-completion-udev
+Summary:       bash-completion for udev
+Summary(pl.UTF-8):     Bashowe dopełnianie składni dla udev
+Group:         Applications/Shells
+Requires:      bash-completion >= 2.0
+Requires:      udev = %{epoch}:%{version}
+
+%description -n bash-completion-udev
+bash-completion for udev.
 
-%description -n udev-initrd
-A userspace implementation of devfs - static binary for initrd.
+%description -n bash-completion-udev -l pl.UTF-8
+Bashowe dopełnianie składni dla udev.
 
-%description -n udev-initrd -l pl.UTF-8
-Implementacja devfs w przestrzeni użytkownika - statyczna binarka dla
-initrd.
 
 %package -n python-systemd
 Summary:       Systemd Python bindings
 Summary(pl.UTF-8):     Wiązania do Systemd dla Pythona
 Group:         Development/Languages/Python
-%pyrequires_eq python
 Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
+Requires:      python
 
 %description -n python-systemd
 Systemd Python bindings.
@@ -585,12 +536,12 @@ Wiązania do Systemd dla Pythona.
 %patch3 -p1
 %patch4 -p1
 %patch6 -p1
-%if %{with uClibc}
-%patch7 -p1
-%endif
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
+%patch11 -p1
+%patch12 -p1
+#patch13 -p1
 cp -p %{SOURCE2} src/systemd_booted.c
 
 %build
@@ -600,63 +551,6 @@ cp -p %{SOURCE2} src/systemd_booted.c
 %{__autoconf}
 %{__autoheader}
 %{__automake}
-%if %{with initrd}
-patch -p1 <%{PATCH100}
-%configure \
-%if "%{?configure_cache}" == "1"
-       --cache-file=%{?configure_cache_file}%{!?configure_cache_file:configure}-initrd.cache \
-%endif
-       %{?with_uClibc:CC="%{_target_cpu}-uclibc-gcc"} \
-       %{?with_dietlibc:CC="diet %{__cc} %{rpmcflags} %{rpmldflags} -Os -D_BSD_SOURCE"} \
-       %{?with_klibc:CC="%{_bindir}/klcc"} \
-       %{?debug:--enable-debug} \
-       --disable-silent-rules \
-       --disable-shared \
-       --enable-static \
-       --with-distro=pld \
-       --with-rootprefix="" \
-       --with-rootlibdir=/%{_lib} \
-       --disable-audit \
-       --disable-gtk-doc \
-       --disable-gudev \
-       --disable-introspection \
-       --disable-keymap \
-       --disable-microhttpd \
-       --disable-pam \
-       --disable-qrencode \
-       --disable-selinux \
-       --enable-split-usr
-
-%{__make} \
-       libudev-core.la \
-       systemd-udevd \
-       udevadm \
-       ata_id \
-       cdrom_id \
-       collect \
-       scsi_id \
-       v4l_id \
-       accelerometer \
-       mtd_probe \
-       LDFLAGS="-all-static" \
-       KMOD_LIBS="-lkmod -lz -llzma"
-
-mkdir udev-initrd
-cp -a systemd-udevd \
-       udevadm \
-       ata_id \
-       cdrom_id \
-       collect \
-       scsi_id \
-       v4l_id \
-       accelerometer \
-       mtd_probe \
-       udev-initrd/
-
-%{__make} clean
-patch -p1 -R <%{PATCH100}
-%endif
-
 %configure \
        QUOTAON=/sbin/quotaon \
        QUOTACHECK=/sbin/quotacheck \
@@ -671,19 +565,25 @@ patch -p1 -R <%{PATCH100}
        %{__enable_disable microhttpd} \
        %{__enable_disable qrencode} \
        --disable-silent-rules \
+       --enable-chkconfig \
        --enable-gtk-doc \
        --enable-introspection \
        --enable-split-usr \
-       --enable-shared \
-       --enable-static \
-       --with-distro=pld \
+       --with-html-dir=%{_gtkdocdir} \
+       --with-kbd-loadkeys=/usr/bin/loadkeys \
+       --with-kbd-setfont=/bin/setfont \
+       --with-sysvinit-path=/etc/rc.d/init.d \
+       --with-sysvrcnd-path=/etc/rc.d \
+       --with-rc-local-script-path-start=/etc/rc.d/rc.local \
+       --with-rc-local-script-path-stop=/sbin/halt.local \
        --with-rootprefix="" \
-       --with-rootlibdir=/%{_lib} \
-       --with-html-dir=%{_gtkdocdir}
+       --with-rootlibdir=/%{_lib}
 
-%{__make}
+%{__make} -j1
 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
 
+%{?with_tests:%{__make} check}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/var/lib/%{name}/coredump \
@@ -700,14 +600,18 @@ ln -s /lib/udev/udevd $RPM_BUILD_ROOT/lib/systemd/systemd-udevd
 ln -s /lib/udev/udevd $RPM_BUILD_ROOT%{_sbindir}/udevd
 
 # compat symlinks for "/ merged into /usr" programs
-mv $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/udevadm
-ln -s %{_sbindir}/udevadm $RPM_BUILD_ROOT%{_bindir}
+mv $RPM_BUILD_ROOT/{,s}bin/udevadm
+ln -s %{_sbindir}/udevadm $RPM_BUILD_ROOT/bin
 ln -s /lib/udev $RPM_BUILD_ROOT/usr/lib/
 
 # install custom udev rules from pld package
 cp -a %{SOURCE101} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/40-alsa-restore.rules
 cp -a %{SOURCE102} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/70-udev-pld.rules
 
+# disable this abomination
+# http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames
+ln -s /dev/null $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/80-net-name-slot.rules
+
 # install udev configs
 cp -a %{SOURCE103} $RPM_BUILD_ROOT%{_sysconfdir}/udev/links.conf
 
@@ -722,18 +626,6 @@ cp -a %{SOURCE121} $RPM_BUILD_ROOT%{_sysconfdir}/modprobe.d/fbdev-blacklist.conf
 mv $RPM_BUILD_ROOT%{_mandir}/man8/{systemd-,}udevd.8
 echo ".so man8/udevd.8" >$RPM_BUILD_ROOT%{_mandir}/man8/systemd-udevd.8
 
-%if %{with initrd}
-install -d $RPM_BUILD_ROOT%{_libdir}/initrd/udev
-install -p udev-initrd/udevadm $RPM_BUILD_ROOT%{_libdir}/initrd
-install -p udev-initrd/systemd-udevd $RPM_BUILD_ROOT%{_libdir}/initrd
-# hardlink udevd -> systemd-udevd
-ln $RPM_BUILD_ROOT%{_libdir}/initrd/{systemd-,}udevd
-ln -s udevd $RPM_BUILD_ROOT%{_libdir}/initrd/udevstart
-install -p udev-initrd/*_id $RPM_BUILD_ROOT%{_libdir}/initrd/udev
-install -p udev-initrd/collect $RPM_BUILD_ROOT%{_libdir}/initrd/udev
-install -p udev-initrd/mtd_probe $RPM_BUILD_ROOT%{_libdir}/initrd/udev
-%endif
-
 # Main binary has been moved, but we don't want to break existing installs
 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
 
@@ -790,14 +682,19 @@ cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdunitdir}/rc-inetd.service
 
 cp -p %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system-preset/default.preset
 
+cp -p %{SOURCE19} $RPM_BUILD_ROOT%{systemdunitdir}/prefdm.service
+
 # handled by rc-local sysv service, no need for generator
 %{__rm} $RPM_BUILD_ROOT/lib/systemd/system-generators/systemd-rc-local-generator
 
+# provided by rc-scripts
+%{__rm} $RPM_BUILD_ROOT/lib/systemd/system/rc-local.service
+
 # Make sure these directories are properly owned:
 #      - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
 #      - syslog _might_ be used by some syslog implementation (none for now),
 #      - isn't dbus populated by dbus-systemd only (so to be moved there)?
-install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
+install -d $RPM_BUILD_ROOT%{systemdunitdir}/{basic,dbus,halt,initrd,kexec,poweroff,reboot,shutdown,syslog}.target.wants
 
 # Create new-style configuration files so that we can ghost-own them
 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,timezone,vconsole.conf}
@@ -811,6 +708,7 @@ install -d $RPM_BUILD_ROOT/var/log
 
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
+%{__rm} $RPM_BUILD_ROOT/%{_lib}/libnss_myhostname.la
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/systemd/*.la
 %py_postclean
@@ -818,7 +716,14 @@ install -d $RPM_BUILD_ROOT/var/log
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%pre
+%groupadd -g 288 systemd-journal
+%groupadd -g 287 systemd-journal-gateway
+%useradd -u 287 -g 287 -d /var/log/journal -s /bin/false -c "Systemd Journal Gateway" systemd-journal-gateway
+
 %post
+# should we?
+#setfacl -nm g:logs:rx,d:g:logs:rx /var/log/journal
 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
 
@@ -826,6 +731,11 @@ rm -rf $RPM_BUILD_ROOT
 if [ $1 -ge 1 ]; then
        /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
 fi
+if [ "$1" = "0" ]; then
+       %userremove systemd-journal-gateway
+       %groupremove systemd-journal-gateway
+       %groupremove systemd-journal
+fi
 
 %post   libs -p /sbin/ldconfig
 %postun libs -p /sbin/ldconfig
@@ -964,6 +874,7 @@ fi
 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
 /etc/dbus-1/system.d/org.freedesktop.login1.conf
+/etc/dbus-1/system.d/org.freedesktop.machine1.conf
 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
 %ghost %config(noreplace) %{_sysconfdir}/machine-id
@@ -972,6 +883,7 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/bootchart.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/journald.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/logind.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system.conf
@@ -983,13 +895,16 @@ fi
 /etc/xdg/systemd
 %attr(755,root,root) /bin/journalctl
 %attr(755,root,root) /bin/loginctl
+%attr(755,root,root) /bin/machinectl
 %attr(755,root,root) /bin/systemd
 %attr(755,root,root) /bin/systemd-ask-password
 %attr(755,root,root) /bin/systemd-inhibit
 %attr(755,root,root) /bin/systemd-machine-id-setup
 %attr(755,root,root) /bin/systemd-notify
 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
+%attr(755,root,root) %{_bindir}/bootctl
 %attr(755,root,root) %{_bindir}/hostnamectl
+%attr(755,root,root) %{_bindir}/kernel-install
 %attr(755,root,root) %{_bindir}/localectl
 %attr(755,root,root) %{_bindir}/systemd-cat
 %attr(755,root,root) %{_bindir}/systemd-cgls
@@ -998,13 +913,16 @@ fi
 %attr(755,root,root) %{_bindir}/systemd-delta
 %attr(755,root,root) %{_bindir}/systemd-detect-virt
 %attr(755,root,root) %{_bindir}/systemd-nspawn
+%attr(755,root,root) %{_bindir}/systemd-run
 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
 %attr(755,root,root) %{_bindir}/timedatectl
 %attr(755,root,root) /lib/systemd/pld-clean-tmp
 %attr(755,root,root) /lib/systemd/pld-storage-init
 %attr(755,root,root) /lib/systemd/systemd-ac-power
+%attr(755,root,root) /lib/systemd/systemd-activate
 %attr(755,root,root) /lib/systemd/systemd-binfmt
+%attr(755,root,root) /lib/systemd/systemd-bootchart
 %attr(755,root,root) /lib/systemd/systemd-cgroups-agent
 %attr(755,root,root) /lib/systemd/systemd-coredump
 %{?with_cryptsetup:%attr(755,root,root) /lib/systemd/systemd-cryptsetup}
@@ -1015,6 +933,7 @@ fi
 %attr(755,root,root) /lib/systemd/systemd-journald
 %attr(755,root,root) /lib/systemd/systemd-localed
 %attr(755,root,root) /lib/systemd/systemd-logind
+%attr(755,root,root) /lib/systemd/systemd-machined
 %attr(755,root,root) /lib/systemd/systemd-modules-load
 %attr(755,root,root) /lib/systemd/systemd-multi-seat-x
 %attr(755,root,root) /lib/systemd/systemd-quotacheck
@@ -1032,7 +951,6 @@ fi
 %attr(755,root,root) /lib/systemd/systemd-update-utmp
 %attr(755,root,root) /lib/systemd/systemd-user-sessions
 %attr(755,root,root) /lib/systemd/systemd-vconsole-setup
-%dir /lib/systemd/system-generators
 %attr(755,root,root) /lib/systemd/systemd
 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
 /lib/udev/rules.d/70-uaccess.rules
@@ -1056,6 +974,7 @@ fi
 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
+%{_datadir}/dbus-1/system-services/org.freedesktop.machine1.service
 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
@@ -1072,6 +991,7 @@ fi
 %{_mandir}/man1/loginctl.1*
 %{_mandir}/man1/systemd.1*
 %{_mandir}/man1/systemd-ask-password.1*
+%{_mandir}/man1/systemd-bootchart.1*
 %{_mandir}/man1/systemd-cat.1*
 %{_mandir}/man1/systemd-cgls.1*
 %{_mandir}/man1/systemd-cgtop.1*
@@ -1085,6 +1005,7 @@ fi
 %{_mandir}/man1/systemd-tty-ask-password-agent.1*
 %{_mandir}/man1/timedatectl.1*
 %{_mandir}/man5/binfmt.d.5*
+%{_mandir}/man5/bootchart.conf.5*
 # cfl with rc-scripts
 #%{_mandir}/man5/crypttab.5*
 %{_mandir}/man5/hostname.5*
@@ -1098,12 +1019,21 @@ fi
 %{_mandir}/man5/os-release.5*
 %{_mandir}/man5/sysctl.d.5*
 %{_mandir}/man5/systemd.*.5*
+%{_mandir}/man5/systemd-sleep.conf.5*
+%{_mandir}/man5/systemd-system.conf.5*
+%{_mandir}/man5/systemd-user.conf.5*
 %{_mandir}/man5/vconsole.conf.5*
 %{_mandir}/man7/bootup.7*
 %{_mandir}/man7/daemon.7*
 %{_mandir}/man7/kernel-command-line.7*
+%{_mandir}/man7/systemd.directives.7*
+%{_mandir}/man7/systemd.index.7*
 %{_mandir}/man7/systemd.journal-fields.7*
 %{_mandir}/man7/systemd.special.7*
+%{_mandir}/man7/systemd.time.7*
+%{_mandir}/man8/kernel-install.8*
+%{_mandir}/man8/nss-myhostname.8*
+%{_mandir}/man8/systemd-activate.8*
 %{_mandir}/man8/systemd-binfmt.8*
 %{?with_cryptsetup:%{_mandir}/man8/systemd-cryptsetup-generator.8*}
 %{_mandir}/man8/systemd-fsck.8*
@@ -1111,6 +1041,7 @@ fi
 %{_mandir}/man8/systemd-getty-generator.8*
 %{_mandir}/man8/systemd-hostnamed.8*
 %{_mandir}/man8/systemd-initctl.8*
+%{?with_microhttpd:%{_mandir}/man8/systemd-journal-gatewayd.8*}
 %{_mandir}/man8/systemd-journald.8*
 %{_mandir}/man8/systemd-localed.8*
 %{_mandir}/man8/systemd-logind.8*
@@ -1133,6 +1064,7 @@ fi
 %dir /var/lib/%{name}/coredump
 %attr(640,root,root) %ghost /var/log/btmp
 %attr(664,root,utmp) %ghost /var/log/wtmp
+%dir /var/log/journal
 
 %if %{with pam}
 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
@@ -1148,10 +1080,11 @@ fi
 %attr(755,root,root) /sbin/runlevel
 %attr(755,root,root) /sbin/shutdown
 %attr(755,root,root) /sbin/telinit
-%{_mandir}/man1/init.1
+%{_mandir}/man1/init.1*
+%{_mandir}/man5/crypttab.5*
 %{_mandir}/man8/halt.8*
-%{_mandir}/man8/poweroff.8
-%{_mandir}/man8/reboot.8
+%{_mandir}/man8/poweroff.8*
+%{_mandir}/man8/reboot.8*
 %{_mandir}/man8/runlevel.8*
 %{_mandir}/man8/shutdown.8*
 %{_mandir}/man8/telinit.8*
@@ -1170,9 +1103,11 @@ fi
 %dir %{_libexecdir}/binfmt.d
 %dir %{_libexecdir}/modules-load.d
 %dir %{_libexecdir}/sysctl.d
+%dir /lib/systemd/system-generators
 %dir /lib/systemd/system-sleep
 %dir /lib/systemd/system-shutdown
-%{_libexecdir}/sysctl.d/coredump.conf
+%{_libexecdir}/sysctl.d/50-coredump.conf
+%{_libexecdir}/sysctl.d/50-default.conf
 %attr(755,root,root) /bin/systemctl
 %attr(755,root,root) /bin/systemd-tmpfiles
 %attr(755,root,root) /bin/systemd_booted
@@ -1185,6 +1120,7 @@ fi
 %{systemdunitdir}/*.mount
 %{systemdunitdir}/*.path
 %{systemdunitdir}/*.service
+%{systemdunitdir}/*.slice
 %exclude %{systemdunitdir}/rc-inetd.service
 %{systemdunitdir}/*.socket
 %{systemdunitdir}/*.target
@@ -1194,6 +1130,7 @@ fi
 %dir %{systemdunitdir}/final.target.wants
 %dir %{systemdunitdir}/graphical.target.wants
 %dir %{systemdunitdir}/halt.target.wants
+%dir %{systemdunitdir}/initrd.target.wants
 %dir %{systemdunitdir}/kexec.target.wants
 %dir %{systemdunitdir}/local-fs.target.wants
 %dir %{systemdunitdir}/multi-user.target.wants
@@ -1204,7 +1141,7 @@ fi
 %dir %{systemdunitdir}/sockets.target.wants
 %dir %{systemdunitdir}/sysinit.target.wants
 %dir %{systemdunitdir}/syslog.target.wants
-%{systemdunitdir}/basic.target.wants/*
+%dir %{systemdunitdir}/timers.target.wants
 %{systemdunitdir}/final.target.wants/*
 %{systemdunitdir}/graphical.target.wants/*
 %{systemdunitdir}/local-fs.target.wants/*
@@ -1214,7 +1151,6 @@ fi
 %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
 %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
 %{systemdunitdir}/runlevel[12345].target.wants/*
-%{systemdunitdir}/shutdown.target.wants/*
 %{systemdunitdir}/sockets.target.wants/*
 %{?with_cryptsetup:%{systemdunitdir}/sysinit.target.wants/cryptsetup.target}
 %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
@@ -1222,6 +1158,7 @@ fi
 %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
 %{systemdunitdir}/sysinit.target.wants/sys-*.mount
 %{systemdunitdir}/sysinit.target.wants/systemd-*
+%{systemdunitdir}/timers.target.wants/*.timer
 %{_mandir}/man8/systemd-ask-password-console.path.8*
 %{_mandir}/man8/systemd-ask-password-console.service.8*
 %{_mandir}/man8/systemd-ask-password-wall.path.8*
@@ -1237,6 +1174,8 @@ fi
 %{_mandir}/man8/systemd-hybrid-sleep.service.8*
 %{_mandir}/man8/systemd-initctl.service.8*
 %{_mandir}/man8/systemd-initctl.socket.8*
+%{?with_microhttpd:%{_mandir}/man8/systemd-journal-gatewayd.service.8*}
+%{?with_microhttpd:%{_mandir}/man8/systemd-journal-gatewayd.socket.8*}
 %{_mandir}/man8/systemd-journald.service.8*
 %{_mandir}/man8/systemd-journald.socket.8*
 %{_mandir}/man8/systemd-kexec.service.8*
@@ -1245,8 +1184,7 @@ fi
 %{_mandir}/man8/systemd-modules-load.service.8*
 %{_mandir}/man8/systemd-poweroff.service.8*
 %{_mandir}/man8/systemd-quotacheck.service.8*
-%{_mandir}/man8/systemd-random-seed-load.service.8*
-%{_mandir}/man8/systemd-random-seed-save.service.8*
+%{_mandir}/man8/systemd-random-seed.service.8*
 %{_mandir}/man8/systemd-readahead-collect.service.8*
 %{_mandir}/man8/systemd-readahead-done.service.8*
 %{_mandir}/man8/systemd-readahead-done.timer.8*
@@ -1261,17 +1199,18 @@ fi
 %{_mandir}/man8/systemd-tmpfiles-clean.service.8*
 %{_mandir}/man8/systemd-tmpfiles-clean.timer.8*
 %{_mandir}/man8/systemd-tmpfiles-setup.service.8*
+%{_mandir}/man8/systemd-tmpfiles-setup-dev.service.8*
 %{_mandir}/man8/systemd-udevd.service.8*
 %{_mandir}/man8/systemd-udevd-control.socket.8*
 %{_mandir}/man8/systemd-udevd-kernel.socket.8*
 %{_mandir}/man8/systemd-update-utmp-runlevel.service.8*
-%{_mandir}/man8/systemd-update-utmp-shutdown.service.8*
+%{_mandir}/man8/systemd-update-utmp.service.8*
 %{_mandir}/man8/systemd-user-sessions.service.8*
 %{_mandir}/man8/systemd-vconsole-setup.service.8*
 
 %files inetd
 %defattr(644,root,root,755)
-%attr(755,root,root) /lib/systemd/system-generators/pld-rc-inetd-generator
+%attr(755,root,root) %{systemdunitdir}-generators/pld-rc-inetd-generator
 %{systemdunitdir}/rc-inetd.service
 
 %files analyze
@@ -1281,6 +1220,7 @@ fi
 
 %files libs
 %defattr(644,root,root,755)
+%attr(755,root,root) /%{_lib}/libnss_myhostname.so.2
 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
@@ -1306,7 +1246,14 @@ fi
 
 %files -n bash-completion-systemd
 %defattr(644,root,root,755)
-/etc/bash_completion.d/systemd-bash-completion.sh
+%{_datadir}/bash-completion/completions/hostnamectl
+%{_datadir}/bash-completion/completions/journalctl
+%{_datadir}/bash-completion/completions/localectl
+%{_datadir}/bash-completion/completions/loginctl
+%{_datadir}/bash-completion/completions/systemctl
+%{_datadir}/bash-completion/completions/systemd-analyze
+%{_datadir}/bash-completion/completions/systemd-coredumpctl
+%{_datadir}/bash-completion/completions/timedatectl
 
 %files -n udev
 %defattr(644,root,root,755)
@@ -1343,15 +1290,16 @@ fi
 %dir /lib/udev/hwdb.d
 /lib/udev/hwdb.d/20-OUI.hwdb
 /lib/udev/hwdb.d/20-acpi-vendor.hwdb
+/lib/udev/hwdb.d/20-bluetooth-vendor-product.hwdb
 /lib/udev/hwdb.d/20-pci-classes.hwdb
-/lib/udev/hwdb.d/20-pci-vendor-product.hwdb
+/lib/udev/hwdb.d/20-pci-vendor-model.hwdb
 /lib/udev/hwdb.d/20-usb-classes.hwdb
-/lib/udev/hwdb.d/20-usb-vendor-product.hwdb
+/lib/udev/hwdb.d/20-usb-vendor-model.hwdb
 
 %attr(755,root,root) %{_sbindir}/start_udev
 %attr(755,root,root) %{_sbindir}/udevd
 %attr(755,root,root) %{_sbindir}/udevadm
-%attr(755,root,root) %{_bindir}/udevadm
+%attr(755,root,root) /bin/udevadm
 
 %dir %{_sysconfdir}/udev
 %dir %{_sysconfdir}/udev/rules.d
@@ -1362,6 +1310,7 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/links.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/rules.d/40-alsa-restore.rules
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/rules.d/70-udev-pld.rules
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/rules.d/80-net-name-slot.rules
 
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/udev.conf
 
@@ -1383,6 +1332,7 @@ fi
 /lib/udev/rules.d/75-tty-description.rules
 /lib/udev/rules.d/78-sound-card.rules
 /lib/udev/rules.d/80-drivers.rules
+/lib/udev/rules.d/80-net-name-slot.rules
 /lib/udev/rules.d/95-keyboard-force-release.rules
 /lib/udev/rules.d/95-keymap.rules
 /lib/udev/rules.d/95-udev-late.rules
@@ -1403,10 +1353,6 @@ fi
 %{_pkgconfigdir}/libudev.pc
 %{_npkgconfigdir}/udev.pc
 
-%files -n udev-static
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libudev.a
-
 %files -n udev-apidocs
 %defattr(644,root,root,755)
 %{_gtkdocdir}/libudev
@@ -1424,26 +1370,13 @@ fi
 %{_pkgconfigdir}/gudev-1.0.pc
 %{_datadir}/gir-1.0/GUdev-1.0.gir
 
-%files -n udev-glib-static
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libgudev-1.0.a
-
 %files -n udev-glib-apidocs
 %defattr(644,root,root,755)
 %{_gtkdocdir}/gudev
 
-%if %{with initrd}
-%files -n udev-initrd
+%files -n bash-completion-udev
 %defattr(644,root,root,755)
-%dir %{_libdir}/initrd/udev
-%attr(755,root,root) %{_libdir}/initrd/systemd-udevd
-%attr(755,root,root) %{_libdir}/initrd/udevd
-%attr(755,root,root) %{_libdir}/initrd/udevadm
-%attr(755,root,root) %{_libdir}/initrd/udevstart
-%attr(755,root,root) %{_libdir}/initrd/udev/*_id
-%attr(755,root,root) %{_libdir}/initrd/udev/collect
-%attr(755,root,root) %{_libdir}/initrd/udev/mtd_probe
-%endif
+%{_datadir}/bash-completion/completions/udevadm
 
 %files -n python-systemd
 %defattr(644,root,root,755)
This page took 0.065764 seconds and 4 git commands to generate.