]> git.pld-linux.org Git - packages/systemd.git/blobdiff - systemd.spec
- updated to 199
[packages/systemd.git] / systemd.spec
index 402f933ef80c20f9ca17cc0dc06531fa8f5dbee6..760fc8c8ec3148cf314a77931c78aef63fe8d74d 100644 (file)
@@ -1,50 +1,26 @@
 # TODO:
-# - pldize vconsole setup:
-#      http://cgit.freedesktop.org/systemd/systemd/tree/src/vconsole/vconsole-setup.c
-# - udev initrd needs love (is probably completly unusable in current form)
-# - replace our rpm macros with systemd provided?
+# - merge rpm macros provided by systemd with ours
 #
 # Conditional build:
 %bcond_without audit           # without audit support
 %bcond_without cryptsetup      # without cryptsetup support
+%bcond_without microhttpd      # microhttpd support
 %bcond_without pam             # PAM authentication support
+%bcond_without qrencode        # QRencode support
 %bcond_without selinux         # without SELinux support
 %bcond_without tcpd            # libwrap (tcp_wrappers) support
 
-%bcond_without initrd          # build without udev-initrd
-%bcond_with    uClibc          # link initrd version with static uClibc
-%bcond_with    klibc           # link initrd version with static klibc
-%bcond_with    dietlibc        # link initrd version with static dietlibc (currently broken and unsupported)
-%bcond_without glibc           # link initrd version with static glibc
-
-%ifarch sparc sparc64
-%define                with_glibc 1
-%endif
-
-# if one of the *libc is enabled disable default uClibc
-%if %{with dietlibc} && %{with uClibc}
-%undefine      with_uClibc
-%endif
-
-%if %{with glibc} && %{with uClibc}
-%undefine      with_uClibc
-%endif
-
-%if %{with klibc} && %{with uClibc}
-%undefine      with_uClibc
-%endif
-
 Summary:       A System and Service Manager
 Summary(pl.UTF-8):     systemd - zarządca systemu i usług dla Linuksa
 Name:          systemd
 # Verify ChangeLog and NEWS when updating (since there are incompatible/breaking changes very often)
-Version:       187
-Release:       3
+Version:       199
+Release:       1
 Epoch:         1
-License:       GPL v2+
+License:       GPL v2+ (udev), LGPL v2.1+ (the rest)
 Group:         Base
 Source0:       http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
-# Source0-md5: 26606e3c84448800ef0b3ffd57e6e8b6
+# Source0-md5: 4bb13f84ce211e93f0141774a90a2322
 Source1:       %{name}-sysv-convert
 Source2:       %{name}_booted.c
 Source3:       network.service
@@ -59,6 +35,7 @@ Source15:     pld-clean-tmp.sh
 Source16:      pld-rc-inetd-generator.sh
 Source17:      rc-inetd.service
 Source18:      default.preset
+Source19:      prefdm.service
 # rules
 Source101:     udev-alsa.rules
 Source102:     udev.rules
@@ -74,16 +51,15 @@ Patch1:             config-pld.patch
 Patch2:                shut-sysv-up.patch
 Patch3:                pld-sysv-network.patch
 Patch4:                tmpfiles-not-fatal.patch
-Patch5:                kmsg-to-syslog.patch
 Patch6:                udev-so.patch
-Patch7:                udev-uClibc.patch
 Patch8:                udev-ploop-rules.patch
 Patch9:                udevadm-in-sbin.patch
 Patch10:       net-rename-revert.patch
-# hack set to allow static udev build
-Patch100:      static-udev.patch
+Patch11:       nss-in-rootlib.patch
+Patch12:       proc-hidepid.patch
 URL:           http://www.freedesktop.org/wiki/Software/systemd
 BuildRequires: acl-devel
+BuildRequires: attr-devel
 %{?with_audit:BuildRequires:   audit-libs-devel}
 BuildRequires: autoconf >= 2.64
 BuildRequires: automake >= 1:1.11
@@ -100,42 +76,36 @@ BuildRequires:     intltool >= 0.40.0
 BuildRequires: kmod-devel >= 5
 BuildRequires: libblkid-devel >= 2.20
 BuildRequires: libcap-devel
-%{?with_selinux:BuildRequires: libselinux-devel >= 2.1.0}
+BuildRequires: libgcrypt-devel >= 1.4.5
+%{?with_microhttpd:BuildRequires:      libmicrohttpd-devel >= 0.9.5}
+%{?with_selinux:BuildRequires: libselinux-devel >= 2.1.9}
 BuildRequires: libtool >= 2:2.2
 %{?with_tcpd:BuildRequires:    libwrap-devel}
 BuildRequires: libxslt-progs
 BuildRequires: m4
 %{?with_pam:BuildRequires:     pam-devel}
-BuildRequires: pciutils
 BuildRequires: pkgconfig >= 0.9.0
+BuildRequires: python-devel
 BuildRequires: python-modules
+%{?with_qrencode:BuildRequires:        qrencode-devel}
+BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.628
 BuildRequires: sed >= 4.0
 BuildRequires: usbutils >= 0.82
 BuildRequires: xz-devel
 BuildRequires: zlib-devel
-%if %{with initrd}
-BuildRequires: acl-static
-BuildRequires: attr-static
-%{?with_dietlibc:BuildRequires:        dietlibc-static}
-BuildRequires: glib2-static >= 1:2.22.0
-%{?with_glibc:BuildRequires:   glibc-static}
-%{?with_klibc:BuildRequires:   klibc-static}
-BuildRequires: kmod-libs-static >= 5
-BuildRequires: libblkid-static >= 2.20
-%{?with_glibc:BuildRequires:   libselinux-static}
-%{?with_glibc:BuildRequires:   libsepol-static}
-%{?with_klibc:BuildRequires:   linux-libc-headers}
-BuildRequires: pcre-static
-%{?with_uClibc:BuildRequires:  uClibc-static >= 4:0.9.30.3}
-BuildRequires: xz-static
-BuildRequires: zlib-static
-%endif
 Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
 Requires:      %{name}-units = %{epoch}:%{version}-%{release}
+Requires(postun):      /usr/sbin/groupdel
+Requires(postun):      /usr/sbin/userdel
+Requires(pre): /bin/id
+Requires(pre): /usr/bin/getgid
+Requires(pre): /usr/sbin/groupadd
+Requires(pre): /usr/sbin/useradd
 Requires:      /etc/os-release
 Requires:      SysVinit-tools
 Requires:      agetty
+%{?with_cryptsetup:Requires:   cryptsetup >= 1.4.3}
 Requires:      dbus >= 1.4.16-6
 Requires:      filesystem >= 4.0-3
 Requires:      libutempter
@@ -147,10 +117,12 @@ Requires: virtual(module-tools)
 Suggests:      ConsoleKit
 Suggests:      fsck >= 2.20
 Suggests:      kmod >= 5
-Suggests:      nss_myhostname
 Suggests:      service(klogd)
 Suggests:      service(syslog)
+Provides:      group(systemd-journal)
+Provides:      group(systemd-journal-gateway)
 Provides:      udev-acl = %{epoch}:%{version}-%{release}
+Provides:      user(systemd-journal-gateway)
 Obsoletes:     systemd-no-compat-tmpfiles
 Obsoletes:     udev-systemd
 # systemd takes care of that and causes problems
@@ -325,9 +297,9 @@ Obsoletes:  xinetd
 %description inetd
 Native inet service support for systemd via socket activation.
 
-This package contains inet service generator that provides
-the functionality of rc-inetd service and replaces a separate
-inet daemon with systemd socket activation feature.
+This package contains inet service generator that provides the
+functionality of rc-inetd service and replaces a separate inet daemon
+with systemd socket activation feature.
 
 %description inetd -l pl.UTF-8
 Natywna obsługa usług inet dla systemd.
@@ -343,7 +315,7 @@ Group:              Base
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      python-dbus
 Requires:      python-modules
-Requires:      python-pycairo
+Suggests:      python-pycairo
 Conflicts:     systemd < 44-3
 
 %description analyze
@@ -361,6 +333,9 @@ start jednostek podczas rozruchu.
 Summary:       Shared systemd libraries
 Summary(pl.UTF-8):     Biblioteki współdzielone systemd
 Group:         Libraries
+Requires:      libgcrypt >= 1.4.5
+%{?with_selinux:Requires:      libselinux >= 2.1.9}
+Obsoletes:     nss_myhostname
 
 %description libs
 Shared systemd libraries.
@@ -380,12 +355,24 @@ Header files for systemd libraries.
 %description devel -l pl.UTF-8
 Pliki nagłówkowe bibliotek systemd.
 
+%package static
+Summary:       Static systemd libraries
+Summary(pl.UTF-8):     Statyczne biblioteki systemd
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
+
+%description static
+Static systemd libraries.
+
+%description static -l pl.UTF-8
+Statyczne biblioteki systemd.
+
 %package -n bash-completion-systemd
 Summary:       bash-completion for systemd
 Summary(pl.UTF-8):     Bashowe dopełnianie składni dla systemd
 Group:         Applications/Shells
 Requires:      %{name} = %{epoch}:%{version}
-Requires:      bash-completion
+Requires:      bash-completion >= 2.0
 
 %description -n bash-completion-systemd
 bash-completion for systemd.
@@ -422,15 +409,20 @@ hotpluga.
 Summary:       A userspace implementation of devfs - core part of udev
 Summary(pl.UTF-8):     Implementacja devfs w przestrzeni użytkownika - główna część udev
 Group:         Base
-Requires:      udev-libs = %{epoch}:%{version}-%{release}
 Requires:      coreutils
 Requires:      filesystem >= 3.0-45
+Requires:      kmod-libs >= 5
+Requires:      libblkid >= 2.20
+%{?with_selinux:Requires:      libselinux >= 2.1.9}
 Requires:      setup >= 2.6.1-1
+Requires:      udev-libs = %{epoch}:%{version}-%{release}
 Requires:      uname(release) >= 2.6.32
+Obsoletes:     udev-compat
+Obsoletes:     udev-initrd < %{epoch}:%{version}-%{release}}
 Conflicts:     rc-scripts < 0.4.5.3-1
 Conflicts:     systemd-units < 1:183
 Conflicts:     udev < 1:118-1
-Obsoletes:     udev-compat
+Conflicts:     geninitrd < 12639
 
 %description -n udev-core
 A userspace implementation of devfs - core part of udev.
@@ -490,8 +482,8 @@ Dokumentacja API libudev.
 Summary:       Shared libgudev library - GObject bindings for libudev
 Summary(pl.UTF-8):     Biblioteka współdzielona libgudev - wiązania GObject do libudev
 Group:         Libraries
-Requires:      udev-libs = %{epoch}:%{version}-%{release}
 Requires:      glib2 >= 1:2.22.0
+Requires:      udev-libs = %{epoch}:%{version}-%{release}
 
 %description -n udev-glib
 Shared libgudev library - GObject bindings for libudev.
@@ -503,9 +495,9 @@ Biblioteka współdzielona libgudev - wiązania GObject do libudev.
 Summary:       Header file for libgudev library
 Summary(pl.UTF-8):     Plik nagłówkowy biblioteki libgudev
 Group:         Development/Libraries
+Requires:      glib2-devel >= 1:2.22.0
 Requires:      udev-devel = %{epoch}:%{version}-%{release}
 Requires:      udev-glib = %{epoch}:%{version}-%{release}
-Requires:      glib2-devel >= 1:2.22.0
 
 %description -n udev-glib-devel
 Header file for libgudev library.
@@ -537,19 +529,32 @@ libgudev API documentation.
 %description -n udev-glib-apidocs -l pl.UTF-8
 Dokumentacja API libgudev.
 
-%package -n udev-initrd
-Summary:       A userspace implementation of devfs - static binary for initrd
-Summary(pl.UTF-8):     Implementacja devfs w przestrzeni użytkownika - statyczna binarka dla initrd
-Group:         Base
-Requires:      udev-core = %{epoch}:%{version}-%{release}
-Conflicts:     geninitrd < 10000.10
+%package -n bash-completion-udev
+Summary:       bash-completion for udev
+Summary(pl.UTF-8):     Bashowe dopełnianie składni dla udev
+Group:         Applications/Shells
+Requires:      bash-completion >= 2.0
+Requires:      udev = %{epoch}:%{version}
+
+%description -n bash-completion-udev
+bash-completion for udev.
 
-%description -n udev-initrd
-A userspace implementation of devfs - static binary for initrd.
+%description -n bash-completion-udev -l pl.UTF-8
+Bashowe dopełnianie składni dla udev.
 
-%description -n udev-initrd -l pl.UTF-8
-Implementacja devfs w przestrzeni użytkownika - statyczna binarka dla
-initrd.
+
+%package -n python-systemd
+Summary:       Systemd Python bindings
+Summary(pl.UTF-8):     Wiązania do Systemd dla Pythona
+Group:         Development/Languages/Python
+Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
+Requires:      python
+
+%description -n python-systemd
+Systemd Python bindings.
+
+%description -n python-systemd -l pl.UTF-8
+Wiązania do Systemd dla Pythona.
 
 %prep
 %setup -q
@@ -558,14 +563,12 @@ initrd.
 #patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
 %patch6 -p1
-%if %{with uClibc}
-%patch7 -p1
-%endif
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
+%patch11 -p1
+%patch12 -p1
 cp -p %{SOURCE2} src/systemd_booted.c
 
 %build
@@ -575,84 +578,36 @@ cp -p %{SOURCE2} src/systemd_booted.c
 %{__autoconf}
 %{__autoheader}
 %{__automake}
-%if %{with initrd}
-patch -p1 <%{PATCH100}
-%configure \
-%if "%{?configure_cache}" == "1"
-       --cache-file=%{?configure_cache_file}%{!?configure_cache_file:configure}-initrd.cache \
-%endif
-       %{?with_uClibc:CC="%{_target_cpu}-uclibc-gcc"} \
-       %{?with_dietlibc:CC="diet %{__cc} %{rpmcflags} %{rpmldflags} -Os -D_BSD_SOURCE"} \
-       %{?with_klibc:CC="%{_bindir}/klcc"} \
-       %{?debug:--enable-debug} \
-       --disable-silent-rules \
-       --disable-shared \
-       --enable-static \
-       --with-distro=pld \
-       --with-rootprefix="" \
-       --with-rootlibdir=/%{_lib} \
-       --disable-gudev \
-       --disable-keymap \
-       --disable-gtk-doc \
-       --disable-introspection \
-       --with-pci-ids-path=%{_sysconfdir}/pci.ids \
-       --disable-audit \
-       --disable-pam \
-       --disable-plymouth \
-       --disable-selinux \
-       --enable-split-usr
-
-%{__make} \
-       libudev-core.la \
-       systemd-udevd \
-       udevadm \
-       ata_id \
-       cdrom_id \
-       collect \
-       scsi_id \
-       v4l_id \
-       accelerometer \
-       mtd_probe \
-       LDFLAGS="-all-static" \
-       KMOD_LIBS="-lkmod -lz -llzma"
-
-mkdir udev-initrd
-cp -a systemd-udevd \
-       udevadm \
-       ata_id \
-       cdrom_id \
-       collect \
-       scsi_id \
-       v4l_id \
-       accelerometer \
-       mtd_probe \
-       udev-initrd/
-
-%{__make} clean
-patch -p1 -R <%{PATCH100}
-%endif
-
 %configure \
+       QUOTAON=/sbin/quotaon \
+       QUOTACHECK=/sbin/quotacheck \
+       SETCAP=/sbin/setcap \
+       KILL=/bin/kill \
        %{?debug:--enable-debug} \
        %{__enable_disable audit} \
        %{__enable_disable cryptsetup libcryptsetup} \
        %{__enable_disable pam} \
        %{__enable_disable selinux} \
        %{__enable_disable tcpd tcpwrap} \
-       --disable-plymouth \
+       %{__enable_disable microhttpd} \
+       %{__enable_disable qrencode} \
        --disable-silent-rules \
-       --enable-shared \
-       --enable-static \
-       --with-distro=pld \
-       --with-rootprefix="" \
-       --with-rootlibdir=/%{_lib} \
-       --with-html-dir=%{_gtkdocdir} \
-       --with-pci-ids-path=%{_sysconfdir}/pci.ids \
+       --enable-chkconfig \
        --enable-gtk-doc \
        --enable-introspection \
-       --enable-split-usr
+       --enable-split-usr \
+       --enable-static \
+       --with-html-dir=%{_gtkdocdir} \
+       --with-kbd-loadkeys=/usr/bin/loadkeys \
+       --with-kbd-setfont=/bin/setfont \
+       --with-sysvinit-path=/etc/rc.d/init.d \
+       --with-sysvrcnd-path=/etc/rc.d \
+       --with-rc-local-script-path-start=/etc/rc.d/rc.local \
+       --with-rc-local-script-path-stop=/sbin/halt.local \
+       --with-rootprefix="" \
+       --with-rootlibdir=/%{_lib}
 
-%{__make}
+%{__make} -j1
 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
 
 %install
@@ -671,14 +626,18 @@ ln -s /lib/udev/udevd $RPM_BUILD_ROOT/lib/systemd/systemd-udevd
 ln -s /lib/udev/udevd $RPM_BUILD_ROOT%{_sbindir}/udevd
 
 # compat symlinks for "/ merged into /usr" programs
-mv $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/udevadm
-ln -s %{_sbindir}/udevadm $RPM_BUILD_ROOT%{_bindir}
+mv $RPM_BUILD_ROOT/{,s}bin/udevadm
+ln -s %{_sbindir}/udevadm $RPM_BUILD_ROOT/bin
 ln -s /lib/udev $RPM_BUILD_ROOT/usr/lib/
 
 # install custom udev rules from pld package
 cp -a %{SOURCE101} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/40-alsa-restore.rules
 cp -a %{SOURCE102} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/70-udev-pld.rules
 
+# disable this abomination
+# http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames
+ln -s /dev/null $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/80-net-name-slot.rules
+
 # install udev configs
 cp -a %{SOURCE103} $RPM_BUILD_ROOT%{_sysconfdir}/udev/links.conf
 
@@ -693,18 +652,6 @@ cp -a %{SOURCE121} $RPM_BUILD_ROOT%{_sysconfdir}/modprobe.d/fbdev-blacklist.conf
 mv $RPM_BUILD_ROOT%{_mandir}/man8/{systemd-,}udevd.8
 echo ".so man8/udevd.8" >$RPM_BUILD_ROOT%{_mandir}/man8/systemd-udevd.8
 
-%if %{with initrd}
-install -d $RPM_BUILD_ROOT%{_libdir}/initrd/udev
-install -p udev-initrd/udevadm $RPM_BUILD_ROOT%{_libdir}/initrd
-install -p udev-initrd/systemd-udevd $RPM_BUILD_ROOT%{_libdir}/initrd
-# hardlink udevd -> systemd-udevd
-ln $RPM_BUILD_ROOT%{_libdir}/initrd/{systemd-,}udevd
-ln -s udevd $RPM_BUILD_ROOT%{_libdir}/initrd/udevstart
-install -p udev-initrd/*_id $RPM_BUILD_ROOT%{_libdir}/initrd/udev
-install -p udev-initrd/collect $RPM_BUILD_ROOT%{_libdir}/initrd/udev
-install -p udev-initrd/mtd_probe $RPM_BUILD_ROOT%{_libdir}/initrd/udev
-%endif
-
 # Main binary has been moved, but we don't want to break existing installs
 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
 
@@ -761,14 +708,19 @@ cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdunitdir}/rc-inetd.service
 
 cp -p %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system-preset/default.preset
 
+cp -p %{SOURCE19} $RPM_BUILD_ROOT%{systemdunitdir}/prefdm.service
+
 # handled by rc-local sysv service, no need for generator
 %{__rm} $RPM_BUILD_ROOT/lib/systemd/system-generators/systemd-rc-local-generator
 
+# provided by rc-scripts
+%{__rm} $RPM_BUILD_ROOT/lib/systemd/system/rc-local.service
+
 # Make sure these directories are properly owned:
 #      - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
 #      - syslog _might_ be used by some syslog implementation (none for now),
 #      - isn't dbus populated by dbus-systemd only (so to be moved there)?
-install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
+install -d $RPM_BUILD_ROOT%{systemdunitdir}/{basic,dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
 
 # Create new-style configuration files so that we can ghost-own them
 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,timezone,vconsole.conf}
@@ -782,12 +734,22 @@ install -d $RPM_BUILD_ROOT/var/log
 
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
+%{__rm} $RPM_BUILD_ROOT/%{_lib}/libnss_myhostname.la
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
+%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/systemd/*.la
+%py_postclean
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%pre
+%groupadd -g 288 systemd-journal
+%groupadd -g 287 systemd-journal-gateway
+%useradd -u 287 -g 287 -d /var/log/journal -s /bin/false -c "Systemd Journal Gateway" systemd-journal-gateway
+
 %post
+# should we?
+#setfacl -nm g:logs:rx,d:g:logs:rx /var/log/journal
 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
 
@@ -795,6 +757,11 @@ rm -rf $RPM_BUILD_ROOT
 if [ $1 -ge 1 ]; then
        /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
 fi
+if [ "$1" = "0" ]; then
+       %userremove systemd-journal-gateway
+       %groupremove systemd-journal-gateway
+       %groupremove systemd-journal
+fi
 
 %post   libs -p /sbin/ldconfig
 %postun libs -p /sbin/ldconfig
@@ -941,6 +908,7 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/bootchart.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/journald.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/logind.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system.conf
@@ -958,24 +926,33 @@ fi
 %attr(755,root,root) /bin/systemd-machine-id-setup
 %attr(755,root,root) /bin/systemd-notify
 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
+%attr(755,root,root) %{_bindir}/bootctl
+%attr(755,root,root) %{_bindir}/hostnamectl
+%attr(755,root,root) %{_bindir}/kernel-install
+%attr(755,root,root) %{_bindir}/localectl
 %attr(755,root,root) %{_bindir}/systemd-cat
-%attr(755,root,root) %{_bindir}/systemd-cgtop
 %attr(755,root,root) %{_bindir}/systemd-cgls
+%attr(755,root,root) %{_bindir}/systemd-cgtop
+%attr(755,root,root) %{_bindir}/systemd-coredumpctl
 %attr(755,root,root) %{_bindir}/systemd-delta
 %attr(755,root,root) %{_bindir}/systemd-detect-virt
 %attr(755,root,root) %{_bindir}/systemd-nspawn
 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
+%attr(755,root,root) %{_bindir}/timedatectl
 %attr(755,root,root) /lib/systemd/pld-clean-tmp
 %attr(755,root,root) /lib/systemd/pld-storage-init
 %attr(755,root,root) /lib/systemd/systemd-ac-power
+%attr(755,root,root) /lib/systemd/systemd-activate
 %attr(755,root,root) /lib/systemd/systemd-binfmt
+%attr(755,root,root) /lib/systemd/systemd-bootchart
 %attr(755,root,root) /lib/systemd/systemd-cgroups-agent
 %attr(755,root,root) /lib/systemd/systemd-coredump
-%attr(755,root,root) /lib/systemd/systemd-cryptsetup
+%{?with_cryptsetup:%attr(755,root,root) /lib/systemd/systemd-cryptsetup}
 %attr(755,root,root) /lib/systemd/systemd-fsck
 %attr(755,root,root) /lib/systemd/systemd-hostnamed
 %attr(755,root,root) /lib/systemd/systemd-initctl
+%{?with_microhttpd:%attr(755,root,root) /lib/systemd/systemd-journal-gatewayd}
 %attr(755,root,root) /lib/systemd/systemd-journald
 %attr(755,root,root) /lib/systemd/systemd-localed
 %attr(755,root,root) /lib/systemd/systemd-logind
@@ -999,11 +976,13 @@ fi
 %dir /lib/systemd/system-generators
 %attr(755,root,root) /lib/systemd/systemd
 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
-/lib/udev/rules.d/99-systemd.rules
 /lib/udev/rules.d/70-uaccess.rules
 /lib/udev/rules.d/71-seat.rules
 /lib/udev/rules.d/73-seat-late.rules
+/lib/udev/rules.d/99-systemd.rules
 %dir %{_libexecdir}/systemd
+%dir %{_libexecdir}/systemd/catalog
+%{_libexecdir}/systemd/catalog/systemd.catalog
 %{_libexecdir}/systemd/user
 %dir %{_libexecdir}/systemd/user-generators
 %{_libexecdir}/tmpfiles.d/legacy.conf
@@ -1026,14 +1005,19 @@ fi
 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
 %dir %{_datadir}/systemd
+%{?with_microhttpd:%{_datadir}/systemd/gatewayd}
 %{_datadir}/systemd/kbd-model-map
+%{_mandir}/man1/hostnamectl.1*
 %{_mandir}/man1/journalctl.1*
+%{_mandir}/man1/localectl.1*
 %{_mandir}/man1/loginctl.1*
 %{_mandir}/man1/systemd.1*
 %{_mandir}/man1/systemd-ask-password.1*
+%{_mandir}/man1/systemd-bootchart.1*
 %{_mandir}/man1/systemd-cat.1*
 %{_mandir}/man1/systemd-cgls.1*
 %{_mandir}/man1/systemd-cgtop.1*
+%{_mandir}/man1/systemd-coredumpctl.1*
 %{_mandir}/man1/systemd-delta.1*
 %{_mandir}/man1/systemd-detect-virt.1*
 %{_mandir}/man1/systemd-inhibit.1*
@@ -1041,12 +1025,15 @@ fi
 %{_mandir}/man1/systemd-notify.1*
 %{_mandir}/man1/systemd-nspawn.1*
 %{_mandir}/man1/systemd-tty-ask-password-agent.1*
+%{_mandir}/man1/timedatectl.1*
 %{_mandir}/man5/binfmt.d.5*
+%{_mandir}/man5/bootchart.conf.5*
 # cfl with rc-scripts
 #%{_mandir}/man5/crypttab.5*
 %{_mandir}/man5/hostname.5*
 %{_mandir}/man5/journald.conf.5*
 %{_mandir}/man5/locale.conf.5*
+%{_mandir}/man5/localtime.5*
 %{_mandir}/man5/logind.conf.5*
 %{_mandir}/man5/machine-id.5*
 %{_mandir}/man5/machine-info.5*
@@ -1054,19 +1041,28 @@ fi
 %{_mandir}/man5/os-release.5*
 %{_mandir}/man5/sysctl.d.5*
 %{_mandir}/man5/systemd.*.5*
-%{_mandir}/man5/timezone.5*
+%{_mandir}/man5/systemd-system.conf.5*
+%{_mandir}/man5/systemd-user.conf.5*
 %{_mandir}/man5/vconsole.conf.5*
 %{_mandir}/man7/bootup.7*
 %{_mandir}/man7/daemon.7*
 %{_mandir}/man7/kernel-command-line.7*
+%{_mandir}/man7/systemd.directives.7*
+%{_mandir}/man7/systemd.index.7*
 %{_mandir}/man7/systemd.journal-fields.7*
 %{_mandir}/man7/systemd.special.7*
+%{_mandir}/man7/systemd.time.7*
+%{_mandir}/man8/kernel-install.8*
+%{_mandir}/man8/nss-myhostname.8*
+%{_mandir}/man8/systemd-activate.8*
 %{_mandir}/man8/systemd-binfmt.8*
-%{_mandir}/man8/systemd-cryptsetup-generator.8*
+%{?with_cryptsetup:%{_mandir}/man8/systemd-cryptsetup-generator.8*}
+%{_mandir}/man8/systemd-fsck.8*
 %{_mandir}/man8/systemd-fstab-generator.8*
 %{_mandir}/man8/systemd-getty-generator.8*
 %{_mandir}/man8/systemd-hostnamed.8*
 %{_mandir}/man8/systemd-initctl.8*
+%{?with_microhttpd:%{_mandir}/man8/systemd-journal-gatewayd.8*}
 %{_mandir}/man8/systemd-journald.8*
 %{_mandir}/man8/systemd-localed.8*
 %{_mandir}/man8/systemd-logind.8*
@@ -1089,6 +1085,7 @@ fi
 %dir /var/lib/%{name}/coredump
 %attr(640,root,root) %ghost /var/log/btmp
 %attr(664,root,utmp) %ghost /var/log/wtmp
+%dir /var/log/journal
 
 %if %{with pam}
 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
@@ -1126,11 +1123,10 @@ fi
 %dir %{_libexecdir}/binfmt.d
 %dir %{_libexecdir}/modules-load.d
 %dir %{_libexecdir}/sysctl.d
+%dir /lib/systemd/system-sleep
 %dir /lib/systemd/system-shutdown
-# Don't package the kernel.core_pattern setting until systemd-coredump
-# is a part of an actual systemd release and it's made clear how to
-# get the core dumps out of the journal.
-#%{_libexecdir}/sysctl.d/coredump.conf
+%{_libexecdir}/sysctl.d/50-coredump.conf
+%{_libexecdir}/sysctl.d/50-default.conf
 %attr(755,root,root) /bin/systemctl
 %attr(755,root,root) /bin/systemd-tmpfiles
 %attr(755,root,root) /bin/systemd_booted
@@ -1143,6 +1139,7 @@ fi
 %{systemdunitdir}/*.mount
 %{systemdunitdir}/*.path
 %{systemdunitdir}/*.service
+%exclude %{systemdunitdir}/rc-inetd.service
 %{systemdunitdir}/*.socket
 %{systemdunitdir}/*.target
 %{systemdunitdir}/*.timer
@@ -1161,7 +1158,7 @@ fi
 %dir %{systemdunitdir}/sockets.target.wants
 %dir %{systemdunitdir}/sysinit.target.wants
 %dir %{systemdunitdir}/syslog.target.wants
-%{systemdunitdir}/basic.target.wants/*
+%dir %{systemdunitdir}/timers.target.wants
 %{systemdunitdir}/final.target.wants/*
 %{systemdunitdir}/graphical.target.wants/*
 %{systemdunitdir}/local-fs.target.wants/*
@@ -1179,20 +1176,24 @@ fi
 %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
 %{systemdunitdir}/sysinit.target.wants/sys-*.mount
 %{systemdunitdir}/sysinit.target.wants/systemd-*
+%{systemdunitdir}/timers.target.wants/*.timer
 %{_mandir}/man8/systemd-ask-password-console.path.8*
 %{_mandir}/man8/systemd-ask-password-console.service.8*
 %{_mandir}/man8/systemd-ask-password-wall.path.8*
 %{_mandir}/man8/systemd-ask-password-wall.service.8*
 %{_mandir}/man8/systemd-binfmt.service.8*
-%{_mandir}/man8/systemd-cryptsetup.8*
-%{_mandir}/man8/systemd-cryptsetup@.service.8*
+%{?with_cryptsetup:%{_mandir}/man8/systemd-cryptsetup.8*}
+%{?with_cryptsetup:%{_mandir}/man8/systemd-cryptsetup@.service.8*}
 %{_mandir}/man8/systemd-fsck-root.service.8*
 %{_mandir}/man8/systemd-fsck@.service.8*
 %{_mandir}/man8/systemd-halt.service.8*
 %{_mandir}/man8/systemd-hibernate.service.8*
 %{_mandir}/man8/systemd-hostnamed.service.8*
+%{_mandir}/man8/systemd-hybrid-sleep.service.8*
 %{_mandir}/man8/systemd-initctl.service.8*
 %{_mandir}/man8/systemd-initctl.socket.8*
+%{?with_microhttpd:%{_mandir}/man8/systemd-journal-gatewayd.service.8*}
+%{?with_microhttpd:%{_mandir}/man8/systemd-journal-gatewayd.socket.8*}
 %{_mandir}/man8/systemd-journald.service.8*
 %{_mandir}/man8/systemd-journald.socket.8*
 %{_mandir}/man8/systemd-kexec.service.8*
@@ -1218,6 +1219,8 @@ fi
 %{_mandir}/man8/systemd-tmpfiles-clean.timer.8*
 %{_mandir}/man8/systemd-tmpfiles-setup.service.8*
 %{_mandir}/man8/systemd-udevd.service.8*
+%{_mandir}/man8/systemd-udevd-control.socket.8*
+%{_mandir}/man8/systemd-udevd-kernel.socket.8*
 %{_mandir}/man8/systemd-update-utmp-runlevel.service.8*
 %{_mandir}/man8/systemd-update-utmp-shutdown.service.8*
 %{_mandir}/man8/systemd-user-sessions.service.8*
@@ -1235,6 +1238,7 @@ fi
 
 %files libs
 %defattr(644,root,root,755)
+%attr(755,root,root) /%{_lib}/libnss_myhostname.so.2
 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
@@ -1258,9 +1262,22 @@ fi
 %{_mandir}/man3/SD_*.3*
 %{_mandir}/man3/sd*.3*
 
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libsystemd-daemon.a
+%{_libdir}/libsystemd-id128.a
+%{_libdir}/libsystemd-journal.a
+%{_libdir}/libsystemd-login.a
+
 %files -n bash-completion-systemd
 %defattr(644,root,root,755)
-/etc/bash_completion.d/systemd-bash-completion.sh
+%{_datadir}/bash-completion/completions/hostnamectl
+%{_datadir}/bash-completion/completions/journalctl
+%{_datadir}/bash-completion/completions/localectl
+%{_datadir}/bash-completion/completions/loginctl
+%{_datadir}/bash-completion/completions/systemctl
+%{_datadir}/bash-completion/completions/systemd-coredumpctl
+%{_datadir}/bash-completion/completions/timedatectl
 
 %files -n udev
 %defattr(644,root,root,755)
@@ -1294,19 +1311,30 @@ fi
 %attr(755,root,root) /lib/udev/accelerometer
 %attr(755,root,root) /lib/udev/findkeyboards
 
+%dir /lib/udev/hwdb.d
+/lib/udev/hwdb.d/20-OUI.hwdb
+/lib/udev/hwdb.d/20-acpi-vendor.hwdb
+/lib/udev/hwdb.d/20-bluetooth-vendor-product.hwdb
+/lib/udev/hwdb.d/20-pci-classes.hwdb
+/lib/udev/hwdb.d/20-pci-vendor-model.hwdb
+/lib/udev/hwdb.d/20-usb-classes.hwdb
+/lib/udev/hwdb.d/20-usb-vendor-model.hwdb
+
 %attr(755,root,root) %{_sbindir}/start_udev
 %attr(755,root,root) %{_sbindir}/udevd
 %attr(755,root,root) %{_sbindir}/udevadm
-%attr(755,root,root) %{_bindir}/udevadm
+%attr(755,root,root) /bin/udevadm
 
 %dir %{_sysconfdir}/udev
 %dir %{_sysconfdir}/udev/rules.d
+%dir %{_sysconfdir}/udev/hwdb.d
 
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modprobe.d/fbdev-blacklist.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modprobe.d/udev_blacklist.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/links.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/rules.d/40-alsa-restore.rules
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/rules.d/70-udev-pld.rules
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/rules.d/80-net-name-slot.rules
 
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/udev.conf
 
@@ -1321,12 +1349,14 @@ fi
 /lib/udev/rules.d/60-persistent-storage.rules
 /lib/udev/rules.d/60-persistent-v4l.rules
 /lib/udev/rules.d/61-accelerometer.rules
+/lib/udev/rules.d/64-btrfs.rules
 /lib/udev/rules.d/70-power-switch.rules
 /lib/udev/rules.d/75-net-description.rules
 /lib/udev/rules.d/75-probe_mtd.rules
 /lib/udev/rules.d/75-tty-description.rules
 /lib/udev/rules.d/78-sound-card.rules
 /lib/udev/rules.d/80-drivers.rules
+/lib/udev/rules.d/80-net-name-slot.rules
 /lib/udev/rules.d/95-keyboard-force-release.rules
 /lib/udev/rules.d/95-keymap.rules
 /lib/udev/rules.d/95-udev-late.rules
@@ -1376,15 +1406,12 @@ fi
 %defattr(644,root,root,755)
 %{_gtkdocdir}/gudev
 
-%if %{with initrd}
-%files -n udev-initrd
+%files -n bash-completion-udev
 %defattr(644,root,root,755)
-%dir %{_libdir}/initrd/udev
-%attr(755,root,root) %{_libdir}/initrd/systemd-udevd
-%attr(755,root,root) %{_libdir}/initrd/udevd
-%attr(755,root,root) %{_libdir}/initrd/udevadm
-%attr(755,root,root) %{_libdir}/initrd/udevstart
-%attr(755,root,root) %{_libdir}/initrd/udev/*_id
-%attr(755,root,root) %{_libdir}/initrd/udev/collect
-%attr(755,root,root) %{_libdir}/initrd/udev/mtd_probe
-%endif
+%{_datadir}/bash-completion/completions/udevadm
+
+%files -n python-systemd
+%defattr(644,root,root,755)
+%dir %{py_sitedir}/systemd
+%{py_sitedir}/systemd/*.py*
+%attr(755,root,root) %{py_sitedir}/systemd/*.so
This page took 0.129906 seconds and 4 git commands to generate.