]> git.pld-linux.org Git - packages/systemd.git/blobdiff - systemd.spec
up to 254.12
[packages/systemd.git] / systemd.spec
index 3d6427680627a9b909a5d720a5bdd8bdd6239421..7df6ea0832f6a10fa39450053337c70b40e806c7 100644 (file)
@@ -20,6 +20,9 @@
 %bcond_without fido2           # FIDO2 support
 %bcond_without tpm2            # TPM2 support
 %bcond_with    tests           # "make check" (requires systemd already installed)
+%bcond_with    xen             # Xen kexec support
+
+%define         min_kernel      3.15
 
 %ifnarch %{ix86} %{x8664} aarch64
 # x32 disabled - maybe it's possible to build x64 EFI, but it requires some hacking (add -m64 to EFI gcc command line?)
@@ -29,14 +32,14 @@ Summary:    A System and Service Manager
 Summary(pl.UTF-8):     systemd - zarządca systemu i usług dla Linuksa
 Name:          systemd
 # Verify ChangeLog and NEWS when updating (since there are incompatible/breaking changes very often)
-Version:       252.4
+Version:       254.12
 Release:       1
 Epoch:         1
 License:       GPL v2+ (udev), LGPL v2.1+ (the rest)
 Group:         Base
 #Source0Download: https://github.com/systemd/systemd/releases
 Source0:       https://github.com/systemd/systemd-stable/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: be1709332649a39c7a143d99a3b1043a
+# Source0-md5: dd6978f427bd9d96fa66c6075a751bb4
 Source1:       %{name}-sysv-convert
 Source2:       %{name}_booted.c
 Source3:       network.service
@@ -57,6 +60,7 @@ Source103:    udev-links.conf
 Source104:     udev-uinput.rules
 Source105:     udev-steam_controller.rules
 Source106:     udev-i2c.rules
+Source107:     udev-raspberrypi.rules
 # scripts / helpers
 Source110:     udev-net.helper
 Source111:     start_udev
@@ -79,10 +83,15 @@ Patch13:    sysctl.patch
 Patch14:       pld-pam-%{name}-user.patch
 Patch15:       %{name}-x32.patch
 Patch16:       rpm-macros.patch
+Patch17:       %{name}-glibc.patch
 URL:           https://www.freedesktop.org/wiki/Software/systemd/
 BuildRequires: acl-devel
 %{?with_audit:BuildRequires:   audit-libs-devel}
+%if %{with efi}
+BuildRequires: binutils >= 4:2.38
+%else
 BuildRequires: binutils >= 3:2.22.52.0.1-2
+%endif
 BuildRequires: bzip2-devel
 %{?with_bpf:BuildRequires:     clang >= 10.0.0}
 # ln --relative
@@ -117,14 +126,14 @@ BuildRequires:    libgpg-error-devel >= 1.12
 BuildRequires: libidn2-devel
 %{?with_microhttpd:BuildRequires:      libmicrohttpd-devel >= 0.9.33}
 BuildRequires: libmount-devel >= 2.30
-BuildRequires: libpwquality-devel
+BuildRequires: libpwquality-devel >= 1.4.1
 BuildRequires: libseccomp-devel >= 2.4.0
 %{?with_selinux:BuildRequires: libselinux-devel >= 2.6}
 BuildRequires: libtool >= 2:2.2
 BuildRequires: libxslt-progs
 BuildRequires: lz4-devel >= 1:1.3.0
 BuildRequires: m4
-BuildRequires: meson >= 0.53.2
+BuildRequires: meson >= 0.60.0
 BuildRequires: ninja
 BuildRequires: openssl-devel
 BuildRequires: p11-kit-devel >= 0.23.3
@@ -134,7 +143,8 @@ BuildRequires:      pcre2-8-devel
 BuildRequires: pld-release
 BuildRequires: pkgconfig >= 1:0.9.0
 BuildRequires: polkit-devel >= 0.106
-BuildRequires: python3
+BuildRequires: python3 >= 1:3.9
+%{?with_efi:BuildRequires:     python3-elftools}
 BuildRequires: python3-jinja2
 BuildRequires: python3-lxml
 %{?with_qrencode:BuildRequires:        qrencode-devel >= 3}
@@ -144,6 +154,7 @@ BuildRequires:      sed >= 4.0
 %{?with_tests:BuildRequires:   systemd}
 %{?with_tpm2:BuildRequires:    tpm2-tss-devel >= 3.0.0}
 BuildRequires: usbutils >= 0.82
+%{?with_xen:BuildRequires:     xen-devel}
 BuildRequires: xorg-lib-libxkbcommon-devel >= 0.5.0
 BuildRequires: xz-devel
 BuildRequires: zlib-devel
@@ -163,9 +174,9 @@ Requires:   /etc/os-release
 Requires:      SysVinit-tools
 Requires:      agetty
 Requires:      dbus >= 1.9.18
-Requires:      elfutils >= 0.177
 Requires:      filesystem >= 4.0-39
-Requires:      glibc >= 2.16
+Requires:      glibc >= 6:2.16
+Requires:      kbd
 Requires:      kmod >= 25-2
 Requires:      libgpg-error >= 1.12
 Requires:      libutempter
@@ -174,7 +185,7 @@ Requires:   rc-scripts >= 0.4.5.3-7
 Requires:      setup >= 2.10.1
 Requires:      udev-core = %{epoch}:%{version}-%{release}
 Requires:      udev-libs = %{epoch}:%{version}-%{release}
-Requires:      uname(release) >= 4.15
+Requires:      uname(release) >= %{min_kernel}
 Requires:      util-linux >= 2.30
 Suggests:      %{name}-container = %{epoch}:%{version}-%{release}
 Suggests:      %{name}-sysv-compat = %{epoch}:%{version}-%{release}
@@ -182,7 +193,7 @@ Suggests:   %{name}-sysv-compat = %{epoch}:%{version}-%{release}
 Suggests:      fsck >= 2.25.0
 %{?with_fido2:Suggests:        libfido2}
 Suggests:      libidn2
-Suggests:      libpwquality
+Suggests:      libpwquality >= 1.4.1
 Suggests:      pcre2-8
 %{?with_qrencode:Suggests:     qrencode-libs >= 3}
 Suggests:      service(klogd)
@@ -480,6 +491,7 @@ Summary:    systemd userspace OOM killer service
 Summary(pl.UTF-8):     Usługa systemd zabójcy OOM w przestrzeni użytkownika
 Group:         Base
 Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      uname(release) >= 4.20
 
 %description oomd
 systemd-oomd is a system service which monitors resource contention
@@ -601,6 +613,19 @@ jednostki systemd na zakończenie podczas rozruchu systemu.
 'systemd-analyze plot' tworzy wykres SVG wizualizujący równoległy
 start jednostek podczas rozruchu.
 
+%package ukify
+Summary:       Tool for combining kernel and initrd into Unified Kernel Image (UKI)
+Summary(pl.UTF-8):     Narzędzie do łączenia jądra oraz initrd w Unified Kernel Image (UKI)
+Group:         Base
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      python3-modules >= 1:3.9
+
+%description ukify
+Tool for combining kernel and initrd into Unified Kernel Image (UKI).
+
+%description ukify -l pl.UTF-8
+Narzędzie do łączenia jądra oraz initrd w Unified Kernel Image (UKI).
+
 %package libs
 Summary:       Shared systemd libraries
 Summary(pl.UTF-8):     Biblioteki współdzielone systemd
@@ -610,6 +635,7 @@ Requires:   libseccomp >= 2.4.0
 %{?with_selinux:Requires:      libselinux >= 2.6}
 Requires:      lz4-libs >= 1:1.3.0
 Requires:      zstd >= 1.4.0
+Suggests:      elfutils-libs >= 0.177
 Obsoletes:     nss_myhostname < 0.4
 
 %description libs
@@ -622,7 +648,7 @@ Biblioteki współdzielone systemd.
 Summary:       Header files for systemd libraries
 Summary(pl.UTF-8):     Pliki nagłówkowe bibliotek systemd
 Group:         Development/Libraries
-Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
+Requires:      %{name}-libs%{?_isa} = %{epoch}:%{version}-%{release}
 Requires:      %{name}-units = %{epoch}:%{version}-%{release}
 Obsoletes:     systemd-static < 1:205
 
@@ -700,7 +726,7 @@ Requires:   libblkid >= 2.24
 Requires:      setup >= 2.10.1
 Requires:      systemd-libs = %{epoch}:%{version}-%{release}
 Requires:      udev-libs = %{epoch}:%{version}-%{release}
-Requires:      uname(release) >= 4.15
+Requires:      uname(release) >= %{min_kernel}
 Obsoletes:     udev-compat < 1:182-1
 Obsoletes:     udev-dbus < 027
 Obsoletes:     udev-digicam < 1:079-2
@@ -733,7 +759,7 @@ urządzeniach udev.
 Summary:       Header file for libudev library
 Summary(pl.UTF-8):     Plik nagłówkowy biblioteki libudev
 Group:         Development/Libraries
-Requires:      udev-libs = %{epoch}:%{version}-%{release}
+Requires:      udev-libs%{?_isa} = %{epoch}:%{version}-%{release}
 Obsoletes:     udev-apidocs < 1:221-1
 Obsoletes:     udev-static < 1:205
 
@@ -801,11 +827,16 @@ Makra RPM-a definiujące ścieżki i skryptlety związane z systemd.
 %patch14 -p1
 %patch15 -p1
 %patch16 -p1
+%patch17 -p1
 
 cp -p %{SOURCE2} src/systemd_booted.c
 
 grep -rlZ -0 '#!/usr/bin/env bash' . | xargs -0 sed -i -e 's,#!/usr/bin/env bash,#!/bin/bash,g'
 
+%{__sed} -i -e '1 s,#!.*env python3,#!%{__python3},' \
+       src/ukify/ukify.py \
+       src/kernel-install/60-ukify.install.in
+
 %build
 %meson build \
        -Dadm-gid=3 \
@@ -854,6 +885,11 @@ grep -rlZ -0 '#!/usr/bin/env bash' . | xargs -0 sed -i -e 's,#!/usr/bin/env bash
        -Drc-local=/etc/rc.d/rc.local \
        -Drootlibdir=/%{_lib} \
        -Drootprefix="" \
+       -Dsbat-distro="%vendor" \
+       -Dsbat-distro-pkgname="%name" \
+       -Dsbat-distro-summary="%distribution" \
+       -Dsbat-distro-url="https://git.pld-linux.org/?p=packages/systemd.git" \
+       -Dsbat-distro-version="%version-%release" \
        -Dselinux=%{__true_false selinux} \
        -Dsetfont-path=/bin/setfont \
        -Dsplit-bin=true \
@@ -863,6 +899,7 @@ grep -rlZ -0 '#!/usr/bin/env bash' . | xargs -0 sed -i -e 's,#!/usr/bin/env bash
        -Dsysvrcnd-path=/etc/rc.d \
        -Dtpm2=%{__true_false tpm2} \
        -Dumount-path=/bin/umount \
+       -Dxenctrl=%{__true_false xen}
 
 %ninja_build -C build
 
@@ -875,7 +912,7 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/var/lib/{%{name}/{catalog,coredump},machines} \
        $RPM_BUILD_ROOT%{_rootsbindir} \
        $RPM_BUILD_ROOT%{_sysconfdir}/{modprobe.d,repart.d,systemd/{system,user}-preset,sysupdate.d} \
-       $RPM_BUILD_ROOT%{systemduserunitdir}/sockets.target.wants \
+       $RPM_BUILD_ROOT%{systemduserunitdir}/{basic,sockets}.target.wants \
        $RPM_BUILD_ROOT%{systemdunitdir}/{final,sound,system-update}.target.wants \
        $RPM_BUILD_ROOT%{systemdunitdir}/systemd-udevd.service.d \
        $RPM_BUILD_ROOT%{_prefix}/lib/{repart.d,systemd/system-environment-generators,sysupdate.d}
@@ -908,6 +945,9 @@ cp -a %{SOURCE102} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/70-udev-pld.rules
 cp -a %{SOURCE104} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/70-uinput.rules
 cp -a %{SOURCE105} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/70-steam_controller.rules
 cp -a %{SOURCE106} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/70-i2c.rules
+%ifarch %{arm} aarch64
+cp -a %{SOURCE107} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/70-raspberrypi.rules
+%endif
 
 # http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames
 ln -s /dev/null $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/80-net-setup-link.rules
@@ -1222,7 +1262,7 @@ fi
 /bin/udevadm info --convert-db
 
 %post -n udev-core
-/bin/udevadm hwdb --update || :
+/bin/systemd-hwdb update || :
 if [ $1 -gt 1 ]; then
        if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
                if grep -qs devtmpfs /proc/mounts && [ -n "$(pidof udevd)" ]; then
@@ -1283,6 +1323,7 @@ fi
 %attr(755,root,root) /bin/loginctl
 %attr(755,root,root) /bin/systemd
 %attr(755,root,root) /bin/systemd-ask-password
+%attr(755,root,root) /bin/systemd-confext
 %attr(755,root,root) /bin/systemd-creds
 %attr(755,root,root) /bin/systemd-escape
 %attr(755,root,root) /bin/systemd-firstboot
@@ -1298,6 +1339,7 @@ fi
 %attr(755,root,root) %{_bindir}/hostnamectl
 %attr(755,root,root) %{_bindir}/kernel-install
 %attr(755,root,root) %{_bindir}/localectl
+%attr(755,root,root) %{_bindir}/systemd-ac-power
 %attr(755,root,root) %{_bindir}/systemd-cat
 %{?with_cryptsetup:%attr(755,root,root) %{_bindir}/systemd-cryptenroll}
 %attr(755,root,root) %{_bindir}/systemd-delta
@@ -1316,8 +1358,8 @@ fi
 /lib/modprobe.d/systemd.conf
 /lib/systemd/resolv.conf
 %attr(755,root,root) /lib/systemd/pld-clean-tmp
-%attr(755,root,root) /lib/systemd/systemd-ac-power
 %attr(755,root,root) /lib/systemd/systemd-backlight
+%attr(755,root,root) /lib/systemd/systemd-battery-check
 %attr(755,root,root) /lib/systemd/systemd-binfmt
 %{?with_efi:%attr(755,root,root) /lib/systemd/systemd-bless-boot}
 %attr(755,root,root) /lib/systemd/systemd-boot-check-no-failures
@@ -1395,22 +1437,23 @@ fi
 %dir %{_prefix}/lib/kernel/install.d
 %{_prefix}/lib/kernel/install.d/50-depmod.install
 %{_prefix}/lib/kernel/install.d/90-loaderentry.install
+%{_prefix}/lib/kernel/install.d/90-uki-copy.install
 %if %{with efi}
 %dir %{_prefix}/lib/systemd/boot
 %dir %{_prefix}/lib/systemd/boot/efi
 %ifarch %{ix86}
+%{_prefix}/lib/systemd/boot/efi/addonia32.efi.stub
 %{_prefix}/lib/systemd/boot/efi/linuxia32.efi.stub
-%{_prefix}/lib/systemd/boot/efi/linuxia32.elf.stub
 %{_prefix}/lib/systemd/boot/efi/systemd-bootia32.efi
 %endif
 %ifarch %{x8664} x32
+%{_prefix}/lib/systemd/boot/efi/addonx64.efi.stub
 %{_prefix}/lib/systemd/boot/efi/linuxx64.efi.stub
-%{_prefix}/lib/systemd/boot/efi/linuxx64.elf.stub
 %{_prefix}/lib/systemd/boot/efi/systemd-bootx64.efi
 %endif
 %ifarch aarch64
+%{_prefix}/lib/systemd/boot/efi/addonaa64.efi.stub
 %{_prefix}/lib/systemd/boot/efi/linuxaa64.efi.stub
-%{_prefix}/lib/systemd/boot/efi/linuxaa64.elf.stub
 %{_prefix}/lib/systemd/boot/efi/systemd-bootaa64.efi
 %endif
 %endif
@@ -1418,12 +1461,17 @@ fi
 %lang(be) %{_prefix}/lib/systemd/catalog/systemd.be.catalog
 %lang(be) %{_prefix}/lib/systemd/catalog/systemd.be@latin.catalog
 %lang(bg) %{_prefix}/lib/systemd/catalog/systemd.bg.catalog
+%lang(da) %{_prefix}/lib/systemd/catalog/systemd.da.catalog
 %lang(de) %{_prefix}/lib/systemd/catalog/systemd.de.catalog
 %lang(fr) %{_prefix}/lib/systemd/catalog/systemd.fr.catalog
+%lang(hr) %{_prefix}/lib/systemd/catalog/systemd.hr.catalog
+%lang(hu) %{_prefix}/lib/systemd/catalog/systemd.hu.catalog
 %lang(it) %{_prefix}/lib/systemd/catalog/systemd.it.catalog
+%lang(ko) %{_prefix}/lib/systemd/catalog/systemd.ko.catalog
 %lang(pl) %{_prefix}/lib/systemd/catalog/systemd.pl.catalog
 %lang(pt_BR) %{_prefix}/lib/systemd/catalog/systemd.pt_BR.catalog
 %lang(ru) %{_prefix}/lib/systemd/catalog/systemd.ru.catalog
+%lang(sr) %{_prefix}/lib/systemd/catalog/systemd.sr.catalog
 %lang(zh_CN) %{_prefix}/lib/systemd/catalog/systemd.zh_CN.catalog
 %lang(zh_TW) %{_prefix}/lib/systemd/catalog/systemd.zh_TW.catalog
 %dir %{_prefix}/lib/sysusers.d
@@ -1431,9 +1479,7 @@ fi
 %{_prefix}/lib/sysusers.d/systemd-coredump.conf
 %{_prefix}/lib/sysusers.d/systemd-journal.conf
 %{_prefix}/lib/sysusers.d/systemd-timesync.conf
-%if %{with microhttpd}
-%{_prefix}/lib/sysusers.d/systemd-remote.conf
-%endif
+%{_prefix}/lib/tmpfiles.d/credstore.conf
 %{_prefix}/lib/tmpfiles.d/etc.conf
 %{_prefix}/lib/tmpfiles.d/home.conf
 %{_prefix}/lib/tmpfiles.d/journal-nocow.conf
@@ -1475,6 +1521,7 @@ fi
 %{_datadir}/factory/etc/nsswitch.conf
 %{_datadir}/factory/etc/pam.d/other
 %{_datadir}/factory/etc/pam.d/system-auth
+%{_datadir}/factory/etc/vconsole.conf
 %{?with_efi:%{_mandir}/man1/bootctl.1*}
 %{_mandir}/man1/busctl.1*
 %{_mandir}/man1/coredumpctl.1*
@@ -1483,6 +1530,7 @@ fi
 %{_mandir}/man1/localectl.1*
 %{_mandir}/man1/loginctl.1*
 %{_mandir}/man1/systemd.1*
+%{_mandir}/man1/systemd-ac-power.1*
 %{_mandir}/man1/systemd-ask-password.1*
 %{_mandir}/man1/systemd-cat.1*
 %{_mandir}/man1/systemd-creds.1*
@@ -1569,6 +1617,7 @@ fi
 %{_mandir}/man7/systemd-boot.7*
 %{_mandir}/man7/systemd-stub.7*
 %endif
+%{_mandir}/man7/smbios-type-11.7*
 %{_mandir}/man7/systemd.directives.7*
 %{_mandir}/man7/systemd.environment-generator.7*
 %{_mandir}/man7/systemd.generator.7*
@@ -1585,12 +1634,14 @@ fi
 %{_mandir}/man8/nss-myhostname.8*
 %{_mandir}/man8/nss-mymachines.8*
 %{_mandir}/man8/systemd-backlight.8*
+%{_mandir}/man8/systemd-battery-check.8*
 %{_mandir}/man8/systemd-binfmt.8*
 %if %{with efi}
 %{_mandir}/man8/systemd-bless-boot.8*
 %{_mandir}/man8/systemd-bless-boot-generator.8*
 %endif
 %{_mandir}/man8/systemd-boot-check-no-failures.8*
+%{_mandir}/man8/systemd-confext.8*
 %{_mandir}/man8/systemd-coredump.8*
 %if %{with cryptsetup}
 %{_mandir}/man8/systemd-cryptsetup-generator.8*
@@ -1598,14 +1649,16 @@ fi
 %endif
 %{_mandir}/man8/systemd-debug-generator.8*
 %{_mandir}/man8/systemd-fsck.8*
+%{_mandir}/man8/systemd-fsck-usr.service.8*
 %{_mandir}/man8/systemd-fstab-generator.8*
 %{_mandir}/man8/systemd-getty-generator.8*
 %{_mandir}/man8/systemd-gpt-auto-generator.8*
 %{_mandir}/man8/systemd-growfs.8*
+%{_mandir}/man8/systemd-growfs-root.service.8*
 %{_mandir}/man8/systemd-growfs@.service.8*
 %{_mandir}/man8/systemd-hibernate-resume-generator.8*
 %{_mandir}/man8/systemd-hibernate-resume.8*
-%{_mandir}/man8/systemd-hibernate-resume@.service.8*
+%{_mandir}/man8/systemd-hibernate-resume.service.8*
 %{_mandir}/man8/systemd-hostnamed.8*
 %{_mandir}/man8/systemd-initctl.8*
 %{_mandir}/man8/systemd-journald-dev-log.socket.8*
@@ -1717,26 +1770,6 @@ fi
 %dir %{_prefix}/lib/systemd/catalog
 %dir %{_prefix}/lib/systemd/system-shutdown
 %dir %{_prefix}/lib/systemd/system-sleep
-%dir %{_prefix}/lib/systemd/user
-%{_prefix}/lib/systemd/user/app.slice
-%{_prefix}/lib/systemd/user/background.slice
-%{_prefix}/lib/systemd/user/basic.target
-%{_prefix}/lib/systemd/user/bluetooth.target
-%{_prefix}/lib/systemd/user/default.target
-%{_prefix}/lib/systemd/user/exit.target
-%{_prefix}/lib/systemd/user/paths.target
-%{_prefix}/lib/systemd/user/printer.target
-%{_prefix}/lib/systemd/user/session.slice
-%{_prefix}/lib/systemd/user/shutdown.target
-%{_prefix}/lib/systemd/user/smartcard.target
-%{_prefix}/lib/systemd/user/sockets.target
-%{_prefix}/lib/systemd/user/sound.target
-%{_prefix}/lib/systemd/user/systemd-tmpfiles-clean.service
-%{_prefix}/lib/systemd/user/systemd-tmpfiles-clean.timer
-%{_prefix}/lib/systemd/user/systemd-tmpfiles-setup.service
-%{_prefix}/lib/systemd/user/timers.target
-%{_prefix}/lib/systemd/user/systemd-exit.service
-%{_prefix}/lib/systemd/user/xdg-desktop-autostart.target
 %dir %{_prefix}/lib/systemd/user-generators
 %attr(755,root,root) %{_prefix}/lib/systemd/user-generators/systemd-xdg-autostart-generator
 %dir %{_prefix}/lib/systemd/user-environment-generators
@@ -1766,7 +1799,6 @@ fi
 %{systemdunitdir}/initrd-root-device.target
 %{systemdunitdir}/proc-sys-fs-binfmt_misc.automount
 %{systemdunitdir}/proc-sys-fs-binfmt_misc.mount
-%{systemdunitdir}/sockets.target.wants/systemd-coredump.socket
 %{systemdunitdir}/sys-fs-fuse-connections.mount
 %{systemdunitdir}/sys-kernel-config.mount
 %{systemdunitdir}/sys-kernel-debug.mount
@@ -1820,18 +1852,21 @@ fi
 %{systemdunitdir}/systemd-ask-password-console.service
 %{systemdunitdir}/systemd-ask-password-wall.service
 %{systemdunitdir}/systemd-backlight@.service
+%{systemdunitdir}/systemd-battery-check.service
 %{systemdunitdir}/systemd-binfmt.service
 %if %{with efi}
 %{systemdunitdir}/systemd-bless-boot.service
-%{systemdunitdir}/systemd-boot-system-token.service
+%{systemdunitdir}/systemd-boot-random-seed.service
 %{systemdunitdir}/systemd-boot-update.service
 %endif
 %{systemdunitdir}/systemd-boot-check-no-failures.service
+%{systemdunitdir}/systemd-confext.service
 %{systemdunitdir}/systemd-firstboot.service
 %{systemdunitdir}/systemd-fsck-root.service
 %{systemdunitdir}/systemd-fsck@.service
+%{systemdunitdir}/systemd-growfs-root.service
+%{systemdunitdir}/systemd-growfs@.service
 %{systemdunitdir}/systemd-halt.service
-%{systemdunitdir}/systemd-hibernate-resume@.service
 %{systemdunitdir}/systemd-hibernate.service
 %{systemdunitdir}/systemd-hostnamed.service
 %{systemdunitdir}/systemd-hwdb-update.service
@@ -1848,6 +1883,9 @@ fi
 %{systemdunitdir}/systemd-modules-load.service
 %{systemdunitdir}/systemd-nspawn@.service
 %if %{with efi} && %{with tpm2}
+%{systemdunitdir}/systemd-pcrfs-root.service
+%{systemdunitdir}/systemd-pcrfs@.service
+%{systemdunitdir}/systemd-pcrmachine.service
 %{systemdunitdir}/systemd-pcrphase-initrd.service
 %{systemdunitdir}/systemd-pcrphase-sysinit.service
 %{systemdunitdir}/systemd-pcrphase.service
@@ -1858,6 +1896,7 @@ fi
 %{systemdunitdir}/systemd-reboot.service
 %{systemdunitdir}/systemd-remount-fs.service
 %{systemdunitdir}/systemd-rfkill.service
+%{systemdunitdir}/systemd-soft-reboot.service
 %{systemdunitdir}/systemd-suspend.service
 %{systemdunitdir}/systemd-suspend-then-hibernate.service
 %{systemdunitdir}/systemd-sysctl.service
@@ -1867,6 +1906,7 @@ fi
 %{systemdunitdir}/systemd-timedated.service
 %{systemdunitdir}/systemd-timesyncd.service
 %{systemdunitdir}/systemd-tmpfiles-clean.service
+%{systemdunitdir}/systemd-tmpfiles-setup-dev-early.service
 %{systemdunitdir}/systemd-tmpfiles-setup-dev.service
 %{systemdunitdir}/systemd-tmpfiles-setup.service
 %{systemdunitdir}/systemd-udev-settle.service
@@ -1912,6 +1952,7 @@ fi
 %{systemdunitdir}/cryptsetup.target
 %{systemdunitdir}/integritysetup-pre.target
 %{systemdunitdir}/integritysetup.target
+%{systemdunitdir}/system-systemd\x2dveritysetup.slice
 %{systemdunitdir}/veritysetup-pre.target
 %{systemdunitdir}/veritysetup.target
 %endif
@@ -1967,6 +2008,7 @@ fi
 %{systemdunitdir}/slices.target
 %{systemdunitdir}/smartcard.target
 %{systemdunitdir}/sockets.target
+%{systemdunitdir}/soft-reboot.target
 %{systemdunitdir}/sound.target
 %{systemdunitdir}/suspend.target
 %{systemdunitdir}/swap.target
@@ -2008,6 +2050,7 @@ fi
 %endif
 %{systemdunitdir}/graphical.target.wants/display-manager.service
 %{systemdunitdir}/graphical.target.wants/systemd-update-utmp-runlevel.service
+%{systemdunitdir}/initrd.target.wants/systemd-battery-check.service
 %if %{with efi} && %{with tpm2}
 %{systemdunitdir}/initrd.target.wants/systemd-pcrphase-initrd.service
 %endif
@@ -2022,8 +2065,8 @@ fi
 %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
 %{systemdunitdir}/rescue.target.wants/systemd-update-utmp-runlevel.service
 %{systemdunitdir}/sigpwr.target.wants/sigpwr-container-shutdown.service
+%{systemdunitdir}/sockets.target.wants/systemd-coredump.socket
 %{systemdunitdir}/sockets.target.wants/systemd-initctl.socket
-%{systemdunitdir}/sockets.target.wants/systemd-journald-audit.socket
 %{systemdunitdir}/sockets.target.wants/systemd-journald-dev-log.socket
 %{systemdunitdir}/sockets.target.wants/systemd-journald.socket
 %{systemdunitdir}/sockets.target.wants/systemd-udevd-control.socket
@@ -2043,7 +2086,7 @@ fi
 %{systemdunitdir}/sysinit.target.wants/sys-kernel-tracing.mount
 %{systemdunitdir}/sysinit.target.wants/systemd-ask-password-console.path
 %{systemdunitdir}/sysinit.target.wants/systemd-binfmt.service
-%{?with_efi:%{systemdunitdir}/sysinit.target.wants/systemd-boot-system-token.service}
+%{?with_efi:%{systemdunitdir}/sysinit.target.wants/systemd-boot-random-seed.service}
 %{systemdunitdir}/sysinit.target.wants/systemd-firstboot.service
 %{systemdunitdir}/sysinit.target.wants/systemd-hwdb-update.service
 %{systemdunitdir}/sysinit.target.wants/systemd-journal-catalog-update.service
@@ -2052,12 +2095,14 @@ fi
 %{systemdunitdir}/sysinit.target.wants/systemd-machine-id-commit.service
 %{systemdunitdir}/sysinit.target.wants/systemd-modules-load.service
 %if %{with efi} && %{with tpm2}
+%{systemdunitdir}/sysinit.target.wants/systemd-pcrmachine.service
 %{systemdunitdir}/sysinit.target.wants/systemd-pcrphase-sysinit.service
 %{systemdunitdir}/sysinit.target.wants/systemd-pcrphase.service
 %endif
 %{systemdunitdir}/sysinit.target.wants/systemd-random-seed.service
 %{systemdunitdir}/sysinit.target.wants/systemd-sysctl.service
 %{systemdunitdir}/sysinit.target.wants/systemd-sysusers.service
+%{systemdunitdir}/sysinit.target.wants/systemd-tmpfiles-setup-dev-early.service
 %{systemdunitdir}/sysinit.target.wants/systemd-tmpfiles-setup-dev.service
 %{systemdunitdir}/sysinit.target.wants/systemd-tmpfiles-setup.service
 %{systemdunitdir}/sysinit.target.wants/systemd-udevd.service
@@ -2065,9 +2110,32 @@ fi
 %{systemdunitdir}/sysinit.target.wants/systemd-update-done.service
 %{systemdunitdir}/sysinit.target.wants/systemd-update-utmp.service
 %{systemdunitdir}/timers.target.wants/systemd-tmpfiles-clean.timer
-%dir %{systemduserunitdir}/sockets.target.wants
-%{systemduserunitdir}/graphical-session-pre.target
+
+%dir %{systemduserunitdir}
+%{systemduserunitdir}/app.slice
+%{systemduserunitdir}/background.slice
+%{systemduserunitdir}/basic.target
+%{systemduserunitdir}/bluetooth.target
+%{systemduserunitdir}/default.target
+%{systemduserunitdir}/exit.target
 %{systemduserunitdir}/graphical-session.target
+%{systemduserunitdir}/graphical-session-pre.target
+%{systemduserunitdir}/paths.target
+%{systemduserunitdir}/printer.target
+%{systemduserunitdir}/session.slice
+%{systemduserunitdir}/shutdown.target
+%{systemduserunitdir}/smartcard.target
+%{systemduserunitdir}/sockets.target
+%{systemduserunitdir}/sound.target
+%{systemduserunitdir}/systemd-exit.service
+%{systemduserunitdir}/systemd-tmpfiles-clean.service
+%{systemduserunitdir}/systemd-tmpfiles-clean.timer
+%{systemduserunitdir}/systemd-tmpfiles-setup.service
+%{systemduserunitdir}/timers.target
+%{systemduserunitdir}/xdg-desktop-autostart.target
+%dir %{systemduserunitdir}/basic.target.wants
+%dir %{systemduserunitdir}/sockets.target.wants
+
 %{_mandir}/man5/user@.service.5*
 %{_mandir}/man5/user-runtime-dir@.service.5*
 %{_mandir}/man8/30-systemd-environment-d-generator.8*
@@ -2077,10 +2145,12 @@ fi
 %{_mandir}/man8/systemd-ask-password-wall.path.8*
 %{_mandir}/man8/systemd-ask-password-wall.service.8*
 %{_mandir}/man8/systemd-backlight@.service.8*
+%{_mandir}/man8/systemd-battery-check.service.8*
 %{_mandir}/man8/systemd-binfmt.service.8*
 %{?with_efi:%{_mandir}/man8/systemd-bless-boot.service.8*}
 %{_mandir}/man8/systemd-boot-check-no-failures.service.8*
-%{?with_efi:%{_mandir}/man8/systemd-boot-system-token.service.8*}
+%{?with_efi:%{_mandir}/man8/systemd-boot-random-seed.service.8*}
+%{_mandir}/man8/systemd-confext.service.8*
 %{_mandir}/man8/systemd-coredump.socket.8*
 %{_mandir}/man8/systemd-coredump@.service.8*
 %if %{with cryptsetup}
@@ -2105,6 +2175,9 @@ fi
 %{_mandir}/man8/systemd-logind.service.8*
 %{_mandir}/man8/systemd-modules-load.service.8*
 %if %{with efi} && %{with tpm2}
+%{_mandir}/man8/systemd-pcrfs-root.service.8*
+%{_mandir}/man8/systemd-pcrfs@.service.8*
+%{_mandir}/man8/systemd-pcrmachine.service.8*
 %{_mandir}/man8/systemd-pcrphase-initrd.service.8*
 %{_mandir}/man8/systemd-pcrphase-sysinit.service.8*
 %{_mandir}/man8/systemd-pcrphase.8*
@@ -2116,6 +2189,7 @@ fi
 %{_mandir}/man8/systemd-reboot.service.8*
 %{_mandir}/man8/systemd-remount-fs.service.8*
 %{_mandir}/man8/systemd-rfkill.socket.8*
+%{_mandir}/man8/systemd-soft-reboot.service.8*
 %{_mandir}/man8/systemd-suspend.service.8*
 %{_mandir}/man8/systemd-suspend-then-hibernate.service.8*
 %{_mandir}/man8/systemd-sysctl.service.8*
@@ -2125,6 +2199,7 @@ fi
 %{_mandir}/man8/systemd-tmpfiles-clean.service.8*
 %{_mandir}/man8/systemd-tmpfiles-clean.timer.8*
 %{_mandir}/man8/systemd-tmpfiles-setup.service.8*
+%{_mandir}/man8/systemd-tmpfiles-setup-dev-early.service.8*
 %{_mandir}/man8/systemd-tmpfiles-setup-dev.service.8*
 %{_mandir}/man8/systemd-udev-settle.service.8*
 %{_mandir}/man8/systemd-udevd.service.8*
@@ -2154,6 +2229,7 @@ fi
 %attr(755,root,root) /lib/systemd/systemd-pull
 %attr(755,root,root) /lib/systemd/systemd-importd
 %attr(755,root,root) %{_bindir}/systemd-dissect
+%attr(755,root,root) /sbin/mount.ddi
 %{_datadir}/dbus-1/system-services/org.freedesktop.import1.service
 %{_datadir}/dbus-1/system-services/org.freedesktop.machine1.service
 %{_datadir}/dbus-1/interfaces/org.freedesktop.import1.*.xml
@@ -2163,8 +2239,10 @@ fi
 %{_datadir}/polkit-1/actions/org.freedesktop.import1.policy
 %{_datadir}/polkit-1/actions/org.freedesktop.machine1.policy
 %{_mandir}/man1/machinectl.1*
+%{_mandir}/man1/mount.ddi.1*
 %{_mandir}/man5/org.freedesktop.import1.5*
 %{_mandir}/man5/org.freedesktop.machine1.5*
+%{_mandir}/man7/systemd.image-policy.7*
 %{_mandir}/man8/systemd-importd.8*
 %{_mandir}/man8/systemd-importd.service.8*
 %{_mandir}/man8/systemd-machined.8*
@@ -2184,6 +2262,7 @@ fi
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/journal-remote.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/journal-upload.conf
+%{_prefix}/lib/sysusers.d/systemd-remote.conf
 %{systemdunitdir}/systemd-journal-gatewayd.service
 %{systemdunitdir}/systemd-journal-gatewayd.socket
 %{systemdunitdir}/systemd-journal-remote.service
@@ -2237,6 +2316,7 @@ fi
 %{_prefix}/lib/tmpfiles.d/systemd-network.conf
 /lib/systemd/network/80-6rd-tunnel.network
 /lib/systemd/network/80-container-host0.network
+/lib/systemd/network/80-container-vb.network
 /lib/systemd/network/80-container-ve.network
 /lib/systemd/network/80-container-vz.network
 /lib/systemd/network/80-vm-vt.network
@@ -2370,6 +2450,14 @@ fi
 %attr(755,root,root) %{_bindir}/systemd-analyze
 %{_mandir}/man1/systemd-analyze.1*
 
+%if %{with efi}
+%files ukify
+%defattr(644,root,root,755)
+%attr(755,root,root) /lib/systemd/ukify
+%{_prefix}/lib/kernel/install.d/60-ukify.install
+%{_mandir}/man1/ukify.1*
+%endif
+
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) /%{_lib}/libnss_myhostname.so.2
@@ -2395,6 +2483,7 @@ fi
 %{_pkgconfigdir}/libsystemd.pc
 %{_npkgconfigdir}/systemd.pc
 %{_mandir}/man3/SD_*.3*
+%{_mandir}/man3/libsystemd.3*
 %{_mandir}/man3/sd*.3*
 
 %files -n bash-completion-systemd
@@ -2421,11 +2510,13 @@ fi
 %{bash_compdir}/systemd-cryptenroll
 %{bash_compdir}/systemd-delta
 %{bash_compdir}/systemd-detect-virt
+%{bash_compdir}/systemd-dissect
 %{bash_compdir}/systemd-id128
 %{bash_compdir}/systemd-nspawn
 %{bash_compdir}/systemd-path
 %{bash_compdir}/systemd-resolve
 %{bash_compdir}/systemd-run
+%{bash_compdir}/systemd-sysext
 %{bash_compdir}/timedatectl
 
 %files -n zsh-completion-systemd
@@ -2474,6 +2565,7 @@ fi
 %attr(755,root,root) /lib/udev/cdrom_id
 %attr(755,root,root) /lib/udev/dmi_memory_id
 %attr(755,root,root) /lib/udev/fido_id
+%attr(755,root,root) /lib/udev/iocost
 %attr(755,root,root) /lib/udev/mtd_probe
 %attr(755,root,root) /lib/udev/scsi_id
 %attr(755,root,root) /lib/udev/v4l_id
@@ -2507,6 +2599,7 @@ fi
 /lib/udev/hwdb.d/70-mouse.hwdb
 /lib/udev/hwdb.d/70-pda.hwdb
 /lib/udev/hwdb.d/70-pointingstick.hwdb
+/lib/udev/hwdb.d/70-sound-card.hwdb
 /lib/udev/hwdb.d/70-touchpad.hwdb
 /lib/udev/hwdb.d/80-ieee1394-unit-function.hwdb
 
@@ -2523,12 +2616,16 @@ fi
 
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modprobe.d/fbdev-blacklist.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modprobe.d/udev_blacklist.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/iocost.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/links.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/rules.d/40-alsa-restore.rules
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/rules.d/70-udev-pld.rules
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/rules.d/70-uinput.rules
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/rules.d/70-steam_controller.rules
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/rules.d/70-i2c.rules
+%ifarch %{arm} aarch64
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/rules.d/70-raspberrypi.rules
+%endif
 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/udev/rules.d/80-net-setup-link.rules
 
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/udev.conf
@@ -2538,9 +2635,11 @@ fi
 /lib/udev/rules.d/60-autosuspend.rules
 /lib/udev/rules.d/60-block.rules
 /lib/udev/rules.d/60-cdrom_id.rules
+/lib/udev/rules.d/60-dmi-id.rules
 /lib/udev/rules.d/60-drm.rules
 /lib/udev/rules.d/60-evdev.rules
 /lib/udev/rules.d/60-fido-id.rules
+/lib/udev/rules.d/60-infiniband.rules
 /lib/udev/rules.d/60-input-id.rules
 /lib/udev/rules.d/60-persistent-alsa.rules
 /lib/udev/rules.d/60-persistent-input.rules
@@ -2565,8 +2664,10 @@ fi
 /lib/udev/rules.d/80-drivers.rules
 /lib/udev/rules.d/80-net-setup-link.rules
 /lib/udev/rules.d/81-net-dhcp.rules
+/lib/udev/rules.d/90-iocost.rules
 /lib/udev/rules.d/90-vconsole.rules
 
+%{_mandir}/man5/iocost.conf.5*
 %{_mandir}/man5/udev.conf.5*
 %{_mandir}/man7/udev.7*
 %{_mandir}/man7/hwdb.7*
This page took 0.201299 seconds and 4 git commands to generate.