]> git.pld-linux.org Git - packages/systemd.git/blobdiff - systemd.spec
- rel 1
[packages/systemd.git] / systemd.spec
index 4dde11f177656412f2214e3283c2b0c670c3069e..69a2dfebe07d6419a0503b57f79e7b75c7b12146 100644 (file)
@@ -2,12 +2,12 @@
 # - pldize vconsole setup:
 #      http://cgit.freedesktop.org/systemd/systemd/tree/src/vconsole/vconsole-setup.c
 # - udev initrd needs love (is probably completly unusable in current form)
+# - replace our rpm macros with systemd provided?
 #
 # Conditional build:
 %bcond_without audit           # without audit support
 %bcond_without cryptsetup      # without cryptsetup support
 %bcond_without pam             # PAM authentication support
-%bcond_without plymouth        # do not install plymouth units
 %bcond_without selinux         # without SELinux support
 %bcond_without tcpd            # libwrap (tcp_wrappers) support
 
@@ -38,13 +38,13 @@ Summary:    A System and Service Manager
 Summary(pl.UTF-8):     systemd - zarządca systemu i usług dla Linuksa
 Name:          systemd
 # Verify ChangeLog and NEWS when updating (since there are incompatible/breaking changes very often)
-Version:       185
-Release:       1.1
+Version:       186
+Release:       1
 Epoch:         1
 License:       GPL v2+
 Group:         Base
 Source0:       http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
-# Source0-md5: a7dbbf05986eb0d2c164ec8e570eb78f
+# Source0-md5: 17eff1d31e6e49bf82e129fe57efd59b
 Source1:       %{name}-sysv-convert
 Source2:       %{name}_booted.c
 Source3:       network.service
@@ -77,10 +77,9 @@ Patch5:              kmsg-to-syslog.patch
 Patch6:                udev-so.patch
 Patch7:                udev-uClibc.patch
 Patch8:                udev-ploop-rules.patch
-Patch9:                udevlibexecdir.patch
-Patch10:       static-udev.patch
-Patch11:       systemd-udev-service.patch
-Patch12:       udevadm-in-sbin.patch
+Patch9:                udevadm-in-sbin.patch
+# hack set to allow static udev build
+Patch100:      static-udev.patch
 URL:           http://www.freedesktop.org/wiki/Software/systemd
 BuildRequires: acl-devel
 %{?with_audit:BuildRequires:   audit-libs-devel}
@@ -335,19 +334,6 @@ Ten pakiet zawiera generator usług inet udostępniający funkcjonalność
 serwisu rc-inetd i zastępujący osobny demon inet przez systemd i
 aktywację usług przez gniazda.
 
-%package plymouth
-Summary:       Plymouth support units for systemd
-Summary(pl.UTF-8):     Jednostki wspierające Plymouth dla systemd
-Group:         Base
-Requires:      %{name}-units = %{epoch}:%{version}-%{release}
-Requires:      plymouth
-
-%description plymouth
-Plymouth (graphical boot) support units for systemd.
-
-%description plymouth -l pl.UTF-8
-Jednostki wspierające Plymouth (graficzny start systemu) dla systemd.
-
 %package analyze
 Summary:       Tool for processing systemd profiling information
 Summary(pl.UTF-8):     Narzędzie do przetwarzania informacji profilujących systemd
@@ -356,7 +342,7 @@ Requires:   %{name} = %{epoch}:%{version}-%{release}
 Requires:      python-dbus
 Requires:      python-modules
 Requires:      python-pycairo
-Conflicts:     %{name} < 44-3
+Conflicts:     systemd < 44-3
 
 %description analyze
 'systemd-analyze blame' lists which systemd unit needed how much time
@@ -416,7 +402,6 @@ Obsoletes:  hotplug
 Obsoletes:     hotplug-input
 Obsoletes:     hotplug-net
 Obsoletes:     hotplug-pci
-Obsoletes:     udev-compat
 Obsoletes:     udev-dev
 Obsoletes:     udev-extras < 20090628
 Obsoletes:     udev-tools
@@ -443,6 +428,7 @@ Requires:   uname(release) >= 2.6.32
 Conflicts:     rc-scripts < 0.4.5.3-1
 Conflicts:     systemd-units < 1:183
 Conflicts:     udev < 1:118-1
+Obsoletes:     udev-compat
 
 %description -n udev-core
 A userspace implementation of devfs - core part of udev.
@@ -577,8 +563,6 @@ initrd.
 %endif
 %patch8 -p1
 %patch9 -p1
-%patch11 -p1
-%patch12 -p1
 cp -p %{SOURCE2} src/systemd_booted.c
 
 %build
@@ -589,7 +573,7 @@ cp -p %{SOURCE2} src/systemd_booted.c
 %{__autoheader}
 %{__automake}
 %if %{with initrd}
-patch -p1 <%{PATCH10}
+patch -p1 <%{PATCH100}
 %configure \
 %if "%{?configure_cache}" == "1"
        --cache-file=%{?configure_cache_file}%{!?configure_cache_file:configure}-initrd.cache \
@@ -642,7 +626,7 @@ cp -a systemd-udevd \
        udev-initrd/
 
 %{__make} clean
-patch -p1 -R <%{PATCH10}
+patch -p1 -R <%{PATCH100}
 %endif
 
 %configure \
@@ -650,9 +634,9 @@ patch -p1 -R <%{PATCH10}
        %{__enable_disable audit} \
        %{__enable_disable cryptsetup libcryptsetup} \
        %{__enable_disable pam} \
-       %{__enable_disable plymouth} \
        %{__enable_disable selinux} \
        %{__enable_disable tcpd tcpwrap} \
+       --disable-plymouth \
        --disable-silent-rules \
        --enable-shared \
        --enable-static \
@@ -887,12 +871,6 @@ fi
 %postun inetd
 %systemd_reload
 
-%post plymouth
-%systemd_reload
-
-%postun plymouth
-%systemd_reload
-
 %triggerpostun -n udev-core -- dev
 if [ "$2" = 0 ]; then
        # need to kill and restart udevd as after obsoleting dev package the
@@ -992,8 +970,7 @@ fi
 %attr(755,root,root) /lib/systemd/systemd-multi-seat-x
 %attr(755,root,root) /lib/systemd/systemd-quotacheck
 %attr(755,root,root) /lib/systemd/systemd-random-seed
-%attr(755,root,root) /lib/systemd/systemd-readahead-collect
-%attr(755,root,root) /lib/systemd/systemd-readahead-replay
+%attr(755,root,root) /lib/systemd/systemd-readahead
 %attr(755,root,root) /lib/systemd/systemd-remount-fs
 %attr(755,root,root) /lib/systemd/systemd-reply-password
 %attr(755,root,root) /lib/systemd/systemd-shutdown
@@ -1009,7 +986,6 @@ fi
 %dir /lib/systemd/system-generators
 %attr(755,root,root) /lib/systemd/systemd
 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
-%dir /lib/systemd/system-shutdown
 /lib/udev/rules.d/99-systemd.rules
 /lib/udev/rules.d/70-uaccess.rules
 /lib/udev/rules.d/71-seat.rules
@@ -1017,10 +993,10 @@ fi
 %dir %{_libexecdir}/systemd
 %{_libexecdir}/systemd/user
 %dir %{_libexecdir}/systemd/user-generators
-%config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/legacy.conf
-%config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/systemd.conf
-%config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/tmp.conf
-%config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/x11.conf
+%{_libexecdir}/tmpfiles.d/legacy.conf
+%{_libexecdir}/tmpfiles.d/systemd.conf
+%{_libexecdir}/tmpfiles.d/tmp.conf
+%{_libexecdir}/tmpfiles.d/x11.conf
 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
@@ -1051,7 +1027,10 @@ fi
 %{_mandir}/man1/systemd-machine-id-setup.1*
 %{_mandir}/man1/systemd-notify.1*
 %{_mandir}/man1/systemd-nspawn.1*
+%{_mandir}/man1/systemd-tty-ask-password-agent.1*
 %{_mandir}/man5/binfmt.d.5*
+# cfl with rc-scripts
+#%{_mandir}/man5/crypttab.5*
 %{_mandir}/man5/hostname.5*
 %{_mandir}/man5/journald.conf.5*
 %{_mandir}/man5/locale.conf.5*
@@ -1064,23 +1043,38 @@ fi
 %{_mandir}/man5/systemd.*.5*
 %{_mandir}/man5/timezone.5*
 %{_mandir}/man5/vconsole.conf.5*
+%{_mandir}/man7/bootup.7*
 %{_mandir}/man7/daemon.7*
+%{_mandir}/man7/kernel-command-line.7*
 %{_mandir}/man7/sd-daemon.7*
 %{_mandir}/man7/sd-login.7*
 %{_mandir}/man7/sd-readahead.7*
-%{_mandir}/man7/systemd.special.7*
 %{_mandir}/man7/systemd.journal-fields.7*
+%{_mandir}/man7/systemd.special.7*
 %{_mandir}/man8/systemd-binfmt.8*
-%{_mandir}/man8/systemd-binfmt.service.8*
+%{_mandir}/man8/systemd-cryptsetup-generator.8*
+%{_mandir}/man8/systemd-fstab-generator.8*
+%{_mandir}/man8/systemd-getty-generator.8*
+%{_mandir}/man8/systemd-hostnamed.8*
+%{_mandir}/man8/systemd-initctl.8*
 %{_mandir}/man8/systemd-journald.8*
-%{_mandir}/man8/systemd-journald.service.8*
+%{_mandir}/man8/systemd-localed.8*
 %{_mandir}/man8/systemd-logind.8*
-%{_mandir}/man8/systemd-logind.service.8*
 %{_mandir}/man8/systemd-modules-load.8*
-%{_mandir}/man8/systemd-modules-load.service.8*
+%{_mandir}/man8/systemd-quotacheck.8*
+%{_mandir}/man8/systemd-random-seed.8*
+%{_mandir}/man8/systemd-readahead.8*
+%{_mandir}/man8/systemd-remount-fs.8*
+%{_mandir}/man8/systemd-shutdown.8*
+%{_mandir}/man8/systemd-shutdownd.8*
+%{_mandir}/man8/systemd-sleep.8*
 %{_mandir}/man8/systemd-sysctl.8*
-%{_mandir}/man8/systemd-sysctl.service.8*
+%{_mandir}/man8/systemd-system-update-generator.8*
+%{_mandir}/man8/systemd-timedated.8*
 %{_mandir}/man8/systemd-udevd.8*
+%{_mandir}/man8/systemd-update-utmp.8*
+%{_mandir}/man8/systemd-user-sessions.8*
+%{_mandir}/man8/systemd-vconsole-setup.8*
 %dir /var/lib/%{name}
 %dir /var/lib/%{name}/coredump
 %attr(640,root,root) %ghost /var/log/btmp
@@ -1120,6 +1114,7 @@ fi
 %dir %{_libexecdir}/binfmt.d
 %dir %{_libexecdir}/modules-load.d
 %dir %{_libexecdir}/sysctl.d
+%dir /lib/systemd/system-shutdown
 # Don't package the kernel.core_pattern setting until systemd-coredump
 # is a part of an actual systemd release and it's made clear how to
 # get the core dumps out of the journal.
@@ -1139,10 +1134,6 @@ fi
 %{systemdunitdir}/*.socket
 %{systemdunitdir}/*.target
 %{systemdunitdir}/*.timer
-%if %{with plymouth}
-%exclude %{systemdunitdir}/plymouth*.service
-%exclude %{systemdunitdir}/systemd-ask-password-plymouth.*
-%endif
 %dir %{systemdunitdir}/basic.target.wants
 %dir %{systemdunitdir}/dbus.target.wants
 %dir %{systemdunitdir}/final.target.wants
@@ -1158,56 +1149,77 @@ fi
 %dir %{systemdunitdir}/sockets.target.wants
 %dir %{systemdunitdir}/sysinit.target.wants
 %dir %{systemdunitdir}/syslog.target.wants
-%config(noreplace,missingok) %{systemdunitdir}/basic.target.wants/*
-%config(noreplace,missingok) %{systemdunitdir}/final.target.wants/*
-%config(noreplace,missingok) %{systemdunitdir}/graphical.target.wants/*
-%config(noreplace,missingok) %{systemdunitdir}/local-fs.target.wants/*
-%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/getty.target
-%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/rc-local.service
-%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
-%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
-%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
-%config(noreplace,missingok) %{systemdunitdir}/runlevel[12345].target.wants/*
-%config(noreplace,missingok) %{systemdunitdir}/shutdown.target.wants/*
-%config(noreplace,missingok) %{systemdunitdir}/sockets.target.wants/*
-%{?with_cryptsetup:%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/cryptsetup.target}
-%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
-%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
-%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
-%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/sys-*.mount
-%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/systemd-*
+%{systemdunitdir}/basic.target.wants/*
+%{systemdunitdir}/final.target.wants/*
+%{systemdunitdir}/graphical.target.wants/*
+%{systemdunitdir}/local-fs.target.wants/*
+%{systemdunitdir}/multi-user.target.wants/getty.target
+%{systemdunitdir}/multi-user.target.wants/rc-local.service
+%{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
+%{systemdunitdir}/multi-user.target.wants/systemd-logind.service
+%{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
+%{systemdunitdir}/runlevel[12345].target.wants/*
+%{systemdunitdir}/shutdown.target.wants/*
+%{systemdunitdir}/sockets.target.wants/*
+%{?with_cryptsetup:%{systemdunitdir}/sysinit.target.wants/cryptsetup.target}
+%{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
+%{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
+%{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
+%{systemdunitdir}/sysinit.target.wants/sys-*.mount
+%{systemdunitdir}/sysinit.target.wants/systemd-*
+%{_mandir}/man8/systemd-ask-password-console.path.8*
+%{_mandir}/man8/systemd-ask-password-console.service.8*
+%{_mandir}/man8/systemd-ask-password-wall.path.8*
+%{_mandir}/man8/systemd-ask-password-wall.service.8*
+%{_mandir}/man8/systemd-binfmt.service.8*
+%{_mandir}/man8/systemd-cryptsetup.8*
+%{_mandir}/man8/systemd-cryptsetup@.service.8*
+%{_mandir}/man8/systemd-fsck-root.service.8*
+%{_mandir}/man8/systemd-fsck@.service.8*
+%{_mandir}/man8/systemd-halt.service.8*
+%{_mandir}/man8/systemd-hibernate.service.8*
+%{_mandir}/man8/systemd-hostnamed.service.8*
+%{_mandir}/man8/systemd-initctl.service.8*
+%{_mandir}/man8/systemd-initctl.socket.8*
+%{_mandir}/man8/systemd-journald.service.8*
+%{_mandir}/man8/systemd-journald.socket.8*
+%{_mandir}/man8/systemd-kexec.service.8*
+%{_mandir}/man8/systemd-localed.service.8*
+%{_mandir}/man8/systemd-logind.service.8*
+%{_mandir}/man8/systemd-modules-load.service.8*
+%{_mandir}/man8/systemd-poweroff.service.8*
+%{_mandir}/man8/systemd-quotacheck.service.8*
+%{_mandir}/man8/systemd-random-seed-load.service.8*
+%{_mandir}/man8/systemd-random-seed-save.service.8*
+%{_mandir}/man8/systemd-readahead-collect.service.8*
+%{_mandir}/man8/systemd-readahead-done.service.8*
+%{_mandir}/man8/systemd-readahead-done.timer.8*
+%{_mandir}/man8/systemd-readahead-replay.service.8*
+%{_mandir}/man8/systemd-reboot.service.8*
+%{_mandir}/man8/systemd-remount-fs.service.8*
+%{_mandir}/man8/systemd-shutdownd.service.8*
+%{_mandir}/man8/systemd-shutdownd.socket.8*
+%{_mandir}/man8/systemd-suspend.service.8*
+%{_mandir}/man8/systemd-sysctl.service.8*
+%{_mandir}/man8/systemd-timedated.service.8*
+%{_mandir}/man8/systemd-tmpfiles-clean.service.8*
+%{_mandir}/man8/systemd-tmpfiles-clean.timer.8*
+%{_mandir}/man8/systemd-tmpfiles-setup.service.8*
+%{_mandir}/man8/systemd-udevd.service.8*
+%{_mandir}/man8/systemd-update-utmp-runlevel.service.8*
+%{_mandir}/man8/systemd-update-utmp-shutdown.service.8*
+%{_mandir}/man8/systemd-user-sessions.service.8*
+%{_mandir}/man8/systemd-vconsole-setup.service.8*
 
 %files inetd
 %defattr(644,root,root,755)
 %attr(755,root,root) /lib/systemd/system-generators/pld-rc-inetd-generator
 %{systemdunitdir}/rc-inetd.service
 
-%if %{with plymouth}
-%files plymouth
-%defattr(644,root,root,755)
-%{systemdunitdir}/plymouth-halt.service
-%{systemdunitdir}/plymouth-kexec.service
-%{systemdunitdir}/plymouth-poweroff.service
-%{systemdunitdir}/plymouth-quit-wait.service
-%{systemdunitdir}/plymouth-quit.service
-%{systemdunitdir}/plymouth-read-write.service
-%{systemdunitdir}/plymouth-reboot.service
-%{systemdunitdir}/plymouth-start.service
-%{systemdunitdir}/systemd-ask-password-plymouth.path
-%{systemdunitdir}/systemd-ask-password-plymouth.service
-%config(noreplace,missingok) %{systemdunitdir}/halt.target.wants/plymouth-halt.service
-%config(noreplace,missingok) %{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
-%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
-%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
-%config(noreplace,missingok) %{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
-%config(noreplace,missingok) %{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
-%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
-%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
-%endif
-
 %files analyze
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/systemd-analyze
+%{_mandir}/man1/systemd-analyze.1*
 
 %files libs
 %defattr(644,root,root,755)
@@ -1281,11 +1293,6 @@ fi
 
 /usr/lib/udev
 
-# /lib/udev/devices/ are not read anymore; systemd-tmpfiles
-# should be used to create dead device nodes as workarounds for broken
-# subsystems.
-%dir /lib/udev/devices
-
 %attr(755,root,root) /lib/udev/collect
 
 %attr(755,root,root) /lib/udev/keyboard-force-release.sh
This page took 0.110488 seconds and 4 git commands to generate.