]> git.pld-linux.org Git - packages/systemd.git/blobdiff - systemd.spec
devel requires -units due .pc file
[packages/systemd.git] / systemd.spec
index 1b2ead23c94315ec5055b0962fede421893e2799..4f0c8be2442d59c690680d5729cb06aa8369d250 100644 (file)
@@ -28,7 +28,7 @@ Summary(pl.UTF-8):    systemd - zarządca systemu i usług dla Linuksa
 Name:          systemd
 # Verify ChangeLog and NEWS when updating (since there are incompatible/breaking changes very often)
 Version:       221
-Release:       1
+Release:       5
 Epoch:         1
 License:       GPL v2+ (udev), LGPL v2.1+ (the rest)
 Group:         Base
@@ -72,6 +72,7 @@ Patch9:               %{name}-configfs.patch
 Patch10:       pld-boot_efi_mount.patch
 Patch11:       optional-tmp-on-tmpfs.patch
 Patch12:       uids_gids.patch
+Patch13:       sysctl.patch
 URL:           http://www.freedesktop.org/wiki/Software/systemd
 BuildRequires: acl-devel
 BuildRequires: attr-devel
@@ -150,7 +151,6 @@ Requires:   setup >= 2.8.0-2
 Requires:      udev-core = %{epoch}:%{version}-%{release}
 Requires:      udev-libs = %{epoch}:%{version}-%{release}
 Requires:      uname(release) >= 3.7
-Suggests:      ConsoleKit
 Suggests:      fsck >= 2.25.0
 Suggests:      service(klogd)
 Suggests:      service(syslog)
@@ -168,6 +168,9 @@ Provides:   user(systemd-journal-upload)
 Provides:      user(systemd-network)
 Provides:      user(systemd-resolve)
 Provides:      user(systemd-timesync)
+# kde4 still can't live without ConsoleKit
+#Obsoletes:    ConsoleKit
+#Obsoletes:    ConsoleKit-x11
 Obsoletes:     systemd-no-compat-tmpfiles
 Obsoletes:     udev-systemd
 # sytemd wants pam with pam_systemd.so in system-auth...
@@ -301,6 +304,8 @@ Conflicts:  rc-scripts < 0.4.5.5-2
 Conflicts:     upstart
 # systemd takes care of that and causes problems
 Conflicts:     binfmt-detector
+# for /lib/systemd/systemd-sysv-install
+Conflicts:     chkconfig < 2:1.5-1
 
 %description init
 Install this package when you are ready to final switch to systemd.
@@ -467,6 +472,7 @@ Summary:    Header files for systemd libraries
 Summary(pl.UTF-8):     Pliki nagłówkowe bibliotek systemd
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
+Requires:      %{name}-units = %{epoch}:%{version}-%{release}
 Obsoletes:     systemd-static
 
 %description devel
@@ -656,6 +662,7 @@ Uzupełnianie parametrów w zsh dla poleceń udev.
 %patch10 -p1
 %patch11 -p1
 %patch12 -p1
+%patch13 -p1
 cp -p %{SOURCE2} src/systemd_booted.c
 
 %build
@@ -665,7 +672,7 @@ cp -p %{SOURCE2} src/systemd_booted.c
 %{__autoheader}
 %{__automake}
 
-for PYTHON in "%{__python}" %{?with_python3:"%{__python3}"} ; do
+for PYTHON in %{__python} %{?with_python3:%{__python3}}; do
 
 %configure \
        QUOTAON=/sbin/quotaon \
@@ -676,6 +683,9 @@ for PYTHON in "%{__python}" %{?with_python3:"%{__python3}"} ; do
        KEXEC=/sbin/kexec \
        PYTHON="$PYTHON" \
        PYTHON_BINARY="$PYTHON" \
+%if "%{?configure_cache}" == "1"
+       --cache-file=%{?configure_cache_file}%{!?configure_cache_file:configure}-$(basename $PYTHON).cache \
+%endif
        %{?debug:--enable-debug} \
        %{__enable_disable audit} \
        %{__enable_disable cryptsetup libcryptsetup} \
@@ -713,12 +723,14 @@ done
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/var/lib/{%{name}/coredump,machines} \
+install -d $RPM_BUILD_ROOT/var/lib/{%{name}/{catalog,coredump},machines} \
        $RPM_BUILD_ROOT{%{_sysconfdir}/{modprobe.d,systemd/system-preset},%{_sbindir}}
 
 %{__make} -j1 install \
        DESTDIR=$RPM_BUILD_ROOT
 
+touch $RPM_BUILD_ROOT/var/lib/%{name}/random-seed
+
 ./libtool --mode=install install -p -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
 
 # compatibility symlinks to udevd binary
@@ -729,7 +741,7 @@ ln -s /lib/udev/udevd $RPM_BUILD_ROOT%{_sbindir}/udevd
 # compat symlinks for "/ merged into /usr" programs
 mv $RPM_BUILD_ROOT/{,s}bin/udevadm
 ln -s %{_sbindir}/udevadm $RPM_BUILD_ROOT/bin
-ln -s /lib/udev $RPM_BUILD_ROOT/usr/lib/
+ln -s /lib/udev $RPM_BUILD_ROOT%{_prefix}/lib
 
 # install custom udev rules from pld package
 cp -a %{SOURCE101} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/40-alsa-restore.rules
@@ -831,7 +843,7 @@ install -d $RPM_BUILD_ROOT%{systemdunitdir}/{basic,dbus,halt,initrd,kexec,powero
 install -d $RPM_BUILD_ROOT%{_libexecdir}/systemd/system-{shutdown,sleep}
 
 # Create new-style configuration files so that we can ghost-own them
-touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,timezone,vconsole.conf}
+touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,vconsole.conf}
 
 # Install SysV conversion tool for systemd
 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
@@ -840,18 +852,18 @@ install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
 install -d $RPM_BUILD_ROOT/lib/systemd/pld-helpers.d
 
 # to be enabled only when the packages are installed
-%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants/systemd-networkd.service
-%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants/systemd-networkd.socket
-%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants/systemd-resolved.service
+%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants/systemd-networkd.service \
+       $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants/systemd-networkd.socket \
+       $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants/systemd-resolved.service
 
 install -d $RPM_BUILD_ROOT/var/log
 :> $RPM_BUILD_ROOT/var/log/btmp
 :> $RPM_BUILD_ROOT/var/log/wtmp
 
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
-%{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
-%{__rm} $RPM_BUILD_ROOT/%{_lib}/libnss_myhostname.la
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
+%{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la \
+       $RPM_BUILD_ROOT/%{_lib}/libnss_myhostname.la \
+       $RPM_BUILD_ROOT%{_libdir}/*.la
 
 %if %{with python3}
 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/systemd/*.la
@@ -1093,11 +1105,10 @@ fi
 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
 %attr(755,root,root) %{_sysconfdir}/X11/xinit/xinitrc.d/50-systemd-user.sh
-%ghost %config(noreplace) %{_sysconfdir}/machine-id
+%attr(444,root,root) %ghost %config(noreplace) %{_sysconfdir}/machine-id
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/bootchart.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/coredump.conf
@@ -1116,8 +1127,8 @@ fi
 %dir %{_sysconfdir}/systemd/system/sockets.target.wants
 %dir %{_sysconfdir}/systemd/system/sysinit.target.wants
 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/getty.target.wants/getty@tty1.service
-%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/sysinit.target.wants/systemd-timesyncd.service
 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/multi-user.target.wants/remote-fs.target
+%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/sysinit.target.wants/systemd-timesyncd.service
 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/systemd-user
 /etc/xdg/systemd
 %attr(755,root,root) /bin/journalctl
@@ -1408,10 +1419,12 @@ fi
 %{_mandir}/man8/systemd-update-utmp.8*
 %{_mandir}/man8/systemd-user-sessions.8*
 %{_mandir}/man8/systemd-vconsole-setup.8*
-%dir /var/lib/machines
+%attr(700,root,root) %dir /var/lib/machines
 %dir /var/lib/%{name}
 %dir /var/lib/%{name}/coredump
-%attr(640,root,root) %ghost /var/log/btmp
+%dir /var/lib/%{name}/catalog
+%attr(640,root,root) %ghost /var/lib/%{name}/random-seed
+%attr(600,root,utmp) %ghost /var/log/btmp
 %attr(664,root,utmp) %ghost /var/log/wtmp
 %attr(2755,root,systemd-journal) %dir /var/log/journal
 
@@ -1975,7 +1988,7 @@ fi
 %files -n udev-core
 %defattr(644,root,root,755)
 
-/usr/lib/udev
+%{_prefix}/lib/udev
 
 %attr(755,root,root) /lib/udev/collect
 
This page took 0.038377 seconds and 4 git commands to generate.