]> git.pld-linux.org Git - packages/systemd.git/blame_incremental - systemd.spec
- fix paths
[packages/systemd.git] / systemd.spec
... / ...
CommitLineData
1#
2# TODO:
3# - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4# after enough packages provide their own tmpfiles.d configs for
5# /var/run directories
6#
7# Conditional build:
8%bcond_without audit # without audit support
9%bcond_without cryptsetup # without cryptsetup support
10%bcond_without gtk # build gtk tools
11%bcond_without pam # PAM authentication support
12%bcond_with plymouth # plymouth support
13%bcond_without selinux # without SELinux support
14%bcond_without tcpd # libwrap (tcp_wrappers) support
15
16Summary: A System and Service Manager
17Summary(pl.UTF-8): systemd - zarządca systemu i usług dla Linuksa
18Name: systemd
19Version: 43
20Release: 2
21License: GPL v2+
22Group: Base
23Source0: http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
24# Source0-md5: 446cc6db7625617af67e2d8e5f503a49
25Source1: %{name}-sysv-convert
26Source2: %{name}_booted.c
27Source3: ifup@.service
28Source4: network-post.service
29Source5: network.service
30Source6: compat-pld-media.tmpfiles
31Source7: compat-pld-var-run.tmpfiles
32Patch0: target-pld.patch
33Patch1: config-pld.patch
34Patch2: shut-sysv-up.patch
35Patch3: pld-sysv-network.patch
36Patch4: tmpfiles-not-fatal.patch
37URL: http://www.freedesktop.org/wiki/Software/systemd
38BuildRequires: acl-devel
39%{?with_audit:BuildRequires: audit-libs-devel}
40BuildRequires: autoconf >= 2.63
41BuildRequires: automake >= 1:1.11
42BuildRequires: binutils >= 3:2.22.52.0.1-2
43%{?with_cryptsetup:BuildRequires: cryptsetup-luks-devel}
44BuildRequires: dbus-devel >= 1.3.2
45BuildRequires: docbook-style-xsl
46BuildRequires: gperf
47BuildRequires: intltool >= 0.40.0
48BuildRequires: kmod-devel >= 5
49BuildRequires: libcap-devel
50%{?with_selinux:BuildRequires: libselinux-devel >= 2.1.0}
51BuildRequires: libtool >= 2:2.2
52%{?with_tcpd:BuildRequires: libwrap-devel}
53BuildRequires: libxslt-progs
54BuildRequires: m4
55%{?with_pam:BuildRequires: pam-devel}
56BuildRequires: pkgconfig >= 0.9.0
57BuildRequires: rpmbuild(macros) >= 1.627
58BuildRequires: udev-devel >= 1:172
59# not required for building from release (which contains *.c for *.vala)
60#BuildRequires: vala >= 0.10.0
61BuildRequires: xz-devel
62%if %{with gtk}
63BuildRequires: glib2-devel >= 1:2.26.1
64BuildRequires: gtk+2-devel >= 2:2.24.0
65BuildRequires: libgee-devel
66BuildRequires: libnotify-devel >= 0.7.0
67%endif
68Requires: %{name}-libs = %{version}-%{release}
69Requires: %{name}-units = %{version}-%{release}
70Requires: /etc/os-release
71Requires: SysVinit-tools
72Requires: agetty
73Requires: dbus >= 1.4.16-6
74Requires: filesystem >= 4.0-2
75Requires: rc-scripts >= 0.4.5.1-7
76Requires: setup >= 2.8.0-2
77Requires: udev-core >= 1:175-5
78Requires: udev-libs >= 1:172
79Requires: virtual(module-tools)
80Suggests: ConsoleKit
81Suggests: fsck >= 2.20
82Suggests: kmod >= 5
83Suggests: nss_myhostname
84# python modules required by systemd-analyze
85Suggests: %{name}-no-compat-tmpfiles
86Suggests: python-dbus
87Suggests: python-modules
88Suggests: service(klogd)
89Suggests: service(syslog)
90Provides: udev-acl
91# systemd takes care of that and causes problems
92Conflicts: binfmt-detector
93# sytemd wants pam with pam_systemd.so in system-auth...
94Conflicts: pam < 1:1.1.5-5
95# ...and sudo hates it
96Conflicts: sudo < 1:1.7.8p2-4
97Conflicts: upstart
98BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100%define _libexecdir %{_prefix}/lib
101
102%description
103systemd is a system and service manager for Linux, compatible with
104SysV and LSB init scripts. systemd provides aggressive parallelization
105capabilities, uses socket and D-Bus activation for starting services,
106offers on-demand starting of daemons, keeps track of processes using
107Linux cgroups, supports snapshotting and restoring of the system
108state, maintains mount and automount points and implements an
109elaborate transactional dependency-based service control logic. It can
110work as a drop-in replacement for sysvinit.
111
112%description -l pl.UTF-8
113systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
114skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
115paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
116oferuje uruchamianie usług na życzenie, monitoruje procesy używając
117linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
118(restore) stanu systemu, zarządza (auto)mount pointami oraz
119implementuje starannie opracowaną transakcjonalną, bazującą na
120zależnościach logikę kontroli usług. Może pracować jako zastępca dla
121sysvinit.
122
123%package init
124Summary: systemd /sbin/init and LSB/SysV compatibility symlinks
125Summary(pl.UTF-8): /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
126Group: Base
127Requires: systemd
128Provides: readahead = 1:1.5.7-3
129Provides: virtual(init-daemon)
130Obsoletes: SysVinit
131Obsoletes: readahead < 1:1.5.7-3
132Obsoletes: virtual(init-daemon)
133
134%description init
135Install this package when you are ready to final switch to systemd.
136
137%description init -l pl.UTF-8
138Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
139przejścia na systemd.
140
141%package units
142Summary: Configuration files, directories and installation tool for systemd
143Summary(pl.UTF-8): Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
144Group: Base
145Requires(post): coreutils
146Requires(post): /bin/awk
147
148%description units
149Basic configuration files, directories and installation tool for the
150systemd system and service manager.
151
152This is common config, use %{_sysconfdir}/systemd/system to override.
153
154%description units -l pl.UTF-8
155Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
156zarządcy systemu i usług systemd.
157
158Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
159poprzez katalog %{_sysconfdir}/systemd/system.
160
161%package plymouth
162Summary: Plymouth support units for systemd
163Summary(pl.UTF-8): Jednostki wspierające Plymouth dla systemd
164Group: Base
165Requires: %{name}-units = %{version}-%{release}
166
167%description plymouth
168Plymouth (graphical boot) support units for systemd.
169
170%description plymouth -l pl.UTF-8
171Jednostki wspierające Plymouth (graficzny start systemu) dla systemd.
172
173%package gtk
174Summary: Graphical frontend for systemd
175Summary(pl.UTF-8): Graficzny interfejs do systemd
176Group: Base
177Requires: %{name} = %{version}-%{release}
178Requires: polkit
179
180%description gtk
181Graphical front-end for systemd.
182
183%description gtk -l pl.UTF-8
184Graficzny interfejs do systemd.
185
186%package libs
187Summary: Shared systemd libraries
188Summary(pl.UTF-8): Biblioteki współdzielone systemd
189Group: Libraries
190
191%description libs
192Shared systemd libraries.
193
194%description libs -l pl.UTF-8
195Biblioteki współdzielone systemd.
196
197%package devel
198Summary: Header files for systemd libraries
199Summary(pl.UTF-8): Pliki nagłówkowe bibliotek systemd
200Group: Development/Libraries
201Requires: %{name}-libs = %{version}-%{release}
202
203%description devel
204Header files for systemd libraries.
205
206%description devel -l pl.UTF-8
207Pliki nagłówkowe bibliotek systemd.
208
209%package -n bash-completion-systemd
210Summary: bash-completion for systemd
211Summary(pl.UTF-8): Bashowe dopełnianie składni dla systemd
212Group: Applications/Shells
213Requires: %{name}
214Requires: bash-completion
215
216%description -n bash-completion-systemd
217bash-completion for systemd.
218
219%description -n bash-completion-systemd -l pl.UTF-8
220Bashowe dopełnianie składni dla systemd
221
222%package no-compat-tmpfiles
223Summary: Force update of packages that provide tmpfiles.d configuration
224Group: Base
225Requires(post): sed > 4.0
226Conflicts: ConsoleKit-dirs < 0.4.5-7
227Conflicts: NetworkManager < 2:0.9.2.0-3
228Conflicts: Zope < 2.11.8-2
229Conflicts: amavisd-new < 1:2.7.0-1
230Conflicts: apache-base < 2.2.21-4
231Conflicts: apache-mod_bw < 0.92-3
232Conflicts: apache-mod_fastcgi < 2.4.6-6
233Conflicts: apache1-base < 1.3.42-5
234Conflicts: apache1-mod_fastcgi < 2.4.6-2
235Conflicts: asterisk < 10.0.1-2
236Conflicts: autossh-init < 1.4b-3
237Conflicts: balance < 3.54-2
238Conflicts: bind < 7:9.8.1.P1-4
239Conflicts: bopm < 3.1.3-4
240Conflicts: callweaver < 1.2.1-9
241Conflicts: cassandra-bin < 0.8.9-2
242Conflicts: clamav < 0.97.3-3
243Conflicts: cups < 1:1.5.0-10
244Conflicts: dbus < 1.4.16-4
245Conflicts: dovecot < 1:2.0.16-3
246Conflicts: dspam < 3.9.0-6
247Conflicts: fail2ban < 0.8.4-4
248Conflicts: filesystem < 4.0-3
249Conflicts: gammu-smsd < 1:1.31.0-3
250# Break gdm2.20 installs
251#Conflicts: gdm < 2:3.2.1.1-9
252Conflicts: greylistd < 0.8.8-2
253Conflicts: inn < 2.4.6-7
254Conflicts: ipsec-tools < 0.8.0-3
255Conflicts: jabber-common < 0-9
256Conflicts: laptop-mode-tools < 1.58-2
257Conflicts: libgpod < 0.8.0-6
258Conflicts: libvirt-utils < 0.9.9-4
259Conflicts: lighttpd < 1.4.30-5
260Conflicts: lirc < 0.9.0-20
261Conflicts: mailman < 5:2.1.14-4
262Conflicts: memcached < 1.4.11-2
263Conflicts: mpd < 0.16.5-4
264Conflicts: mrtg < 2.17.0-3
265Conflicts: munin-common < 1.4.5-5
266Conflicts: nagios-nrpe < 2.13-2
267Conflicts: ndisc6-rdnssd < 1.0.1-3
268Conflicts: nscd < 6:2.14.1-5
269Conflicts: nss_ldapd-nslcd < 0.8.4-2
270Conflicts: openct < 0.6.20-3
271Conflicts: openl2tp < 1.8-3
272Conflicts: openldap-overlay-nssov < 2.4.28-4
273Conflicts: openldap-servers < 2.4.28-4
274Conflicts: openvpn < 2.2.2-2
275Conflicts: pam-pam_mount < 2.12-3
276Conflicts: pam-pam_ssh < 1.97-2
277Conflicts: pcsc-lite < 1.8.1-2
278Conflicts: php-dirs < 1.2-3
279Conflicts: policyd < 2.0.10-3
280Conflicts: pound < 2.6-2
281Conflicts: pptp < 1.7.2-3
282Conflicts: proftpd-common < 2:1.3.4a-2
283Conflicts: pulseaudio-server < 1.1-2
284Conflicts: quagga < 0.99.20-3
285Conflicts: radvd < 1.8.5-2
286Conflicts: rc-scripts < 0.4.5.2-3
287Conflicts: red5 < 0.9.0-2
288Conflicts: redis-server < 2.4.2-4
289Conflicts: smokeping < 2.4.2-10
290Conflicts: smtp-gated < 1.4.17-2
291Conflicts: socat < 1.7.2.0-2
292Conflicts: speech-dispatcher < 0.7.1-2
293Conflicts: sphinx < 2.0.3-4
294Conflicts: splashutils < 1.5.4.3-3
295Conflicts: stunnel < 4.50-2
296Conflicts: tenshi < 0.12-2
297Conflicts: tor < 0.2.2.35-2
298Conflicts: ucarp < 1.5.2-3
299Conflicts: udisks < 1.0.4-3
300Conflicts: util-vserver < 0.30.216-1.pre3002.3
301Conflicts: vpnc < 0.5.3-2
302Conflicts: web2ldap < 1.1.0rc1-2
303Conflicts: wesnoth-server < 1:1.10-2
304Conflicts: wpa_supplicant < 0.7.3-10
305Conflicts: xl2tpd < 1.3.0-2
306
307%description no-compat-tmpfiles
308Force update of packages that provide tmpfiles.d configuration
309
310%prep
311%setup -q
312%patch0 -p1
313%patch1 -p1
314%patch2 -p1
315%patch3 -p1
316%patch4 -p1
317cp -p %{SOURCE2} src/systemd_booted.c
318
319%build
320%{__aclocal} -I m4
321%{__autoconf}
322%{__autoheader}
323%{__automake}
324%configure \
325 %{__enable_disable audit} \
326 %{__enable_disable cryptsetup libcryptsetup} \
327 %{__enable_disable gtk} \
328 %{__enable_disable pam} \
329 %{__enable_disable plymouth} \
330 %{__enable_disable selinux} \
331 %{__enable_disable tcpd tcpwrap} \
332 --disable-silent-rules \
333 --disable-static \
334 --with-distro=pld \
335 --with-rootprefix= \
336 --with-rootlibdir=/%{_lib} \
337 --enable-split-usr
338
339%{__make}
340./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
341
342%install
343rm -rf $RPM_BUILD_ROOT
344
345%{__make} install \
346 DESTDIR=$RPM_BUILD_ROOT
347
348./libtool --mode=install install -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
349
350# Main binary has been moved, but we don't want to break existing installs
351ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
352
353# Create SysV compatibility symlinks. systemctl/systemd are smart
354# enough to detect the way they were called
355install -d $RPM_BUILD_ROOT/sbin
356ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
357ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
358ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
359ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
360ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
361ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
362ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
363
364ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
365# disable random and console SYSV service
366ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
367ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
368
369# add static (non-NetworkManager) networking
370install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/ifup@.service
371install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/network-post.service
372install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
373
374# install compatibility tmpfiles configs
375install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
376install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
377
378# All wants links are created at %post to make sure they are not owned
379# and hence overriden by rpm if the user deletes them (missingok?)
380%{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants
381
382# it is in rc-scripts pkg
383%{__rm} $RPM_BUILD_ROOT%{systemdunitdir}/rc-local.service
384
385# Make sure these directories are properly owned:
386# - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
387# - syslog _might_ be used by some syslog implementation (none for now),
388# - isn't dbus populated by dbus-systemd only (so to be moved there)?
389install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
390
391# Create new-style configuration files so that we can ghost-own them
392touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,timezone,vconsole.conf}
393
394# Install SysV conversion tool for systemd
395install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
396
397install -d $RPM_BUILD_ROOT/var/log
398:> $RPM_BUILD_ROOT/var/log/btmp
399:> $RPM_BUILD_ROOT/var/log/wtmp
400
401%if %{without gtk}
402%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
403%endif
404
405%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
406%{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
407%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
408
409%clean
410rm -rf $RPM_BUILD_ROOT
411
412%post
413/bin/systemd-machine-id-setup > /dev/null 2>&1 || :
414/bin/systemctl daemon-reexec > /dev/null 2>&1 || :
415
416%postun
417if [ $1 -ge 1 ]; then
418 /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
419fi
420
421%post libs -p /sbin/ldconfig
422%postun libs -p /sbin/ldconfig
423
424%post units
425if [ $1 -eq 1 ]; then
426 # Try to read default runlevel from the old inittab if it exists
427 runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
428 if [ -z "$runlevel" ] ; then
429 target="%{systemdunitdir}/graphical.target"
430 else
431 target="%{systemdunitdir}/runlevel$runlevel.target"
432 fi
433
434 # And symlink what we found to the new-style default.target
435 ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
436
437 # Setup hostname
438 [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
439 if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
440 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
441 echo $HOSTNAME > /etc/hostname
442 chmod 644 /etc/hostname
443 fi
444fi
445# Enable the services we install by default.
446/bin/systemctl enable \
447 getty@.service \
448 network.service \
449 network-post.service \
450 remote-fs.target \
451 systemd-readahead-replay.service \
452 systemd-readahead-collect.service >/dev/null 2>&1 || :
453
454# Find and enable all installed interfaces
455mkdir -p %{_sysconfdir}/systemd/system/network.target.wants >/dev/null 2>&1 || :
456for f in /etc/sysconfig/interfaces/ifcfg-* ; do
457 ff=$(basename $f)
458 ff=${ff##ifcfg-}
459 case "$ff" in
460 *.rpmorig|*.rpmnew|*.rpmsave|*~|*.orig)
461 continue
462 ;;
463 *)
464 DEVICE="" ; ONBOOT="" ; USERS=""
465 . $f 2>/dev/null
466 [ ${USERS:-no} != no ] && continue
467 if [ "$DEVICE" = "$ff" -a ${ONBOOT:-no} = "yes" ]; then
468 ln -s %{systemdunitdir}/ifup@.service \
469 %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@$ff.service >/dev/null 2>&1 || :
470 fi
471 ;;
472 esac
473done
474
475%preun units
476if [ $1 -eq 0 ] ; then
477 /bin/systemctl disable \
478 getty@.service \
479 network.service \
480 network-post.service \
481 remote-fs.target \
482 systemd-readahead-replay.service \
483 systemd-readahead-collect.service >/dev/null 2>&1 || :
484
485 %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
486 %{__rm} -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
487fi
488
489%postun units
490if [ $1 -ge 1 ]; then
491 /bin/systemctl daemon-reload > /dev/null 2>&1 || :
492fi
493
494%post no-compat-tmpfiles
495%{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
496
497%files
498%defattr(644,root,root,755)
499%doc DISTRO_PORTING README TODO
500/etc/dbus-1/system.d/org.freedesktop.hostname1.conf
501/etc/dbus-1/system.d/org.freedesktop.locale1.conf
502/etc/dbus-1/system.d/org.freedesktop.login1.conf
503/etc/dbus-1/system.d/org.freedesktop.systemd1.conf
504/etc/dbus-1/system.d/org.freedesktop.timedate1.conf
505%ghost %config(noreplace) %{_sysconfdir}/machine-id
506%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
507%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
508%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
509%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
510%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
511%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
512%dir %{_sysconfdir}/systemd/user
513/etc/xdg/systemd
514%attr(755,root,root) /bin/systemd
515%attr(755,root,root) /bin/systemd-ask-password
516%attr(755,root,root) /bin/systemd-journalctl
517%attr(755,root,root) /bin/systemd-loginctl
518%attr(755,root,root) /bin/systemd-machine-id-setup
519%attr(755,root,root) /bin/systemd-notify
520%attr(755,root,root) /bin/systemd-tty-ask-password-agent
521%attr(755,root,root) %{_bindir}/systemd-analyze
522%attr(755,root,root) %{_bindir}/systemd-cat
523%attr(755,root,root) %{_bindir}/systemd-cgtop
524%attr(755,root,root) %{_bindir}/systemd-cgls
525%attr(755,root,root) %{_bindir}/systemd-nspawn
526%attr(755,root,root) %{_bindir}/systemd-stdio-bridge
527%attr(755,root,root) %{_bindir}/systemd-sysv-convert
528%attr(755,root,root) /lib/systemd/systemd-*
529%dir /lib/systemd/system-generators
530%attr(755,root,root) /lib/systemd/systemd
531%attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
532%dir /lib/systemd/system-shutdown
533/lib/udev/rules.d/99-systemd.rules
534/lib/udev/rules.d/70-uaccess.rules
535/lib/udev/rules.d/71-seat.rules
536/lib/udev/rules.d/73-seat-late.rules
537%dir %{_libexecdir}/systemd
538%{_libexecdir}/systemd/user
539%dir %{_libexecdir}/systemd/user-generators
540%config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
541%{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
542%{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
543%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
544%{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
545%{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
546%{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
547%{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
548%{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
549%{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
550%{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
551%{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
552%{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
553%{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
554%{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
555%{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
556%dir %{_datadir}/systemd
557%{_datadir}/systemd/kbd-model-map
558%{_mandir}/man1/systemd.1*
559%{_mandir}/man1/systemd-*.1*
560%{_mandir}/man3/sd_booted.3*
561%{_mandir}/man3/sd_is_fifo.3*
562%{_mandir}/man3/sd_is_socket.3
563%{_mandir}/man3/sd_is_socket_inet.3
564%{_mandir}/man3/sd_is_socket_unix.3
565%{_mandir}/man3/sd_listen_fds.3*
566%{_mandir}/man3/sd_notify.3*
567%{_mandir}/man3/sd_notifyf.3
568%{_mandir}/man3/sd_readahead.3*
569%{_mandir}/man5/binfmt.d.5*
570%{_mandir}/man5/hostname.5*
571%{_mandir}/man5/locale.conf.5*
572%{_mandir}/man5/machine-id.5*
573%{_mandir}/man5/machine-info.5*
574%{_mandir}/man5/modules-load.d.5*
575%{_mandir}/man5/os-release.5*
576%{_mandir}/man5/sysctl.d.5*
577%{_mandir}/man5/systemd.*.5*
578%{_mandir}/man5/systemd-logind.conf.5*
579%{_mandir}/man5/timezone.5*
580%{_mandir}/man5/vconsole.conf.5*
581%{_mandir}/man7/daemon.7*
582%{_mandir}/man7/sd-daemon.7*
583%{_mandir}/man7/sd-login.7*
584%{_mandir}/man7/sd-readahead.7*
585%{_mandir}/man7/systemd.special.7*
586%attr(640,root,root) %ghost /var/log/btmp
587%attr(664,root,utmp) %ghost /var/log/wtmp
588
589%if %{with pam}
590%attr(755,root,root) /%{_lib}/security/pam_systemd.so
591%{_mandir}/man8/pam_systemd.8*
592%endif
593
594%files init
595%defattr(644,root,root,755)
596%attr(755,root,root) /sbin/halt
597%attr(755,root,root) /sbin/init
598%attr(755,root,root) /sbin/poweroff
599%attr(755,root,root) /sbin/reboot
600%attr(755,root,root) /sbin/runlevel
601%attr(755,root,root) /sbin/shutdown
602%attr(755,root,root) /sbin/telinit
603%{_mandir}/man1/init.1
604%{_mandir}/man8/halt.8*
605%{_mandir}/man8/poweroff.8
606%{_mandir}/man8/reboot.8
607%{_mandir}/man8/runlevel.8*
608%{_mandir}/man8/shutdown.8*
609%{_mandir}/man8/telinit.8*
610
611%files units
612%defattr(644,root,root,755)
613%dir %{_sysconfdir}/binfmt.d
614%dir %{_sysconfdir}/modules-load.d
615%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
616%dir %{_sysconfdir}/sysctl.d
617%dir %{_sysconfdir}/systemd
618%dir %{_sysconfdir}/systemd/system
619%dir %{_sysconfdir}/tmpfiles.d
620%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
621%dir %{_libexecdir}/binfmt.d
622%dir %{_libexecdir}/modules-load.d
623%dir %{_libexecdir}/sysctl.d
624%{_libexecdir}/sysctl.d/coredump.conf
625%attr(755,root,root) /bin/systemctl
626%attr(755,root,root) /bin/systemd-tmpfiles
627%attr(755,root,root) /bin/systemd_booted
628%{_mandir}/man1/systemctl.1*
629%{_mandir}/man5/tmpfiles.d.5*
630%{_mandir}/man8/systemd-tmpfiles.8*
631%{_npkgconfigdir}/systemd.pc
632
633%{systemdunitdir}/*.automount
634%{systemdunitdir}/*.mount
635%{systemdunitdir}/*.path
636%{systemdunitdir}/*.service
637%{systemdunitdir}/*.socket
638%{systemdunitdir}/*.target
639%{systemdunitdir}/*.timer
640%if %{with plymouth}
641%exclude %{systemdunitdir}/plymouth*.service
642%exclude %{systemdunitdir}/systemd-ask-password-plymouth.*
643%endif
644%dir %{systemdunitdir}/basic.target.wants
645%dir %{systemdunitdir}/dbus.target.wants
646%dir %{systemdunitdir}/final.target.wants
647%dir %{systemdunitdir}/graphical.target.wants
648%dir %{systemdunitdir}/halt.target.wants
649%dir %{systemdunitdir}/kexec.target.wants
650%dir %{systemdunitdir}/local-fs.target.wants
651%dir %{systemdunitdir}/multi-user.target.wants
652%dir %{systemdunitdir}/poweroff.target.wants
653%dir %{systemdunitdir}/reboot.target.wants
654%dir %{systemdunitdir}/runlevel[12345].target.wants
655%dir %{systemdunitdir}/shutdown.target.wants
656%dir %{systemdunitdir}/sockets.target.wants
657%dir %{systemdunitdir}/sysinit.target.wants
658%dir %{systemdunitdir}/syslog.target.wants
659%config(noreplace,missingok) %{systemdunitdir}/basic.target.wants/*
660%config(noreplace,missingok) %{systemdunitdir}/final.target.wants/*
661%config(noreplace,missingok) %{systemdunitdir}/graphical.target.wants/*
662%config(noreplace,missingok) %{systemdunitdir}/local-fs.target.wants/*
663%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/getty.target
664%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/rc-local.service
665%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
666%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
667%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
668%config(noreplace,missingok) %{systemdunitdir}/runlevel[12345].target.wants/*
669%config(noreplace,missingok) %{systemdunitdir}/shutdown.target.wants/*
670%config(noreplace,missingok) %{systemdunitdir}/sockets.target.wants/*
671%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/cryptsetup.target
672%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
673%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
674%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
675%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/sys-*.mount
676%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/systemd-*
677
678%if %{with plymouth}
679%files plymouth
680%defattr(644,root,root,755)
681%{systemdunitdir}/plymouth-halt.service
682%{systemdunitdir}/plymouth-kexec.service
683%{systemdunitdir}/plymouth-poweroff.service
684%{systemdunitdir}/plymouth-quit-wait.service
685%{systemdunitdir}/plymouth-quit.service
686%{systemdunitdir}/plymouth-read-write.service
687%{systemdunitdir}/plymouth-reboot.service
688%{systemdunitdir}/plymouth-start.service
689%{systemdunitdir}/systemd-ask-password-plymouth.path
690%{systemdunitdir}/systemd-ask-password-plymouth.service
691%config(noreplace,missingok) %{systemdunitdir}/halt.target.wants/plymouth-halt.service
692%config(noreplace,missingok) %{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
693%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
694%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
695%config(noreplace,missingok) %{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
696%config(noreplace,missingok) %{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
697%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
698%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
699%endif
700
701%if %{with gtk}
702%files gtk
703%defattr(644,root,root,755)
704%attr(755,root,root) %{_bindir}/systemadm
705%attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
706%{_mandir}/man1/systemadm.1*
707%endif
708
709%files libs
710%defattr(644,root,root,755)
711%attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
712%attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
713%attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
714%attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
715%attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
716%attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
717%attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
718%attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
719
720%files devel
721%defattr(644,root,root,755)
722%attr(755,root,root) %{_libdir}/libsystemd-daemon.so
723%attr(755,root,root) %{_libdir}/libsystemd-id128.so
724%attr(755,root,root) %{_libdir}/libsystemd-journal.so
725%attr(755,root,root) %{_libdir}/libsystemd-login.so
726%{_includedir}/%{name}
727%{_pkgconfigdir}/libsystemd-daemon.pc
728%{_pkgconfigdir}/libsystemd-id128.pc
729%{_pkgconfigdir}/libsystemd-journal.pc
730%{_pkgconfigdir}/libsystemd-login.pc
731%{_mandir}/man3/sd_get_seats.3*
732%{_mandir}/man3/sd_get_sessions.3*
733%{_mandir}/man3/sd_get_uids.3*
734%{_mandir}/man3/sd_is_mq.3*
735%{_mandir}/man3/sd_login_monitor_flush.3*
736%{_mandir}/man3/sd_login_monitor_get_fd.3*
737%{_mandir}/man3/sd_login_monitor_new.3*
738%{_mandir}/man3/sd_login_monitor_unref.3*
739%{_mandir}/man3/sd_pid_get_owner_uid.3*
740%{_mandir}/man3/sd_pid_get_session.3*
741%{_mandir}/man3/sd_pid_get_unit.3*
742%{_mandir}/man3/sd_seat_can_multi_session.3*
743%{_mandir}/man3/sd_seat_get_active.3*
744%{_mandir}/man3/sd_seat_get_sessions.3*
745%{_mandir}/man3/sd_session_get_seat.3*
746%{_mandir}/man3/sd_session_get_uid.3*
747%{_mandir}/man3/sd_session_is_active.3*
748%{_mandir}/man3/sd_uid_get_seats.3*
749%{_mandir}/man3/sd_uid_get_sessions.3*
750%{_mandir}/man3/sd_uid_get_state.3*
751%{_mandir}/man3/sd_uid_is_on_seat.3*
752
753%files -n bash-completion-systemd
754%defattr(644,root,root,755)
755/etc/bash_completion.d/systemd-bash-completion.sh
756
757%files no-compat-tmpfiles
758%defattr(644,root,root,755)
759# empty package
This page took 0.23141 seconds and 4 git commands to generate.