]> git.pld-linux.org Git - packages/sysprof.git/blob - sysprof.spec
807ee156faeadb189bf1f6f5714e7381de0c2380
[packages/sysprof.git] / sysprof.spec
1 #
2 # Conditional build:
3 %bcond_without  sysprofd        # daemon to run UI without root permissions
4 #
5 Summary:        Sampling CPU profiler for Linux
6 Summary(pl.UTF-8):      Próbkujący profiler procesora dla Linuksa
7 Name:           sysprof
8 Version:        3.34.1
9 Release:        1
10 License:        GPL v3+
11 Group:          Applications/System
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/sysprof/3.34/%{name}-%{version}.tar.xz
13 # Source0-md5:  cc32455277b31afb1965d627ae3e3629
14 URL:            http://sysprof.com/
15 # -std=gnu11 + C11 atomics
16 BuildRequires:  gcc >= 6:4.9
17 BuildRequires:  gdk-pixbuf2-devel >= 2.0
18 BuildRequires:  gettext-tools >= 0.19.6
19 BuildRequires:  glib2-devel >= 1:2.61.3
20 BuildRequires:  gobject-introspection-devel >= 1.42.0
21 BuildRequires:  gtk+3-devel >= 3.22
22 BuildRequires:  libdazzle-devel >= 3.30.0
23 BuildRequires:  libstdc++-devel >= 6:4.7
24 BuildRequires:  meson >= 0.50.0
25 BuildRequires:  ninja >= 1.5
26 BuildRequires:  pango-devel
27 BuildRequires:  pkgconfig >= 1:0.22
28 %{?with_sysprofd:BuildRequires: polkit-devel >= 0.105}
29 BuildRequires:  rpmbuild(macros) >= 1.736
30 %{?with_sysprofd:BuildRequires: systemd-devel >= 1:222}
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  vala
33 BuildRequires:  xz
34 BuildRequires:  yelp-tools
35 Requires:       %{name}-libs = %{version}-%{release}
36 %{?with_sysprofd:Requires:      polkit >= 0.105}
37 %{?with_sysprofd:Requires:      systemd-units >= 1:222}
38 Requires:       uname(release) >= 2.6.31
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Sysprof is a sampling CPU profiler for Linux that uses a kernel module
43 to profile the entire system, not just a single application. Sysprof
44 handles shared libraries and applications do not need to be
45 recompiled. In fact they don't even have to be restarted.
46
47 Just insert the kernel module and start sysprof.
48
49 %description -l pl.UTF-8
50 Sysprof to próbkujący profiler procesora dla Linuksa wykorzystujący
51 moduł jądra do profilowania całego systemu, nie tylko pojedynczej
52 aplikacji. Sysprof obsługuje biblioteki współdzielone, a aplikacje nie
53 wymagają rekompilacji. Właściwie nawet nie trzeba ich restartować.
54
55 Wystarczy załadować moduł jądra i uruchomić sysprof.
56
57 %package libs
58 Summary:        The sysprof profiler library
59 Summary(pl.UTF-8):      Biblioteka profilera sysprof
60 Group:          Libraries
61 Requires:       glib2 >= 1:2.61.3
62
63 %description libs
64 The sysprof profiler library.
65
66 %description libs -l pl.UTF-8
67 Biblioteka profilera sysprof.
68
69 %package devel
70 Summary:        Header files for sysprof library
71 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki sysprof
72 Group:          Development/Libraries
73 Requires:       %{name}-libs = %{version}-%{release}
74 Requires:       glib2-devel >= 1:2.61.3
75 Obsoletes:      sysprof-static < 3.28.0
76
77 %description devel
78 Header files for sysprof library.
79
80 %description devel -l pl.UTF-8
81 Pliki nagłówkowe biblioteki sysprof.
82
83 %package ui
84 Summary:        The sysprof graphical user interface
85 Summary(pl.UTF-8):      Graficzny interfejs użytkownika profilera sysprof
86 Group:          Applications/System
87 Requires(post,postun):  desktop-file-utils
88 Requires(post,postun):  glib2 >= 1:2.61.3
89 Requires(post,postun):  gtk-update-icon-cache
90 Requires:       %{name} = %{version}-%{release}
91 Requires:       %{name}-ui-libs = %{version}-%{release}
92 Requires:       hicolor-icon-theme
93 Requires:       shared-mime-info
94
95 %description ui
96 The sysprof graphical user interface.
97
98 %description ui -l pl.UTF-8
99 Graficzny interfejs użytkownika profilera sysprof.
100
101 %package ui-libs
102 Summary:        The sysprof library containing reusable GTK+ widgets
103 Summary(pl.UTF-8):      Biblioteka sysprofa zawierająca widgety GTK+ wielokrotnego użytku
104 Group:          X11/Libraries
105 Requires:       %{name}-libs = %{version}-%{release}
106 Requires:       gtk+3 >= 3.22
107 Requires:       libdazzle >= 3.30.0
108
109 %description ui-libs
110 The sysprof library containing reusable GTK+ widgets.
111
112 %description ui-libs -l pl.UTF-8
113 Biblioteka sysprofa zawierająca widgety GTK+ wielokrotnego użytku.
114
115 %package ui-devel
116 Summary:        Header files for sysprof-ui library
117 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki sysprof-ui
118 Group:          X11/Development/Libraries
119 Requires:       %{name}-devel = %{version}-%{release}
120 Requires:       %{name}-ui-libs = %{version}-%{release}
121 Requires:       gtk+3-devel >= 3.22
122 Obsoletes:      sysprof-ui-static < 3.28.0
123
124 %description ui-devel
125 Header files for sysprof-ui library.
126
127 %description ui-devel -l pl.UTF-8
128 Pliki nagłówkowe biblioteki sysprof-ui.
129
130 %prep
131 %setup -q
132
133 %build
134 %meson build \
135         %{!?with_sysprofd:-Dwith_sysprofd=host}
136
137 %ninja_build -C build
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141
142 %ninja_install -C build
143
144 %find_lang %{name} -o %{name}-ui.lang --with-gnome --without-mo
145 %find_lang %{name}
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %if %{with sysprofd}
151 %post
152 %systemd_post sysprof2.service
153
154 %preun
155 %systemd_preun sysprof2.service
156
157 %postun
158 %systemd_reload
159 %endif
160
161 %post   libs -p /sbin/ldconfig
162 %postun libs -p /sbin/ldconfig
163
164 %post ui
165 %glib_compile_schemas
166 %update_icon_cache hicolor
167 %update_mime_database
168 %update_desktop_database
169
170 %postun ui
171 %glib_compile_schemas
172 %update_icon_cache hicolor
173 %update_mime_database
174 %update_desktop_database
175
176 %post   ui-libs -p /sbin/ldconfig
177 %postun ui-libs -p /sbin/ldconfig
178
179 %files -f %{name}.lang
180 %defattr(644,root,root,755)
181 %doc AUTHORS NEWS TODO
182 %attr(755,root,root) %{_bindir}/sysprof-cli
183 %if %{with sysprofd}
184 %attr(755,root,root) %{_libexecdir}/sysprofd
185 %{systemdunitdir}/sysprof2.service
186 %{systemdunitdir}/sysprof3.service
187 %{_datadir}/dbus-1/system-services/org.gnome.Sysprof2.service
188 %{_datadir}/dbus-1/system-services/org.gnome.Sysprof3.service
189 %{_datadir}/dbus-1/system.d/org.gnome.Sysprof2.conf
190 %{_datadir}/dbus-1/system.d/org.gnome.Sysprof3.conf
191 %{_datadir}/polkit-1/actions/org.gnome.sysprof3.policy
192 %endif
193
194 %files libs
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_libdir}/libsysprof-3.so
197
198 %files devel
199 %defattr(644,root,root,755)
200 %{_libdir}/libsysprof-capture-3.a
201 %dir %{_includedir}/sysprof-3
202 %{_includedir}/sysprof-3/sysprof.h
203 %{_includedir}/sysprof-3/sysprof-address.h
204 %{_includedir}/sysprof-3/sysprof-battery-source.h
205 %{_includedir}/sysprof-3/sysprof-callgraph-profile.h
206 %{_includedir}/sysprof-3/sysprof-capture*.h
207 %{_includedir}/sysprof-3/sysprof-check.h
208 %{_includedir}/sysprof-3/sysprof-clock.h
209 %{_includedir}/sysprof-3/sysprof-diskstat-source.h
210 %{_includedir}/sysprof-3/sysprof-elf-symbol-resolver.h
211 %{_includedir}/sysprof-3/sysprof-gjs-source.h
212 %{_includedir}/sysprof-3/sysprof-governor-source.h
213 %{_includedir}/sysprof-3/sysprof-hostinfo-source.h
214 %{_includedir}/sysprof-3/sysprof-jitmap-symbol-resolver.h
215 %{_includedir}/sysprof-3/sysprof-kernel-symbol.h
216 %{_includedir}/sysprof-3/sysprof-kernel-symbol-resolver.h
217 %{_includedir}/sysprof-3/sysprof-local-profiler.h
218 %{_includedir}/sysprof-3/sysprof-memory-source.h
219 %{_includedir}/sysprof-3/sysprof-model-filter.h
220 %{_includedir}/sysprof-3/sysprof-netdev-source.h
221 %{_includedir}/sysprof-3/sysprof-perf-counter.h
222 %{_includedir}/sysprof-3/sysprof-perf-source.h
223 %{_includedir}/sysprof-3/sysprof-platform.h
224 %{_includedir}/sysprof-3/sysprof-proc-source.h
225 %{_includedir}/sysprof-3/sysprof-process-model.h
226 %{_includedir}/sysprof-3/sysprof-process-model-item.h
227 %{_includedir}/sysprof-3/sysprof-profile.h
228 %{_includedir}/sysprof-3/sysprof-profiler.h
229 %{_includedir}/sysprof-3/sysprof-proxy-source.h
230 %{_includedir}/sysprof-3/sysprof-selection.h
231 %{_includedir}/sysprof-3/sysprof-source.h
232 %{_includedir}/sysprof-3/sysprof-spawnable.h
233 %{_includedir}/sysprof-3/sysprof-symbol-resolver.h
234 %{_includedir}/sysprof-3/sysprof-symbols-source.h
235 %{_includedir}/sysprof-3/sysprof-tracefd-source.h
236 %{_includedir}/sysprof-3/sysprof-version.h
237 %{_includedir}/sysprof-3/sysprof-version-macros.h
238 %{_pkgconfigdir}/sysprof-3.pc
239 %{_pkgconfigdir}/sysprof-capture-3.pc
240 %{_datadir}/dbus-1/interfaces/org.gnome.Sysprof2.xml
241 %{_datadir}/dbus-1/interfaces/org.gnome.Sysprof3.Profiler.xml
242 %{_datadir}/dbus-1/interfaces/org.gnome.Sysprof3.Service.xml
243
244 %files ui -f %{name}-ui.lang
245 %defattr(644,root,root,755)
246 %attr(755,root,root) %{_bindir}/sysprof
247 %{_datadir}/glib-2.0/schemas/org.gnome.sysprof3.gschema.xml
248 %{_datadir}/metainfo/org.gnome.Sysprof3.appdata.xml
249 %{_datadir}/mime/packages/sysprof-mime.xml
250 %{_desktopdir}/org.gnome.Sysprof3.desktop
251 %{_iconsdir}/hicolor/scalable/actions/sysprof-trace-app.svg
252 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Sysprof.svg
253 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Sysprof-symbolic.svg
254
255 %files ui-libs
256 %defattr(644,root,root,755)
257 %attr(755,root,root) %{_libdir}/libsysprof-ui-3.so
258
259 %files ui-devel
260 %defattr(644,root,root,755)
261 %{_includedir}/sysprof-3/sysprof-display.h
262 %{_includedir}/sysprof-3/sysprof-notebook.h
263 %{_includedir}/sysprof-3/sysprof-page.h
264 %{_includedir}/sysprof-3/sysprof-process-model-row.h
265 %{_includedir}/sysprof-3/sysprof-ui.h
266 %{_includedir}/sysprof-3/sysprof-visualizer.h
267 %{_includedir}/sysprof-3/sysprof-visualizer-group.h
268 %{_includedir}/sysprof-3/sysprof-zoom-manager.h
269 %{_pkgconfigdir}/sysprof-ui-3.pc
This page took 0.110799 seconds and 2 git commands to generate.