]> git.pld-linux.org Git - packages/sysprof.git/blob - sysprof.spec
4cf39d015144822563de54ac9df67ffe02129ea7
[packages/sysprof.git] / sysprof.spec
1 #
2 # Conditional build:
3 %bcond_without  sysprofd        # daemon to run UI without root permissions
4 #
5 Summary:        Sampling CPU profiler for Linux
6 Summary(pl.UTF-8):      Próbkujący profiler procesora dla Linuksa
7 Name:           sysprof
8 Version:        3.36.0
9 Release:        1
10 License:        GPL v3+
11 Group:          Applications/System
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/sysprof/3.36/%{name}-%{version}.tar.xz
13 # Source0-md5:  3956e82b8744715006dde59e0ce8910b
14 Patch0:         %{name}-types.patch
15 URL:            http://sysprof.com/
16 # -std=gnu11 + C11 atomics
17 BuildRequires:  gcc >= 6:4.9
18 BuildRequires:  gdk-pixbuf2-devel >= 2.0
19 BuildRequires:  gettext-tools >= 0.19.6
20 BuildRequires:  glib2-devel >= 1:2.61.3
21 BuildRequires:  gobject-introspection-devel >= 1.42.0
22 BuildRequires:  gtk+3-devel >= 3.22
23 BuildRequires:  libdazzle-devel >= 3.30.0
24 BuildRequires:  libstdc++-devel >= 6:4.7
25 BuildRequires:  meson >= 0.50.0
26 BuildRequires:  ninja >= 1.5
27 BuildRequires:  pango-devel
28 BuildRequires:  pkgconfig >= 1:0.22
29 %{?with_sysprofd:BuildRequires: polkit-devel >= 0.114}
30 BuildRequires:  rpmbuild(macros) >= 1.736
31 %{?with_sysprofd:BuildRequires: systemd-devel >= 1:222}
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  vala
34 BuildRequires:  xz
35 BuildRequires:  yelp-tools
36 Requires:       %{name}-libs = %{version}-%{release}
37 %{?with_sysprofd:Requires:      polkit >= 0.114}
38 %{?with_sysprofd:Requires:      systemd-units >= 1:222}
39 Requires:       uname(release) >= 2.6.31
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Sysprof is a sampling CPU profiler for Linux that uses a kernel module
44 to profile the entire system, not just a single application. Sysprof
45 handles shared libraries and applications do not need to be
46 recompiled. In fact they don't even have to be restarted.
47
48 Just insert the kernel module and start sysprof.
49
50 %description -l pl.UTF-8
51 Sysprof to próbkujący profiler procesora dla Linuksa wykorzystujący
52 moduł jądra do profilowania całego systemu, nie tylko pojedynczej
53 aplikacji. Sysprof obsługuje biblioteki współdzielone, a aplikacje nie
54 wymagają rekompilacji. Właściwie nawet nie trzeba ich restartować.
55
56 Wystarczy załadować moduł jądra i uruchomić sysprof.
57
58 %package libs
59 Summary:        The sysprof profiler library
60 Summary(pl.UTF-8):      Biblioteka profilera sysprof
61 Group:          Libraries
62 Requires:       glib2 >= 1:2.61.3
63
64 %description libs
65 The sysprof profiler library.
66
67 %description libs -l pl.UTF-8
68 Biblioteka profilera sysprof.
69
70 %package devel
71 Summary:        Header files for sysprof library
72 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki sysprof
73 Group:          Development/Libraries
74 Requires:       %{name}-libs = %{version}-%{release}
75 Requires:       glib2-devel >= 1:2.61.3
76 Obsoletes:      sysprof-static < 3.28.0
77
78 %description devel
79 Header files for sysprof library.
80
81 %description devel -l pl.UTF-8
82 Pliki nagłówkowe biblioteki sysprof.
83
84 %package ui
85 Summary:        The sysprof graphical user interface
86 Summary(pl.UTF-8):      Graficzny interfejs użytkownika profilera sysprof
87 Group:          Applications/System
88 Requires(post,postun):  desktop-file-utils
89 Requires(post,postun):  glib2 >= 1:2.61.3
90 Requires(post,postun):  gtk-update-icon-cache
91 Requires:       %{name} = %{version}-%{release}
92 Requires:       %{name}-ui-libs = %{version}-%{release}
93 Requires:       hicolor-icon-theme
94 Requires:       shared-mime-info
95
96 %description ui
97 The sysprof graphical user interface.
98
99 %description ui -l pl.UTF-8
100 Graficzny interfejs użytkownika profilera sysprof.
101
102 %package ui-libs
103 Summary:        The sysprof library containing reusable GTK+ widgets
104 Summary(pl.UTF-8):      Biblioteka sysprofa zawierająca widgety GTK+ wielokrotnego użytku
105 Group:          X11/Libraries
106 Requires:       %{name}-libs = %{version}-%{release}
107 Requires:       gtk+3 >= 3.22
108 Requires:       libdazzle >= 3.30.0
109
110 %description ui-libs
111 The sysprof library containing reusable GTK+ widgets.
112
113 %description ui-libs -l pl.UTF-8
114 Biblioteka sysprofa zawierająca widgety GTK+ wielokrotnego użytku.
115
116 %package ui-devel
117 Summary:        Header files for sysprof-ui library
118 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki sysprof-ui
119 Group:          X11/Development/Libraries
120 Requires:       %{name}-devel = %{version}-%{release}
121 Requires:       %{name}-ui-libs = %{version}-%{release}
122 Requires:       gtk+3-devel >= 3.22
123 Obsoletes:      sysprof-ui-static < 3.28.0
124
125 %description ui-devel
126 Header files for sysprof-ui library.
127
128 %description ui-devel -l pl.UTF-8
129 Pliki nagłówkowe biblioteki sysprof-ui.
130
131 %prep
132 %setup -q
133 %patch0 -p1
134
135 %build
136 %meson build \
137         %{!?with_sysprofd:-Dwith_sysprofd=host}
138
139 %ninja_build -C build
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %ninja_install -C build
145
146 %find_lang %{name} -o %{name}-ui.lang --with-gnome --without-mo
147 %find_lang %{name}
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %if %{with sysprofd}
153 %post
154 %systemd_post sysprof2.service
155
156 %preun
157 %systemd_preun sysprof2.service
158
159 %postun
160 %systemd_reload
161 %endif
162
163 %post   libs -p /sbin/ldconfig
164 %postun libs -p /sbin/ldconfig
165
166 %post ui
167 %glib_compile_schemas
168 %update_icon_cache hicolor
169 %update_mime_database
170 %update_desktop_database
171
172 %postun ui
173 %glib_compile_schemas
174 %update_icon_cache hicolor
175 %update_mime_database
176 %update_desktop_database
177
178 %post   ui-libs -p /sbin/ldconfig
179 %postun ui-libs -p /sbin/ldconfig
180
181 %files -f %{name}.lang
182 %defattr(644,root,root,755)
183 %doc AUTHORS DESIGN.md NEWS README.md
184 %attr(755,root,root) %{_bindir}/sysprof-cli
185 %if %{with sysprofd}
186 %attr(755,root,root) %{_libexecdir}/sysprofd
187 %{systemdunitdir}/sysprof2.service
188 %{systemdunitdir}/sysprof3.service
189 %{_datadir}/dbus-1/system-services/org.gnome.Sysprof2.service
190 %{_datadir}/dbus-1/system-services/org.gnome.Sysprof3.service
191 %{_datadir}/dbus-1/system.d/org.gnome.Sysprof2.conf
192 %{_datadir}/dbus-1/system.d/org.gnome.Sysprof3.conf
193 %{_datadir}/polkit-1/actions/org.gnome.sysprof3.policy
194 %endif
195
196 %files libs
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_libdir}/libsysprof-3.so
199 %attr(755,root,root) %{_libdir}/libsysprof-memory-3.so
200
201 %files devel
202 %defattr(644,root,root,755)
203 %{_libdir}/libsysprof-capture-3.a
204 %dir %{_includedir}/sysprof-3
205 %{_includedir}/sysprof-3/sysprof.h
206 %{_includedir}/sysprof-3/sysprof-address.h
207 %{_includedir}/sysprof-3/sysprof-battery-source.h
208 %{_includedir}/sysprof-3/sysprof-callgraph-profile.h
209 %{_includedir}/sysprof-3/sysprof-capture*.h
210 %{_includedir}/sysprof-3/sysprof-check.h
211 %{_includedir}/sysprof-3/sysprof-clock.h
212 %{_includedir}/sysprof-3/sysprof-collector.h
213 %{_includedir}/sysprof-3/sysprof-control-source.h
214 %{_includedir}/sysprof-3/sysprof-diskstat-source.h
215 %{_includedir}/sysprof-3/sysprof-elf-symbol-resolver.h
216 %{_includedir}/sysprof-3/sysprof-gjs-source.h
217 %{_includedir}/sysprof-3/sysprof-governor-source.h
218 %{_includedir}/sysprof-3/sysprof-hostinfo-source.h
219 %{_includedir}/sysprof-3/sysprof-jitmap-symbol-resolver.h
220 %{_includedir}/sysprof-3/sysprof-kernel-symbol.h
221 %{_includedir}/sysprof-3/sysprof-kernel-symbol-resolver.h
222 %{_includedir}/sysprof-3/sysprof-local-profiler.h
223 %{_includedir}/sysprof-3/sysprof-memory-source.h
224 %{_includedir}/sysprof-3/sysprof-memprof-profile.h
225 %{_includedir}/sysprof-3/sysprof-memprof-source.h
226 %{_includedir}/sysprof-3/sysprof-model-filter.h
227 %{_includedir}/sysprof-3/sysprof-netdev-source.h
228 %{_includedir}/sysprof-3/sysprof-perf-counter.h
229 %{_includedir}/sysprof-3/sysprof-perf-source.h
230 %{_includedir}/sysprof-3/sysprof-platform.h
231 %{_includedir}/sysprof-3/sysprof-proc-source.h
232 %{_includedir}/sysprof-3/sysprof-process-model.h
233 %{_includedir}/sysprof-3/sysprof-process-model-item.h
234 %{_includedir}/sysprof-3/sysprof-profile.h
235 %{_includedir}/sysprof-3/sysprof-profiler.h
236 %{_includedir}/sysprof-3/sysprof-proxy-source.h
237 %{_includedir}/sysprof-3/sysprof-selection.h
238 %{_includedir}/sysprof-3/sysprof-source.h
239 %{_includedir}/sysprof-3/sysprof-spawnable.h
240 %{_includedir}/sysprof-3/sysprof-symbol-resolver.h
241 %{_includedir}/sysprof-3/sysprof-symbols-source.h
242 %{_includedir}/sysprof-3/sysprof-tracefd-source.h
243 %{_includedir}/sysprof-3/sysprof-version.h
244 %{_includedir}/sysprof-3/sysprof-version-macros.h
245 %{_pkgconfigdir}/sysprof-3.pc
246 %{_pkgconfigdir}/sysprof-capture-3.pc
247 %{_datadir}/dbus-1/interfaces/org.gnome.Sysprof2.xml
248 %{_datadir}/dbus-1/interfaces/org.gnome.Sysprof3.Profiler.xml
249 %{_datadir}/dbus-1/interfaces/org.gnome.Sysprof3.Service.xml
250
251 %files ui -f %{name}-ui.lang
252 %defattr(644,root,root,755)
253 %attr(755,root,root) %{_bindir}/sysprof
254 %{_datadir}/glib-2.0/schemas/org.gnome.sysprof3.gschema.xml
255 %{_datadir}/metainfo/org.gnome.Sysprof3.appdata.xml
256 %{_datadir}/mime/packages/sysprof-mime.xml
257 %{_desktopdir}/org.gnome.Sysprof3.desktop
258 %{_iconsdir}/hicolor/scalable/actions/sysprof-*.svg
259 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Sysprof.svg
260 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Sysprof-symbolic.svg
261
262 %files ui-libs
263 %defattr(644,root,root,755)
264 %attr(755,root,root) %{_libdir}/libsysprof-ui-3.so
265
266 %files ui-devel
267 %defattr(644,root,root,755)
268 %{_includedir}/sysprof-3/sysprof-display.h
269 %{_includedir}/sysprof-3/sysprof-notebook.h
270 %{_includedir}/sysprof-3/sysprof-page.h
271 %{_includedir}/sysprof-3/sysprof-process-model-row.h
272 %{_includedir}/sysprof-3/sysprof-ui.h
273 %{_includedir}/sysprof-3/sysprof-visualizer.h
274 %{_includedir}/sysprof-3/sysprof-visualizer-group.h
275 %{_includedir}/sysprof-3/sysprof-zoom-manager.h
276 %{_pkgconfigdir}/sysprof-ui-3.pc
This page took 0.072325 seconds and 2 git commands to generate.