]> git.pld-linux.org Git - packages/syslog-ng.git/blobdiff - syslog-ng.spec
- updated to 2.0.3
[packages/syslog-ng.git] / syslog-ng.spec
index 382f24ffcf650ee029a60927d23e1d974c603ffb..c037aace0c29f8d9fbb354f7a8bd8cfb933656b4 100644 (file)
@@ -1,33 +1,53 @@
+#
+# Conditional build:
+%bcond_with    dynamic         # link dynamically with glib and eventlog
+#
+%define                mainver         2.0
+%define                minver          3
+
 Summary:       Syslog-ng - new generation of the system logger
-Summary(pl):   Syslog-ng - zamiennik syskloga
-Summary(pt_BR):        Daemon de log nova geração
+Summary(pl.UTF-8):     Syslog-ng - zamiennik syskloga
+Summary(pt_BR.UTF-8):  Daemon de log nova geração
 Name:          syslog-ng
-Version:       1.4.15
-Release:       2
-License:       GPL
+Version:       %{mainver}.%{minver}
+Release:       1
+License:       GPL v2
 Group:         Daemons
-Source0:       http://www.balabit.hu/downloads/syslog-ng/1.4/%{name}-%{version}.tar.gz
+Source0:       http://www.balabit.com/downloads/syslog-ng/%{mainver}/src/%{name}-%{version}.tar.gz
+# Source0-md5: 01cafcfebf1c05f9253c3f3c9a987434
 Source1:       %{name}.init
 Source2:       %{name}.conf
 Source3:       %{name}.logrotate
-Patch0:                %{name}-autoconf.patch
-Patch1:                %{name}-notestlibolver.patch
-URL:           http://www.balabit.hu/products/syslog-ng/
-BuildRequires: autoconf
+Patch0:                %{name}-link.patch
+URL:           http://www.balabit.com/products/syslog_ng/
+BuildRequires: autoconf >= 2.53
 BuildRequires: automake
-BuildRequires: libol-static >= 0.2.21
+BuildRequires: bison
 BuildRequires: flex
-Prereq:                rc-scripts >= 0.2.0
-Prereq:                /sbin/chkconfig
+BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.268
+%if %{with dynamic}
+BuildRequires: eventlog-devel >= 0.2
+BuildRequires: glib2-devel >= 1:2.2.0
+BuildRequires: libnet-devel >= 1:1.1.2.1-3
+BuildRequires: libwrap-devel
+%else
+BuildRequires: eventlog-static >= 0.2
+BuildRequires: glib2-static >= 1:2.2.0
+BuildRequires: libnet-static >= 1:1.1.2.1-3
+BuildRequires: libwrap-static
+%endif
+Requires(post):        fileutils
+Requires(post,preun):  /sbin/chkconfig
 Requires:      logrotate
-Requires:      fileutils
 Requires:      psmisc >= 20.1
+Requires:      rc-scripts >= 0.2.0
 Provides:      syslogdaemon
+Obsoletes:     klogd
+Obsoletes:     msyslog
 Obsoletes:     syslog
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _sysconfdir     /etc
-
 %description
 syslog-ng is a syslogd replacement for unix and unix-like systems. It
 has been tested on Solaris, BSDi and Linux, and were found to run
@@ -39,50 +59,58 @@ simple file to a network connection. syslog-ng supports TCP
 logforwarding, together with hashing to prevent unauthorized
 modification on the line.
 
-%description -l pl
-Syslog-ng jest zamiennikiem dla standartowo u¿ywanych programów typu
-sysklog. Dzia³a w systemie SunOS, BSD, Linux. Daje znacznie wiêksze
-mo¿liwo¶ci logowania i kontrolowania zbieranych informacji.
+%description -l pl.UTF-8
+Syslog-ng jest zamiennikiem dla standardowo używanych programów typu
+sysklog. Działa w systemie SunOS, BSD, Linux. Daje znacznie większe
+możliwości logowania i kontrolowania zbieranych informacji.
 
-%description -l pt_BR
-Syslog-ng é um substituto para o syslog tradicional, mas com diversas
+%description -l pt_BR.UTF-8
+Syslog-ng é um substituto para o syslog tradicional, mas com diversas
 melhorias, como, por exemplo, a habilidade de filtrar mensagens de log
-por seu conteúdo (usando expressões regulares) e não apenas pelo par
+por seu conteúdo (usando expressões regulares) e não apenas pelo par
 facility/prioridade como o syslog original.
 
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p0
+
+%{__tar} xzf doc/reference/syslog-ng.html.tar.gz
 
 %build
-rm -f missing
-aclocal
-autoconf
-automake -a -c -f
-%configure
+%{__aclocal}
+%{__autoconf}
+%{__automake}
+%configure \
+       --sysconfdir=%{_sysconfdir}/syslog-ng \
+%if %{with dynamic}
+       --enable-dynamic-linking
+%endif
+
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_sysconfdir}/{syslog-ng,logrotate.d}} \
-       $RPM_BUILD_ROOT/var/log/{archiv,}/{news,mail}
+install -d $RPM_BUILD_ROOT{/etc/{sysconfig,logrotate.d,rc.d/init.d},%{_sysconfdir}/syslog-ng} \
+       $RPM_BUILD_ROOT/var/log
 
-%{__make} DESTDIR=$RPM_BUILD_ROOT install
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/syslog-ng
 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/syslog-ng/syslog-ng.conf
-install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/syslog-ng
-
-gzip -9nf doc/syslog-ng.conf.{demo,sample} doc/sgml/syslog-ng.txt \
+install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/syslog-ng
 
-touch $RPM_BUILD_ROOT/var/log/syslog
+for n in daemon debug iptables kernel lpr maillog messages secure spooler syslog user xferlog
+do
+       > $RPM_BUILD_ROOT/var/log/$n
+done
+touch $RPM_BUILD_ROOT/etc/sysconfig/%{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-for n in /var/log/{kernel,messages,secure,maillog,spooler,debug,cron,syslog,daemon,lpr,user,ppp,mail/{info,warn,err}}
+for n in /var/log/{daemon,debug,iptables,kernel,lpr,maillog,messages,secure,spooler,syslog,user,xferlog}
 do
        [ -f $n ] && continue
        touch $n
@@ -90,34 +118,24 @@ do
 done
 
 /sbin/chkconfig --add syslog-ng
-if [ -f /var/lock/subsys/syslog-ng ]; then
-       /etc/rc.d/init.d/syslog-ng restart &>/dev/null
-else
-       echo "Run \"/etc/rc.d/init.d/syslog-ng start\" to start syslog-ng daemon."
-fi
-if [ -f /var/lock/subsys/klogd ]; then
-       /etc/rc.d/init.d/klogd restart 1>&2
-fi
+%service syslog-ng restart "syslog-ng daemon"
 
 %preun
 if [ "$1" = "0" ]; then
-       if [ -f /var/lock/subsys/syslog-ng ]; then
-               /etc/rc.d/init.d/syslog-ng stop >&2
-       fi
+       %service syslog-ng stop
        /sbin/chkconfig --del syslog-ng
 fi
 
 %files
 %defattr(644,root,root,755)
-%doc doc/*.gz doc/sgml/syslog-ng.txt*
+%doc doc/examples/syslog-ng.conf.sample doc/reference/syslog-ng.txt* contrib/syslog-ng.conf.{doc,RedHat}
+%doc syslog-ng.html/*
+%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
 %attr(750,root,root) %dir %{_sysconfdir}/syslog-ng
-%attr(640,root,root) %config %verify(not size mtime md5) %{_sysconfdir}/syslog-ng/syslog-ng.conf
-%attr(640,root,root) %config %verify(not size mtime md5) %{_sysconfdir}/logrotate.d/syslog-ng
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/syslog-ng/syslog-ng.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/syslog-ng
 %attr(754,root,root) /etc/rc.d/init.d/syslog-ng
 %attr(755,root,root) %{_sbindir}/syslog-ng
 %{_mandir}/man[58]/*
 
-%attr(640,root,root) %ghost /var/log/syslog
-%attr(750,root,root) %ghost /var/log/news
-%attr(750,root,root) %dir /var/log/mail
-%attr(750,root,root) %dir /var/log/archiv/mail
+%attr(640,root,root) %ghost /var/log/*
This page took 0.101581 seconds and 4 git commands to generate.