patch to use maintained ayatana indicators; rel 2 master auto/th/synapse-0.2.99.4-2
authorJan Palus <atler@pld-linux.org>
Wed, 24 Nov 2021 15:58:08 +0000 (16:58 +0100)
committerJan Palus <atler@pld-linux.org>
Wed, 24 Nov 2021 15:58:08 +0000 (16:58 +0100)
ayatana-indicator.patch [new file with mode: 0644]
synapse.spec

diff --git a/ayatana-indicator.patch b/ayatana-indicator.patch
new file mode 100644 (file)
index 0000000..ee11bef
--- /dev/null
@@ -0,0 +1,25 @@
+diff --color -ur synapse-0.2.99.4.orig/configure.ac synapse-0.2.99.4/configure.ac
+--- synapse-0.2.99.4.orig/configure.ac 2018-04-08 20:52:10.000000000 +0200
++++ synapse-0.2.99.4/configure.ac      2021-11-24 16:47:10.073022755 +0100
+@@ -110,16 +110,16 @@
+ AM_CONDITIONAL(HAVE_ZEITGEIST, test "x$enable_zeitgeist" = "xyes")
+ if test "x$enable_indicator" = "xauto" ; then
+-      PKG_CHECK_EXISTS([appindicator3-0.1],
++      PKG_CHECK_EXISTS([ayatana-appindicator3-0.1],
+                        enable_indicator="yes",
+                        enable_indicator="no")
+ fi
+ if test "x$enable_indicator" = "xyes" ; then
+-      PKG_CHECK_EXISTS([appindicator3-0.1],,
+-                       AC_MSG_ERROR([appindicator3-0.1 is not installed]))
+-      PKG_CHECK_MODULES(APP_INDICATOR, appindicator3-0.1)
+-      APP_INDICATOR_VALAFLAGS=" --pkg appindicator3-0.1 -D HAVE_INDICATOR"
++      PKG_CHECK_EXISTS([ayatana-appindicator3-0.1],,
++                       AC_MSG_ERROR([ayatana-appindicator3-0.1 is not installed]))
++      PKG_CHECK_MODULES(APP_INDICATOR, ayatana-appindicator3-0.1)
++      APP_INDICATOR_VALAFLAGS=" --pkg ayatana-appindicator3-0.1 -D HAVE_INDICATOR"
+       AC_SUBST(APP_INDICATOR_VALAFLAGS)
+       AC_DEFINE(HAVE_INDICATOR, 1, [Have AppIndicator])
+ fi
index 103eb5148f1cfd64d129bf3b9fa3e8f40741c17d..b191098a28392d4bc022aaabcfc5b12f5dbd6112 100644 (file)
@@ -6,12 +6,13 @@
 Summary:       Application launcher
 Name:          synapse
 Version:       0.2.99.4
-Release:       1
+Release:       2
 License:       GPL v3+
 Group:         X11/Applications
 Source0:       https://launchpad.net/synapse-project/0.3/%{version}/+download/%{name}-%{version}.tar.xz
 # Source0-md5: 38105c87200d82cf2066fb70cc9af59f
 Patch0:                %{name}-mate.patch
+Patch1:                ayatana-indicator.patch
 URL:           https://launchpad.net/synapse-project
 BuildRequires: autoconf >= 2.65
 BuildRequires: automake >= 1:1.11
@@ -20,7 +21,7 @@ BuildRequires:        glib2-devel >= 1:2.28.0
 BuildRequires: gtk+3-devel
 BuildRequires: json-glib-devel >= 0.10.0
 BuildRequires: keybinder3-devel
-%{?with_appindicator:BuildRequires:    libappindicator-gtk3-devel}
+%{?with_appindicator:BuildRequires:    libayatana-appindicator-gtk3-devel}
 BuildRequires: libgee-devel >= 0.5.2
 BuildRequires: libnotify-devel
 BuildRequires: libtool
@@ -29,7 +30,7 @@ BuildRequires:        rest-devel >= 0.7
 BuildRequires: rpmbuild(macros) >= 1.527
 BuildRequires: tar >= 1:1.22
 BuildRequires: vala >= 0.16.0
-%{?with_appindicator:BuildRequires:    vala-libappindicator-gtk3}
+%{?with_appindicator:BuildRequires:    vala-libayatana-appindicator-gtk3}
 BuildRequires: vala-libgee >= 0.6.4
 %if %{with zeitgeist}
 BuildRequires: vala-zeitgeist >= 0.9.14
@@ -53,6 +54,7 @@ files by making use of the Zeitgeist engine.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__gettextize}
This page took 0.096923 seconds and 4 git commands to generate.