]> git.pld-linux.org Git - packages/synapse.git/commitdiff
upstream revisions 652,653 to fix type compatibility; rel 2 auto/th/synapse-0.2.99.2-2
authorJan Palus <atler@pld-linux.org>
Mon, 15 May 2017 21:54:43 +0000 (23:54 +0200)
committerJan Palus <atler@pld-linux.org>
Mon, 15 May 2017 21:54:43 +0000 (23:54 +0200)
synapse-types.patch [new file with mode: 0644]
synapse.spec

diff --git a/synapse-types.patch b/synapse-types.patch
new file mode 100644 (file)
index 0000000..0df874d
--- /dev/null
@@ -0,0 +1,41 @@
+=== modified file 'src/plugins/desktop-file-plugin.vala'
+--- src/plugins/desktop-file-plugin.vala       2015-11-30 22:01:12 +0000
++++ src/plugins/desktop-file-plugin.vala       2016-09-29 17:57:47 +0000
+@@ -83,8 +83,8 @@
+     construct
+     {
+       desktop_files = new Gee.ArrayList<DesktopFileMatch> ();
+-      mimetype_map = new Gee.HashMap<string, OpenWithAction> ();
+-      actions_map = new Gee.HashMap<string, OpenAppAction> ();
++      mimetype_map = new Gee.HashMap<string, Gee.List<OpenWithAction>> ();
++      actions_map = new Gee.HashMap<string, Gee.List<OpenAppAction>> ();
+       var dfs = DesktopFileService.get_default ();
+       dfs.reload_started.connect (() => {
+
+=== modified file 'src/plugins/hybrid-search-plugin.vala'
+--- src/plugins/hybrid-search-plugin.vala      2014-07-10 11:39:28 +0000
++++ src/plugins/hybrid-search-plugin.vala      2016-09-29 17:57:47 +0000
+@@ -74,7 +74,7 @@
+     construct
+     {
+       directory_hits = new Gee.HashMap<string, int> ();
+-      directory_contents = new Gee.HashMap<string, Utils.FileInfo?> ();
++      directory_contents = new Gee.HashMap<string, DirectoryInfo> ();
+       analyze_recent_documents.begin ();
+     }
+
+=== modified file 'src/core/result-set.vala'
+--- src/core/result-set.vala   2014-07-10 14:05:57 +0000
++++ src/core/result-set.vala   2016-10-06 09:34:42 +0000
+@@ -57,7 +57,7 @@
+       owned get { return matches.entries; }
+     }
+-    public Gee.Iterator<Gee.Map.Entry <Match, int>?> iterator ()
++    public Gee.Iterator<Gee.Map.Entry <Match, int>> iterator ()
+     {
+       return matches.iterator ();
+     }
+
index 3dceb106676e80b53988c52877b965164ea0601b..e89b4ebecd6a33fbec077b0a567f62f90d04c376 100644 (file)
@@ -1,12 +1,13 @@
 Summary:       Application launcher
 Name:          synapse
 Version:       0.2.99.2
-Release:       1
+Release:       2
 License:       GPL v3+
 Group:         X11/Applications
 Source0:       https://launchpad.net/synapse-project/0.3/%{version}/+download/%{name}-%{version}.tar.xz
 # Source0-md5: 0d5559793377cee3b292db95f7ebcc4c
 Patch0:                %{name}-mate.patch
+Patch1:                %{name}-types.patch
 URL:           http://synapse.zeitgeist-project.com/
 BuildRequires: autoconf >= 2.65
 BuildRequires: automake >= 1:1.11
@@ -36,6 +37,7 @@ files by making use of the Zeitgeist engine.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p0
 
 %build
 %{__intltoolize}
This page took 0.082601 seconds and 4 git commands to generate.