]> git.pld-linux.org Git - packages/synapse.git/blob - synapse.spec
patch to use maintained ayatana indicators; rel 2
[packages/synapse.git] / synapse.spec
1 #
2 # Conditional build:
3 %bcond_without  appindicator    # build without appindicator support
4 %bcond_with     zeitgeist       # build with zeitgeist support (causes stability issues)
5
6 Summary:        Application launcher
7 Name:           synapse
8 Version:        0.2.99.4
9 Release:        2
10 License:        GPL v3+
11 Group:          X11/Applications
12 Source0:        https://launchpad.net/synapse-project/0.3/%{version}/+download/%{name}-%{version}.tar.xz
13 # Source0-md5:  38105c87200d82cf2066fb70cc9af59f
14 Patch0:         %{name}-mate.patch
15 Patch1:         ayatana-indicator.patch
16 URL:            https://launchpad.net/synapse-project
17 BuildRequires:  autoconf >= 2.65
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  gettext-tools >= 0.19.6
20 BuildRequires:  glib2-devel >= 1:2.28.0
21 BuildRequires:  gtk+3-devel
22 BuildRequires:  json-glib-devel >= 0.10.0
23 BuildRequires:  keybinder3-devel
24 %{?with_appindicator:BuildRequires:     libayatana-appindicator-gtk3-devel}
25 BuildRequires:  libgee-devel >= 0.5.2
26 BuildRequires:  libnotify-devel
27 BuildRequires:  libtool
28 BuildRequires:  pkgconfig >= 1:0.21
29 BuildRequires:  rest-devel >= 0.7
30 BuildRequires:  rpmbuild(macros) >= 1.527
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  vala >= 0.16.0
33 %{?with_appindicator:BuildRequires:     vala-libayatana-appindicator-gtk3}
34 BuildRequires:  vala-libgee >= 0.6.4
35 %if %{with zeitgeist}
36 BuildRequires:  vala-zeitgeist >= 0.9.14
37 BuildRequires:  xz
38 BuildRequires:  zeitgeist-devel >= 0.9.14
39 %endif
40 Requires:       glib2 >= 1:2.28.0
41 Requires:       json-glib >= 0.10.0
42 Requires:       libgee >= 0.5.2
43 Requires:       rest >= 0.7
44 %if %{with zeitgeist}
45 Requires:       zeitgeist-libs >= 0.9.14
46 %endif
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Synapse is a semantic launcher written in Vala that you can use to
51 start applications as well as find and access relevant documents and
52 files by making use of the Zeitgeist engine.
53
54 %prep
55 %setup -q
56 %patch0 -p1
57 %patch1 -p1
58
59 %build
60 %{__gettextize}
61 %{__libtoolize}
62 %{__aclocal}
63 %{__autoconf}
64 %{__autoheader}
65 %{__automake}
66 %configure \
67         --disable-silent-rules \
68         --enable-librest=yes \
69         %{__enable_disable appindicator indicator} \
70         %{__enable_disable zeitgeist}
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %find_lang %{name}
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post
85 %update_icon_cache hicolor
86 %update_desktop_database
87
88 %postun
89 %update_icon_cache hicolor
90 %update_desktop_database_postun
91
92 %files -f %{name}.lang
93 %defattr(644,root,root,755)
94 %attr(755,root,root) %{_bindir}/synapse
95 %{_iconsdir}/hicolor/scalable/apps/*.svg
96 %{_desktopdir}/*.desktop
97 %{_mandir}/man1/synapse.*
This page took 0.060841 seconds and 3 git commands to generate.