]> git.pld-linux.org Git - packages/synapse.git/blob - synapse.spec
ae6d323702cbcae7bb4a4027578e60f4904e6217
[packages/synapse.git] / synapse.spec
1 #
2 # Conditional build:
3 %bcond_with     zeitgeist       # build with zeitgeist support (causes stability issues)
4
5 Summary:        Application launcher
6 Name:           synapse
7 Version:        0.2.99.4
8 Release:        1
9 License:        GPL v3+
10 Group:          X11/Applications
11 Source0:        https://launchpad.net/synapse-project/0.3/%{version}/+download/%{name}-%{version}.tar.xz
12 # Source0-md5:  38105c87200d82cf2066fb70cc9af59f
13 Patch0:         %{name}-mate.patch
14 URL:            https://launchpad.net/synapse-project
15 BuildRequires:  autoconf >= 2.65
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  gettext-tools >= 0.19.6
18 BuildRequires:  glib2-devel >= 1:2.28.0
19 BuildRequires:  gtk+3-devel
20 BuildRequires:  json-glib-devel >= 0.10.0
21 BuildRequires:  keybinder3-devel
22 BuildRequires:  libappindicator-gtk3-devel
23 BuildRequires:  libgee-devel >= 0.5.2
24 BuildRequires:  libnotify-devel
25 BuildRequires:  libtool
26 BuildRequires:  pkgconfig >= 1:0.21
27 BuildRequires:  rest-devel >= 0.7
28 BuildRequires:  vala >= 0.16.0
29 BuildRequires:  vala-libappindicator-gtk3
30 BuildRequires:  vala-libgee >= 0.6.4
31 %if %{with zeitgeist}
32 BuildRequires:  vala-zeitgeist >= 0.9.14
33 BuildRequires:  zeitgeist-devel >= 0.9.14
34 %endif
35 Requires:       glib2 >= 1:2.28.0
36 Requires:       json-glib >= 0.10.0
37 Requires:       libgee >= 0.5.2
38 Requires:       rest >= 0.7
39 %if %{with zeitgeist}
40 Requires:       zeitgeist-libs >= 0.9.14
41 %endif
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Synapse is a semantic launcher written in Vala that you can use to
46 start applications as well as find and access relevant documents and
47 files by making use of the Zeitgeist engine.
48
49 %prep
50 %setup -q
51 %patch0 -p1
52
53 %build
54 %{__gettextize}
55 %{__libtoolize}
56 %{__aclocal}
57 %{__autoconf}
58 %{__autoheader}
59 %{__automake}
60 %configure \
61         --disable-silent-rules \
62         --enable-librest=yes \
63         %{__enable_disable zeitgeist}
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %find_lang %{name}
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post
78 %update_icon_cache hicolor
79 %update_desktop_database
80
81 %postun
82 %update_icon_cache hicolor
83 %update_desktop_database_postun
84
85 %files -f %{name}.lang
86 %defattr(644,root,root,755)
87 %attr(755,root,root) %{_bindir}/synapse
88 %{_iconsdir}/hicolor/scalable/apps/*.svg
89 %{_desktopdir}/*.desktop
90 %{_mandir}/man1/synapse.*
This page took 0.023076 seconds and 2 git commands to generate.