]> git.pld-linux.org Git - packages/synapse.git/blob - synapse.spec
79c9d8d3ea35e6718b1cc0e701f089bbf0176bbb
[packages/synapse.git] / synapse.spec
1 #
2 # Conditional build:
3 %bcond_with     zeitgeist       # build with zeitgeist support (causes stability issues)
4
5 Summary:        Application launcher
6 Name:           synapse
7 Version:        0.2.99.3
8 Release:        1
9 License:        GPL v3+
10 Group:          X11/Applications
11 Source0:        https://launchpad.net/synapse-project/0.3/%{version}/+download/%{name}-%{version}.tar.xz
12 # Source0-md5:  7e24bc78ebe47b4d055b22eead40a6c5
13 Patch0:         %{name}-mate.patch
14 URL:            https://launchpad.net/synapse-project
15 BuildRequires:  autoconf >= 2.65
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  gettext-tools >= 0.19.6
18 BuildRequires:  glib2-devel >= 1:2.28.0
19 BuildRequires:  gtk+3-devel
20 BuildRequires:  json-glib-devel >= 0.10.0
21 BuildRequires:  keybinder3-devel
22 BuildRequires:  libappindicator-gtk3-devel
23 BuildRequires:  libgee-devel >= 0.5.2
24 BuildRequires:  libnotify-devel
25 BuildRequires:  libtool
26 BuildRequires:  pkgconfig >= 1:0.21
27 BuildRequires:  rest-devel >= 0.7
28 BuildRequires:  vala >= 0.16.0
29 BuildRequires:  vala-libappindicator-gtk3
30 BuildRequires:  vala-libgee >= 0.6.4
31 %if %{with zeitgeist}
32 BuildRequires:  vala-zeitgeist >= 0.9.14
33 BuildRequires:  zeitgeist-devel >= 0.9.14
34 %endif
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Synapse is a semantic launcher written in Vala that you can use to
39 start applications as well as find and access relevant documents and
40 files by making use of the Zeitgeist engine.
41
42 %prep
43 %setup -q
44 %patch0 -p1
45
46 %build
47 %{__gettextize}
48 %{__libtoolize}
49 %{__aclocal}
50 %{__autoconf}
51 %{__autoheader}
52 %{__automake}
53 %configure \
54         --disable-silent-rules \
55         --enable-librest=yes \
56         %{__enable_disable zeitgeist}
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %find_lang %{name}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 %update_icon_cache hicolor
72 %update_desktop_database
73
74 %postun
75 %update_icon_cache hicolor
76 %update_desktop_database_postun
77
78 %files -f %{name}.lang
79 %defattr(644,root,root,755)
80 %attr(755,root,root) %{_bindir}/synapse
81 %{_iconsdir}/hicolor/scalable/apps/*.svg
82 %{_desktopdir}/*.desktop
83 %{_mandir}/man1/synapse.*
This page took 0.058052 seconds and 2 git commands to generate.