]> git.pld-linux.org Git - packages/synapse.git/blob - synapse.spec
6656478ed4830d6c27a794a472db7d60442e0e9b
[packages/synapse.git] / synapse.spec
1 #
2 # Conditional build:
3 %bcond_without  appindicator    # build without appindicator support
4 %bcond_with     zeitgeist       # build with zeitgeist support (causes stability issues)
5
6 Summary:        Application launcher
7 Name:           synapse
8 Version:        0.2.99.4
9 Release:        1
10 License:        GPL v3+
11 Group:          X11/Applications
12 Source0:        https://launchpad.net/synapse-project/0.3/%{version}/+download/%{name}-%{version}.tar.xz
13 # Source0-md5:  38105c87200d82cf2066fb70cc9af59f
14 Patch0:         %{name}-mate.patch
15 URL:            https://launchpad.net/synapse-project
16 BuildRequires:  autoconf >= 2.65
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  gettext-tools >= 0.19.6
19 BuildRequires:  glib2-devel >= 1:2.28.0
20 BuildRequires:  gtk+3-devel
21 BuildRequires:  json-glib-devel >= 0.10.0
22 BuildRequires:  keybinder3-devel
23 %{?with_appindicator:BuildRequires:     libappindicator-gtk3-devel}
24 BuildRequires:  libgee-devel >= 0.5.2
25 BuildRequires:  libnotify-devel
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig >= 1:0.21
28 BuildRequires:  rest-devel >= 0.7
29 BuildRequires:  vala >= 0.16.0
30 %{?with_appindicator:BuildRequires:     vala-libappindicator-gtk3}
31 BuildRequires:  vala-libgee >= 0.6.4
32 %if %{with zeitgeist}
33 BuildRequires:  vala-zeitgeist >= 0.9.14
34 BuildRequires:  zeitgeist-devel >= 0.9.14
35 %endif
36 Requires:       glib2 >= 1:2.28.0
37 Requires:       json-glib >= 0.10.0
38 Requires:       libgee >= 0.5.2
39 Requires:       rest >= 0.7
40 %if %{with zeitgeist}
41 Requires:       zeitgeist-libs >= 0.9.14
42 %endif
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Synapse is a semantic launcher written in Vala that you can use to
47 start applications as well as find and access relevant documents and
48 files by making use of the Zeitgeist engine.
49
50 %prep
51 %setup -q
52 %patch0 -p1
53
54 %build
55 %{__gettextize}
56 %{__libtoolize}
57 %{__aclocal}
58 %{__autoconf}
59 %{__autoheader}
60 %{__automake}
61 %configure \
62         --disable-silent-rules \
63         --enable-librest=yes \
64         %{__enable_disable appindicator indicator} \
65         %{__enable_disable zeitgeist}
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %find_lang %{name}
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post
80 %update_icon_cache hicolor
81 %update_desktop_database
82
83 %postun
84 %update_icon_cache hicolor
85 %update_desktop_database_postun
86
87 %files -f %{name}.lang
88 %defattr(644,root,root,755)
89 %attr(755,root,root) %{_bindir}/synapse
90 %{_iconsdir}/hicolor/scalable/apps/*.svg
91 %{_desktopdir}/*.desktop
92 %{_mandir}/man1/synapse.*
This page took 0.044734 seconds and 2 git commands to generate.