]> git.pld-linux.org Git - packages/synapse.git/blob - synapse.spec
103eb5148f1cfd64d129bf3b9fa3e8f40741c17d
[packages/synapse.git] / synapse.spec
1 #
2 # Conditional build:
3 %bcond_without  appindicator    # build without appindicator support
4 %bcond_with     zeitgeist       # build with zeitgeist support (causes stability issues)
5
6 Summary:        Application launcher
7 Name:           synapse
8 Version:        0.2.99.4
9 Release:        1
10 License:        GPL v3+
11 Group:          X11/Applications
12 Source0:        https://launchpad.net/synapse-project/0.3/%{version}/+download/%{name}-%{version}.tar.xz
13 # Source0-md5:  38105c87200d82cf2066fb70cc9af59f
14 Patch0:         %{name}-mate.patch
15 URL:            https://launchpad.net/synapse-project
16 BuildRequires:  autoconf >= 2.65
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  gettext-tools >= 0.19.6
19 BuildRequires:  glib2-devel >= 1:2.28.0
20 BuildRequires:  gtk+3-devel
21 BuildRequires:  json-glib-devel >= 0.10.0
22 BuildRequires:  keybinder3-devel
23 %{?with_appindicator:BuildRequires:     libappindicator-gtk3-devel}
24 BuildRequires:  libgee-devel >= 0.5.2
25 BuildRequires:  libnotify-devel
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig >= 1:0.21
28 BuildRequires:  rest-devel >= 0.7
29 BuildRequires:  rpmbuild(macros) >= 1.527
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  vala >= 0.16.0
32 %{?with_appindicator:BuildRequires:     vala-libappindicator-gtk3}
33 BuildRequires:  vala-libgee >= 0.6.4
34 %if %{with zeitgeist}
35 BuildRequires:  vala-zeitgeist >= 0.9.14
36 BuildRequires:  xz
37 BuildRequires:  zeitgeist-devel >= 0.9.14
38 %endif
39 Requires:       glib2 >= 1:2.28.0
40 Requires:       json-glib >= 0.10.0
41 Requires:       libgee >= 0.5.2
42 Requires:       rest >= 0.7
43 %if %{with zeitgeist}
44 Requires:       zeitgeist-libs >= 0.9.14
45 %endif
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Synapse is a semantic launcher written in Vala that you can use to
50 start applications as well as find and access relevant documents and
51 files by making use of the Zeitgeist engine.
52
53 %prep
54 %setup -q
55 %patch0 -p1
56
57 %build
58 %{__gettextize}
59 %{__libtoolize}
60 %{__aclocal}
61 %{__autoconf}
62 %{__autoheader}
63 %{__automake}
64 %configure \
65         --disable-silent-rules \
66         --enable-librest=yes \
67         %{__enable_disable appindicator indicator} \
68         %{__enable_disable zeitgeist}
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %find_lang %{name}
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post
83 %update_icon_cache hicolor
84 %update_desktop_database
85
86 %postun
87 %update_icon_cache hicolor
88 %update_desktop_database_postun
89
90 %files -f %{name}.lang
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_bindir}/synapse
93 %{_iconsdir}/hicolor/scalable/apps/*.svg
94 %{_desktopdir}/*.desktop
95 %{_mandir}/man1/synapse.*
This page took 0.030514 seconds and 2 git commands to generate.