]> git.pld-linux.org Git - packages/sword.git/blobdiff - sword.spec
- release 4 (by relup.sh)
[packages/sword.git] / sword.spec
index b0955353a7d0f21a529142309dddd1683d8aae31..8d5f508a671031e334d3a821a8ae028393936282 100644 (file)
@@ -1,29 +1,28 @@
-#
 # TODO:
-# - Split out subpackages for tests, examples
-# - Fix debug package. Patch Makefile so debugfiles.list is generated?
 # - Package icu-sword and add bcond for it here
 #
-%define debug_package 0
-
-%bcond_with            examples
+# Conditional build:
 #%bcond_with   icusword
-%bcond_with            tests
 %bcond_without clucene
 %bcond_without curl
 %bcond_without icu
 %bcond_without utilities
 
+%define debug_package 0
+
 Summary:       The SWORD Project framework for manipulating Bible texts
 Name:          sword
-Version:       1.6.1
-Release:       0.3
+Version:       1.7.3
+Release:       4
 License:       GPL
 Group:         Libraries
-Source0:       http://www.crosswire.org/ftpmirror/pub/sword/source/v1.6/%{name}-%{version}.tar.gz
-# Source0-md5: 347e72f73313ff3ba700368db76a5d50
+Source0:       http://www.crosswire.org/ftpmirror/pub/sword/source/v1.7/%{name}-%{version}.tar.gz
+# Source0-md5: bd2ffadaa9f92f7b6e657e323e27a028
 Patch0:                %{name}-curl.patch
 URL:           http://www.crosswire.org/sword
+BuildRequires: pakchois-devel
+BuildRequires: pkgconfig
+BuildRequires: sqlite3-devel
 %{?with_clucene:BuildRequires: clucene-core-devel}
 %{?with_clucene:Requires:      clucene-core}
 %{?with_curl:BuildRequires:    curl-devel}
@@ -31,40 +30,48 @@ URL:                http://www.crosswire.org/sword
 %{?with_icu:BuildRequires:     icu}
 %{?with_icu:BuildRequires:     libicu-devel}
 %{?with_icu:Requires:  icu}
-BuildRequires: pkgconfig
 #%{?with_icusword:BuildRequires:       icu-sword}
 #%{?with_icusword:Requires:    icu-sword}
+Requires:      wwwbrowser
 Requires:      zlib
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-The SWORD Project is an effort to create an ever expanding software
-package for research and study of God and His Word. The SWORD Bible
-Framework allows easy manipulation of Bible texts, commentaries,
-lexicons, dictionaries, etc. Many frontends are build using this
-framework. An installed module set may be shared between any frontend
-using the framework.
+The SWORD Project creats cross-platform open-source tools that allow
+programmers and Bible societies to write new Bible software more
+quickly and easily. The SWORD Bible Framework allows easy manipulation
+of Bible texts, commentaries, lexicons, dictionaries, etc. Many
+frontends are built using this framework. An installed module set may
+be shared between any frontend using the framework.
 
 %package utilities
-Summary:       Utility programes using the sword libraries.
+Summary:       Utility programs that use the sword libraries
 Group:         Applications
-Provides:      diatheke
 Requires:      %{name} = %{version}-%{release}
+Provides:      diatheke
 
 %description utilities
-Utility programes using the sword libraries.
+Utility programs that use the sword libraries.
 
 %package devel
-Summary:       Include files and static libraries for developing sword applications
+Summary:       Include files for developing sword applications
 Group:         Development/Libraries
-Requires:      curl-devel >= 7.10.5
 Requires:      %{name} = %{version}-%{release}
+Requires:      curl-devel >= 7.10.5
 Requires:      zlib-devel
 
 %description devel
-Include files and static libraries for developing sword applications.
+Include files for developing sword applications.
 This package is required to compile Sword frontends, too.
 
+%package static
+Summary:       Static libraries for developing sword applications
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description static
+Static libraries for developing sword applications.
+
 %prep
 %setup -q
 %if %{with_curl}
@@ -73,14 +80,15 @@ This package is required to compile Sword frontends, too.
 
 %build
 %{configure} \
+       --with-conf \
        --with%{!?with_clucene:out}-clucene \
        --with%{!?with_curl:out}-curl \
        --with%{!?with_icu:out}-icu \
-       --%{?with_utilities:en}%{!?with_utilities:dis}able-utilities \
-       --%{?with_tests:en}%{!?with_tests:dis}able-tests \
-       --with-conf \
        --disable-debug \
-       --disable-dependency-tracking
+       --disable-dependency-tracking \
+       --disable-examples \
+       --disable-tests \
+       --%{?with_utilities:en}%{!?with_utilities:dis}able-utilities \
        #--with%{!?with_icusword:out}-icusword \
 
 %{__make}
@@ -94,26 +102,24 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install_config \
        DESTDIR=$RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT%{_libdir}/sword
-exit 0
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsword.la
 
-%post devel -p /sbin/ldconfig
+%clean
+rm -rf $RPM_BUILD_ROOT
 
-%postun devel -p /sbin/ldconfig
+%post -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
-%config %{_sysconfdir}/sword.conf
+%doc README AUTHORS NEWS INSTALL
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sword.conf
 %dir %{_datadir}/sword
 %dir %{_datadir}/sword/mods.d
 %dir %{_datadir}/sword/locales.d
-%config %{_datadir}/sword/mods.d/globals.conf
-%config %{_datadir}/sword/locales.d/*.conf
-%doc README AUTHORS NEWS INSTALL
-%attr(755,root,root) %{_libdir}/libsword*.so*
-%dir %{_libdir}/sword
-%dir %{_libdir}/sword/*icu*
-%{_libdir}/sword/*/*.res
+%{_datadir}/sword/mods.d/globals.conf
+%{_datadir}/sword/locales.d/*.conf
+%attr(755,root,root) %{_libdir}/libsword-%{version}.so
 
 %files utilities
 %defattr(644,root,root,755)
@@ -124,7 +130,8 @@ exit 0
 %doc doc/*
 %{_pkgconfigdir}/sword.pc
 %{_includedir}/sword
-%{_libdir}/libsword*.*a
+%attr(755,root,root) %{_libdir}/libsword.so
 
-%clean
-rm -rf $RPM_BUILD_ROOT
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libsword.a
This page took 0.100608 seconds and 4 git commands to generate.