]> git.pld-linux.org Git - packages/sword.git/blobdiff - sword.spec
- release 11 (by relup.sh)
[packages/sword.git] / sword.spec
index 7a9baa1c0de0198fbc4ec767e3827c661c0e4d16..69ac221ea25c80565857a175fe76efc6d361ecab 100644 (file)
@@ -1,62 +1,66 @@
-#
 # TODO:
-# - Split out subpackages for tests, examples
-# - Fix debug package. Patch Makefile so debugfiles.list is generated?
 # - Package icu-sword and add bcond for it here
 #
-%define debug_package 0
-
-%bcond_with            examples
+# Conditional build:
 #%bcond_with   icusword
-%bcond_with            tests
 %bcond_without clucene
 %bcond_without curl
 %bcond_without icu
 %bcond_without utilities
 
+%define debug_package 0
+
 Summary:       The SWORD Project framework for manipulating Bible texts
 Name:          sword
-Version:       1.6.1
-Release:       3
+Version:       1.6.2
+Release:       11
 License:       GPL
 Group:         Libraries
 Source0:       http://www.crosswire.org/ftpmirror/pub/sword/source/v1.6/%{name}-%{version}.tar.gz
-# Source0-md5: 347e72f73313ff3ba700368db76a5d50
+# Source0-md5: a7dc4456e20e915fec46d774b690e305
 Patch0:                %{name}-curl.patch
+Patch1:                %{name}-gcc47.patch
+Patch2:                %{name}-clucene2.patch
 URL:           http://www.crosswire.org/sword
+BuildRequires: pakchois-devel
+BuildRequires: pkgconfig
+BuildRequires: sqlite3-devel
+BuildRequires: xulrunner-devel >= 1.9.2.3
 %{?with_clucene:BuildRequires: clucene-core-devel}
 %{?with_clucene:Requires:      clucene-core}
 %{?with_curl:BuildRequires:    curl-devel}
 %{?with_curl:Requires: curl}
 %{?with_icu:BuildRequires:     icu}
+%{?with_icu:BuildRequires:     libicu-devel}
 %{?with_icu:Requires:  icu}
 #%{?with_icusword:BuildRequires:       icu-sword}
 #%{?with_icusword:Requires:    icu-sword}
+Requires:      xulrunner >= 1.9.2.3
 Requires:      zlib
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-The SWORD Project is an effort to create an ever expanding software
-package for research and study of God and His Word. The SWORD Bible
-Framework allows easy manipulation of Bible texts, commentaries,
-lexicons, dictionaries, etc. Many frontends are build using this
-framework. An installed module set may be shared between any frontend
-using the framework.
+The SWORD Project creats cross-platform open-source tools that allow
+programmers and Bible societies to write new Bible software more
+quickly and easily. The SWORD Bible Framework allows easy manipulation
+of Bible texts, commentaries, lexicons, dictionaries, etc. Many
+frontends are built using this framework. An installed module set may
+be shared between any frontend using the framework.
 
 %package utilities
-Summary:       Utility programes using the sword libraries.
+Summary:       Utility programs that use the sword libraries
 Group:         Applications
-Provides:      diatheke
 Requires:      %{name} = %{version}-%{release}
+Provides:      diatheke
 
 %description utilities
-Utility programes using the sword libraries.
+Utility programs that use the sword libraries.
 
 %package devel
 Summary:       Include files and static libraries for developing sword applications
 Group:         Development/Libraries
-Requires:      curl-devel >= 7.10.5
 Requires:      %{name} = %{version}-%{release}
+Requires:      curl-devel >= 7.10.5
 Requires:      zlib-devel
 
 %description devel
@@ -68,17 +72,20 @@ This package is required to compile Sword frontends, too.
 %if %{with_curl}
 %patch0 -p0
 %endif
+%patch1 -p0
+%patch2 -p1
 
 %build
 %{configure} \
+       --with-conf \
        --with%{!?with_clucene:out}-clucene \
        --with%{!?with_curl:out}-curl \
        --with%{!?with_icu:out}-icu \
-       --%{?with_utilities:en}%{!?with_utilities:dis}able-utilities \
-       --%{?with_tests:en}%{!?with_tests:dis}able-tests \
-       --with-conf \
        --disable-debug \
-       --disable-dependency-tracking
+       --disable-dependency-tracking \
+       --disable-examples \
+       --disable-tests \
+       --%{?with_utilities:en}%{!?with_utilities:dis}able-utilities \
        #--with%{!?with_icusword:out}-icusword \
 
 %{__make}
This page took 0.128109 seconds and 4 git commands to generate.