]> git.pld-linux.org Git - packages/sword.git/blob - sword.spec
- updated to 1.7.3
[packages/sword.git] / sword.spec
1 # TODO:
2 # - Package icu-sword and add bcond for it here
3 #
4 # Conditional build:
5 #%bcond_with    icusword
6 %bcond_without  clucene
7 %bcond_without  curl
8 %bcond_without  icu
9 %bcond_without  utilities
10
11 %define debug_package 0
12
13 Summary:        The SWORD Project framework for manipulating Bible texts
14 Name:           sword
15 Version:        1.7.3
16 Release:        1
17 License:        GPL
18 Group:          Libraries
19 Source0:        http://www.crosswire.org/ftpmirror/pub/sword/source/v1.7/%{name}-%{version}.tar.gz
20 # Source0-md5:  bd2ffadaa9f92f7b6e657e323e27a028
21 Patch0:         %{name}-curl.patch
22 URL:            http://www.crosswire.org/sword
23 BuildRequires:  pakchois-devel
24 BuildRequires:  pkgconfig
25 BuildRequires:  sqlite3-devel
26 %{?with_clucene:BuildRequires:  clucene-core-devel}
27 %{?with_clucene:Requires:       clucene-core}
28 %{?with_curl:BuildRequires:     curl-devel}
29 %{?with_curl:Requires:  curl}
30 %{?with_icu:BuildRequires:      icu}
31 %{?with_icu:BuildRequires:      libicu-devel}
32 %{?with_icu:Requires:   icu}
33 #%{?with_icusword:BuildRequires:        icu-sword}
34 #%{?with_icusword:Requires:     icu-sword}
35 Requires:       wwwbrowser
36 Requires:       zlib
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 The SWORD Project creats cross-platform open-source tools that allow
41 programmers and Bible societies to write new Bible software more
42 quickly and easily. The SWORD Bible Framework allows easy manipulation
43 of Bible texts, commentaries, lexicons, dictionaries, etc. Many
44 frontends are built using this framework. An installed module set may
45 be shared between any frontend using the framework.
46
47 %package utilities
48 Summary:        Utility programs that use the sword libraries
49 Group:          Applications
50 Requires:       %{name} = %{version}-%{release}
51 Provides:       diatheke
52
53 %description utilities
54 Utility programs that use the sword libraries.
55
56 %package devel
57 Summary:        Include files for developing sword applications
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       curl-devel >= 7.10.5
61 Requires:       zlib-devel
62
63 %description devel
64 Include files for developing sword applications.
65 This package is required to compile Sword frontends, too.
66
67 %package static
68 Summary:        Static libraries for developing sword applications
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static libraries for developing sword applications.
74
75 %prep
76 %setup -q
77 %if %{with_curl}
78 %patch0 -p0
79 %endif
80
81 %build
82 %{configure} \
83         --with-conf \
84         --with%{!?with_clucene:out}-clucene \
85         --with%{!?with_curl:out}-curl \
86         --with%{!?with_icu:out}-icu \
87         --disable-debug \
88         --disable-dependency-tracking \
89         --disable-examples \
90         --disable-tests \
91         --%{?with_utilities:en}%{!?with_utilities:dis}able-utilities \
92         #--with%{!?with_icusword:out}-icusword \
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install-strip \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %{__make} install_config \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsword.la
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files
114 %defattr(644,root,root,755)
115 %doc README AUTHORS NEWS INSTALL
116 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sword.conf
117 %dir %{_datadir}/sword
118 %dir %{_datadir}/sword/mods.d
119 %dir %{_datadir}/sword/locales.d
120 %{_datadir}/sword/mods.d/globals.conf
121 %{_datadir}/sword/locales.d/*.conf
122 %attr(755,root,root) %{_libdir}/libsword-%{version}.so
123
124 %files utilities
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_bindir}/*
127
128 %files devel
129 %defattr(644,root,root,755)
130 %doc doc/*
131 %{_pkgconfigdir}/sword.pc
132 %{_includedir}/sword
133 %attr(755,root,root) %{_libdir}/libsword.so
134
135 %files static
136 %defattr(644,root,root,755)
137 %{_libdir}/libsword.a
This page took 0.088734 seconds and 3 git commands to generate.