]> git.pld-linux.org Git - packages/sword.git/blob - sword.spec
c399fe14b6ac16603cbd3877eb3541bcbfcc2c5a
[packages/sword.git] / sword.spec
1 # TODO:
2 # - Package icu-sword and add bcond for it here
3 #
4 # Conditional build:
5 %bcond_without  clucene         # Lucene searching support
6 %bcond_without  curl            # manager support using libcurl
7 %bcond_without  cxx11           # C++11 regex support
8 %bcond_without  icu             # ICU for Unicode
9 %bcond_with     icusword        # custom SWORD ICU
10 %bcond_without  utilities       # sword utilities
11
12 %define debug_package 0
13
14 Summary:        The SWORD Project framework for manipulating Bible texts
15 Summary(pl.UTF-8):      Szkielet projektu SWORD do pracy nad tekstami biblijnymi
16 Name:           sword
17 Version:        1.7.4
18 Release:        3
19 License:        GPL v2
20 Group:          Libraries
21 Source0:        http://www.crosswire.org/ftpmirror/pub/sword/source/v1.7/%{name}-%{version}.tar.gz
22 # Source0-md5:  1677f02a86cbf07713d4e1d4c39791e6
23 URL:            http://www.crosswire.org/sword
24 BuildRequires:  autoconf >= 2.52
25 BuildRequires:  automake
26 BuildRequires:  cppunit-devel >= 1.8.0
27 %{?with_clucene:BuildRequires:  clucene-core-devel >= 2.3}
28 %{?with_curl:BuildRequires:     curl-devel}
29 #%{?with_icu:BuildRequires:     icu}
30 %{?with_icusword:BuildRequires: icu-sword}
31 %{?with_icu:BuildRequires:      libicu-devel}
32 BuildRequires:  libstdc++-devel %{?with_cxx11:>= 6:4.7}
33 BuildRequires:  libtool >= 2:1.5
34 BuildRequires:  pakchois-devel
35 BuildRequires:  pkgconfig >= 1:0.14
36 BuildRequires:  sqlite3-devel
37 BuildRequires:  zlib-devel
38 %{?with_clucene:Requires:       clucene-core >= 2.3}
39 %{?with_curl:Requires:  curl}
40 %{?with_icu:Requires:   icu}
41 %{?with_icusword:Requires:      icu-sword}
42 Requires:       wwwbrowser
43 Requires:       zlib
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 The SWORD Project creates cross-platform open-source tools that allow
48 programmers and Bible societies to write new Bible software more
49 quickly and easily. The SWORD Bible Framework allows easy manipulation
50 of Bible texts, commentaries, lexicons, dictionaries, etc. Many
51 frontends are built using this framework. An installed module set may
52 be shared between any frontend using the framework.
53
54 %description -l pl.UTF-8
55 Projekt SWORD tworzy wieloplatformowe, mające otwarte źródła narzędzia
56 pozwalające programistom oraz badaczom biblijnym pisać nowe
57 oprogramowanie biblijne szybciej i łatwiej. Szkielet biblijny SWORD
58 pozwala na łatwe operowanie na biblijnych tekstach, komentarzach,
59 leksykonach, słownikach itp. W oparciu o ten szkielet powstaje wiele
60 interfejsów użytkownika. Zainstalowany zestaw modułów może być łatwo
61 współdzielony między interfejsami.
62
63 %package utilities
64 Summary:        Utility programs that use the sword library
65 Summary(pl.UTF-8):      Programy narzędziowe wykorzystujące bibliotekę sword
66 Group:          Applications/Text
67 Requires:       %{name} = %{version}-%{release}
68 Provides:       diatheke
69
70 %description utilities
71 Utility programs that use the sword library.
72
73 %description utilities -l pl.UTF-8
74 Programy narzędziowe wykorzystujące bibliotekę sword.
75
76 %package devel
77 Summary:        Include files for developing sword applications
78 Summary(pl.UTF-8):      Pliki nagłówkowe do rozwijania aplikacji sword
79 Group:          Development/Libraries
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       curl-devel >= 7.10.5
82 Requires:       zlib-devel
83
84 %description devel
85 Include files for developing sword applications. This package is
86 required to compile Sword frontends, too.
87
88 %description devel -l pl.UTF-8
89 Pliki nagłówkowe do rozwijania plikacji sword. Ten pakiet jest
90 wymagany także do kompilowania interfejsów użytkownika sword.
91
92 %package static
93 Summary:        Static library for developing sword applications
94 Summary(pl.UTF-8):      Biblioteka statyczna do rozwijania aplikacji sword
95 Group:          Development/Libraries
96 Requires:       %{name}-devel = %{version}-%{release}
97
98 %description static
99 Static library for developing sword applications.
100
101 %description static -l pl.UTF-8
102 Biblioteka statyczna do rozwijania aplikacji sword.
103
104 %prep
105 %setup -q
106
107 %build
108 %{__libtoolize}
109 %{__aclocal} -I m4
110 %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113 %configure \
114         --with-conf \
115         --with-clucene%{!?with_clucene:=no} \
116         --with-curl%{!?with_curl:=no} \
117         %{?with_cxx11:--with-cxx11regex} \
118         --with-icu%{!?with_icu:=no} \
119         %{?with_icusword:--with-icusword} \
120         --disable-debug \
121         --disable-dependency-tracking \
122         --disable-examples \
123         --disable-tests \
124         --enable-utilities%{!?with_utilities:=no}
125
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} install-strip \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 %{__make} install_config \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsword.la
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post   -p /sbin/ldconfig
143 %postun -p /sbin/ldconfig
144
145 %files
146 %defattr(644,root,root,755)
147 %doc AUTHORS COPYING ChangeLog INSTALL README
148 %attr(755,root,root) %{_libdir}/libsword-%{version}.so
149 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sword.conf
150 %dir %{_datadir}/sword
151 %dir %{_datadir}/sword/mods.d
152 %dir %{_datadir}/sword/locales.d
153 %{_datadir}/sword/mods.d/globals.conf
154 %{_datadir}/sword/locales.d/*.conf
155
156 %files utilities
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_bindir}/diatheke
159 %attr(755,root,root) %{_bindir}/imp2gbs
160 %attr(755,root,root) %{_bindir}/imp2ld
161 %attr(755,root,root) %{_bindir}/imp2vs
162 %attr(755,root,root) %{_bindir}/installmgr
163 %attr(755,root,root) %{_bindir}/mkfastmod
164 %attr(755,root,root) %{_bindir}/mod2imp
165 %attr(755,root,root) %{_bindir}/mod2osis
166 %attr(755,root,root) %{_bindir}/mod2vpl
167 %attr(755,root,root) %{_bindir}/mod2zmod
168 %attr(755,root,root) %{_bindir}/osis2mod
169 %attr(755,root,root) %{_bindir}/tei2mod
170 %attr(755,root,root) %{_bindir}/vpl2mod
171 %attr(755,root,root) %{_bindir}/vs2osisref
172 %attr(755,root,root) %{_bindir}/vs2osisreftxt
173 %attr(755,root,root) %{_bindir}/xml2gbs
174
175 %files devel
176 %defattr(644,root,root,755)
177 %doc doc/*
178 %attr(755,root,root) %{_libdir}/libsword.so
179 %{_includedir}/sword
180 %{_pkgconfigdir}/sword.pc
181
182 %files static
183 %defattr(644,root,root,755)
184 %{_libdir}/libsword.a
This page took 0.06521 seconds and 2 git commands to generate.