]> git.pld-linux.org Git - packages/sword.git/blob - sword.spec
- release 4, rebuild against icu 64
[packages/sword.git] / sword.spec
1 # TODO:
2 # - Package icu-sword and add bcond for it here
3 #
4 # Conditional build:
5 %bcond_without  clucene         # Lucene searching support
6 %bcond_without  curl            # manager support using libcurl
7 %bcond_without  cxx11           # C++11 regex support
8 %bcond_without  icu             # ICU for Unicode
9 %bcond_with     icusword        # custom SWORD ICU
10 %bcond_without  utilities       # sword utilities
11
12 %define debug_package 0
13
14 Summary:        The SWORD Project framework for manipulating Bible texts
15 Summary(pl.UTF-8):      Szkielet projektu SWORD do pracy nad tekstami biblijnymi
16 Name:           sword
17 Version:        1.7.4
18 Release:        4
19 License:        GPL v2
20 Group:          Libraries
21 Source0:        http://www.crosswire.org/ftpmirror/pub/sword/source/v1.7/%{name}-%{version}.tar.gz
22 # Source0-md5:  1677f02a86cbf07713d4e1d4c39791e6
23 Patch0:         %{name}-icu64.patch
24 URL:            http://www.crosswire.org/sword
25 BuildRequires:  autoconf >= 2.52
26 BuildRequires:  automake
27 BuildRequires:  cppunit-devel >= 1.8.0
28 %{?with_clucene:BuildRequires:  clucene-core-devel >= 2.3}
29 %{?with_curl:BuildRequires:     curl-devel}
30 #%{?with_icu:BuildRequires:     icu}
31 %{?with_icusword:BuildRequires: icu-sword}
32 %{?with_icu:BuildRequires:      libicu-devel}
33 BuildRequires:  libstdc++-devel %{?with_cxx11:>= 6:4.7}
34 BuildRequires:  libtool >= 2:1.5
35 BuildRequires:  pakchois-devel
36 BuildRequires:  pkgconfig >= 1:0.14
37 BuildRequires:  sqlite3-devel
38 BuildRequires:  zlib-devel
39 %{?with_clucene:Requires:       clucene-core >= 2.3}
40 %{?with_curl:Requires:  curl}
41 %{?with_icu:Requires:   icu}
42 %{?with_icusword:Requires:      icu-sword}
43 Requires:       wwwbrowser
44 Requires:       zlib
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 The SWORD Project creates cross-platform open-source tools that allow
49 programmers and Bible societies to write new Bible software more
50 quickly and easily. The SWORD Bible Framework allows easy manipulation
51 of Bible texts, commentaries, lexicons, dictionaries, etc. Many
52 frontends are built using this framework. An installed module set may
53 be shared between any frontend using the framework.
54
55 %description -l pl.UTF-8
56 Projekt SWORD tworzy wieloplatformowe, mające otwarte źródła narzędzia
57 pozwalające programistom oraz badaczom biblijnym pisać nowe
58 oprogramowanie biblijne szybciej i łatwiej. Szkielet biblijny SWORD
59 pozwala na łatwe operowanie na biblijnych tekstach, komentarzach,
60 leksykonach, słownikach itp. W oparciu o ten szkielet powstaje wiele
61 interfejsów użytkownika. Zainstalowany zestaw modułów może być łatwo
62 współdzielony między interfejsami.
63
64 %package utilities
65 Summary:        Utility programs that use the sword library
66 Summary(pl.UTF-8):      Programy narzędziowe wykorzystujące bibliotekę sword
67 Group:          Applications/Text
68 Requires:       %{name} = %{version}-%{release}
69 Provides:       diatheke
70
71 %description utilities
72 Utility programs that use the sword library.
73
74 %description utilities -l pl.UTF-8
75 Programy narzędziowe wykorzystujące bibliotekę sword.
76
77 %package devel
78 Summary:        Include files for developing sword applications
79 Summary(pl.UTF-8):      Pliki nagłówkowe do rozwijania aplikacji sword
80 Group:          Development/Libraries
81 Requires:       %{name} = %{version}-%{release}
82 Requires:       curl-devel >= 7.10.5
83 Requires:       zlib-devel
84
85 %description devel
86 Include files for developing sword applications. This package is
87 required to compile Sword frontends, too.
88
89 %description devel -l pl.UTF-8
90 Pliki nagłówkowe do rozwijania plikacji sword. Ten pakiet jest
91 wymagany także do kompilowania interfejsów użytkownika sword.
92
93 %package static
94 Summary:        Static library for developing sword applications
95 Summary(pl.UTF-8):      Biblioteka statyczna do rozwijania aplikacji sword
96 Group:          Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98
99 %description static
100 Static library for developing sword applications.
101
102 %description static -l pl.UTF-8
103 Biblioteka statyczna do rozwijania aplikacji sword.
104
105 %prep
106 %setup -q
107 %patch0 -p1
108
109 %build
110 %{__libtoolize}
111 %{__aclocal} -I m4
112 %{__autoconf}
113 %{__autoheader}
114 %{__automake}
115 %configure \
116         --with-conf \
117         --with-clucene%{!?with_clucene:=no} \
118         --with-curl%{!?with_curl:=no} \
119         %{?with_cxx11:--with-cxx11regex} \
120         --with-icu%{!?with_icu:=no} \
121         %{?with_icusword:--with-icusword} \
122         --disable-debug \
123         --disable-dependency-tracking \
124         --disable-examples \
125         --disable-tests \
126         --enable-utilities%{!?with_utilities:=no}
127
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} install-strip \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 %{__make} install_config \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsword.la
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post   -p /sbin/ldconfig
145 %postun -p /sbin/ldconfig
146
147 %files
148 %defattr(644,root,root,755)
149 %doc AUTHORS COPYING ChangeLog INSTALL README
150 %attr(755,root,root) %{_libdir}/libsword-%{version}.so
151 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sword.conf
152 %dir %{_datadir}/sword
153 %dir %{_datadir}/sword/mods.d
154 %dir %{_datadir}/sword/locales.d
155 %{_datadir}/sword/mods.d/globals.conf
156 %{_datadir}/sword/locales.d/*.conf
157
158 %files utilities
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_bindir}/diatheke
161 %attr(755,root,root) %{_bindir}/imp2gbs
162 %attr(755,root,root) %{_bindir}/imp2ld
163 %attr(755,root,root) %{_bindir}/imp2vs
164 %attr(755,root,root) %{_bindir}/installmgr
165 %attr(755,root,root) %{_bindir}/mkfastmod
166 %attr(755,root,root) %{_bindir}/mod2imp
167 %attr(755,root,root) %{_bindir}/mod2osis
168 %attr(755,root,root) %{_bindir}/mod2vpl
169 %attr(755,root,root) %{_bindir}/mod2zmod
170 %attr(755,root,root) %{_bindir}/osis2mod
171 %attr(755,root,root) %{_bindir}/tei2mod
172 %attr(755,root,root) %{_bindir}/vpl2mod
173 %attr(755,root,root) %{_bindir}/vs2osisref
174 %attr(755,root,root) %{_bindir}/vs2osisreftxt
175 %attr(755,root,root) %{_bindir}/xml2gbs
176
177 %files devel
178 %defattr(644,root,root,755)
179 %doc doc/*
180 %attr(755,root,root) %{_libdir}/libsword.so
181 %{_includedir}/sword
182 %{_pkgconfigdir}/sword.pc
183
184 %files static
185 %defattr(644,root,root,755)
186 %{_libdir}/libsword.a
This page took 0.044746 seconds and 3 git commands to generate.