]> git.pld-linux.org Git - packages/swig.git/commitdiff
- adjusted php-freearg patch to emit arg_count checks only for optional arguments, auto/th/swig-2.0.12-2 auto/ti/swig-2.0.12-2
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 11 May 2014 04:23:45 +0000 (06:23 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 11 May 2014 04:23:45 +0000 (06:23 +0200)
  not e.g. outputs; fixes compilation errors regarding arg_count
- release 2

swig-php-freearg.patch
swig.spec

index cc3b72df8ac6bca5e41c846fb9071a261fe1eb8a..cdc8624d58e847de38d735655c15e82ae71f0ee2 100644 (file)
@@ -4,7 +4,7 @@
  
      /* Insert cleanup code */
      for (i = 0, p = l; p; i++) {
-+      if(i>= (num_required))
++      if((i >= num_required) && (i < num_required+numopt))
 +      Printf(cleanup,"\tif(arg_count > %d) {\n", i);
        if ((tm = Getattr(p, "tmap:freearg"))) {
        Replaceall(tm, "$source", Getattr(p, "lname"));
@@ -13,7 +13,7 @@
        } else {
        p = nextSibling(p);
        }
-+      if (i >= num_required)
++      if ((i >= num_required) && (i < num_required+numopt))
 +        Printf(cleanup,"}\n");
      }
  
index 864a6234b08981c2305cee8f7f15b0792a137535..1cada5b7dd924b59ca2c0754ec86267f83f3d8c6 100644 (file)
--- a/swig.spec
+++ b/swig.spec
@@ -13,7 +13,7 @@ Summary(pl.UTF-8):    Generator interfejsów do Perla, Tcl-a, Guile'a i Pythona
 Summary(pt_BR.UTF-8):  Gerador de Interfaces e "Wrappers" Simplificado (SWIG)
 Name:          swig
 Version:       2.0.12
-Release:       1
+Release:       2
 License:       GPL v3+ (utility), free (library)
 Group:         Development/Languages
 Source0:       http://downloads.sourceforge.net/swig/%{name}-%{version}.tar.gz
This page took 0.104325 seconds and 4 git commands to generate.