]> git.pld-linux.org Git - packages/sudo.git/blobdiff - sudo.spec
- added linux audit support
[packages/sudo.git] / sudo.spec
index d67f7f1b12cd24da083ba8adf2c56c394d9803df..8f8c83703d419be22d51d3d5c2b2cc9ecd70aabe 100644 (file)
--- a/sudo.spec
+++ b/sudo.spec
@@ -1,5 +1,6 @@
 #
 # Conditional build:
+%bcond_without audit           # Linux audit support
 %bcond_with    kerberos5       # enable Kerberos V support (conflicts with PAM)
 %bcond_without ldap            # disable LDAP support
 %bcond_without pam             # disable PAM support
@@ -20,13 +21,13 @@ Summary(pt_BR.UTF-8):       Permite que usuários específicos executem comandos como
 Summary(ru.UTF-8):     Позволяет определенным пользователям исполнять команды от имени root
 Summary(uk.UTF-8):     Дозволяє вказаним користувачам виконувати команди від імені root
 Name:          sudo
-Version:       1.7.9
-Release:       2
+Version:       1.7.10p7
+Release:       1
 Epoch:         1
 License:       BSD
 Group:         Applications/System
 Source0:       ftp://ftp.sudo.ws/pub/sudo/%{name}-%{version}.tar.gz
-# Source0-md5: d9002b306986fa7735ee6aa003624885
+# Source0-md5: 9faa5ceaf23cca0468d0f5d211bac6e4
 Source1:       %{name}.pamd
 Source2:       %{name}-i.pamd
 Source3:       %{name}.logrotate
@@ -34,12 +35,15 @@ Patch0:             %{name}-libtool.patch
 Patch1:                %{name}-env.patch
 Patch2:                config.patch
 URL:           http://www.sudo.ws/sudo/
+%{?with_audit:BuildRequires:   audit-libs-devel}
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake
+BuildRequires: bison
+BuildRequires: flex
 BuildRequires: gettext-devel
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
 %{?with_selinux:BuildRequires: libselinux-devel}
-BuildRequires: libtool >= 2:2.2.6
+BuildRequires: libtool >= 2:2.2.6b
 %{?with_ldap:BuildRequires:    openldap-devel >= 2.3.0}
 %{?with_pam:BuildRequires:     pam-devel}
 BuildRequires: rpm >= 4.4.9-56
@@ -152,26 +156,28 @@ cp -p acinclude.m4 acinclude.m4.orig
 %{__libtoolize}
 %{__mv} install-custom-sh install-sh
 cp -f /usr/share/automake/config.sub .
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoconf}
 %configure \
        NROFFPROG=nroff \
+       --enable-zlib=system \
+       --with-env-editor \
+       --with-ignore-dot \
        --with-incpath=/usr/include/security \
-       --with-pam \
-       --with-pam-login \
-       --with-logging=both \
+       %{?with_kerberos5:--with-kerb5} \
+       %{?with_ldap:--with-ldap} \
+       %{?with_audit:--with-linux-audit} \
        --with-logfac=auth \
+       --with-logging=both \
+       --with-loglen=320 \
        --with-logpath=/var/log/sudo \
-       --with-ignore-dot \
-       --with-env-editor \
+       --with-long-otp-prompt \
+       --with-pam \
+       --with-pam-login \
+       --with-passprompt="[sudo] password for %%p: " \
        --with-secure-path="/bin:/sbin:/usr/bin:/usr/sbin" \
-       --with-loglen=320 \
-       --enable-zlib=system \
-       --with%{!?with_kerberos5:out}-kerb5 \
-       --with%{!?with_ldap:out}-ldap \
-       --with%{!?with_skey:out}-skey \
-       --with%{!?with_selinux:out}-selinux \
-       --with-long-otp-prompt
+       %{?with_selinux:--with-selinux} \
+       %{?with_skey:--with-skey}
 
 %{__make}
 
@@ -249,6 +255,8 @@ rmdir /var/run/sudo 2>/dev/null || :
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/sudo
 %attr(700,root,root) %dir /var/db/sudo
 
+%if %{with ldap}
 %files -n openldap-schema-sudo
 %defattr(644,root,root,755)
 %{schemadir}/sudo.schema
+%endif
This page took 0.082325 seconds and 4 git commands to generate.