]> git.pld-linux.org Git - packages/sudo.git/blobdiff - sudo.spec
- added linux audit support
[packages/sudo.git] / sudo.spec
index 2197b03086796777450f67cb069e30df77de40bc..8f8c83703d419be22d51d3d5c2b2cc9ecd70aabe 100644 (file)
--- a/sudo.spec
+++ b/sudo.spec
@@ -1,11 +1,18 @@
 #
 # Conditional build:
+%bcond_without audit           # Linux audit support
 %bcond_with    kerberos5       # enable Kerberos V support (conflicts with PAM)
 %bcond_without ldap            # disable LDAP support
 %bcond_without pam             # disable PAM support
 %bcond_without selinux         # build without SELinux support
 %bcond_with    skey            # enable skey (onetime passwords) support (conflicts with PAM)
-#
+
+%if "%{pld_release}" == "ac"
+%define                pam_ver 0.80.1
+%else
+%define                pam_ver 0.99.7.1
+%endif
+
 Summary:       Allows command execution as root for specified users
 Summary(es.UTF-8):     Permite que usuarios específicos ejecuten comandos como se fueran el root
 Summary(ja.UTF-8):     指定ユーザに制限付のroot権限を許可する
@@ -14,32 +21,41 @@ Summary(pt_BR.UTF-8):       Permite que usuários específicos executem comandos como
 Summary(ru.UTF-8):     Позволяет определенным пользователям исполнять команды от имени root
 Summary(uk.UTF-8):     Дозволяє вказаним користувачам виконувати команди від імені root
 Name:          sudo
-Version:       1.7.2p7
-Release:       2
+Version:       1.7.10p7
+Release:       1
 Epoch:         1
 License:       BSD
 Group:         Applications/System
 Source0:       ftp://ftp.sudo.ws/pub/sudo/%{name}-%{version}.tar.gz
-# Source0-md5: 3ac78668427a53e12d7639fdfab2f1af
+# Source0-md5: 9faa5ceaf23cca0468d0f5d211bac6e4
 Source1:       %{name}.pamd
 Source2:       %{name}-i.pamd
 Source3:       %{name}.logrotate
-Patch0:                %{name}-pam-login.patch
-Patch1:                %{name}-libtool.patch
-Patch2:                %{name}-env.patch
+Patch0:                %{name}-libtool.patch
+Patch1:                %{name}-env.patch
+Patch2:                config.patch
 URL:           http://www.sudo.ws/sudo/
+%{?with_audit:BuildRequires:   audit-libs-devel}
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake
+BuildRequires: bison
+BuildRequires: flex
+BuildRequires: gettext-devel
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
 %{?with_selinux:BuildRequires: libselinux-devel}
-BuildRequires: libtool
+BuildRequires: libtool >= 2:2.2.6b
 %{?with_ldap:BuildRequires:    openldap-devel >= 2.3.0}
 %{?with_pam:BuildRequires:     pam-devel}
+BuildRequires: rpm >= 4.4.9-56
+BuildRequires: rpmbuild(macros) >= 1.595
 %{?with_skey:BuildRequires:    skey-devel >= 2.2-11}
-Requires:      pam >= 0.99.7.1
+BuildRequires: zlib-devel
+Requires:      pam >= %{pam_ver}
 Obsoletes:     cu-sudo
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                schemadir       /usr/share/openldap/schema
+
 %description
 Sudo (superuser do) allows a permitted user to execute a command as
 the superuser (real and effective uid and gid are set to 0 and root's
@@ -109,12 +125,27 @@ Sudo (superuser do) дозволяє системному адміністрат
 пам'ятає пароль; використання одного конфігураційного файлу (sudoers)
 на багатьох машинах.
 
+%package -n openldap-schema-sudo
+Summary:       Sudo LDAP schema
+Summary(pl.UTF-8):     Schemat bazy sudo dla LDAP
+Group:         Networking/Daemons
+Requires(post,postun): sed >= 4.0
+Requires:      openldap-servers
+Requires:      sed >= 4.0
+
+%description -n openldap-schema-sudo
+This package contains sudo.schema for openldap.
+
+%description -n openldap-schema-sudo -l pl.UTF-8
+Ten pakiet zawiera sudo.schema dla pakietu openldap.
+
 %prep
 %setup -q
 # only local macros
-mv -f aclocal.m4 acinclude.m4
-# kill libtool.m4 copy
-rm -f acsite.m4
+mv aclocal.m4 acinclude.m4
+# do not load libtool macros from acinclude
+cp -p acinclude.m4 acinclude.m4.orig
+%{__sed} -i -e '/Pull in libtool macros/,$d' acinclude.m4
 
 %patch0 -p1
 %patch1 -p1
@@ -125,73 +156,107 @@ rm -f acsite.m4
 %{__libtoolize}
 %{__mv} install-custom-sh install-sh
 cp -f /usr/share/automake/config.sub .
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoconf}
 %configure \
        NROFFPROG=nroff \
+       --enable-zlib=system \
+       --with-env-editor \
+       --with-ignore-dot \
        --with-incpath=/usr/include/security \
-       --with-timedir=/var/run/sudo \
-       --with-pam \
-       --with-pam-login \
-       --with-logging=both \
+       %{?with_kerberos5:--with-kerb5} \
+       %{?with_ldap:--with-ldap} \
+       %{?with_audit:--with-linux-audit} \
        --with-logfac=auth \
+       --with-logging=both \
+       --with-loglen=320 \
        --with-logpath=/var/log/sudo \
-       --with-ignore-dot \
-       --with-env-editor \
+       --with-long-otp-prompt \
+       --with-pam \
+       --with-pam-login \
+       --with-passprompt="[sudo] password for %%p: " \
        --with-secure-path="/bin:/sbin:/usr/bin:/usr/sbin" \
-       --with-loglen=320 \
-       --with%{!?with_kerberos5:out}-kerb5 \
-       --with%{!?with_ldap:out}-ldap \
-       --with%{!?with_skey:out}-skey \
-       --with%{!?with_selinux:out}-selinux \
-       --with-long-otp-prompt
+       %{?with_selinux:--with-selinux} \
+       %{?with_skey:--with-skey}
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sysconfdir}/{pam.d,logrotate.d},/var/{log,run/sudo},%{_mandir}/man8}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir}/{sudoers.d,pam.d,logrotate.d},/var/log/sudo-io,%{_mandir}/man8}
 
 %{__make} -j1 install \
        DESTDIR=$RPM_BUILD_ROOT \
-       install_uid=`id -u` \
-       install_gid=`id -g` \
-       sudoers_uid=`id -u` \
-       sudoers_gid=`id -g`
+       install_uid=$(id -u) \
+       install_gid=$(id -g) \
+       sudoers_uid=$(id -u) \
+       sudoers_gid=$(id -g)
 
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/sudo
-install %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/sudo-i
-touch $RPM_BUILD_ROOT/var/log/sudo
-install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/sudo
+cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/sudo
+cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/sudo-i
+cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/sudo
 
-chmod -R +r $RPM_BUILD_ROOT%{_prefix}
+touch $RPM_BUILD_ROOT/var/log/sudo
 
-rm -f $RPM_BUILD_ROOT%{_libdir}/sudo_noexec.la
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
 
-# replace hardlinks with symlinks
-ln -sf %{_bindir}/sudo $RPM_BUILD_ROOT%{_bindir}/sudoedit
-rm -f $RPM_BUILD_ROOT%{_mandir}/man8/sudoedit.8
-echo '.so sudo.8' > $RPM_BUILD_ROOT%{_mandir}/man8/sudoedit.8
+%if %{with ldap}
+install -d $RPM_BUILD_ROOT%{schemadir}
+cp -p schema.OpenLDAP $RPM_BUILD_ROOT%{schemadir}/sudo.schema
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post -n openldap-schema-sudo
+%openldap_schema_register %{schemadir}/sudo.schema -d core
+%service -q ldap restart
+%banner -o -e openldap-schema-sudo <<'EOF'
+NOTE:
+In order for sudoRole LDAP queries to be efficient, the server must index
+the attribute 'sudoUser', e.g.
+
+    # Indices to maintain
+    index   sudoUser    eq
+EOF
+
+%postun -n openldap-schema-sudo
+if [ "$1" = "0" ]; then
+       %openldap_schema_unregister %{schemadir}/sudo.schema
+       %service -q ldap restart
+fi
+
+%triggerpostun -- %{name} < 1:1.7.8p2-5
+mv -f /var/run/sudo/* /var/db/sudo 2>/dev/null
+rmdir /var/run/sudo 2>/dev/null || :
+
 %files
 %defattr(644,root,root,755)
-%doc HISTORY README TROUBLESHOOTING sample.sudoers
+%doc ChangeLog HISTORY NEWS README TROUBLESHOOTING UPGRADE sample.*
+%{?with_ldap:%doc README.LDAP sudoers2ldif}
+%attr(550,root,root) %dir %{_sysconfdir}/sudoers.d
 %attr(440,root,root) %verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/sudoers
 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sudo
 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sudo-i
 %attr(4755,root,root) %{_bindir}/sudo
 %attr(4755,root,root) %{_bindir}/sudoedit
+%attr(755,root,root) %{_bindir}/sudoreplay
 %attr(755,root,root) %{_sbindir}/visudo
 %{?with_selinux:%attr(755,root,root) %{_libdir}/sesh}
 %attr(755,root,root) %{_libdir}/sudo_noexec.so
 %{_mandir}/man5/sudoers.5*
-%{_mandir}/man5/sudoers.ldap.5*
+%{?with_ldap:%{_mandir}/man5/sudoers.ldap.5*}
 %{_mandir}/man8/sudo.8*
 %{_mandir}/man8/sudoedit.8*
+%{_mandir}/man8/sudoreplay.8*
 %{_mandir}/man8/visudo.8*
 %attr(600,root,root) %ghost /var/log/sudo
+%attr(700,root,root) /var/log/sudo-io
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/sudo
-%attr(700,root,root) %dir /var/run/sudo
+%attr(700,root,root) %dir /var/db/sudo
+
+%if %{with ldap}
+%files -n openldap-schema-sudo
+%defattr(644,root,root,755)
+%{schemadir}/sudo.schema
+%endif
This page took 0.04255 seconds and 4 git commands to generate.