]> git.pld-linux.org Git - packages/sudo.git/blobdiff - sudo.spec
- release 2
[packages/sudo.git] / sudo.spec
index 3fb72dfa2e65f1d8d6299c10287035b521abc7bf..2197b03086796777450f67cb069e30df77de40bc 100644 (file)
--- a/sudo.spec
+++ b/sudo.spec
@@ -14,24 +14,23 @@ Summary(pt_BR.UTF-8):       Permite que usuários específicos executem comandos como
 Summary(ru.UTF-8):     Позволяет определенным пользователям исполнять команды от имени root
 Summary(uk.UTF-8):     Дозволяє вказаним користувачам виконувати команди від імені root
 Name:          sudo
-Version:       1.6.9p3
-Release:       1
+Version:       1.7.2p7
+Release:       2
 Epoch:         1
 License:       BSD
 Group:         Applications/System
 Source0:       ftp://ftp.sudo.ws/pub/sudo/%{name}-%{version}.tar.gz
-# Source0-md5: 21791b0bfb14fe1dc508fdcfaae9bacc
+# Source0-md5: 3ac78668427a53e12d7639fdfab2f1af
 Source1:       %{name}.pamd
 Source2:       %{name}-i.pamd
 Source3:       %{name}.logrotate
-Patch0:                %{name}-selinux.patch
-Patch1:                %{name}-ac.patch
-Patch2:                %{name}-pam-login.patch
-Patch3:                %{name}-libtool.patch
+Patch0:                %{name}-pam-login.patch
+Patch1:                %{name}-libtool.patch
+Patch2:                %{name}-env.patch
 URL:           http://www.sudo.ws/sudo/
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake
-%{?with_kerberos5:BuildRequires:       krb5-devel}
+%{?with_kerberos5:BuildRequires:       heimdal-devel}
 %{?with_selinux:BuildRequires: libselinux-devel}
 BuildRequires: libtool
 %{?with_ldap:BuildRequires:    openldap-devel >= 2.3.0}
@@ -112,28 +111,22 @@ Sudo (superuser do) дозволяє системному адміністрат
 
 %prep
 %setup -q
-%{?with_selinux:%patch0 -p1}
-
 # only local macros
 mv -f aclocal.m4 acinclude.m4
 # kill libtool.m4 copy
 rm -f acsite.m4
 
+%patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
 
 %build
-cp -f /usr/share/automake/config.sub .
+%{__mv} install-sh install-custom-sh
 %{__libtoolize}
+%{__mv} install-custom-sh install-sh
+cp -f /usr/share/automake/config.sub .
 %{__aclocal}
 %{__autoconf}
-# sparc64 2.4.x kernels have buggy sys32_utimes(somefile, NULL) syscall
-# it's fixed in >= 2.4.31-0.3, but keep workaround not to require very
-# fresh kernel
-%ifarch sparc sparcv9
-export ac_cv_func_utimes=no
-%endif
 %configure \
        NROFFPROG=nroff \
        --with-incpath=/usr/include/security \
@@ -147,19 +140,19 @@ export ac_cv_func_utimes=no
        --with-env-editor \
        --with-secure-path="/bin:/sbin:/usr/bin:/usr/sbin" \
        --with-loglen=320 \
-       --disable-saved-ids \
        --with%{!?with_kerberos5:out}-kerb5 \
        --with%{!?with_ldap:out}-ldap \
        --with%{!?with_skey:out}-skey \
+       --with%{!?with_selinux:out}-selinux \
        --with-long-otp-prompt
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sysconfdir}/{pam.d,logrotate.d},/var/{log,run/sudo}}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir}/{pam.d,logrotate.d},/var/{log,run/sudo},%{_mandir}/man8}
 
-%{__make} install \
+%{__make} -j1 install \
        DESTDIR=$RPM_BUILD_ROOT \
        install_uid=`id -u` \
        install_gid=`id -g` \
@@ -175,21 +168,30 @@ chmod -R +r $RPM_BUILD_ROOT%{_prefix}
 
 rm -f $RPM_BUILD_ROOT%{_libdir}/sudo_noexec.la
 
+# replace hardlinks with symlinks
+ln -sf %{_bindir}/sudo $RPM_BUILD_ROOT%{_bindir}/sudoedit
+rm -f $RPM_BUILD_ROOT%{_mandir}/man8/sudoedit.8
+echo '.so sudo.8' > $RPM_BUILD_ROOT%{_mandir}/man8/sudoedit.8
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc BUGS CHANGES HISTORY README TODO TROUBLESHOOTING sample.sudoers
+%doc HISTORY README TROUBLESHOOTING sample.sudoers
 %attr(440,root,root) %verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/sudoers
 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sudo
 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sudo-i
 %attr(4755,root,root) %{_bindir}/sudo
 %attr(4755,root,root) %{_bindir}/sudoedit
-%{?with_selinux:%attr(755,root,root) %{_sbindir}/sesh}
 %attr(755,root,root) %{_sbindir}/visudo
+%{?with_selinux:%attr(755,root,root) %{_libdir}/sesh}
 %attr(755,root,root) %{_libdir}/sudo_noexec.so
-%{_mandir}/man*/*
+%{_mandir}/man5/sudoers.5*
+%{_mandir}/man5/sudoers.ldap.5*
+%{_mandir}/man8/sudo.8*
+%{_mandir}/man8/sudoedit.8*
+%{_mandir}/man8/visudo.8*
 %attr(600,root,root) %ghost /var/log/sudo
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/*
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/sudo
 %attr(700,root,root) %dir /var/run/sudo
This page took 0.093106 seconds and 4 git commands to generate.