]> git.pld-linux.org Git - packages/subversion.git/blobdiff - subversion.spec
up to 1.14.0
[packages/subversion.git] / subversion.spec
index 7797ac7478f5451a6bb188e4104a93062426fd6c..a229bc28c2135307725389cef27da36f8bad9694 100644 (file)
@@ -2,10 +2,10 @@
 # Conditional build:
 %bcond_with    net_client_only         # build only net client
 %bcond_without swig                    # disable bindings generation with Swig
-%bcond_without python                  # build without Python bindings (broken)
+%bcond_without python                  # build without Python bindings
 %bcond_without csvn                    # build Python csvn bindings
 %bcond_without perl                    # build without Perl bindings
-%bcond_without ruby                    # build without Ruby bindings
+%bcond_with    ruby                    # build without Ruby bindings
 %bcond_without apache                  # build without Apache support (webdav, etc)
 %bcond_without java                    # build without javahl support (Java high-level bindings)
 %bcond_with    tests                   # don't perform "make check"
 %define        pdir    SVN
 %define        pnam    _Core
 
-%{?with_perl:%include  /usr/lib/rpm/macros.perl}
 Summary:       A Concurrent Versioning system similar to but better than CVS
 Summary(pl.UTF-8):     System kontroli wersji podobny, ale lepszy, niż CVS
 Summary(pt_BR.UTF-8):  Sistema de versionamento concorrente
 Name:          subversion
-Version:       1.10.3
+Version:       1.14.0
 Release:       1
 License:       Apache v2.0
 Group:         Development/Version Control
 Source0:       http://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
-# Source0-md5: 34b493f22988956af2e2e8fdb2ad0151
+# Source0-md5: 8f6c50632355ae08445c2ed63ba9689e
 Source1:       %{name}-dav_svn.conf
 Source2:       %{name}-authz_svn.conf
 Source3:       %{name}-svnserve.init
@@ -91,7 +90,7 @@ BuildRequires:        gettext-tools
 %{?with_gnome:BuildRequires:   libgnome-keyring-devel}
 %{?with_gnome:BuildRequires:   libsecret-devel}
 BuildRequires: libmagic-devel
-BuildRequires: libtool >= 1.4-9
+BuildRequires: libtool >= 2:2
 BuildRequires: libutf8proc-devel >= 1.3.1-4
 BuildRequires: lz4-devel
 BuildRequires: pkgconfig
@@ -105,8 +104,8 @@ BuildRequires:      texinfo
 BuildRequires: which
 BuildRequires: zlib-devel >= 1.2
 %if %{with java}
-BuildRequires: jdk >= 1.5
-BuildRequires: libstdc++-devel
+BuildRequires: jdk >= 1.8
+BuildRequires: libstdc++-devel >= 6:4.7
 %endif
 %if %{with perl}
 BuildRequires: perl-devel >= 1:5.8.0
@@ -114,8 +113,10 @@ BuildRequires:     rpm-perlprov >= 4.1-13
 BuildRequires: swig-perl >= 1.3.24
 %endif
 %if %{with python}
+BuildRequires: py3c
 BuildRequires: python-devel >= 1:2.4
-BuildRequires: swig-python >= 1.3.24
+BuildRequires: swig3-python >= 3.0.12
+BuildRequires: swig3-python < 4.0.0
 %endif
 %if %{with ruby}
 BuildRequires: rpm-rubyprov
@@ -199,6 +200,7 @@ Summary(pt_BR.UTF-8):       Arquivos de desenvolvimento para o Subversion
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      apr-util-devel >= 1:1.3
+Requires:      libutf8proc-devel >= 1.3.1-4
 Requires:      serf-devel >= 1.3.4
 Obsoletes:     libsubversion0-devel
 
@@ -260,7 +262,7 @@ Summary(pt_BR.UTF-8):       Módulos python para acessar os recursos do Subversion
 Group:         Applications
 Requires:      %{name} = %{version}-%{release}
 Requires:      python
-Requires:      python-subversion = %{version}
+%{?with_python:Requires:       python-subversion = %{version}}
 
 %description tools
 Subversion tools and scripts.
@@ -454,6 +456,20 @@ uwierzytelniać się przy użyciu Portfela KDE.
 
 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
 
+sed -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
+      tools/backup/hot-backup.py.in \
+      tools/examples/blame.py \
+      tools/examples/check-modified.py \
+      tools/examples/dumpprops.py \
+      tools/examples/get-location-segments.py \
+      tools/examples/getfile.py \
+      tools/examples/geturl.py \
+      tools/examples/putfile.py \
+      tools/examples/revplist.py \
+      tools/examples/svnlook.py \
+      tools/examples/svnshell.py \
+      tools/examples/walk-config-auth.py
+
 %build
 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
 #%{__rm} subversion/bindings/swig/proxy/*.swg
@@ -480,6 +496,9 @@ chmod +x ./autogen.sh && ./autogen.sh
 %if %{without swig}
        --without-swig \
 %endif
+%if %{with python}
+       --with-swig=/usr/bin/swig-3 \
+%endif
 %if %{with ruby}
        svn_cv_ruby_sitedir_libsuffix="" \
        svn_cv_ruby_sitedir_archsuffix="" \
@@ -990,7 +1009,7 @@ fi
 %dir %{perl_vendorarch}/auto/SVN
 %dir %{perl_vendorarch}/auto/SVN/*
 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
-%{_mandir}/man3/*.3pm*
+%{_mandir}/man3/SVN::*.3pm*
 %endif
 
 %if %{with ruby}
This page took 0.037878 seconds and 4 git commands to generate.