]> git.pld-linux.org Git - packages/subversion.git/blobdiff - subversion.spec
up to 1.14.1 (fixes CVE-2020-17525)
[packages/subversion.git] / subversion.spec
index a072ab86274ab19f9a291d569a634802a297c626..640e50c901291b0922a57813895d652cb72138ff 100644 (file)
@@ -2,15 +2,15 @@
 # Conditional build:
 %bcond_with    net_client_only         # build only net client
 %bcond_without swig                    # disable bindings generation with Swig
-%bcond_without python                  # build without Python bindings (broken)
+%bcond_without python                  # build without Python bindings
 %bcond_without csvn                    # build Python csvn bindings
 %bcond_without perl                    # build without Perl bindings
-%bcond_without ruby                    # build without Ruby bindings
+%bcond_with    ruby                    # build without Ruby bindings
 %bcond_without apache                  # build without Apache support (webdav, etc)
 %bcond_without java                    # build without javahl support (Java high-level bindings)
 %bcond_with    tests                   # don't perform "make check"
-%bcond_without kwallet                 # build without kde4 wallet support
-%bcond_without kde                     # build without kde4 support (alias for kwallet)
+%bcond_without kwallet                 # build without kde5 wallet support
+%bcond_without kde                     # build without kde5 support (alias for kwallet)
 %bcond_without gnome                   # build without gnome keyring support
 %bcond_without db                      # disable Subversion Berkeley DB based filesystem library
 %bcond_with    db6                     # allow BDB6 (not tested by upstream, released on AGPL)
 %define        pdir    SVN
 %define        pnam    _Core
 
-%{?with_perl:%include  /usr/lib/rpm/macros.perl}
 Summary:       A Concurrent Versioning system similar to but better than CVS
 Summary(pl.UTF-8):     System kontroli wersji podobny, ale lepszy, niż CVS
 Summary(pt_BR.UTF-8):  Sistema de versionamento concorrente
 Name:          subversion
-Version:       1.10.0
-Release:       3
+Version:       1.14.1
+Release:       1
 License:       Apache v2.0
 Group:         Development/Version Control
 Source0:       http://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
-# Source0-md5: 0126847f9e8cb8ed0b90a6a18b203309
+# Source0-md5: 2eccc2c7451397e01a13682600af9563
 Source1:       %{name}-dav_svn.conf
 Source2:       %{name}-authz_svn.conf
 Source3:       %{name}-svnserve.init
@@ -69,12 +68,11 @@ Patch1:             %{name}-DESTDIR.patch
 Patch2:                %{name}-ruby-datadir-path.patch
 Patch3:                %{name}-tests.patch
 Patch4:                x32-libdir.patch
-Patch5:                %{name}-rdoc.patch
-Patch6:                with_gnome_keyring_sefault.patch
 URL:           http://subversion.apache.org/
 %{?with_apache:BuildRequires:  apache-devel >= 2.4.14}
-BuildRequires: apr-devel >= 1:1.3
+BuildRequires: apr-devel >= 1:1.4
 BuildRequires: apr-util-devel >= 1:1.3
+BuildRequires: apr-util-crypto-openssl
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
 BuildRequires: bison
@@ -87,12 +85,12 @@ BuildRequires:      db-devel >= 4.1.25
 BuildRequires: expat-devel
 BuildRequires: gettext-tools
 %{?with_gnome:BuildRequires:   glib2-devel >= 2.0}
-%{?with_kde:BuildRequires:     kf5-kdelibs4supporti-devel}
-%{?with_kwallet:BuildRequires: kde4-kdelibs-devel}
+%{?with_kde:BuildRequires:     kf5-kdelibs4support-devel}
+%{?with_kwallet:BuildRequires: kf5-kwallet-devel}
 %{?with_gnome:BuildRequires:   libgnome-keyring-devel}
 %{?with_gnome:BuildRequires:   libsecret-devel}
 BuildRequires: libmagic-devel
-BuildRequires: libtool >= 1.4-9
+BuildRequires: libtool >= 2:2
 BuildRequires: libutf8proc-devel >= 1.3.1-4
 BuildRequires: lz4-devel
 BuildRequires: pkgconfig
@@ -106,8 +104,8 @@ BuildRequires:      texinfo
 BuildRequires: which
 BuildRequires: zlib-devel >= 1.2
 %if %{with java}
-BuildRequires: jdk >= 1.5
-BuildRequires: libstdc++-devel
+BuildRequires: jdk >= 1.8
+BuildRequires: libstdc++-devel >= 6:4.7
 %endif
 %if %{with perl}
 BuildRequires: perl-devel >= 1:5.8.0
@@ -115,8 +113,10 @@ BuildRequires:     rpm-perlprov >= 4.1-13
 BuildRequires: swig-perl >= 1.3.24
 %endif
 %if %{with python}
+BuildRequires: py3c
 BuildRequires: python-devel >= 1:2.4
-BuildRequires: swig-python >= 1.3.24
+BuildRequires: swig3-python >= 3.0.12
+BuildRequires: swig3-python < 4.0.0
 %endif
 %if %{with ruby}
 BuildRequires: rpm-rubyprov
@@ -181,7 +181,7 @@ System) na comunidade opensource, fornecendo grandes melhorias.
 Summary:       Subversion libraries and modules
 Summary(pl.UTF-8):     Biblioteka subversion oraz ładowalne moduły
 Group:         Libraries
-Requires:      apr >= 1:1.3
+Requires:      apr >= 1:1.4
 Requires:      apr-util >= 1:1.3
 Requires:      serf >= 1.3.4
 Requires:      zlib >= 1.2
@@ -200,6 +200,7 @@ Summary(pt_BR.UTF-8):       Arquivos de desenvolvimento para o Subversion
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      apr-util-devel >= 1:1.3
+Requires:      libutf8proc-devel >= 1.3.1-4
 Requires:      serf-devel >= 1.3.4
 Obsoletes:     libsubversion0-devel
 
@@ -261,7 +262,7 @@ Summary(pt_BR.UTF-8):       Módulos python para acessar os recursos do Subversion
 Group:         Applications
 Requires:      %{name} = %{version}-%{release}
 Requires:      python
-Requires:      python-subversion = %{version}
+%{?with_python:Requires:       python-subversion = %{version}}
 
 %description tools
 Subversion tools and scripts.
@@ -431,17 +432,17 @@ to authenticate using GNOME Keyring.
 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
 
-%package -n kde4-kwallet-subversion
+%package -n kde5-kwallet-subversion
 Summary:       KDE Wallet authentication provider for Subversion
 Summary(pl.UTF-8):     Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
 Group:         X11/Applications
 Requires:      %{name}-libs = %{version}-%{release}
 
-%description -n kde4-kwallet-subversion
+%description -n kde5-kwallet-subversion
 Authentication provider module for Subversion which allows SVN client
 to authenticate using KDE Wallet.
 
-%description -n kde4-kwallet-subversion -l pl.UTF-8
+%description -n kde5-kwallet-subversion -l pl.UTF-8
 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
 uwierzytelniać się przy użyciu Portfela KDE.
 
@@ -452,11 +453,23 @@ uwierzytelniać się przy użyciu Portfela KDE.
 %patch2 -p0
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
-%patch6 -p0
 
 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
 
+sed -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
+      tools/backup/hot-backup.py.in \
+      tools/examples/blame.py \
+      tools/examples/check-modified.py \
+      tools/examples/dumpprops.py \
+      tools/examples/get-location-segments.py \
+      tools/examples/getfile.py \
+      tools/examples/geturl.py \
+      tools/examples/putfile.py \
+      tools/examples/revplist.py \
+      tools/examples/svnlook.py \
+      tools/examples/svnshell.py \
+      tools/examples/walk-config-auth.py
+
 %build
 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
 #%{__rm} subversion/bindings/swig/proxy/*.swg
@@ -483,6 +496,9 @@ chmod +x ./autogen.sh && ./autogen.sh
 %if %{without swig}
        --without-swig \
 %endif
+%if %{with python}
+       --with-swig=/usr/bin/swig-3 \
+%endif
 %if %{with ruby}
        svn_cv_ruby_sitedir_libsuffix="" \
        svn_cv_ruby_sitedir_archsuffix="" \
@@ -691,8 +707,8 @@ rm -rf $RPM_BUILD_ROOT
 %post  -n gnome-keyring-subversion -p /sbin/ldconfig
 %postun        -n gnome-keyring-subversion -p /sbin/ldconfig
 
-%post  -n kde4-kwallet-subversion -p /sbin/ldconfig
-%postun        -n kde4-kwallet-subversion -p /sbin/ldconfig
+%post  -n kde5-kwallet-subversion -p /sbin/ldconfig
+%postun        -n kde5-kwallet-subversion -p /sbin/ldconfig
 
 %post svnserve
 /sbin/chkconfig --add svnserve
@@ -892,7 +908,7 @@ fi
 %endif
 
 %if %{with kwallet}
-%files -n kde4-kwallet-subversion
+%files -n kde5-kwallet-subversion
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
@@ -993,7 +1009,7 @@ fi
 %dir %{perl_vendorarch}/auto/SVN
 %dir %{perl_vendorarch}/auto/SVN/*
 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
-%{_mandir}/man3/*.3pm*
+%{_mandir}/man3/SVN::*.3pm*
 %endif
 
 %if %{with ruby}
This page took 0.069745 seconds and 4 git commands to generate.