]> git.pld-linux.org Git - packages/subversion.git/blobdiff - subversion.spec
- versioned Obsoletes
[packages/subversion.git] / subversion.spec
index 247c53b7996d08d3fd2f8ced8ec8a81f8794ff0f..273521f7f33d201be10bcaa3cdee6a4145c8f34d 100644 (file)
@@ -1,15 +1,17 @@
+# TODO: python3 module (using swig >= 4.0.0) instead of python2
+#
 # Conditional build:
 %bcond_with    net_client_only         # build only net client
 %bcond_without swig                    # disable bindings generation with Swig
-%bcond_without python                  # build without Python bindings (broken)
+%bcond_without python                  # build without Python bindings
 %bcond_without csvn                    # build Python csvn bindings
 %bcond_without perl                    # build without Perl bindings
-%bcond_without ruby                    # build without Ruby bindings
+%bcond_with    ruby                    # build without Ruby bindings
 %bcond_without apache                  # build without Apache support (webdav, etc)
 %bcond_without java                    # build without javahl support (Java high-level bindings)
-%bcond_without tests                   # don't perform "make check"
-%bcond_without kwallet                 # build without kde4 wallet support
-%bcond_without kde                     # build without kde4 support (alias for kwallet)
+%bcond_with    tests                   # don't perform "make check"
+%bcond_without kwallet                 # build without kde5 wallet support
+%bcond_without kde                     # build without kde5 support (alias for kwallet)
 %bcond_without gnome                   # build without gnome keyring support
 %bcond_without db                      # disable Subversion Berkeley DB based filesystem library
 %bcond_with    db6                     # allow BDB6 (not tested by upstream, released on AGPL)
 %define        pdir    SVN
 %define        pnam    _Core
 
-%{?with_perl:%include  /usr/lib/rpm/macros.perl}
+%define                use_jdk         openjdk8
+
 Summary:       A Concurrent Versioning system similar to but better than CVS
 Summary(pl.UTF-8):     System kontroli wersji podobny, ale lepszy, niż CVS
 Summary(pt_BR.UTF-8):  Sistema de versionamento concorrente
 Name:          subversion
-Version:       1.8.9
-Release:       2
+Version:       1.14.2
+Release:       1
 License:       Apache v2.0
 Group:         Development/Version Control
-Source0:       http://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
-# Source0-md5: bd495517a760ddd764ce449a891971db
+Source0:       https://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
+# Source0-md5: 9927b167d1c67d663ca63125907f6f69
 Source1:       %{name}-dav_svn.conf
 Source2:       %{name}-authz_svn.conf
 Source3:       %{name}-svnserve.init
@@ -67,10 +70,13 @@ Patch0:             %{name}-home_etc.patch
 Patch1:                %{name}-DESTDIR.patch
 Patch2:                %{name}-ruby-datadir-path.patch
 Patch3:                %{name}-tests.patch
+Patch4:                x32-libdir.patch
+Patch5:                %{name}-sh.patch
 URL:           http://subversion.apache.org/
-%{?with_apache:BuildRequires:  apache-devel >= 2.2.0-8}
-BuildRequires: apr-devel >= 1:1.0.0
-BuildRequires: apr-util-devel >= 1:1.2.8-3
+%{?with_apache:BuildRequires:  apache-devel >= 2.4.14}
+BuildRequires: apr-devel >= 1:1.4
+BuildRequires: apr-util-devel >= 1:1.3
+BuildRequires: apr-util-crypto-openssl
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
 BuildRequires: bison
@@ -78,25 +84,34 @@ BuildRequires:      cyrus-sasl-devel
 %if %{with kwallet} || %{with gnome}
 BuildRequires: dbus-devel
 %endif
+%{!?with_db6:BuildRequires:    db-devel < 6}
 BuildRequires: db-devel >= 4.1.25
 BuildRequires: expat-devel
-BuildRequires: gettext-devel
-%{?with_kwallet:BuildRequires: kde4-kdelibs-devel}
+BuildRequires: gettext-tools
+%{?with_gnome:BuildRequires:   glib2-devel >= 2.0}
+%{?with_kde:BuildRequires:     kf5-kdelibs4support-devel}
+%{?with_kwallet:BuildRequires: kf5-kwallet-devel}
 %{?with_gnome:BuildRequires:   libgnome-keyring-devel}
+%{?with_gnome:BuildRequires:   libsecret-devel}
 BuildRequires: libmagic-devel
-BuildRequires: libtool >= 1.4-9
+BuildRequires: libtool >= 2:2
+BuildRequires: libutf8proc-devel >= 1.3.1-4
+BuildRequires: lz4-devel
 BuildRequires: pkgconfig
-%{?with_csvn:BuildRequires:    python-ctypesgen}
+BuildRequires: python >= 1:2.7
+%{?with_csvn:BuildRequires:    python-ctypesgen >= 1.0.2}
+BuildRequires: rpm-build >= 4.6
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.656
+BuildRequires: rpmbuild(macros) >= 1.752
 BuildRequires: sed >= 4.0
-BuildRequires: serf-devel >= 1.2.1
-BuildRequires: sqlite3-devel >= 3.6.18
+BuildRequires: serf-devel >= 1.3.4
+BuildRequires: sqlite3-devel >= 3.8.11.1
 BuildRequires: texinfo
 BuildRequires: which
+BuildRequires: zlib-devel >= 1.2
 %if %{with java}
-BuildRequires: jdk >= 1.5
-BuildRequires: libstdc++-devel
+BuildRequires: openjdk8-jdk-base
+BuildRequires: libstdc++-devel >= 6:4.7
 %endif
 %if %{with perl}
 BuildRequires: perl-devel >= 1:5.8.0
@@ -104,15 +119,17 @@ BuildRequires:    rpm-perlprov >= 4.1-13
 BuildRequires: swig-perl >= 1.3.24
 %endif
 %if %{with python}
+BuildRequires: py3c
 BuildRequires: python-devel >= 1:2.4
-BuildRequires: swig-python >= 1.3.24
+BuildRequires: swig3-python >= 3.0.12
+BuildRequires: swig3-python < 4.0.0
 %endif
 %if %{with ruby}
 BuildRequires: rpm-rubyprov
 BuildRequires: ruby-devel >= 1:1.8.2
 BuildRequires: ruby-irb
 BuildRequires: ruby-rubygems
-BuildRequires: swig-ruby >= 1.3.24
+BuildRequires: swig-ruby >= 3.0.9
 %endif
 Requires:      %{name}-libs = %{version}-%{release}
 %requires_ge   sqlite3
@@ -122,7 +139,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
 %define                apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
 
-%define                skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
+%define                skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.* libsvn_fs_x-1.so.*
 
 %description
 The goal of the Subversion project is to build a version control
@@ -170,8 +187,11 @@ System) na comunidade opensource, fornecendo grandes melhorias.
 Summary:       Subversion libraries and modules
 Summary(pl.UTF-8):     Biblioteka subversion oraz ładowalne moduły
 Group:         Libraries
-Requires:      serf >= 1.2.1
-Obsoletes:     libsubversion0
+Requires:      apr >= 1:1.4
+Requires:      apr-util >= 1:1.3
+Requires:      serf >= 1.3.4
+Requires:      zlib >= 1.2
+Obsoletes:     libsubversion0 < 1
 
 %description libs
 Subversion libraries and modules.
@@ -185,9 +205,10 @@ Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
 Summary(pt_BR.UTF-8):  Arquivos de desenvolvimento para o Subversion
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
-Requires:      apr-util-devel >= 1:1.0.0
-Requires:      serf-devel >= 1.2.1
-Obsoletes:     libsubversion0-devel
+Requires:      apr-util-devel >= 1:1.3
+Requires:      libutf8proc-devel >= 1.3.1-4
+Requires:      serf-devel >= 1.3.4
+Obsoletes:     libsubversion0-devel < 1
 
 %description devel
 Header files and develpment documentation for subversion.
@@ -205,7 +226,7 @@ Summary(pl.UTF-8):  Biblioteka statyczna subversion
 Summary(pt_BR.UTF-8):  Sistema de versionamento concorrente
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}
-Obsoletes:     libsubversion0-static-devel
+Obsoletes:     libsubversion0-static-devel < 1
 
 %description static
 Static subversion library.
@@ -247,7 +268,6 @@ Summary(pt_BR.UTF-8):       Módulos python para acessar os recursos do Subversion
 Group:         Applications
 Requires:      %{name} = %{version}-%{release}
 Requires:      python
-Requires:      python-subversion = %{version}
 
 %description tools
 Subversion tools and scripts.
@@ -262,9 +282,7 @@ Group:              Applications/Shells
 Requires:      %{name} = %{version}-%{release}
 Requires:      bash-completion
 Conflicts:     %{name}-tools <= 1.1.0-0.rc6.1
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description -n bash-completion-subversion
 Bash completion for subversion.
@@ -298,7 +316,7 @@ Summary(pt_BR.UTF-8):       Módulos Python para acessar os recursos do Subversion
 Group:         Development/Languages/Python
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      python
-Obsoletes:     subversion-python
+Obsoletes:     subversion-python < 0.14.1
 
 %description -n python-subversion
 Subversion Python bindings.
@@ -332,7 +350,7 @@ Summary(pl.UTF-8):  Dowiązania do Subversion dla Perla
 Summary(pt_BR.UTF-8):  Módulos Perl para acessar os recursos do Subversion
 Group:         Development/Languages/Perl
 Requires:      %{name}-libs = %{version}-%{release}
-Obsoletes:     subversion-perl
+Obsoletes:     subversion-perl < 0.33.1-2
 
 %description -n perl-subversion
 Subversion Perl bindings.
@@ -349,7 +367,7 @@ Summary(pl.UTF-8):  Dowiązania do Subversion dla języka Ruby
 Summary(pt_BR.UTF-8):  Módulos Ruby para acessar os recursos do Subversion
 Group:         Development/Languages
 Requires:      %{name}-libs = %{version}-%{release}
-Obsoletes:     subversion-ruby
+Obsoletes:     subversion-ruby < 1.5.0-1
 
 %description -n ruby-subversion
 Subversion Ruby bindings.
@@ -417,17 +435,17 @@ to authenticate using GNOME Keyring.
 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
 
-%package -n kde4-kwallet-subversion
+%package -n kde5-kwallet-subversion
 Summary:       KDE Wallet authentication provider for Subversion
 Summary(pl.UTF-8):     Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
 Group:         X11/Applications
 Requires:      %{name}-libs = %{version}-%{release}
 
-%description -n kde4-kwallet-subversion
+%description -n kde5-kwallet-subversion
 Authentication provider module for Subversion which allows SVN client
 to authenticate using KDE Wallet.
 
-%description -n kde4-kwallet-subversion -l pl.UTF-8
+%description -n kde5-kwallet-subversion -l pl.UTF-8
 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
 uwierzytelniać się przy użyciu Portfela KDE.
 
@@ -437,35 +455,66 @@ uwierzytelniać się przy użyciu Portfela KDE.
 %patch1 -p1
 %patch2 -p0
 %patch3 -p1
+%patch4 -p1
+%patch5 -p1
 
 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
 
+sed -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
+       tools/backup/hot-backup.py.in \
+       tools/examples/blame.py \
+       tools/examples/check-modified.py \
+       tools/examples/dumpprops.py \
+       tools/examples/get-location-segments.py \
+       tools/examples/getfile.py \
+       tools/examples/geturl.py \
+       tools/examples/putfile.py \
+       tools/examples/revplist.py \
+       tools/examples/svnlook.py \
+       tools/examples/svnshell.py \
+       tools/examples/walk-config-auth.py
+
 %build
 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
 #%{__rm} subversion/bindings/swig/proxy/*.swg
 #cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
 chmod +x ./autogen.sh && ./autogen.sh
-%{__libtoolize}
+#{__libtoolize}
 %configure \
+       --disable-mod-activation \
+       --disable-runtime-module-search \
+       --with-apr=%{_bindir}/apr-1-config \
+       --with-apr-util=%{_bindir}/apu-1-config \
        --with-editor=vi \
+       --with-serf=%{_prefix} \
        --with-zlib=%{_libdir} \
-       --disable-runtime-module-search \
-       --disable-mod-activation \
+%if %{with apache}
+       --with-apache-libexecdir="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
+       --with-apxs=%{_sbindir}/apxs \
+%else
+       --without-apxs \
+%endif
 %if %{with db}
        --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
        %{?with_db6:--enable-bdb6} \
 %else
        --without-berkeley-db \
 %endif
-%if %{with apache}
-       --with-apache-libexecdir="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
-       --with-apxs=%{_sbindir}/apxs \
-%else
-       --without-apxs \
+%if %{with csvn}
+       --with-ctypesgen=%{_bindir}/ctypesgen-2 \
+%endif
+%if %{with gnome}
+       --with-gnome-keyring \
+%endif
+%if %{with kwallet}
+       --with-kwallet \
 %endif
 %if %{without swig}
        --without-swig \
 %endif
+%if %{with python}
+       --with-swig=/usr/bin/swig-3 \
+%endif
 %if %{with ruby}
        svn_cv_ruby_sitedir_libsuffix="" \
        svn_cv_ruby_sitedir_archsuffix="" \
@@ -473,27 +522,15 @@ chmod +x ./autogen.sh && ./autogen.sh
 %else
        ac_cv_path_RUBY=none \
 %endif
-%if %{with csvn}
-       --with-ctypesgen=%{_bindir}/ctypesgen.py \
-%endif
-%if %{with javahl}
+%if %{with java}
        --enable-javahl \
        --with-jdk="%{java_home}" \
        --without-jikes \
 %else
        --disable-javahl \
 %endif
-       --with-serf=%{_prefix} \
-       --with-apr=%{_bindir}/apr-1-config \
-       --with-apr-util=%{_bindir}/apu-1-config \
-%if %{with kwallet}
-       --with-kwallet \
-%endif
-%if %{with gnome}
-       --with-gnome-keyring
-%endif
 
-%{__make} -j1
+%{__make}
 
 %{__make} tools
 
@@ -515,7 +552,7 @@ cd subversion/bindings/swig/perl/native
 %{__make} -j1
 cd -
 %endif
-%if %{with javahl}
+%if %{with java}
 %{__make} -j1 javahl \
        javahl_javadir="%{_javadir}"
 %endif
@@ -549,11 +586,12 @@ install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
        $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
        $RPM_BUILD_ROOT/home/services/subversion{,/repos}
 
-%{__make} install -j1 \
+%{__make} -j1 install \
+       pkgconfig_dir=%{_pkgconfigdir} \
        toolsdir=%{_bindir} \
        DESTDIR=$RPM_BUILD_ROOT \
        APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
-%if %{with javahl}
+%if %{with java}
        install-javahl \
        javahl_javadir="%{_javadir}" \
 %endif
@@ -562,21 +600,26 @@ install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
        swig_pydir=%{py_sitedir}/libsvn \
        swig_pydir_extra=%{py_sitedir}/svn \
 %endif
+       install-tools
+
 %if %{with csvn}
-       install-ctypes-python \
+# manually execute install-ctypes-python target
+cd subversion/bindings/ctypes-python
+%py_install
+cd ../../..
 %endif
-       install-tools
 
 %if %{with ruby}
-%{__make} install -j1 \
+%{__make} -j1 install-swig-rb install-swig-rb-doc \
        SWIG_RB_RI_DATADIR=$RPM_BUILD_ROOT%{ruby_ridir} \
-       DESTDIR=$RPM_BUILD_ROOT \
-       install-swig-rb install-swig-rb-doc
+       DESTDIR=$RPM_BUILD_ROOT
 
 # not our package
 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
+%if "%{ruby_abi}" >= "2.0"
 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/File
+%endif
 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
 %endif
@@ -602,9 +645,9 @@ install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
 %endif
 
 # rename not to conflict with standard packages. (are these needed at all?)
-mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff
-mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff3
-mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff4
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/{,svn}diff
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/{,svn}diff3
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/{,svn}diff4
 
 %if %{with python} || %{with csvn}
 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
@@ -621,7 +664,7 @@ cp -p tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{versio
 cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
 cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
-%if %{with javahl}
+%if %{with java}
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}
 %endif
 %if %{with swig}
@@ -632,7 +675,7 @@ cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 %endif
 %if %{with gnome} || %{with kwallet}
 # dlopened by soname (libsvn_auth_*-1.so.0)
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la}
 %endif
 
 %find_lang %{name}
@@ -668,8 +711,8 @@ rm -rf $RPM_BUILD_ROOT
 %post  -n gnome-keyring-subversion -p /sbin/ldconfig
 %postun        -n gnome-keyring-subversion -p /sbin/ldconfig
 
-%post  -n kde4-kwallet-subversion -p /sbin/ldconfig
-%postun        -n kde4-kwallet-subversion -p /sbin/ldconfig
+%post  -n kde5-kwallet-subversion -p /sbin/ldconfig
+%postun        -n kde5-kwallet-subversion -p /sbin/ldconfig
 
 %post svnserve
 /sbin/chkconfig --add svnserve
@@ -718,10 +761,14 @@ fi
 %doc tools/hook-scripts/*.{pl,py,example}
 %doc tools/hook-scripts/mailer/*.{py,example}
 %doc tools/xslt/*
+%attr(755,root,root) %{_bindir}/fsfs-stats
 %attr(755,root,root) %{_bindir}/svn
+%attr(755,root,root) %{_bindir}/svn-mergeinfo-normalizer
 %attr(755,root,root) %{_bindir}/svnadmin
+%attr(755,root,root) %{_bindir}/svnconflict
 %attr(755,root,root) %{_bindir}/svndumpfilter
 %attr(755,root,root) %{_bindir}/svnlook
+%attr(755,root,root) %{_bindir}/svnmover
 %attr(755,root,root) %{_bindir}/svnmucc
 %attr(755,root,root) %{_bindir}/svnrdump
 %attr(755,root,root) %{_bindir}/svnsync
@@ -754,6 +801,8 @@ fi
 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
+%attr(755,root,root) %{_libdir}/libsvn_fs_x-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_x-1.so.0
 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
@@ -780,6 +829,7 @@ fi
 %endif
 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
+%attr(755,root,root) %{_libdir}/libsvn_fs_x-1.so
 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
 %attr(755,root,root) %{_libdir}/libsvn_ra_serf-1.so
@@ -796,6 +846,7 @@ fi
 %endif
 %{_libdir}/libsvn_fs_fs-1.la
 %{_libdir}/libsvn_fs_util-1.la
+%{_libdir}/libsvn_fs_x-1.la
 %{_libdir}/libsvn_ra-1.la
 %{_libdir}/libsvn_ra_local-1.la
 %{_libdir}/libsvn_ra_serf-1.la
@@ -803,6 +854,31 @@ fi
 %{_libdir}/libsvn_repos-1.la
 %{_libdir}/libsvn_subr-1.la
 %{_libdir}/libsvn_wc-1.la
+%if %{with gnome}
+# only for feature check, linking will fail (no libsvn_auth_gnome_keyring.so)
+%{_pkgconfigdir}/libsvn_auth_gnome_keyring.pc
+%endif
+%if %{with kwallet}
+# only for feature check, linking will fail (no libsvn_auth_kwallet.so)
+%{_pkgconfigdir}/libsvn_auth_kwallet.pc
+%endif
+%{_pkgconfigdir}/libsvn_client.pc
+%{_pkgconfigdir}/libsvn_delta.pc
+%{_pkgconfigdir}/libsvn_diff.pc
+%{_pkgconfigdir}/libsvn_fs.pc
+%if %{without net_client_only}
+%{_pkgconfigdir}/libsvn_fs_base.pc
+%endif
+%{_pkgconfigdir}/libsvn_fs_fs.pc
+%{_pkgconfigdir}/libsvn_fs_util.pc
+%{_pkgconfigdir}/libsvn_fs_x.pc
+%{_pkgconfigdir}/libsvn_ra.pc
+%{_pkgconfigdir}/libsvn_ra_local.pc
+%{_pkgconfigdir}/libsvn_ra_serf.pc
+%{_pkgconfigdir}/libsvn_ra_svn.pc
+%{_pkgconfigdir}/libsvn_repos.pc
+%{_pkgconfigdir}/libsvn_subr.pc
+%{_pkgconfigdir}/libsvn_wc.pc
 %{_includedir}/%{name}-1
 %{_examplesdir}/%{name}-%{version}
 
@@ -817,6 +893,7 @@ fi
 %endif
 %{_libdir}/libsvn_fs_fs-1.a
 %{_libdir}/libsvn_fs_util-1.a
+%{_libdir}/libsvn_fs_x-1.a
 %{_libdir}/libsvn_ra-1.a
 %{_libdir}/libsvn_ra_local-1.a
 %{_libdir}/libsvn_ra_serf-1.a
@@ -830,13 +907,17 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
+# does anything use it? requires libsvn_auth_gnome_keyring.so
+#%{_pkgconfigdir}/libsvn_auth_gnome_keyring.pc
 %endif
 
 %if %{with kwallet}
-%files -n kde4-kwallet-subversion
+%files -n kde5-kwallet-subversion
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
+# does anything use it? requires libsvn_auth_kwallet.so
+#%{_pkgconfigdir}/libsvn_auth_kwallet.pc
 %endif
 
 %if %{without net_client_only}
@@ -863,21 +944,20 @@ fi
 %attr(755,root,root) %{_bindir}/svndiff4
 
 # tools/server-side
-%attr(755,root,root) %{_bindir}/fsfs-stats
+%attr(755,root,root) %{_bindir}/svnfsfs
 %attr(755,root,root) %{_bindir}/svn-populate-node-origins-index
-%attr(755,root,root) %{_bindir}/svn-rep-sharing-stats
 %attr(755,root,root) %{_bindir}/svnauthz
 %attr(755,root,root) %{_bindir}/svnauthz-validate
 
 # tools/client-side
-%attr(755,root,root) %{_bindir}/svn-bench
+%attr(755,root,root) %{_bindir}/svnbench
 
 # tools/dev/svnraisetreeconflict
 %attr(755,root,root) %{_bindir}/svnraisetreeconflict
 
 # tools/dev/
 %attr(755,root,root) %{_bindir}/fsfs-access-map
-%attr(755,root,root) %{_bindir}/fsfs-reorg
+%attr(755,root,root) %{_bindir}/x509-parser
 
 %files -n bash-completion-subversion
 %defattr(644,root,root,755)
@@ -885,7 +965,7 @@ fi
 
 %endif # net_client_only
 
-%if %{with javahl}
+%if %{with java}
 %files -n java-subversion
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
@@ -933,8 +1013,7 @@ fi
 %dir %{perl_vendorarch}/auto/SVN
 %dir %{perl_vendorarch}/auto/SVN/*
 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
-%{perl_vendorarch}/auto/SVN/*/*.bs
-%{_mandir}/man3/*.3pm*
+%{_mandir}/man3/SVN::*.3pm*
 %endif
 
 %if %{with ruby}
This page took 1.207176 seconds and 4 git commands to generate.