]> git.pld-linux.org Git - packages/subversion.git/blobdiff - subversion.spec
- versioned Obsoletes
[packages/subversion.git] / subversion.spec
index 089036ed93b985ec363a3a7abf475098cd17e12b..273521f7f33d201be10bcaa3cdee6a4145c8f34d 100644 (file)
@@ -1,3 +1,4 @@
+# TODO: python3 module (using swig >= 4.0.0) instead of python2
 #
 # Conditional build:
 %bcond_with    net_client_only         # build only net client
 %define        pdir    SVN
 %define        pnam    _Core
 
+%define                use_jdk         openjdk8
+
 Summary:       A Concurrent Versioning system similar to but better than CVS
 Summary(pl.UTF-8):     System kontroli wersji podobny, ale lepszy, niż CVS
 Summary(pt_BR.UTF-8):  Sistema de versionamento concorrente
 Name:          subversion
-Version:       1.13.0
-Release:       4
+Version:       1.14.2
+Release:       1
 License:       Apache v2.0
 Group:         Development/Version Control
-Source0:       http://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
-# Source0-md5: 3004b4dae18bf45a0b6ea4ef8820064d
+Source0:       https://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
+# Source0-md5: 9927b167d1c67d663ca63125907f6f69
 Source1:       %{name}-dav_svn.conf
 Source2:       %{name}-authz_svn.conf
 Source3:       %{name}-svnserve.init
@@ -68,9 +71,10 @@ Patch1:              %{name}-DESTDIR.patch
 Patch2:                %{name}-ruby-datadir-path.patch
 Patch3:                %{name}-tests.patch
 Patch4:                x32-libdir.patch
+Patch5:                %{name}-sh.patch
 URL:           http://subversion.apache.org/
 %{?with_apache:BuildRequires:  apache-devel >= 2.4.14}
-BuildRequires: apr-devel >= 1:1.3
+BuildRequires: apr-devel >= 1:1.4
 BuildRequires: apr-util-devel >= 1:1.3
 BuildRequires: apr-util-crypto-openssl
 BuildRequires: autoconf >= 2.59
@@ -94,9 +98,11 @@ BuildRequires:       libtool >= 2:2
 BuildRequires: libutf8proc-devel >= 1.3.1-4
 BuildRequires: lz4-devel
 BuildRequires: pkgconfig
-%{?with_csvn:BuildRequires:    python-ctypesgen}
+BuildRequires: python >= 1:2.7
+%{?with_csvn:BuildRequires:    python-ctypesgen >= 1.0.2}
+BuildRequires: rpm-build >= 4.6
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.656
+BuildRequires: rpmbuild(macros) >= 1.752
 BuildRequires: sed >= 4.0
 BuildRequires: serf-devel >= 1.3.4
 BuildRequires: sqlite3-devel >= 3.8.11.1
@@ -104,7 +110,7 @@ BuildRequires:      texinfo
 BuildRequires: which
 BuildRequires: zlib-devel >= 1.2
 %if %{with java}
-BuildRequires: jdk >= 1.8
+BuildRequires: openjdk8-jdk-base
 BuildRequires: libstdc++-devel >= 6:4.7
 %endif
 %if %{with perl}
@@ -113,6 +119,7 @@ BuildRequires:      rpm-perlprov >= 4.1-13
 BuildRequires: swig-perl >= 1.3.24
 %endif
 %if %{with python}
+BuildRequires: py3c
 BuildRequires: python-devel >= 1:2.4
 BuildRequires: swig3-python >= 3.0.12
 BuildRequires: swig3-python < 4.0.0
@@ -122,7 +129,7 @@ BuildRequires:      rpm-rubyprov
 BuildRequires: ruby-devel >= 1:1.8.2
 BuildRequires: ruby-irb
 BuildRequires: ruby-rubygems
-BuildRequires: swig-ruby >= 1.3.24
+BuildRequires: swig-ruby >= 3.0.9
 %endif
 Requires:      %{name}-libs = %{version}-%{release}
 %requires_ge   sqlite3
@@ -180,11 +187,11 @@ System) na comunidade opensource, fornecendo grandes melhorias.
 Summary:       Subversion libraries and modules
 Summary(pl.UTF-8):     Biblioteka subversion oraz ładowalne moduły
 Group:         Libraries
-Requires:      apr >= 1:1.3
+Requires:      apr >= 1:1.4
 Requires:      apr-util >= 1:1.3
 Requires:      serf >= 1.3.4
 Requires:      zlib >= 1.2
-Obsoletes:     libsubversion0
+Obsoletes:     libsubversion0 < 1
 
 %description libs
 Subversion libraries and modules.
@@ -199,8 +206,9 @@ Summary(pt_BR.UTF-8):       Arquivos de desenvolvimento para o Subversion
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      apr-util-devel >= 1:1.3
+Requires:      libutf8proc-devel >= 1.3.1-4
 Requires:      serf-devel >= 1.3.4
-Obsoletes:     libsubversion0-devel
+Obsoletes:     libsubversion0-devel < 1
 
 %description devel
 Header files and develpment documentation for subversion.
@@ -218,7 +226,7 @@ Summary(pl.UTF-8):  Biblioteka statyczna subversion
 Summary(pt_BR.UTF-8):  Sistema de versionamento concorrente
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}
-Obsoletes:     libsubversion0-static-devel
+Obsoletes:     libsubversion0-static-devel < 1
 
 %description static
 Static subversion library.
@@ -260,7 +268,6 @@ Summary(pt_BR.UTF-8):       Módulos python para acessar os recursos do Subversion
 Group:         Applications
 Requires:      %{name} = %{version}-%{release}
 Requires:      python
-%{?with_python:Requires:       python-subversion = %{version}}
 
 %description tools
 Subversion tools and scripts.
@@ -275,9 +282,7 @@ Group:              Applications/Shells
 Requires:      %{name} = %{version}-%{release}
 Requires:      bash-completion
 Conflicts:     %{name}-tools <= 1.1.0-0.rc6.1
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description -n bash-completion-subversion
 Bash completion for subversion.
@@ -311,7 +316,7 @@ Summary(pt_BR.UTF-8):       Módulos Python para acessar os recursos do Subversion
 Group:         Development/Languages/Python
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      python
-Obsoletes:     subversion-python
+Obsoletes:     subversion-python < 0.14.1
 
 %description -n python-subversion
 Subversion Python bindings.
@@ -345,7 +350,7 @@ Summary(pl.UTF-8):  Dowiązania do Subversion dla Perla
 Summary(pt_BR.UTF-8):  Módulos Perl para acessar os recursos do Subversion
 Group:         Development/Languages/Perl
 Requires:      %{name}-libs = %{version}-%{release}
-Obsoletes:     subversion-perl
+Obsoletes:     subversion-perl < 0.33.1-2
 
 %description -n perl-subversion
 Subversion Perl bindings.
@@ -362,7 +367,7 @@ Summary(pl.UTF-8):  Dowiązania do Subversion dla języka Ruby
 Summary(pt_BR.UTF-8):  Módulos Ruby para acessar os recursos do Subversion
 Group:         Development/Languages
 Requires:      %{name}-libs = %{version}-%{release}
-Obsoletes:     subversion-ruby
+Obsoletes:     subversion-ruby < 1.5.0-1
 
 %description -n ruby-subversion
 Subversion Ruby bindings.
@@ -451,49 +456,65 @@ uwierzytelniać się przy użyciu Portfela KDE.
 %patch2 -p0
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
 
 sed -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
-      tools/backup/hot-backup.py \
-      tools/examples/blame.py \
-      tools/examples/check-modified.py \
-      tools/examples/dumpprops.py \
-      tools/examples/get-location-segments.py \
-      tools/examples/getfile.py \
-      tools/examples/geturl.py \
-      tools/examples/putfile.py \
-      tools/examples/revplist.py \
-      tools/examples/svnlook.py \
-      tools/examples/svnshell.py \
-      tools/examples/walk-config-auth.py
+       tools/backup/hot-backup.py.in \
+       tools/examples/blame.py \
+       tools/examples/check-modified.py \
+       tools/examples/dumpprops.py \
+       tools/examples/get-location-segments.py \
+       tools/examples/getfile.py \
+       tools/examples/geturl.py \
+       tools/examples/putfile.py \
+       tools/examples/revplist.py \
+       tools/examples/svnlook.py \
+       tools/examples/svnshell.py \
+       tools/examples/walk-config-auth.py
 
 %build
 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
 #%{__rm} subversion/bindings/swig/proxy/*.swg
 #cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
 chmod +x ./autogen.sh && ./autogen.sh
-%{__libtoolize}
+#{__libtoolize}
 %configure \
+       --disable-mod-activation \
+       --disable-runtime-module-search \
+       --with-apr=%{_bindir}/apr-1-config \
+       --with-apr-util=%{_bindir}/apu-1-config \
        --with-editor=vi \
+       --with-serf=%{_prefix} \
        --with-zlib=%{_libdir} \
-       --disable-runtime-module-search \
-       --disable-mod-activation \
+%if %{with apache}
+       --with-apache-libexecdir="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
+       --with-apxs=%{_sbindir}/apxs \
+%else
+       --without-apxs \
+%endif
 %if %{with db}
        --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
        %{?with_db6:--enable-bdb6} \
 %else
        --without-berkeley-db \
 %endif
-%if %{with apache}
-       --with-apache-libexecdir="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
-       --with-apxs=%{_sbindir}/apxs \
-%else
-       --without-apxs \
+%if %{with csvn}
+       --with-ctypesgen=%{_bindir}/ctypesgen-2 \
+%endif
+%if %{with gnome}
+       --with-gnome-keyring \
+%endif
+%if %{with kwallet}
+       --with-kwallet \
 %endif
 %if %{without swig}
        --without-swig \
 %endif
+%if %{with python}
+       --with-swig=/usr/bin/swig-3 \
+%endif
 %if %{with ruby}
        svn_cv_ruby_sitedir_libsuffix="" \
        svn_cv_ruby_sitedir_archsuffix="" \
@@ -501,9 +522,6 @@ chmod +x ./autogen.sh && ./autogen.sh
 %else
        ac_cv_path_RUBY=none \
 %endif
-%if %{with csvn}
-       --with-ctypesgen=%{_bindir}/ctypesgen.py \
-%endif
 %if %{with java}
        --enable-javahl \
        --with-jdk="%{java_home}" \
@@ -511,17 +529,8 @@ chmod +x ./autogen.sh && ./autogen.sh
 %else
        --disable-javahl \
 %endif
-       --with-serf=%{_prefix} \
-       --with-apr=%{_bindir}/apr-1-config \
-       --with-apr-util=%{_bindir}/apu-1-config \
-%if %{with kwallet}
-       --with-kwallet \
-%endif
-%if %{with gnome}
-       --with-gnome-keyring
-%endif
 
-%{__make} -j1
+%{__make}
 
 %{__make} tools
 
@@ -532,7 +541,6 @@ chmod +x ./autogen.sh && ./autogen.sh
 %if %{with python}
 # Python swig bindings
 %{__make} swig-py \
-       SWIG="swig-3" \
        swig_pydir=%{py_sitedir}/libsvn \
        swig_pydir_extra=%{py_sitedir}/svn
 %endif
This page took 0.557839 seconds and 4 git commands to generate.