]> git.pld-linux.org Git - packages/subversion.git/blobdiff - subversion.spec
-up to 1.7.16
[packages/subversion.git] / subversion.spec
index afb10b1375aac33748b9a8da5bc69cbf5faf916a..1abe60c5e658784d28f9067015519bec3dea6432 100644 (file)
@@ -1,42 +1,65 @@
 # TODO:
-# - remove net_client_only and add db bcond (then without apache and
-#   without db => net_client_only - spec will be more simpler, I think)
-# - finish ruby
-# - http://subversion.tigris.org/issues/show_bug.cgi?id=2753
+# - serf as default: https://subversion.apache.org/docs/release-notes/1.7.html#serf
 #
 # Conditional build:
 %bcond_with    net_client_only         # build only net client
 %bcond_without neon                    # use serf instead of neon
-%bcond_without python                  # build without python bindings (broken)
-%bcond_without perl                    # build without perl bindings
-%bcond_without ruby                    # build without ruby bindings
-%bcond_without apache                  # build without apache support (webdav, etc)
+%bcond_without swig                    # disable bindings generation with Swig
+%bcond_without python                  # build without Python bindings (broken)
+%bcond_without csvn                    # build Python csvn bindings
+%bcond_without perl                    # build without Perl bindings
+%bcond_without ruby                    # build without Ruby bindings
+%bcond_without apache                  # build without Apache support (webdav, etc)
 %bcond_without javahl                  # build without javahl support (Java high-level bindings)
 %bcond_without tests                   # don't perform "make check"
 %bcond_without kwallet                 # build without kde4 wallet support
+%bcond_without kde                     # build without kde4 support (alias for kwallet)
 %bcond_without gnome                   # build without gnome keyring support
-#
-%{!?with_net_client_only:%include      /usr/lib/rpm/macros.perl}
+%bcond_without db                      # disable Subversion Berkeley DB based filesystem library
+
+# for AC: --without csvn,gnome,javahl,kde,ruby
+
+%if %{with net_client_only}
+%undefine      with_apache
+%undefine      with_db
+%undefine      with_swig
+%undefine      with_javahl
+%endif
+
+%if %{without swig}
+%undefine      with_perl
+%undefine      with_python
+%undefine      with_ruby
+%endif
+
+%if %{without kde}
+%undefine      with_kwallet
+%endif
+
+%if %{without python} && %{without perl} && %{without ruby}
+%undefine      with_swig
+%endif
+
 %define        apxs    /usr/sbin/apxs
 %define        pdir    SVN
 %define        pnam    _Core
-#
+
 %if %{with neon}
 %define        webdavlib       neon
 %else
 %define        webdavlib       serf
 %endif
-#
+%{?with_perl:%include  /usr/lib/rpm/macros.perl}
 Summary:       A Concurrent Versioning system similar to but better than CVS
 Summary(pl.UTF-8):     System kontroli wersji podobny, ale lepszy, niż CVS
 Summary(pt_BR.UTF-8):  Sistema de versionamento concorrente
 Name:          subversion
-Version:       1.6.12
+Version:       1.7.16
 Release:       1
-License:       Apache/BSD-like
+License:       Apache v2.0
 Group:         Development/Version Control
-Source0:       http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
-# Source0-md5: a4b1d0d7f3a4587c59da9c1acf9dedd0
+Source0:       http://ftp.ps.pl/pub/apache/subversion/%{name}-%{version}.tar.bz2
+# Source0-md5: 70d633fc6bd173b419c92d5e494919a5
 Source1:       %{name}-dav_svn.conf
 Source2:       %{name}-authz_svn.conf
 Source3:       %{name}-svnserve.init
@@ -48,54 +71,58 @@ Source5:    %{name}-convert-typemaps-to-ifdef.py
 Patch0:                %{name}-home_etc.patch
 Patch1:                %{name}-DESTDIR.patch
 Patch2:                %{name}-ruby-datadir-path.patch
+Patch3:                %{name}-tests.patch
+Patch4:                subversion-1.7.2-ruby19.patch
 URL:           http://subversion.apache.org/
-%if %{with net_client_only}
-%global apache_modules_api 0
-%else
 %{?with_apache:BuildRequires:  apache-devel >= 2.2.0-8}
-BuildRequires: automake
-BuildRequires: db-devel >= 4.1.25
-BuildRequires: rpmbuild(macros) >= 1.559
-%if %{with perl}
-BuildRequires: perl-devel >= 1:5.8.0
-BuildRequires: rpm-perlprov >= 4.1-13
-BuildRequires: swig-perl >= 1.3.24
-%endif
-%if %{with python}
-BuildRequires: python-ctypesgen
-BuildRequires: python-devel >= 2.2
-BuildRequires: swig-python >= 1.3.24
-%endif
-%if %{with ruby}
-BuildRequires: ruby-devel
-BuildRequires: swig-ruby >= 1.3.24
-%endif
-%if %{with javahl}
-BuildRequires: jdk
-%endif
-BuildRequires: cyrus-sasl-devel
-%endif
 BuildRequires: apr-devel >= 1:1.0.0
 BuildRequires: apr-util-devel >= 1:1.2.8-3
 BuildRequires: autoconf >= 2.59
+BuildRequires: automake
 BuildRequires: bison
+BuildRequires: cyrus-sasl-devel
+%if %{with kwallet} || %{with gnome}
+BuildRequires: dbus-devel
+%endif
+BuildRequires: db-devel >= 4.1.25
 BuildRequires: expat-devel
 BuildRequires: gettext-devel
-%{?with_gnome:BuildRequires:   libgnome-keyring-devel}
 %{?with_kwallet:BuildRequires: kde4-kdelibs-devel}
+%{?with_gnome:BuildRequires:   libgnome-keyring-devel}
+BuildRequires: libmagic-devel
 BuildRequires: libtool >= 1.4-9
 BuildRequires: pkgconfig
+%{?with_csvn:BuildRequires:    python-ctypesgen}
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.656
 BuildRequires: sed >= 4.0
-BuildRequires: sqlite3-devel >= 3.6.11
+BuildRequires: sqlite3-devel >= 3.6.18
 BuildRequires: texinfo
 BuildRequires: which
 %if %{with neon}
 BuildRequires: neon-devel >= 0.26.0
 %else
-BuildRequires: serf-devel
+BuildRequires: serf-devel >= 0.7.1
+%endif
+%if %{with javahl}
+BuildRequires: jdk >= 1.5
+BuildRequires: libstdc++-devel
+%endif
+%if %{with perl}
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: swig-perl >= 1.3.24
+%endif
+%if %{with python}
+BuildRequires: python-devel >= 1:2.4
+BuildRequires: swig-python >= 1.3.24
+%endif
+%if %{with ruby}
+BuildRequires: rpm-rubyprov
+BuildRequires: ruby-devel >= 1:1.8.2
+BuildRequires: ruby-rubygems
+BuildRequires: swig-ruby >= 1.3.24
 %endif
-BuildRequires: python >= 2.2
-BuildRequires: python-modules >= 2.2
 Requires:      %{name}-libs = %{version}-%{release}
 %requires_ge   sqlite3
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -104,6 +131,8 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
 %define                apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
 
+%define                skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
+
 %description
 The goal of the Subversion project is to build a version control
 system that is a compelling replacement for CVS in the open source
@@ -150,7 +179,11 @@ System) na comunidade opensource, fornecendo grandes melhorias.
 Summary:       Subversion libraries and modules
 Summary(pl.UTF-8):     Biblioteka subversion oraz ładowalne moduły
 Group:         Libraries
-%{?with_neon:Requires: neon >= 0.26.0}
+%if %{with neon}
+Requires:      neon >= 0.26.0
+%else
+Requires:      serf >= 0.7.1
+%endif
 Obsoletes:     libsubversion0
 
 %description libs
@@ -225,8 +258,8 @@ Summary:    Subversion tools and scripts
 Summary(pl.UTF-8):     Narzędzia oraz skrypty dla subversion
 Summary(pt_BR.UTF-8):  Módulos python para acessar os recursos do Subversion
 Group:         Applications
-%pyrequires_eq python
 Requires:      %{name} = %{version}-%{release}
+Requires:      python
 Requires:      python-subversion = %{version}
 
 %description tools
@@ -273,8 +306,8 @@ Summary:    Subversion Python bindings
 Summary(pl.UTF-8):     Dowiązania do Subversion dla Pythona
 Summary(pt_BR.UTF-8):  Módulos Python para acessar os recursos do Subversion
 Group:         Development/Languages/Python
-%pyrequires_eq python
 Requires:      %{name}-libs = %{version}-%{release}
+Requires:      python
 Obsoletes:     subversion-python
 
 %description -n python-subversion
@@ -291,8 +324,8 @@ Summary:    CTypes Subversion Python bindings
 Summary(pl.UTF-8):     Dowiązania do Subversion dla Pythona
 Summary(pt_BR.UTF-8):  Módulos Python para acessar os recursos do Subversion
 Group:         Development/Languages/Python
-%pyrequires_eq python
 Requires:      %{name}-libs = %{version}-%{release}
+Requires:      python
 
 %description -n python-csvn
 Subversion CTypes Python bindings.
@@ -339,7 +372,7 @@ Módulos Ruby para acessar os recursos do Subversion.
 
 %package -n apache-mod_dav_svn
 Summary:       Apache module: Subversion Server
-Summary(pl.UTF-8):     Moduł apache: Serwer Subversion
+Summary(pl.UTF-8):     Moduł Apache'a: serwer Subversion
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
 Requires:      apache(modules-api) = %apache_modules_api
@@ -349,12 +382,13 @@ Requires: apache-mod_dav
 Apache module: Subversion Server.
 
 %description -n apache-mod_dav_svn -l pl.UTF-8
-Moduł apache: Serwer Subversion.
+Moduł Apache'a: serwer Subversion.
 
 %package -n apache-mod_authz_svn
 Summary:       Apache module: Subversion Server - path-based authorization
-Summary(pl.UTF-8):     Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
+Summary(pl.UTF-8):     Moduł Apache'a: autoryzacja na podstawie ścieżki dla serwera Subversion
 Group:         Networking/Daemons
+Requires:      %{name}-libs = %{version}-%{release}
 Requires:      apache(modules-api) = %apache_modules_api
 Requires:      apache-mod_dav_svn = %{version}-%{release}
 
@@ -362,36 +396,58 @@ Requires: apache-mod_dav_svn = %{version}-%{release}
 Apache module: Subversion Server - path-based authorization.
 
 %description -n apache-mod_authz_svn -l pl.UTF-8
-Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
+Moduł Apache'a: autoryzacja na podstawie ścieżki dla serwera
+Subversion.
+
+%package -n apache-mod_dontdothat_svn
+Summary:       Apache module: Allows you to block specific svn requests
+Summary(pl.UTF-8):     Moduł Apache'a pozwalający na blokowanie pewnych zapytań svn
+Group:         Networking/Daemons
+Requires:      %{name}-libs = %{version}-%{release}
+Requires:      apache(modules-api) = %apache_modules_api
+Requires:      apache-mod_dav_svn = %{version}-%{release}
+
+%description -n apache-mod_dontdothat_svn
+Apache module: Allows you to block specific svn requests.
+
+%description -n apache-mod_dontdothat_svn -l pl.UTF-8
+Moduł Apache'a pozwalający na blokowanie pewnych zapytań svn.
 
 %package -n gnome-keyring-subversion
-Summary:       Subversion module for Gnome Keyring
-Summary(pl.UTF-8):     Moduł subversion dla zarządcy kluczy Gnome
+Summary:       GNOME Keyring authentication provider for Subversion
+Summary(pl.UTF-8):     Moduł uwierzytelniający GNOME Keyring dla Subversion
 Group:         X11/Applications
+Requires:      %{name}-libs = %{version}-%{release}
 
 %description -n gnome-keyring-subversion
-Subversion module for Gnome Keyring.
+Authentication provider module for Subversion which allows SVN client
+to authenticate using GNOME Keyring.
 
 %description -n gnome-keyring-subversion -l pl.UTF-8
-Moduł subversion dla zarządcy kluczy Gnome.
+Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
+uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
 
 %package -n kde4-kwallet-subversion
-Summary:       Subversion module for KDE Wallet
-Summary(pl.UTF-8):     Moduł subversion dla Portfela KDE
+Summary:       KDE Wallet authentication provider for Subversion
+Summary(pl.UTF-8):     Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
 Group:         X11/Applications
+Requires:      %{name}-libs = %{version}-%{release}
 
 %description -n kde4-kwallet-subversion
-Subversion module for KDE Wallet.
+Authentication provider module for Subversion which allows SVN client
+to authenticate using KDE Wallet.
 
 %description -n kde4-kwallet-subversion -l pl.UTF-8
-Moduł subversion dla Portfela KDE.
+Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
+uwierzytelniać się przy użyciu Portfela KDE.
 
 %prep
 %setup -q
-rm -rf apr apr-util neon
 %patch0 -p0
 %patch1 -p1
 %patch2 -p0
+%patch3 -p1
+%patch4 -p1
 
 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
 
@@ -399,37 +455,46 @@ sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
 
 %build
-rm subversion/bindings/swig/proxy/*.swg
-cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
-cp -f /usr/share/automake/config.sub ac-helpers
+# disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
+#%{__rm} subversion/bindings/swig/proxy/*.swg
+#cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
 chmod +x ./autogen.sh && ./autogen.sh
-
+%{__libtoolize}
 %configure \
        --with-editor=vi \
        --with-zlib=%{_libdir} \
-%if %{with net_client_only}
-       --without-apache \
-       --without-swig \
-       --without-apxs \
-       --without-berkeley-db \
-%else
        --disable-runtime-module-search \
        --disable-mod-activation \
+%if %{with db}
        --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
+%else
+       --without-berkeley-db \
+%endif
 %if %{with apache}
        --with-apxs=%{_sbindir}/apxs \
 %else
-       --without-apache \
        --without-apxs \
 %endif
-%if !%{with python} && !%{with perl} && !%{with ruby}
+%if %{without swig}
        --without-swig \
 %endif
-       %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
-       --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
+%if %{with ruby}
+       svn_cv_ruby_sitedir_libsuffix="" \
+       svn_cv_ruby_sitedir_archsuffix="" \
+       --with-ruby-sitedir=%{ruby_vendorarchdir} \
+%else
+       ac_cv_path_RUBY=none \
+%endif
+%if %{with csvn}
+       --with-ctypesgen=%{_bindir}/ctypesgen.py \
 %endif
+%if %{with javahl}
+       --enable-javahl \
        --with-jdk="%{java_home}" \
        --without-jikes \
+%else
+       --disable-javahl \
+%endif
 %if %{with neon}
        --without-serf \
        --with-neon=%{_prefix} \
@@ -449,24 +514,25 @@ chmod +x ./autogen.sh && ./autogen.sh
 
 %{__make} -j1
 
-%if !%{with net_client_only}
-# python
-%if %{with python}
-# ctypes bindings
+%{__make} tools
+
+%if %{with csvn}
+# Python ctypes bindings
 %{__make} ctypes-python
-# swig bindings
+%endif
+%if %{with python}
+# Python swig bindings
 %{__make} swig-py \
        swig_pydir=%{py_sitedir}/libsvn \
        swig_pydir_extra=%{py_sitedir}/svn
 %endif
-# perl
 %if %{with perl}
+# Perl swig bindings
 %{__make} -j1 swig-pl-lib
-odir=$(pwd)
 cd subversion/bindings/swig/perl/native
 %{__perl} Makefile.PL INSTALLDIRS=vendor
 %{__make} -j1
-cd $odir
+cd -
 %endif
 %if %{with javahl}
 %{__make} -j1 javahl \
@@ -476,19 +542,21 @@ cd $odir
 %if %{with ruby}
 %{__make} swig-rb
 %endif
-%endif
 
 %if %{with tests}
-%{__make} check
+%{__make} -j1 check
+%if %{with csvn}
+%{__make} -j1 check-ctypes-python
+%endif
 %if %{with python}
-%{__make} check-ctypes-python
-%{__make} check-swig-py
+%{__make} -j1 check-swig-py
 %endif
 %if %{with perl}
-%{__make} check-swig-pl
+%{__make} -j1 check-swig-pl
 %endif
 %if %{with ruby}
-%{__make} check-swig-rb
+# disabled, see https://bugs.launchpad.net/pld-linux/+bug/734340
+#%{__make} check-swig-rb
 %endif
 %endif
 
@@ -497,28 +565,40 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
        $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
        $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
+       $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
        $RPM_BUILD_ROOT/home/services/subversion{,/repos}
 
 %{__make} install -j1 \
+       toolsdir=%{_bindir} \
+       DESTDIR=$RPM_BUILD_ROOT \
+       APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
 %if %{with javahl}
        install-javahl \
        javahl_javadir="%{_javadir}" \
 %endif
-%if !%{with net_client_only}
 %if %{with python}
        install-swig-py \
+       swig_pydir=%{py_sitedir}/libsvn \
+       swig_pydir_extra=%{py_sitedir}/svn \
+%endif
+%if %{with csvn}
        install-ctypes-python \
 %endif
+       install-tools
+
 %if %{with ruby}
+%{__make} install -j1 \
+       DESTDIR=$RPM_BUILD_ROOT \
        install-swig-rb install-swig-rb-doc \
+
+# not our package
+%{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
+%{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
+%{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
+%{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
 %endif
-%endif
-       APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
-       DESTDIR=$RPM_BUILD_ROOT \
-       swig_pydir=%{py_sitedir}/libsvn \
-       swig_pydir_extra=%{py_sitedir}/svn
 
-%if !%{with net_client_only} && %{with perl}
+%if %{with perl}
 %{__make} install-swig-pl-lib \
        DESTDIR=$RPM_BUILD_ROOT
 %{__make} -C subversion/bindings/swig/perl/native install \
@@ -528,30 +608,51 @@ install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
 %endif
 
 %if %{with apache}
-install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
-install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
-install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
-install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
+cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
+install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
 %endif
 
-%if !%{with net_client_only}
-install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
-%if %{with python}
+%if %{without net_client_only}
+install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
+%endif
+
+# rename not to conflict with standard packages. (are these needed at all?)
+mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff
+mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff3
+mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff4
+
+%if %{with python} || %{with csvn}
 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
-find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
-install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
+%py_postclean
 %endif
+%if %{with python}
+%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
+# .a created on ac only
+%{__rm} -f $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.a
+cp -p tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
 %endif
 
-install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
-install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
+cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
-%find_lang %{name}
+%if %{with javahl}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}
+%endif
+%if %{with swig}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
+%if %{with ruby}
+%{__rm} $RPM_BUILD_ROOT%{ruby_vendorarchdir}/svn/ext/*.la
+%endif
+%endif
+%if %{with gnome} || %{with kwallet}
+# dlopened by soname (libsvn_auth_*-1.so.0)
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
+%endif
 
-%{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
-rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
-rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
+%find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -569,12 +670,24 @@ rm -rf $RPM_BUILD_ROOT
 %postun        devel -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
+%post  -n java-subversion -p /sbin/ldconfig
+%postun        -n java-subversion -p /sbin/ldconfig
+
 %post  -n perl-subversion -p /sbin/ldconfig
 %postun        -n perl-subversion -p /sbin/ldconfig
 
 %post  -n python-subversion -p /sbin/ldconfig
 %postun        -n python-subversion -p /sbin/ldconfig
 
+%post  -n ruby-subversion -p /sbin/ldconfig
+%postun        -n ruby-subversion -p /sbin/ldconfig
+
+%post  -n gnome-keyring-subversion -p /sbin/ldconfig
+%postun        -n gnome-keyring-subversion -p /sbin/ldconfig
+
+%post  -n kde4-kwallet-subversion -p /sbin/ldconfig
+%postun        -n kde4-kwallet-subversion -p /sbin/ldconfig
+
 %post svnserve
 /sbin/chkconfig --add svnserve
 %service svnserve restart "svnserve daemon"
@@ -587,8 +700,8 @@ fi
 
 %postun svnserve
 if [ "$1" = "0" ]; then
-        %userremove svn
-        %groupremove svn
+       %userremove svn
+       %groupremove svn
 fi
 
 %post -n apache-mod_dav_svn
@@ -607,9 +720,17 @@ if [ "$1" = "0" ]; then
        %service -q httpd restart
 fi
 
+%post -n apache-mod_dontdothat_svn
+%service -q httpd restart
+
+%postun -n apache-mod_dontdothat_svn
+if [ "$1" = "0" ]; then
+       %service -q httpd restart
+fi
+
 %files
 %defattr(644,root,root,755)
-%doc BUGS CHANGES COPYING INSTALL README
+%doc BUGS CHANGES INSTALL README
 %doc doc/*/*.html
 %doc tools/hook-scripts/*.{pl,py,example}
 %doc tools/hook-scripts/mailer/*.{py,example}
@@ -617,18 +738,21 @@ fi
 %attr(755,root,root) %{_bindir}/svn
 %attr(755,root,root) %{_bindir}/svnadmin
 %attr(755,root,root) %{_bindir}/svndumpfilter
+%attr(755,root,root) %{_bindir}/svnrdump
 %attr(755,root,root) %{_bindir}/svnlook
 %attr(755,root,root) %{_bindir}/svnsync
 %attr(755,root,root) %{_bindir}/svnversion
 %{_mandir}/man1/svn.1*
 %{_mandir}/man1/svnadmin.1*
 %{_mandir}/man1/svndumpfilter.1*
+%{_mandir}/man1/svnrdump.1*
 %{_mandir}/man1/svnlook.1*
 %{_mandir}/man1/svnsync.1*
 %{_mandir}/man1/svnversion.1*
 
 %files libs -f %{name}.lang
 %defattr(644,root,root,755)
+%dir %{_sysconfdir}/%{name}
 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
@@ -637,8 +761,10 @@ fi
 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
+%if %{without net_client_only}
 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
+%endif
 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
@@ -664,7 +790,9 @@ fi
 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
+%if %{without net_client_only}
 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
+%endif
 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
@@ -678,7 +806,9 @@ fi
 %{_libdir}/libsvn_delta-1.la
 %{_libdir}/libsvn_diff-1.la
 %{_libdir}/libsvn_fs-1.la
+%if %{without net_client_only}
 %{_libdir}/libsvn_fs_base-1.la
+%endif
 %{_libdir}/libsvn_fs_fs-1.la
 %{_libdir}/libsvn_fs_util-1.la
 %{_libdir}/libsvn_ra-1.la
@@ -697,7 +827,9 @@ fi
 %{_libdir}/libsvn_delta-1.a
 %{_libdir}/libsvn_diff-1.a
 %{_libdir}/libsvn_fs-1.a
+%if %{without net_client_only}
 %{_libdir}/libsvn_fs_base-1.a
+%endif
 %{_libdir}/libsvn_fs_fs-1.a
 %{_libdir}/libsvn_fs_util-1.a
 %{_libdir}/libsvn_ra-1.a
@@ -722,7 +854,7 @@ fi
 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
 %endif
 
-%if !%{with net_client_only}
+%if %{without net_client_only}
 %files svnserve
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/svnserve
@@ -737,12 +869,30 @@ fi
 
 %files tools
 %defattr(644,root,root,755)
+# tools/backup/hot-backup.py
 %attr(755,root,root) %{_bindir}/svn-hot-backup
 
+# tools/diff
+%attr(755,root,root) %{_bindir}/svndiff
+%attr(755,root,root) %{_bindir}/svndiff3
+%attr(755,root,root) %{_bindir}/svndiff4
+
+# tools/server-side
+%attr(755,root,root) %{_bindir}/svn-populate-node-origins-index
+%attr(755,root,root) %{_bindir}/svn-rep-sharing-stats
+%attr(755,root,root) %{_bindir}/svnauthz-validate
+
+# tools/client-side/svnmucc
+%attr(755,root,root) %{_bindir}/svnmucc
+# tools/dev/svnraisetreeconflict
+%attr(755,root,root) %{_bindir}/svnraisetreeconflict
+
 %files -n bash-completion-subversion
 %defattr(644,root,root,755)
 /etc/bash_completion.d/%{name}
 
+%endif # net_client_only
+
 %if %{with javahl}
 %files -n java-subversion
 %defattr(644,root,root,755)
@@ -755,17 +905,19 @@ fi
 %if %{with python}
 %files -n python-subversion
 %defattr(644,root,root,755)
-%doc tools/backup/*.py tools/examples/*.py
+%doc tools/backup/*.py
 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
 %dir %{py_sitedir}/libsvn
+%attr(755,root,root) %{py_sitedir}/libsvn/_*.so
 %{py_sitedir}/libsvn/*.py[co]
 %dir %{py_sitedir}/svn
 %{py_sitedir}/svn/*.py[co]
-%attr(755,root,root) %{py_sitedir}/libsvn/*.so
 %{_examplesdir}/python-%{name}-%{version}
+%endif
 
+%if %{with csvn}
 %files -n python-csvn
 %defattr(644,root,root,755)
 %doc subversion/bindings/ctypes-python/{README,TODO}
@@ -776,7 +928,7 @@ fi
 %{py_sitescriptdir}/csvn/core/*.py[co]
 %dir %{py_sitescriptdir}/csvn/ext
 %{py_sitescriptdir}/csvn/ext/*.py[co]
-%{py_sitescriptdir}/*.egg-info
+%{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
 %endif
 
 %if %{with perl}
@@ -799,11 +951,10 @@ fi
 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
-%dir %{ruby_sitelibdir}/svn
-%{ruby_sitelibdir}/svn/*.rb
-%dir %{ruby_sitearchdir}/svn
-%dir %{ruby_sitearchdir}/svn/ext
-%attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
+%dir %{ruby_vendorarchdir}/svn
+%{ruby_vendorarchdir}/svn/*.rb
+%dir %{ruby_vendorarchdir}/svn/ext
+%attr(755,root,root) %{ruby_vendorarchdir}/svn/ext/*.so
 %{ruby_ridir}/Svn
 %endif
 
@@ -818,6 +969,9 @@ fi
 %doc subversion/mod_authz_svn/INSTALL
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
-%endif
 
-%endif # net_client_only
+%files -n apache-mod_dontdothat_svn
+%defattr(644,root,root,755)
+%doc tools/server-side/mod_dontdothat/README
+%attr(755,root,root) %{apachelibdir}/mod_dontdothat.so
+%endif
This page took 0.152299 seconds and 4 git commands to generate.