]> git.pld-linux.org Git - packages/subversion.git/blame - subversion.spec
- pl for java-
[packages/subversion.git] / subversion.spec
CommitLineData
1f630180 1# TODO:
1930bef0 2# - remove net_client_only and add db bcond (then without apache and
3# without db => net_client_only - spec will be more simpler, I think)
4#
bab73684 5# Conditional build:
65c1d4bd
JB
6%bcond_with net_client_only # build only net client
7%bcond_without python # build without python bindings (broken)
8%bcond_without perl # build without perl bindings
9%bcond_without apache # build without apache support (webdav, etc)
10%bcond_without javahl # build without javahl support (Java high-level bindings)
11%bcond_without tests # don't perform "make check"
7b27380f 12#
b56474ff 13%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
f4070f5f 14%define apxs /usr/sbin/apxs
1f630180
ER
15%define pdir SVN
16%define pnam _Core
12ae68c1
AM
17#
18%define snap rc4
67cb9518 19Summary: A Concurrent Versioning system similar to but better than CVS
abe3c421
ER
20Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
21Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127 22Name: subversion
12ae68c1
AM
23Version: 1.5.0
24Release: 0.%{snap}.1
6f88d80e 25License: Apache/BSD-like
93b78127 26Group: Development/Version Control
12ae68c1
AM
27# Source0: http://subversion.tigris.org/downloads/%{name}-%{version}.tar.gz
28Source0: http://orac.ece.utexas.edu/pub/svn/%{version}-%{snap}/leander-hackberry/%{name}-%{version}-%{snap}.tar.gz
29# Source0-md5: 905fc5030be179d4d387803b8397668a
93b78127 30Source1: %{name}-dav_svn.conf
65318afa 31Source2: %{name}-authz_svn.conf
b56474ff
AM
32Source3: %{name}-svnserve.init
33Source4: %{name}-svnserve.sysconfig
f313e9a9 34Source5: %{name}-convert-typemaps-to-ifdef.py
ed6210a2 35Patch0: %{name}-home_etc.patch
d4bccc60 36Patch1: %{name}-DESTDIR.patch
93b78127 37URL: http://subversion.tigris.org/
4945947e
AM
38%if %{with net_client_only}
39%global apache_modules_api 0
40%else
f2a757d6 41%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
7b27380f 42BuildRequires: automake
3817faf5 43BuildRequires: db-devel >= 4.1.25
e8d9186f 44BuildRequires: rpmbuild(macros) >= 1.268
0905b458 45%if %{with perl}
522a69b4 46BuildRequires: perl-devel >= 1:5.8.0
47BuildRequires: rpm-perlprov >= 4.1-13
15f9818d 48BuildRequires: swig-perl >= 1.3.24
536b3fd3 49%endif
1cc7453a 50%{?with_javahl:BuildRequires: jdk}
0905b458 51%endif
16429189 52BuildRequires: apr-devel >= 1:1.0.0
a6ecf312 53BuildRequires: apr-util-devel >= 1:1.2.8-3
b0a7a5b2 54BuildRequires: autoconf >= 2.59
79d8c53c 55BuildRequires: bison
12ae68c1 56BuildRequires: cyrus-sasl-devel
93b78127 57BuildRequires: expat-devel
86ea8fde 58BuildRequires: gettext-devel
f4e6a380 59BuildRequires: libtool >= 1.4-9
bd3c99a8 60BuildRequires: neon-devel >= 0.26.0
53855fbf 61BuildRequires: python >= 2.2
ed6210a2 62BuildRequires: python-modules >= 2.2
f313e9a9 63%if %{with python}
64BuildRequires: python-devel >= 2.2
1f16145f 65BuildRequires: sed >= 4.0
15f9818d 66BuildRequires: swig-python >= 1.3.24
0905b458 67%endif
93b78127 68BuildRequires: texinfo
7b35d179 69BuildRequires: which
027f8ebe 70Requires: %{name}-libs = %{version}-%{release}
93b78127
AM
71BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
f4070f5f 73%define _libexecdir %{_libdir}/svn
1af5e34d
ER
74%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
75%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
93b78127
AM
76
77%description
78The goal of the Subversion project is to build a version control
79system that is a compelling replacement for CVS in the open source
80community.
81
82Our goals are:
83- All current CVS features.
84- Directories, renames, and file meta-data are versioned.
85- Symbolic links, etc, are supported
86- Commits are truly atomic.
87- Branching and tagging are cheap (constant time) operations
88- Repeated merges are handled gracefully
89- Support for plug-in client side diff programs
90- Natively client/server
91- Client/server protocol sends diffs in both directions
92- Costs are proportional to change size, not project size
93- Internationalization
94- Progressive multi-lingual support
95
aa59005f 96%description -l pl.UTF-8
93b78127
AM
97Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
98zamiennika dla CVS.
99
100Cele projektu to:
aa59005f 101- Wszystkie aktualne możliwości CVS.
24406120
JB
102- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
103- Obsługa dowiązań symbolicznych itp.
aa59005f
JR
104- Commity są w pełni atomowe.
105- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
24406120
JB
106- Dobra obsługa powtarzanego łączenia (merge).
107- Obsługa wtyczek diff po stronie klienta.
93b78127 108- Natywny klient/serwer.
aa59005f 109- Klient/Serwer przesyłają diffy w obu kierunkach.
93b78127
AM
110- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
111- Internacjonalizacja.
aa59005f 112- Postępujące wsparcie dla wielu języków.
93b78127 113
aa59005f
JR
114%description -l pt_BR.UTF-8
115O objetivo do projeto Subversion é construir um sistema de controle de
116versões que seja um substituto para o CVS (Concurrent Versioning
92066deb 117System) na comunidade opensource, fornecendo grandes melhorias.
118
f4e6a380
AM
119%package libs
120Summary: Subversion libraries and modules
abe3c421 121Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
f4e6a380 122Group: Libraries
24406120 123Requires: neon >= 0.26.0
53855fbf 124Obsoletes: libsubversion0
f4e6a380
AM
125
126%description libs
127Subversion libraries and modules.
128
aa59005f
JR
129%description libs -l pl.UTF-8
130Biblioteka subversion oraz ładowalne moduły.
f4e6a380 131
93b78127
AM
132%package devel
133Summary: Header files and develpment documentation for subversion
abe3c421
ER
134Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
135Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
93b78127 136Group: Development/Libraries
9cb7e099 137Requires: %{name}-libs = %{version}-%{release}
c5b1d686 138Requires: apr-util-devel >= 1:1.0.0
24406120 139Requires: neon-devel >= 0.26.0
12cf252c 140Obsoletes: libsubversion0-devel
93b78127
AM
141
142%description devel
143Header files and develpment documentation for subversion.
144
aa59005f
JR
145%description devel -l pl.UTF-8
146Pliki nagłówkowe i dokumetacja do subversion.
93b78127 147
aa59005f
JR
148%description devel -l pt_BR.UTF-8
149Este pacote provê os arquivos necessários para desenvolvedores
92066deb 150interagirem com o Subversion.
151
93b78127
AM
152%package static
153Summary: Static subversion library
abe3c421
ER
154Summary(pl.UTF-8): Biblioteka statyczna subversion
155Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127
AM
156Group: Development/Libraries
157Requires: %{name}-devel = %{version}
12cf252c 158Obsoletes: libsubversion0-static-devel
93b78127
AM
159
160%description static
161Static subversion library.
162
aa59005f 163%description static -l pl.UTF-8
93b78127
AM
164Biblioteka statyczna subversion.
165
aa59005f
JR
166%description static -l pt_BR.UTF-8
167Este pacote provê um cliente estático do subversion.
92066deb 168
b56474ff
AM
169%package svnserve
170Summary: Subversion svnserve
abe3c421 171Summary(pl.UTF-8): Subversion svnserve
b56474ff 172Group: Networking/Daemons
3817faf5 173Requires(post,preun): /sbin/chkconfig
93f1d402 174Requires(postun): /usr/sbin/groupdel
175Requires(postun): /usr/sbin/userdel
176Requires(pre): /bin/id
177Requires(pre): /usr/bin/getgid
178Requires(pre): /usr/lib/rpm/user_group.sh
179Requires(pre): /usr/sbin/groupadd
180Requires(pre): /usr/sbin/useradd
181Requires(pre): /usr/sbin/usermod
9cb7e099 182Requires: %{name} = %{version}-%{release}
7b27380f 183Requires: rc-scripts
a1bac09d
184Provides: group(svn)
185Provides: user(svn)
b56474ff
AM
186
187%description svnserve
188Subversion svnserve server.
189
aa59005f 190%description svnserve -l pl.UTF-8
b56474ff
AM
191Serwer subversion svnserve.
192
4bbdbbf8
AM
193%package tools
194Summary: Subversion tools and scripts
abe3c421
ER
195Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
196Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
4bbdbbf8 197Group: Applications
4bbdbbf8 198%pyrequires_eq python
7b27380f 199Requires: %{name} = %{version}-%{release}
1271c9bd 200Requires: python-rcsparse >= 0.1-0.20031026.0
4bbdbbf8
AM
201Requires: python-subversion = %{version}
202
203%description tools
204Subversion tools and scripts.
205
aa59005f
JR
206%description tools -l pl.UTF-8
207Narzędzia oraz skrypty dla subversion.
4bbdbbf8 208
fe5bb6bb 209%package -n bash-completion-subversion
210Summary: bash completion for subversion
abe3c421 211Summary(pl.UTF-8): Dopełnienia basha dla subversion
fe5bb6bb 212Group: Applications/Shells
e30588c4 213Requires: %{name} = %{version}-%{release}
53855fbf 214Requires: bash-completion
e30588c4 215Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
fe5bb6bb 216
217%description -n bash-completion-subversion
218Bash completion for subversion.
219
aa59005f
JR
220%description -n bash-completion-subversion -l pl.UTF-8
221Dopełnienia basha dla subversion.
fe5bb6bb 222
1cc7453a 223%package -n java-subversion
65c1d4bd
JB
224Summary: Subversion Java bindings
225Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
1cc7453a 226Group: Development/Languages/Java
227Requires: %{name}-libs = %{version}-%{release}
228
229%description -n java-subversion
230This is a set of Java classes which provide the functionality of
231subversion-libs, the Subversion libraries. It is useful if you want
232to, for example, write a Java class that manipulates a Subversion
233repository or working copy. See the 'subversion' package for more
234information.
235
65c1d4bd
JB
236%description -n java-subversion -l pl.UTF-8
237Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
238subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
239pisaniu klas Javy np. modyfikujących repozytorium Subversion lub
240kopię roboczą. Więcej informacji w pakiecie subversion.
241
fa3ff1b2 242%package -n python-subversion
65c1d4bd
JB
243Summary: Subversion Python bindings
244Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
245Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
f4e6a380 246Group: Development/Languages/Python
f4e6a380 247%pyrequires_eq python
9cb7e099 248Requires: %{name}-libs = %{version}-%{release}
53855fbf 249Obsoletes: subversion-python
f4e6a380 250
fa3ff1b2 251%description -n python-subversion
65c1d4bd 252Subversion Python bindings.
f4e6a380 253
aa59005f 254%description -n python-subversion -l pl.UTF-8
65c1d4bd 255Dowiązania do Subversion dla Pythona.
f4e6a380 256
aa59005f 257%description -n python-subversion -l pt_BR.UTF-8
65c1d4bd 258Módulos Python para acessar os recursos do Subversion.
92066deb 259
b56474ff 260%package -n perl-subversion
65c1d4bd
JB
261Summary: Subversion Perl bindings
262Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
263Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
b56474ff 264Group: Development/Languages/Perl
9cb7e099 265Requires: %{name}-libs = %{version}-%{release}
53855fbf 266Obsoletes: subversion-perl
b56474ff
AM
267
268%description -n perl-subversion
65c1d4bd 269Subversion Perl bindings.
b56474ff 270
aa59005f 271%description -n perl-subversion -l pl.UTF-8
65c1d4bd 272Dowiązania do Subversion dla Perla.
b56474ff 273
aa59005f 274%description -n perl-subversion -l pt_BR.UTF-8
65c1d4bd 275Módulos Perl para acessar os recursos do Subversion.
b56474ff 276
93b78127
AM
277%package -n apache-mod_dav_svn
278Summary: Apache module: Subversion Server
abe3c421 279Summary(pl.UTF-8): Moduł apache: Serwer Subversion
93b78127 280Group: Networking/Daemons
7b27380f 281Requires: %{name} = %{version}-%{release}
53855fbf 282Requires: apache(modules-api) = %apache_modules_api
7887b1ac 283Requires: apache-mod_dav
93b78127
AM
284
285%description -n apache-mod_dav_svn
286Apache module: Subversion Server.
287
aa59005f
JR
288%description -n apache-mod_dav_svn -l pl.UTF-8
289Moduł apache: Serwer Subversion.
93b78127 290
65318afa
AF
291%package -n apache-mod_authz_svn
292Summary: Apache module: Subversion Server - path-based authorization
abe3c421 293Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
65318afa 294Group: Networking/Daemons
53855fbf 295Requires: apache(modules-api) = %apache_modules_api
9cb7e099 296Requires: apache-mod_dav_svn = %{version}-%{release}
65318afa
AF
297
298%description -n apache-mod_authz_svn
299Apache module: Subversion Server - path-based authorization.
300
aa59005f
JR
301%description -n apache-mod_authz_svn -l pl.UTF-8
302Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
e23909be 303
93b78127 304%prep
12ae68c1 305%setup -q -n %{name}-%{version}-%{snap}
e30588c4 306rm -rf apr apr-util neon
ed6210a2 307%patch0 -p0
d4bccc60 308%patch1 -p1
027f8ebe 309
93b78127 310%build
93f1d402 311rm subversion/bindings/swig/proxy/*.swg
24406120 312cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
a7bcb345 313cp -f /usr/share/automake/config.sub ac-helpers
67cb9518 314chmod +x ./autogen.sh && ./autogen.sh
8a3d9172 315
fa3ff1b2 316# don't enable dso - currently it's broken
93b78127 317%configure \
5dfeafd7 318 --with-editor=vi \
12ae68c1 319 --with-zlib=%{_libdir} \
93f1d402 320 --with-python=%{__python} \
321 --with-perl5=%{__perl} \
536b3fd3
AM
322%if %{with net_client_only}
323 --without-apache \
324 --without-swig \
325 --without-apxs \
326 --without-berkeley-db \
327%else
227d7ab4 328 --disable-dso \
86ee97d3 329 --disable-mod-activation \
0905b458 330%if %{with apache}
536b3fd3 331 --with-apxs=%{_sbindir}/apxs \
0905b458 332%else
333 --without-apache \
334 --without-apxs \
536b3fd3 335 --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
0905b458 336%endif
cf353d53 337%if !%{with python} && !%{with perl}
0905b458 338 --without-swig \
339%endif
1cc7453a 340 --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
536b3fd3 341%endif
1cc7453a 342 --with-jdk="%{java_home}" \
e30588c4 343 --with-neon=%{_prefix} \
78f330c4 344 --disable-neon-version-check \
16429189 345 --with-apr=%{_bindir}/apr-1-config \
346 --with-apr-util=%{_bindir}/apu-1-config
536b3fd3 347
1f630180 348%{__make} -j1
536b3fd3 349
cf353d53 350%if !%{with net_client_only}
b56474ff 351# python
0905b458 352%if %{with python}
86a4919e 353%{__make} swig-py \
65318afa
AF
354 swig_pydir=%{py_sitedir}/libsvn \
355 swig_pydir_extra=%{py_sitedir}/svn
0905b458 356%endif
b56474ff 357# perl
0905b458 358%if %{with perl}
bf539998
AM
359%{__make} swig-pl-lib
360odir=$(pwd)
361cd subversion/bindings/swig/perl/native
362%{__perl} Makefile.PL INSTALLDIRS=vendor
363%{__make}
364cd $odir
536b3fd3 365%endif
1cc7453a 366%if %{with javahl}
367%{__make} javahl \
368 javahl_javadir="%{_javadir}"
369%endif
12ae68c1
AM
370%endif
371
372%if %{with tests}
373%{__make} check
0905b458 374%endif
93b78127
AM
375
376%install
377rm -rf $RPM_BUILD_ROOT
1326bb99 378install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
1af5e34d 379 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
afb35189 380 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
a54611db 381 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
93b78127 382
1f630180 383%{__make} install -j1 \
1cc7453a 384%if %{with javahl}
385 install-javahl \
386 javahl_javadir="%{_javadir}" \
387%endif
cf353d53 388%if !%{with net_client_only} && %{with python}
0905b458 389 install-swig-py \
390%endif
f2a757d6 391 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
86a4919e 392 DESTDIR=$RPM_BUILD_ROOT \
65318afa
AF
393 swig_pydir=%{py_sitedir}/libsvn \
394 swig_pydir_extra=%{py_sitedir}/svn
93b78127 395
cf353d53 396%if !%{with net_client_only} && %{with perl}
bf539998
AM
397%{__make} install-swig-pl-lib \
398 DESTDIR=$RPM_BUILD_ROOT
399odir=$(pwd)
400cd subversion/bindings/swig/perl/native
401%{__make} install \
402 DESTDIR=$RPM_BUILD_ROOT \
403 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
404 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
405cd $odir
406%endif
407
0905b458 408%if %{with apache}
1af5e34d
ER
409install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
410install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
b56474ff
AM
411install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
412install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
0905b458 413%endif
93b78127 414
cf353d53 415%if !%{with net_client_only}
1326bb99 416install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
0905b458 417%if %{with python}
f4e6a380
AM
418%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
419%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1326bb99
JK
420find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
421install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
536b3fd3 422%endif
0905b458 423%endif
f4e6a380 424
1326bb99
JK
425install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
426install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
1326bb99 427
205a3ddc
AM
428%find_lang %{name}
429
a6ecf312 430rm -f $RPM_BUILD_ROOT%{_libdir}/lib*swig*.la
431
e23909be
JB
432%clean
433rm -rf $RPM_BUILD_ROOT
434
a1bac09d
435%pre svnserve
436%groupadd -g 86 svn
437%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
438
6f99c3bd
ER
439%post devel -p /sbin/postshell
440-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 441
6f99c3bd
ER
442%postun devel -p /sbin/postshell
443-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 444
e23909be
JB
445%post libs -p /sbin/ldconfig
446%postun libs -p /sbin/ldconfig
164f681b
AM
447%post -n python-subversion -p /sbin/ldconfig
448%postun -n perl-subversion -p /sbin/ldconfig
f4e6a380 449
b56474ff 450%post svnserve
e8d9186f
ER
451/sbin/chkconfig --add svnserve
452%service svnserve restart "svnserve daemon"
453
b56474ff
AM
454%preun svnserve
455if [ "$1" = "0" ]; then
e8d9186f
ER
456 %service svnserve stop
457 /sbin/chkconfig --del svnserve
b56474ff
AM
458fi
459
a1bac09d
460%postun svnserve
461if [ "$1" = "0" ]; then
462 %userremove svn
463 %groupremove svn
464fi
465
93b78127 466%post -n apache-mod_dav_svn
e8d9186f 467%service -q httpd restart
93b78127
AM
468
469%preun -n apache-mod_dav_svn
470if [ "$1" = "0" ]; then
e8d9186f 471 %service -q httpd restart
93b78127
AM
472fi
473
93b78127
AM
474%files
475%defattr(644,root,root,755)
983a49f6 476%doc BUGS CHANGES COPYING INSTALL README
d37298dc 477%doc doc/*/*.html
4bbdbbf8
AM
478%doc tools/hook-scripts/*.{pl,py,example}
479%doc tools/hook-scripts/mailer/*.{py,example}
1326bb99 480%doc tools/xslt/*
fa3ff1b2 481%attr(755,root,root) %{_bindir}/svn*
b56474ff 482%exclude %{_bindir}/svnserve
cf353d53 483%if !%{with net_client_only}
9cb7e099 484%exclude %{_bindir}/svn-hot-backup
d62de3c9 485%endif
f4e6a380 486%{_mandir}/man1/*
af654ba5
AM
487%{_mandir}/man5/*
488%{_mandir}/man8/*
b56474ff 489%exclude %{_mandir}/man?/svnserve*
f4e6a380 490
205a3ddc 491%files libs -f %{name}.lang
f4e6a380 492%defattr(644,root,root,755)
227d7ab4 493%attr(755,root,root) %{_libdir}/lib*.so.*
164f681b
AM
494%if %{with perl} || %{with python}
495%exclude %{_libdir}/lib*_swig_*.so.*
496%endif
1cc7453a 497%if %{with javahl}
498%exclude %{_libdir}/libsvnjavahl*.so.*.*.*
499%exclude %{_libdir}/libsvnjavahl*.so.?
500%exclude %{_libdir}/libsvnjavahl*.so
501%endif
93b78127
AM
502
503%files devel
504%defattr(644,root,root,755)
227d7ab4
AM
505%{_includedir}/%{name}*
506%attr(755,root,root) %{_libdir}/lib*.so
b2bcb22a 507%{_libdir}/lib*.la
b72a2fbb 508%if %{with perl} || %{with python}
c00fdf6f 509%exclude %{_libdir}/lib*_swig_*.so
b72a2fbb 510%endif
1cc7453a 511%if %{with javahl}
512%exclude %{_libdir}/libsvnjavahl*.so
513%endif
1326bb99 514%{_examplesdir}/%{name}-%{version}
93b78127
AM
515
516%files static
517%defattr(644,root,root,755)
518%{_libdir}/lib*.a
519
cf353d53 520%if !%{with net_client_only}
b56474ff
AM
521%files svnserve
522%defattr(644,root,root,755)
523%attr(755,root,root) %{_bindir}/svnserve
524%{_mandir}/man?/svnserve*
a1bac09d
525%dir %attr(750,svn,svn) /home/services/subversion
526%dir %attr(750,svn,svn) /home/services/subversion/repos
0905b458 527%if %{with apache}
b56474ff 528%attr(754,root,root) /etc/rc.d/init.d/svnserve
86ea8fde 529%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
0905b458 530%endif
b56474ff 531
4bbdbbf8
AM
532%files tools
533%defattr(644,root,root,755)
1326bb99 534%attr(755,root,root) %{_bindir}/svn-hot-backup
fe5bb6bb 535
536%files -n bash-completion-subversion
101e74de 537%defattr(644,root,root,755)
1326bb99 538/etc/bash_completion.d/%{name}
536b3fd3 539
1cc7453a 540%if %{with javahl}
541%files -n java-subversion
542%defattr(644,root,root,755)
543%attr(755,root,root) %{_libdir}/libsvnjavahl*.so.*.*.*
544%attr(755,root,root) %{_libdir}/libsvnjavahl*.so.?
545%attr(755,root,root) %{_libdir}/libsvnjavahl*.so
546%{_javadir}/svn-javahl.jar
547%endif
548
0905b458 549%if %{with python}
fa3ff1b2 550%files -n python-subversion
f4e6a380 551%defattr(644,root,root,755)
4bbdbbf8 552%doc tools/backup/*.py tools/examples/*.py
f4e6a380 553%dir %{py_sitedir}/svn
65318afa 554%dir %{py_sitedir}/libsvn
f4e6a380 555%{py_sitedir}/svn/*.py[co]
65318afa
AF
556%{py_sitedir}/libsvn/*.py[co]
557%attr(755,root,root) %{py_sitedir}/libsvn/*.so
1326bb99 558%{_examplesdir}/python-%{name}-%{version}
c00fdf6f 559%attr(755,root,root) %{_libdir}/lib*_swig_py*.so*
0905b458 560%endif
f4e6a380 561
0905b458 562%if %{with perl}
b56474ff
AM
563%files -n perl-subversion
564%defattr(644,root,root,755)
565%{perl_vendorarch}/SVN
566%dir %{perl_vendorarch}/auto/SVN
567%dir %{perl_vendorarch}/auto/SVN/*
568%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
569%{perl_vendorarch}/auto/SVN/*/*.bs
570%{_mandir}/man3/*.3pm*
c00fdf6f 571%attr(755,root,root) %{_libdir}/lib*_swig_perl*.so*
0905b458 572%endif
b56474ff 573
0905b458 574%if %{with apache}
93b78127
AM
575%files -n apache-mod_dav_svn
576%defattr(644,root,root,755)
1af5e34d
ER
577%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
578%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
65318afa
AF
579
580%files -n apache-mod_authz_svn
581%defattr(644,root,root,755)
582%doc subversion/mod_authz_svn/INSTALL
1af5e34d
ER
583%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
584%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
536b3fd3 585%endif
7b27380f
ER
586
587%endif # net_client_only
This page took 3.266018 seconds and 4 git commands to generate.