]> git.pld-linux.org Git - packages/subversion.git/blame - subversion.spec
- up to 1.6.12
[packages/subversion.git] / subversion.spec
CommitLineData
1f630180 1# TODO:
1930bef0 2# - remove net_client_only and add db bcond (then without apache and
3# without db => net_client_only - spec will be more simpler, I think)
d46e45ba 4# - finish ruby
9688ba4c 5# - http://subversion.tigris.org/issues/show_bug.cgi?id=2753
1930bef0 6#
bab73684 7# Conditional build:
65c1d4bd 8%bcond_with net_client_only # build only net client
3fc01170 9%bcond_without neon # use serf instead of neon
65c1d4bd
JB
10%bcond_without python # build without python bindings (broken)
11%bcond_without perl # build without perl bindings
73ab938a 12%bcond_without ruby # build without ruby bindings
65c1d4bd
JB
13%bcond_without apache # build without apache support (webdav, etc)
14%bcond_without javahl # build without javahl support (Java high-level bindings)
15%bcond_without tests # don't perform "make check"
65f2befa 16%bcond_without kwallet # build without kde4 wallet support
bfb248d0 17%bcond_without gnome # build without gnome keyring support
7b27380f 18#
b56474ff 19%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
f4070f5f 20%define apxs /usr/sbin/apxs
1f630180
ER
21%define pdir SVN
22%define pnam _Core
12ae68c1 23#
04129f48 24%if %{with neon}
a510fada 25%define webdavlib neon
04129f48
AG
26%else
27%define webdavlib serf
a510fada
AM
28%endif
29#
67cb9518 30Summary: A Concurrent Versioning system similar to but better than CVS
abe3c421
ER
31Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
32Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127 33Name: subversion
3819cb33
AM
34Version: 1.6.12
35Release: 1
6f88d80e 36License: Apache/BSD-like
93b78127 37Group: Development/Version Control
a5c00029 38Source0: http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
3819cb33 39# Source0-md5: a4b1d0d7f3a4587c59da9c1acf9dedd0
93b78127 40Source1: %{name}-dav_svn.conf
65318afa 41Source2: %{name}-authz_svn.conf
b56474ff
AM
42Source3: %{name}-svnserve.init
43Source4: %{name}-svnserve.sysconfig
a510fada
AM
44# current subversion tarball has correct *.swg files
45# but after regeneration these are broken again, so
46# we still need this script
f313e9a9 47Source5: %{name}-convert-typemaps-to-ifdef.py
ed6210a2 48Patch0: %{name}-home_etc.patch
d46e45ba 49Patch1: %{name}-DESTDIR.patch
00664663 50Patch2: %{name}-ruby-datadir-path.patch
dc8fcc41 51URL: http://subversion.apache.org/
4945947e
AM
52%if %{with net_client_only}
53%global apache_modules_api 0
54%else
f2a757d6 55%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
7b27380f 56BuildRequires: automake
3817faf5 57BuildRequires: db-devel >= 4.1.25
8b023a9d 58BuildRequires: rpmbuild(macros) >= 1.559
0905b458 59%if %{with perl}
522a69b4 60BuildRequires: perl-devel >= 1:5.8.0
61BuildRequires: rpm-perlprov >= 4.1-13
15f9818d 62BuildRequires: swig-perl >= 1.3.24
536b3fd3 63%endif
6ac3574b
AM
64%if %{with python}
65BuildRequires: python-ctypesgen
66BuildRequires: python-devel >= 2.2
67BuildRequires: swig-python >= 1.3.24
68%endif
69%if %{with ruby}
70BuildRequires: ruby-devel
71BuildRequires: swig-ruby >= 1.3.24
72%endif
af0d490b 73%if %{with javahl}
20c5f543 74BuildRequires: jdk
af0d490b 75%endif
6ac3574b 76BuildRequires: cyrus-sasl-devel
0905b458 77%endif
16429189 78BuildRequires: apr-devel >= 1:1.0.0
a6ecf312 79BuildRequires: apr-util-devel >= 1:1.2.8-3
b0a7a5b2 80BuildRequires: autoconf >= 2.59
79d8c53c 81BuildRequires: bison
93b78127 82BuildRequires: expat-devel
86ea8fde 83BuildRequires: gettext-devel
7b9fe651 84%{?with_gnome:BuildRequires: libgnome-keyring-devel}
65f2befa 85%{?with_kwallet:BuildRequires: kde4-kdelibs-devel}
f4e6a380 86BuildRequires: libtool >= 1.4-9
54271075 87BuildRequires: pkgconfig
a562165a 88BuildRequires: sed >= 4.0
c26d84c4 89BuildRequires: sqlite3-devel >= 3.6.11
a562165a
JB
90BuildRequires: texinfo
91BuildRequires: which
92%if %{with neon}
bd3c99a8 93BuildRequires: neon-devel >= 0.26.0
a562165a
JB
94%else
95BuildRequires: serf-devel
e3ad24ea 96%endif
53855fbf 97BuildRequires: python >= 2.2
ed6210a2 98BuildRequires: python-modules >= 2.2
027f8ebe 99Requires: %{name}-libs = %{version}-%{release}
8b023a9d 100%requires_ge sqlite3
93b78127
AM
101BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
f4070f5f 103%define _libexecdir %{_libdir}/svn
1af5e34d
ER
104%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
105%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
93b78127
AM
106
107%description
108The goal of the Subversion project is to build a version control
109system that is a compelling replacement for CVS in the open source
110community.
111
112Our goals are:
113- All current CVS features.
114- Directories, renames, and file meta-data are versioned.
115- Symbolic links, etc, are supported
116- Commits are truly atomic.
117- Branching and tagging are cheap (constant time) operations
118- Repeated merges are handled gracefully
119- Support for plug-in client side diff programs
120- Natively client/server
121- Client/server protocol sends diffs in both directions
122- Costs are proportional to change size, not project size
123- Internationalization
124- Progressive multi-lingual support
125
aa59005f 126%description -l pl.UTF-8
93b78127
AM
127Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
128zamiennika dla CVS.
129
130Cele projektu to:
aa59005f 131- Wszystkie aktualne możliwości CVS.
24406120
JB
132- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
133- Obsługa dowiązań symbolicznych itp.
aa59005f
JR
134- Commity są w pełni atomowe.
135- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
24406120
JB
136- Dobra obsługa powtarzanego łączenia (merge).
137- Obsługa wtyczek diff po stronie klienta.
93b78127 138- Natywny klient/serwer.
aa59005f 139- Klient/Serwer przesyłają diffy w obu kierunkach.
93b78127
AM
140- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
141- Internacjonalizacja.
aa59005f 142- Postępujące wsparcie dla wielu języków.
93b78127 143
aa59005f
JR
144%description -l pt_BR.UTF-8
145O objetivo do projeto Subversion é construir um sistema de controle de
146versões que seja um substituto para o CVS (Concurrent Versioning
92066deb 147System) na comunidade opensource, fornecendo grandes melhorias.
148
f4e6a380
AM
149%package libs
150Summary: Subversion libraries and modules
abe3c421 151Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
f4e6a380 152Group: Libraries
04129f48 153%{?with_neon:Requires: neon >= 0.26.0}
53855fbf 154Obsoletes: libsubversion0
f4e6a380
AM
155
156%description libs
157Subversion libraries and modules.
158
aa59005f
JR
159%description libs -l pl.UTF-8
160Biblioteka subversion oraz ładowalne moduły.
f4e6a380 161
93b78127
AM
162%package devel
163Summary: Header files and develpment documentation for subversion
abe3c421
ER
164Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
165Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
93b78127 166Group: Development/Libraries
9cb7e099 167Requires: %{name}-libs = %{version}-%{release}
c5b1d686 168Requires: apr-util-devel >= 1:1.0.0
04129f48 169%{?with_neon:Requires: neon-devel >= 0.26.0}
12cf252c 170Obsoletes: libsubversion0-devel
93b78127
AM
171
172%description devel
173Header files and develpment documentation for subversion.
174
aa59005f
JR
175%description devel -l pl.UTF-8
176Pliki nagłówkowe i dokumetacja do subversion.
93b78127 177
aa59005f
JR
178%description devel -l pt_BR.UTF-8
179Este pacote provê os arquivos necessários para desenvolvedores
92066deb 180interagirem com o Subversion.
181
93b78127
AM
182%package static
183Summary: Static subversion library
abe3c421
ER
184Summary(pl.UTF-8): Biblioteka statyczna subversion
185Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127
AM
186Group: Development/Libraries
187Requires: %{name}-devel = %{version}
12cf252c 188Obsoletes: libsubversion0-static-devel
93b78127
AM
189
190%description static
191Static subversion library.
192
aa59005f 193%description static -l pl.UTF-8
93b78127
AM
194Biblioteka statyczna subversion.
195
aa59005f
JR
196%description static -l pt_BR.UTF-8
197Este pacote provê um cliente estático do subversion.
92066deb 198
b56474ff
AM
199%package svnserve
200Summary: Subversion svnserve
abe3c421 201Summary(pl.UTF-8): Subversion svnserve
b56474ff 202Group: Networking/Daemons
3817faf5 203Requires(post,preun): /sbin/chkconfig
93f1d402 204Requires(postun): /usr/sbin/groupdel
205Requires(postun): /usr/sbin/userdel
206Requires(pre): /bin/id
207Requires(pre): /usr/bin/getgid
208Requires(pre): /usr/lib/rpm/user_group.sh
209Requires(pre): /usr/sbin/groupadd
210Requires(pre): /usr/sbin/useradd
211Requires(pre): /usr/sbin/usermod
9cb7e099 212Requires: %{name} = %{version}-%{release}
7b27380f 213Requires: rc-scripts
a1bac09d
214Provides: group(svn)
215Provides: user(svn)
b56474ff
AM
216
217%description svnserve
218Subversion svnserve server.
219
aa59005f 220%description svnserve -l pl.UTF-8
b56474ff
AM
221Serwer subversion svnserve.
222
4bbdbbf8
AM
223%package tools
224Summary: Subversion tools and scripts
abe3c421
ER
225Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
226Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
4bbdbbf8 227Group: Applications
4bbdbbf8 228%pyrequires_eq python
7b27380f 229Requires: %{name} = %{version}-%{release}
4bbdbbf8
AM
230Requires: python-subversion = %{version}
231
232%description tools
233Subversion tools and scripts.
234
aa59005f
JR
235%description tools -l pl.UTF-8
236Narzędzia oraz skrypty dla subversion.
4bbdbbf8 237
fe5bb6bb 238%package -n bash-completion-subversion
239Summary: bash completion for subversion
abe3c421 240Summary(pl.UTF-8): Dopełnienia basha dla subversion
fe5bb6bb 241Group: Applications/Shells
e30588c4 242Requires: %{name} = %{version}-%{release}
53855fbf 243Requires: bash-completion
e30588c4 244Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
fe5bb6bb 245
246%description -n bash-completion-subversion
247Bash completion for subversion.
248
aa59005f
JR
249%description -n bash-completion-subversion -l pl.UTF-8
250Dopełnienia basha dla subversion.
fe5bb6bb 251
1cc7453a 252%package -n java-subversion
65c1d4bd
JB
253Summary: Subversion Java bindings
254Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
1cc7453a 255Group: Development/Languages/Java
256Requires: %{name}-libs = %{version}-%{release}
257
258%description -n java-subversion
259This is a set of Java classes which provide the functionality of
260subversion-libs, the Subversion libraries. It is useful if you want
261to, for example, write a Java class that manipulates a Subversion
262repository or working copy. See the 'subversion' package for more
263information.
264
65c1d4bd
JB
265%description -n java-subversion -l pl.UTF-8
266Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
267subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
d46e45ba
AM
268pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
269roboczą. Więcej informacji w pakiecie subversion.
65c1d4bd 270
fa3ff1b2 271%package -n python-subversion
65c1d4bd
JB
272Summary: Subversion Python bindings
273Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
274Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
f4e6a380 275Group: Development/Languages/Python
f4e6a380 276%pyrequires_eq python
9cb7e099 277Requires: %{name}-libs = %{version}-%{release}
53855fbf 278Obsoletes: subversion-python
f4e6a380 279
fa3ff1b2 280%description -n python-subversion
65c1d4bd 281Subversion Python bindings.
f4e6a380 282
aa59005f 283%description -n python-subversion -l pl.UTF-8
65c1d4bd 284Dowiązania do Subversion dla Pythona.
f4e6a380 285
aa59005f 286%description -n python-subversion -l pt_BR.UTF-8
65c1d4bd 287Módulos Python para acessar os recursos do Subversion.
92066deb 288
137fcafd
AM
289%package -n python-csvn
290Summary: CTypes Subversion Python bindings
291Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
292Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
293Group: Development/Languages/Python
294%pyrequires_eq python
295Requires: %{name}-libs = %{version}-%{release}
296
297%description -n python-csvn
298Subversion CTypes Python bindings.
299
300%description -n python-csvn -l pl.UTF-8
301Dowiązania do Subversion dla Pythona używające CTypes.
302
303%description -n python-csvn -l pt_BR.UTF-8
304Módulos Python para acessar os recursos do Subversion.
305
b56474ff 306%package -n perl-subversion
65c1d4bd
JB
307Summary: Subversion Perl bindings
308Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
309Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
b56474ff 310Group: Development/Languages/Perl
9cb7e099 311Requires: %{name}-libs = %{version}-%{release}
53855fbf 312Obsoletes: subversion-perl
b56474ff
AM
313
314%description -n perl-subversion
65c1d4bd 315Subversion Perl bindings.
b56474ff 316
aa59005f 317%description -n perl-subversion -l pl.UTF-8
65c1d4bd 318Dowiązania do Subversion dla Perla.
b56474ff 319
aa59005f 320%description -n perl-subversion -l pt_BR.UTF-8
65c1d4bd 321Módulos Perl para acessar os recursos do Subversion.
b56474ff 322
d46e45ba
AM
323%package -n ruby-subversion
324Summary: Subversion Ruby bindings
d2bf70bf 325Summary(pl.UTF-8): Dowiązania do Subversion dla języka Ruby
d46e45ba
AM
326Summary(pt_BR.UTF-8): Módulos Ruby para acessar os recursos do Subversion
327Group: Development/Languages
328Requires: %{name}-libs = %{version}-%{release}
329Obsoletes: subversion-ruby
330
331%description -n ruby-subversion
332Subversion Ruby bindings.
333
334%description -n ruby-subversion -l pl.UTF-8
d2bf70bf 335Dowiązania do Subversion dla języka Ruby.
d46e45ba
AM
336
337%description -n ruby-subversion -l pt_BR.UTF-8
338Módulos Ruby para acessar os recursos do Subversion.
339
93b78127
AM
340%package -n apache-mod_dav_svn
341Summary: Apache module: Subversion Server
abe3c421 342Summary(pl.UTF-8): Moduł apache: Serwer Subversion
93b78127 343Group: Networking/Daemons
7b27380f 344Requires: %{name} = %{version}-%{release}
53855fbf 345Requires: apache(modules-api) = %apache_modules_api
7887b1ac 346Requires: apache-mod_dav
93b78127
AM
347
348%description -n apache-mod_dav_svn
349Apache module: Subversion Server.
350
aa59005f
JR
351%description -n apache-mod_dav_svn -l pl.UTF-8
352Moduł apache: Serwer Subversion.
93b78127 353
65318afa
AF
354%package -n apache-mod_authz_svn
355Summary: Apache module: Subversion Server - path-based authorization
abe3c421 356Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
65318afa 357Group: Networking/Daemons
53855fbf 358Requires: apache(modules-api) = %apache_modules_api
9cb7e099 359Requires: apache-mod_dav_svn = %{version}-%{release}
65318afa
AF
360
361%description -n apache-mod_authz_svn
362Apache module: Subversion Server - path-based authorization.
363
aa59005f
JR
364%description -n apache-mod_authz_svn -l pl.UTF-8
365Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
e23909be 366
1429fa1c
AM
367%package -n gnome-keyring-subversion
368Summary: Subversion module for Gnome Keyring
369Summary(pl.UTF-8): Moduł subversion dla zarządcy kluczy Gnome
370Group: X11/Applications
371
372%description -n gnome-keyring-subversion
373Subversion module for Gnome Keyring.
374
375%description -n gnome-keyring-subversion -l pl.UTF-8
376Moduł subversion dla zarządcy kluczy Gnome.
377
378%package -n kde4-kwallet-subversion
379Summary: Subversion module for KDE Wallet
380Summary(pl.UTF-8): Moduł subversion dla Portfela KDE
381Group: X11/Applications
382
383%description -n kde4-kwallet-subversion
384Subversion module for KDE Wallet.
385
386%description -n kde4-kwallet-subversion -l pl.UTF-8
387Moduł subversion dla Portfela KDE.
388
93b78127 389%prep
a5c00029 390%setup -q
e30588c4 391rm -rf apr apr-util neon
ed6210a2 392%patch0 -p0
d4bccc60 393%patch1 -p1
00664663 394%patch2 -p0
a510fada
AM
395
396sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
397
398# serf.m4 macro is broken and ignores --without serf
244bdb04 399%{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
027f8ebe 400
93b78127 401%build
93f1d402 402rm subversion/bindings/swig/proxy/*.swg
24406120 403cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
a7bcb345 404cp -f /usr/share/automake/config.sub ac-helpers
67cb9518 405chmod +x ./autogen.sh && ./autogen.sh
8a3d9172 406
93b78127 407%configure \
5dfeafd7 408 --with-editor=vi \
12ae68c1 409 --with-zlib=%{_libdir} \
536b3fd3
AM
410%if %{with net_client_only}
411 --without-apache \
412 --without-swig \
413 --without-apxs \
414 --without-berkeley-db \
415%else
fa6fa2cf 416 --disable-runtime-module-search \
86ee97d3 417 --disable-mod-activation \
ad5c551e 418 --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
0905b458 419%if %{with apache}
536b3fd3 420 --with-apxs=%{_sbindir}/apxs \
0905b458 421%else
422 --without-apache \
423 --without-apxs \
0905b458 424%endif
73ab938a 425%if !%{with python} && !%{with perl} && !%{with ruby}
0905b458 426 --without-swig \
427%endif
137fcafd 428 %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
1cc7453a 429 --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
536b3fd3 430%endif
1cc7453a 431 --with-jdk="%{java_home}" \
cf2589d0 432 --without-jikes \
04129f48 433%if %{with neon}
e3ad24ea 434 --without-serf \
e30588c4 435 --with-neon=%{_prefix} \
78f330c4 436 --disable-neon-version-check \
04129f48
AG
437%else
438 --with-serf=%{_prefix} \
439 --without-neon \
e3ad24ea 440%endif
16429189 441 --with-apr=%{_bindir}/apr-1-config \
1429fa1c 442 --with-apr-util=%{_bindir}/apu-1-config \
65f2befa 443%if %{with kwallet}
1429fa1c 444 --with-kwallet \
65f2befa 445%endif
bfb248d0 446%if %{with gnome}
1429fa1c 447 --with-gnome-keyring
bfb248d0 448%endif
536b3fd3 449
1f630180 450%{__make} -j1
536b3fd3 451
cf353d53 452%if !%{with net_client_only}
b56474ff 453# python
0905b458 454%if %{with python}
137fcafd
AM
455# ctypes bindings
456%{__make} ctypes-python
457# swig bindings
86a4919e 458%{__make} swig-py \
65318afa
AF
459 swig_pydir=%{py_sitedir}/libsvn \
460 swig_pydir_extra=%{py_sitedir}/svn
0905b458 461%endif
b56474ff 462# perl
0905b458 463%if %{with perl}
390bb8f4 464%{__make} -j1 swig-pl-lib
bf539998
AM
465odir=$(pwd)
466cd subversion/bindings/swig/perl/native
467%{__perl} Makefile.PL INSTALLDIRS=vendor
b445847c 468%{__make} -j1
bf539998 469cd $odir
536b3fd3 470%endif
1cc7453a 471%if %{with javahl}
b445847c 472%{__make} -j1 javahl \
1cc7453a 473 javahl_javadir="%{_javadir}"
474%endif
d46e45ba
AM
475# ruby
476%if %{with ruby}
477%{__make} swig-rb
478%endif
12ae68c1
AM
479%endif
480
481%if %{with tests}
482%{__make} check
d46e45ba 483%if %{with python}
137fcafd 484%{__make} check-ctypes-python
d46e45ba
AM
485%{__make} check-swig-py
486%endif
487%if %{with perl}
488%{__make} check-swig-pl
489%endif
490%if %{with ruby}
491%{__make} check-swig-rb
492%endif
0905b458 493%endif
93b78127
AM
494
495%install
496rm -rf $RPM_BUILD_ROOT
1326bb99 497install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
1af5e34d 498 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
afb35189 499 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
a54611db 500 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
93b78127 501
1f630180 502%{__make} install -j1 \
1cc7453a 503%if %{with javahl}
504 install-javahl \
505 javahl_javadir="%{_javadir}" \
506%endif
d46e45ba
AM
507%if !%{with net_client_only}
508%if %{with python}
0905b458 509 install-swig-py \
137fcafd 510 install-ctypes-python \
d46e45ba
AM
511%endif
512%if %{with ruby}
513 install-swig-rb install-swig-rb-doc \
514%endif
0905b458 515%endif
f2a757d6 516 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
86a4919e 517 DESTDIR=$RPM_BUILD_ROOT \
65318afa
AF
518 swig_pydir=%{py_sitedir}/libsvn \
519 swig_pydir_extra=%{py_sitedir}/svn
93b78127 520
cf353d53 521%if !%{with net_client_only} && %{with perl}
bf539998
AM
522%{__make} install-swig-pl-lib \
523 DESTDIR=$RPM_BUILD_ROOT
b445847c 524%{__make} -C subversion/bindings/swig/perl/native install \
bf539998
AM
525 DESTDIR=$RPM_BUILD_ROOT \
526 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
527 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
bf539998
AM
528%endif
529
0905b458 530%if %{with apache}
1af5e34d
ER
531install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
532install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
b56474ff
AM
533install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
534install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
0905b458 535%endif
93b78127 536
cf353d53 537%if !%{with net_client_only}
1326bb99 538install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
0905b458 539%if %{with python}
f4e6a380
AM
540%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
541%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1326bb99
JK
542find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
543install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
536b3fd3 544%endif
0905b458 545%endif
f4e6a380 546
1326bb99
JK
547install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
548install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
1326bb99 549
205a3ddc
AM
550%find_lang %{name}
551
dd73606c 552%{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
c39b6844 553rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
554rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
a6ecf312 555
e23909be
JB
556%clean
557rm -rf $RPM_BUILD_ROOT
558
a1bac09d
559%pre svnserve
560%groupadd -g 86 svn
561%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
562
d2bf70bf
JB
563%post libs -p /sbin/ldconfig
564%postun libs -p /sbin/ldconfig
565
566%post devel -p /sbin/postshell
6f99c3bd 567-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 568
d2bf70bf 569%postun devel -p /sbin/postshell
6f99c3bd 570-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 571
d2bf70bf
JB
572%post -n perl-subversion -p /sbin/ldconfig
573%postun -n perl-subversion -p /sbin/ldconfig
574
575%post -n python-subversion -p /sbin/ldconfig
576%postun -n python-subversion -p /sbin/ldconfig
f4e6a380 577
b56474ff 578%post svnserve
e8d9186f
ER
579/sbin/chkconfig --add svnserve
580%service svnserve restart "svnserve daemon"
581
b56474ff
AM
582%preun svnserve
583if [ "$1" = "0" ]; then
e8d9186f
ER
584 %service svnserve stop
585 /sbin/chkconfig --del svnserve
b56474ff
AM
586fi
587
a1bac09d
588%postun svnserve
589if [ "$1" = "0" ]; then
590 %userremove svn
591 %groupremove svn
592fi
593
93b78127 594%post -n apache-mod_dav_svn
e8d9186f 595%service -q httpd restart
93b78127 596
ba425c92 597%postun -n apache-mod_dav_svn
93b78127 598if [ "$1" = "0" ]; then
e8d9186f 599 %service -q httpd restart
93b78127
AM
600fi
601
9688ba4c
JR
602%post -n apache-mod_authz_svn
603%service -q httpd restart
604
ba425c92 605%postun -n apache-mod_authz_svn
9688ba4c
JR
606if [ "$1" = "0" ]; then
607 %service -q httpd restart
608fi
609
93b78127
AM
610%files
611%defattr(644,root,root,755)
983a49f6 612%doc BUGS CHANGES COPYING INSTALL README
d37298dc 613%doc doc/*/*.html
4bbdbbf8
AM
614%doc tools/hook-scripts/*.{pl,py,example}
615%doc tools/hook-scripts/mailer/*.{py,example}
1326bb99 616%doc tools/xslt/*
b445847c
JB
617%attr(755,root,root) %{_bindir}/svn
618%attr(755,root,root) %{_bindir}/svnadmin
619%attr(755,root,root) %{_bindir}/svndumpfilter
620%attr(755,root,root) %{_bindir}/svnlook
621%attr(755,root,root) %{_bindir}/svnsync
622%attr(755,root,root) %{_bindir}/svnversion
623%{_mandir}/man1/svn.1*
624%{_mandir}/man1/svnadmin.1*
625%{_mandir}/man1/svndumpfilter.1*
626%{_mandir}/man1/svnlook.1*
627%{_mandir}/man1/svnsync.1*
628%{_mandir}/man1/svnversion.1*
f4e6a380 629
205a3ddc 630%files libs -f %{name}.lang
f4e6a380 631%defattr(644,root,root,755)
b445847c
JB
632%attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
633%attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
634%attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
635%attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
636%attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
637%attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
638%attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
639%attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
640%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
641%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
642%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
643%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
644%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
645%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
646%attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
647%attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
648%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
649%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
a510fada
AM
650%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
651%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
b445847c
JB
652%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
653%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
654%attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
655%attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
656%attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
657%attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
658%attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
659%attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
93b78127
AM
660
661%files devel
662%defattr(644,root,root,755)
b445847c
JB
663%attr(755,root,root) %{_libdir}/libsvn_client-1.so
664%attr(755,root,root) %{_libdir}/libsvn_delta-1.so
665%attr(755,root,root) %{_libdir}/libsvn_diff-1.so
666%attr(755,root,root) %{_libdir}/libsvn_fs-1.so
667%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
668%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
669%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
670%attr(755,root,root) %{_libdir}/libsvn_ra-1.so
671%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
a510fada 672%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
b445847c
JB
673%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
674%attr(755,root,root) %{_libdir}/libsvn_repos-1.so
675%attr(755,root,root) %{_libdir}/libsvn_subr-1.so
676%attr(755,root,root) %{_libdir}/libsvn_wc-1.so
677%{_libdir}/libsvn_client-1.la
678%{_libdir}/libsvn_delta-1.la
679%{_libdir}/libsvn_diff-1.la
680%{_libdir}/libsvn_fs-1.la
681%{_libdir}/libsvn_fs_base-1.la
682%{_libdir}/libsvn_fs_fs-1.la
683%{_libdir}/libsvn_fs_util-1.la
684%{_libdir}/libsvn_ra-1.la
685%{_libdir}/libsvn_ra_local-1.la
a510fada 686%{_libdir}/libsvn_ra_%{webdavlib}-1.la
b445847c
JB
687%{_libdir}/libsvn_ra_svn-1.la
688%{_libdir}/libsvn_repos-1.la
689%{_libdir}/libsvn_subr-1.la
690%{_libdir}/libsvn_wc-1.la
691%{_includedir}/%{name}-1
1326bb99 692%{_examplesdir}/%{name}-%{version}
93b78127
AM
693
694%files static
695%defattr(644,root,root,755)
b445847c
JB
696%{_libdir}/libsvn_client-1.a
697%{_libdir}/libsvn_delta-1.a
698%{_libdir}/libsvn_diff-1.a
699%{_libdir}/libsvn_fs-1.a
700%{_libdir}/libsvn_fs_base-1.a
701%{_libdir}/libsvn_fs_fs-1.a
702%{_libdir}/libsvn_fs_util-1.a
703%{_libdir}/libsvn_ra-1.a
704%{_libdir}/libsvn_ra_local-1.a
a510fada 705%{_libdir}/libsvn_ra_%{webdavlib}-1.a
b445847c
JB
706%{_libdir}/libsvn_ra_svn-1.a
707%{_libdir}/libsvn_repos-1.a
708%{_libdir}/libsvn_subr-1.a
709%{_libdir}/libsvn_wc-1.a
93b78127 710
bfb248d0 711%if %{with gnome}
1429fa1c
AM
712%files -n gnome-keyring-subversion
713%defattr(644,root,root,755)
714%attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
715%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
bfb248d0 716%endif
1429fa1c 717
65f2befa 718%if %{with kwallet}
1429fa1c
AM
719%files -n kde4-kwallet-subversion
720%defattr(644,root,root,755)
721%attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
722%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
65f2befa 723%endif
1429fa1c 724
cf353d53 725%if !%{with net_client_only}
b56474ff
AM
726%files svnserve
727%defattr(644,root,root,755)
728%attr(755,root,root) %{_bindir}/svnserve
b445847c
JB
729%{_mandir}/man5/svnserve.conf.5*
730%{_mandir}/man8/svnserve.8*
a1bac09d
731%dir %attr(750,svn,svn) /home/services/subversion
732%dir %attr(750,svn,svn) /home/services/subversion/repos
0905b458 733%if %{with apache}
b56474ff 734%attr(754,root,root) /etc/rc.d/init.d/svnserve
86ea8fde 735%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
0905b458 736%endif
b56474ff 737
4bbdbbf8
AM
738%files tools
739%defattr(644,root,root,755)
1326bb99 740%attr(755,root,root) %{_bindir}/svn-hot-backup
fe5bb6bb 741
742%files -n bash-completion-subversion
101e74de 743%defattr(644,root,root,755)
1326bb99 744/etc/bash_completion.d/%{name}
536b3fd3 745
1cc7453a 746%if %{with javahl}
747%files -n java-subversion
748%defattr(644,root,root,755)
b445847c
JB
749%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
750%attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
751%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
1cc7453a 752%{_javadir}/svn-javahl.jar
753%endif
754
0905b458 755%if %{with python}
fa3ff1b2 756%files -n python-subversion
f4e6a380 757%defattr(644,root,root,755)
4bbdbbf8 758%doc tools/backup/*.py tools/examples/*.py
b445847c
JB
759%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
760%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
761%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
65318afa 762%dir %{py_sitedir}/libsvn
65318afa 763%{py_sitedir}/libsvn/*.py[co]
b445847c
JB
764%dir %{py_sitedir}/svn
765%{py_sitedir}/svn/*.py[co]
65318afa 766%attr(755,root,root) %{py_sitedir}/libsvn/*.so
1326bb99 767%{_examplesdir}/python-%{name}-%{version}
137fcafd
AM
768
769%files -n python-csvn
770%defattr(644,root,root,755)
771%doc subversion/bindings/ctypes-python/{README,TODO}
772%doc subversion/bindings/ctypes-python/examples/*.py
773%dir %{py_sitescriptdir}/csvn
774%{py_sitescriptdir}/csvn/*.py[co]
775%dir %{py_sitescriptdir}/csvn/core
776%{py_sitescriptdir}/csvn/core/*.py[co]
777%dir %{py_sitescriptdir}/csvn/ext
778%{py_sitescriptdir}/csvn/ext/*.py[co]
779%{py_sitescriptdir}/*.egg-info
0905b458 780%endif
f4e6a380 781
0905b458 782%if %{with perl}
b56474ff
AM
783%files -n perl-subversion
784%defattr(644,root,root,755)
b445847c
JB
785%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
786%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
787%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
b56474ff
AM
788%{perl_vendorarch}/SVN
789%dir %{perl_vendorarch}/auto/SVN
790%dir %{perl_vendorarch}/auto/SVN/*
791%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
792%{perl_vendorarch}/auto/SVN/*/*.bs
793%{_mandir}/man3/*.3pm*
0905b458 794%endif
b56474ff 795
d46e45ba
AM
796%if %{with ruby}
797%files -n ruby-subversion
798%defattr(644,root,root,755)
b445847c
JB
799%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
800%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
801%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
916011ef
JR
802%dir %{ruby_sitelibdir}/svn
803%{ruby_sitelibdir}/svn/*.rb
804%dir %{ruby_sitearchdir}/svn
805%dir %{ruby_sitearchdir}/svn/ext
e2c6dc67 806%attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
916011ef 807%{ruby_ridir}/Svn
d46e45ba
AM
808%endif
809
0905b458 810%if %{with apache}
93b78127
AM
811%files -n apache-mod_dav_svn
812%defattr(644,root,root,755)
1af5e34d
ER
813%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
814%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
65318afa
AF
815
816%files -n apache-mod_authz_svn
817%defattr(644,root,root,755)
818%doc subversion/mod_authz_svn/INSTALL
1af5e34d
ER
819%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
820%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
536b3fd3 821%endif
7b27380f
ER
822
823%endif # net_client_only
This page took 1.292707 seconds and 4 git commands to generate.