]> git.pld-linux.org Git - packages/strace.git/blobdiff - strace.spec
- updated to 5.3
[packages/strace.git] / strace.spec
index 5e24c1500a570dab9f3437bdb0b0c620380155f3..faa77c719d6070f02d52527e4c3eaca62c943d5c 100644 (file)
@@ -1,28 +1,36 @@
+#
+# Conditional build:
+%bcond_without libunwind       # strack tracing using libunwind
+%bcond_without libiberty       # symbol demangling in stack backtraces
+#
+%ifnarch %{ix86} %{x8664} x32 %{arm} hppa ia64 mips ppc ppc64 sh
+%undefine      with_libunwind
+%endif
 Summary:       prints system call strace of a running process
-Summary(de.UTF-8):   druckt ein Protokoll der Systemaufrufe eines laufenden Prozesses
-Summary(es.UTF-8):   Enseña las llamadas de sistema de un proceso en ejecución
-Summary(fr.UTF-8):   affiche l'appel système strace d'un processus en exécution
-Summary(pl.UTF-8):   strace wyświetla funkcje systemowe wywoływane przez uruchomiony proces
-Summary(pt_BR.UTF-8):   Mostra as chamadas de sistema de um processo rodando
-Summary(ru.UTF-8):   Отслеживает и показывает системные вызовы, связанные с запущенным процессом
-Summary(tr.UTF-8):   Çalışan bir sürecin yaptığı sistem çağrılarını listeler
-Summary(uk.UTF-8):   Відслідковує та показує системні виклики, пов'язані із запущеним процесом
+Summary(de.UTF-8):     druckt ein Protokoll der Systemaufrufe eines laufenden Prozesses
+Summary(es.UTF-8):     Enseña las llamadas de sistema de un proceso en ejecución
+Summary(fr.UTF-8):     affiche l'appel système strace d'un processus en exécution
+Summary(pl.UTF-8):     strace wyświetla funkcje systemowe wywoływane przez uruchomiony proces
+Summary(pt_BR.UTF-8):  Mostra as chamadas de sistema de um processo rodando
+Summary(ru.UTF-8):     Отслеживает и показывает системные вызовы, связанные с запущенным процессом
+Summary(tr.UTF-8):     Çalışan bir sürecin yaptığı sistem çağrılarını listeler
+Summary(uk.UTF-8):     Відслідковує та показує системні виклики, пов'язані із запущеним процесом
 Name:          strace
-Version:       4.5.15
+Version:       5.3
 Release:       1
-License:       BSD-like
+License:       LGPL v2.1+
 Group:         Development/Debuggers
-Source0:       http://dl.sourceforge.net/strace/%{name}-%{version}.tar.bz2
-# Source0-md5: ef40944118841803391d212cb64d3c5b
+Source0:       https://github.com/strace/strace/releases/download/v%{version}/%{name}-%{version}.tar.xz
+# Source0-md5: 84f5e72de813c9b1bb6057ee8ab428d8
 Source1:       %{name}.1.pl
-Patch0:                %{name}-newsysc.patch
-Patch1:                %{name}-getdents64.patch
-Patch2:                %{name}-kernel26_userspace.patch
-Patch3:                %{name}-stat64.patch
-Patch4:                %{name}-sparc64.patch
-URL:           http://sourceforge.net/projects/strace/
-BuildRequires: autoconf >= 2.57
-BuildRequires: automake
+URL:           https://strace.io/
+# acl and libaio for headers only
+BuildRequires: acl-devel
+%{?with_libiberty:BuildRequires:       binutils-devel >= 4:2.30-1}
+BuildRequires: libaio-devel
+%{?with_libunwind:BuildRequires:       libunwind-devel}
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -74,7 +82,7 @@ Strace корисний для діагностики проблем та від
 
 %package graph
 Summary:       strace graph
-Summary(pl.UTF-8):   Graf strace
+Summary(pl.UTF-8):     Graf strace
 Group:         Development/Debuggers
 # NOTE: doesn't require directly strace binary.
 
@@ -83,8 +91,8 @@ strace-graph script processes strace -f output. It displays a graph of
 invoked subprocesses, and is useful for finding out what complex
 commands do.
 
-The script can also handle the output with strace -t, -tt, or -ttt.
-It will add elapsed time for each process in that case.
+The script can also handle the output with strace -t, -tt, or -ttt. It
+will add elapsed time for each process in that case.
 
 %description graph -l pl.UTF-8
 Skrypt strace-graph przetwarza wynik strace -f i wyświetla graf
@@ -96,18 +104,18 @@ Doda wtedy upływający czas dla każdego procesu.
 
 %prep
 %setup -q
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
 
 %build
-%{__aclocal}
-%{__autoconf}
-%{__autoheader}
-%{__automake}
-%configure
+%if %{with libunwind}
+# workaround for:
+# /usr/bin/ld: copy reloc against protected `_UPT_accessors' is invalid
+# /usr/bin/ld: failed to set dynamic section sizes: Bad value
+# (should be fixed in gcc >(=?) 5.1)
+CFLAGS="%{rpmcflags} -fPIE"
+%endif
+%configure \
+       %{!?with_libiberty:--without-libiberty} \
+       %{!?with_libunwind:--without-libunwind}
 %{__make}
 
 %install
@@ -123,10 +131,12 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc COPYRIGHT CREDITS ChangeLog NEWS README-linux TODO
+%doc COPYING CREDITS ChangeLog NEWS README-linux-ptrace
 %attr(755,root,root) %{_bindir}/strace
-%{_mandir}/man1/*
-%lang(pl) %{_mandir}/pl/man1/*
+%attr(755,root,root) %{_bindir}/strace-log-merge
+%{_mandir}/man1/strace.1*
+%{_mandir}/man1/strace-log-merge.1*
+%lang(pl) %{_mandir}/pl/man1/strace.1*
 
 %files graph
 %defattr(644,root,root,755)
This page took 0.056382 seconds and 4 git commands to generate.