]> git.pld-linux.org Git - packages/steam-launcher.git/commitdiff
up to 1.0.0.72 master auto/th/steam-launcher-1.0.0.72-1
authorJan Palus <atler@pld-linux.org>
Sat, 11 Sep 2021 11:17:28 +0000 (13:17 +0200)
committerJan Palus <atler@pld-linux.org>
Sat, 11 Sep 2021 11:17:28 +0000 (13:17 +0200)
steam-launcher.spec
steamdeps.patch

index 9ce080c0237bfc39d37b3a85bc8f0a7ee3891b85..f89d692f1f64cfcbc7e3777350464e5ab9e658a9 100644 (file)
@@ -2,12 +2,12 @@
 
 Summary:       Launcher for the Steam software distribution service
 Name:          steam-launcher
-Version:       1.0.0.71
+Version:       1.0.0.72
 Release:       1
 License:       distributable
 Group:         Applications
 Source0:       https://repo.steampowered.com/steam/pool/steam/s/steam/steam_%{version}.tar.gz
-# Source0-md5: 02be920816bc369c8ac6579942535910
+# Source0-md5: 53c8ec53d0efd81490f9a2827af6366a
 Source1:       %{name}.sysconfig
 Patch0:                steamdeps.patch
 Patch1:                desktop_path.patch
index c4ff2ee1c9113463f1d12bfabd1a85b47ada9d8d..342e3fa1aa21a749947ffc61693768f9586fb67f 100644 (file)
      # If your host file is misconfigured in certain circumstances this
      # can cause sudo to block for a while, which causes gksudo to go into
      # limbo and never return.
-@@ -347,31 +440,30 @@
+@@ -347,33 +440,32 @@
      else
          return 0
      fi
 +{sudo} poldek {poldek_options} --up
  echo
  
- # Install the packages!
--sudo apt-get install %s
+ # Install the packages using the option "--no-remove" to avoid
+ # unexpected dependencies cycle that end up removing packages that are
+ # essential for the OS to run
+-sudo apt-get install --no-remove %s
 -echo $? >%s
 +{sudo} poldek {poldek_options} -u --pset={pset}
 +echo $? >{status_file}
          packages[name].set_installed(match.group(2))
  
      # See which ones need to be installed
--    needed = []
+-    needed = set()
 +    consider_installed = pld_config_get("INSTALLED", "").split()
 +    needed = set()
      for row in dependencies:
                  satisfied = True
                  break
          if not satisfied:
--            needed.append(row[0])
+-            needed.add(row[0])
 +            if row[0].name not in consider_installed:
 +                needed.add( row[0] )
 +            else:
  
      # If we have anything to install, do it!
      if len(needed) > 0:
-@@ -587,7 +706,12 @@
-         if args.dry_run:
-             return 1
-         else:
--            return update_packages(needed)
+@@ -587,8 +706,12 @@
+             # ones listed in "ensure_installed_packages". If they were already
+             # installed, this forces apt to keep them into consideration when
+             # it evaluates the new packages dependencies.
+-            needed.update(ensure_installed_packages)
+-            return update_packages(sorted(needed, key=lambda x: x.name))
 +            if pld_config_enabled("INSTALL_PACKAGES", True):
 +                print("Installing packages as configured through {0}...".format(PLD_CONFIG_FN))
 +                return updatePackages( needed )
This page took 0.066492 seconds and 4 git commands to generate.