]> git.pld-linux.org Git - packages/steam-launcher.git/blob - steam-launcher.spec
a5950e0395be8524980d14727df29d753657263d
[packages/steam-launcher.git] / steam-launcher.spec
1 Summary:        Launcher for the Steam software distribution service
2 Name:           steam-launcher
3 Version:        1.0.0.69
4 Release:        1
5 License:        distributable
6 Group:          Applications
7 Source0:        http://repo.steampowered.com/steam/pool/steam/s/steam/steam_%{version}.tar.gz
8 # Source0-md5:  9099e348686ac5d50f6a8823e40c421d
9 Source1:        %{name}.sysconfig
10 Patch0:         steamdeps.patch
11 Patch1:         desktop_path.patch
12 URL:            http://store.steampowered.com/
13 BuildRequires:  sed >= 4.0
14 Requires:       ca-certificates >= 20180409-3
15 Requires:       curl
16 Requires:       fonts-TTF-RedHat-liberation
17 Requires:       glibc >= 6:2.15
18 Requires:       libtxc_dxtn
19 Requires:       pld-release
20 Requires:       poldek
21 Requires:       python-modules
22 Requires:       rpm
23 Requires:       which
24 Requires:       xdg-user-dirs
25 Requires:       xterm
26 Requires:       xz
27 Requires:       zenity
28 ExclusiveArch:  %{ix86} %{x8664}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %ifarch %{x8664}
32 %define poldek_sources  -n th -n th-i686
33 %else
34 %define poldek_sources  -n th
35 %endif
36
37 %description
38 Steam is a software distribution service with an online store,
39 automated installation, automatic updates, achievements, SteamCloud
40 synchronized savegame and screenshot functionality, and many social
41 features.
42
43 %prep
44 %setup -qn steam-launcher
45 %patch0 -p1
46 %patch1 -p1
47
48 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' bin_steamdeps.py
49 %{__sed} -i -e '1s,/usr/bin/env bash,%{__bash},' bin_steam.sh
50
51 sed -i -e's/^ARCH\s*=.*$/ARCH = "%{_arch}"/' steamdeps
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 install -d $RPM_BUILD_ROOT/etc/sysconfig
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 rm $RPM_BUILD_ROOT%{_docdir}/steam/{README,steam_subscriber_agreement.txt}
62
63 # installed only when apt is installed on the build host
64 [ -d $RPM_BUILD_ROOT/etc/apt ] && rm -r $RPM_BUILD_ROOT/etc/apt
65
66 sed -e's/@SOURCES@/%{poldek_sources}/' %{SOURCE1} > $RPM_BUILD_ROOT/etc/sysconfig/%{name}
67
68 %{__rm} $RPM_BUILD_ROOT%{_desktopdir}/steam.desktop
69 %{__mv} $RPM_BUILD_ROOT/usr/lib/steam/steam.desktop $RPM_BUILD_ROOT%{_desktopdir}/steam.desktop
70
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post
76 %update_icon_cache hicolor
77 %update_desktop_database
78 %glib_compile_schemas
79
80 %postun
81 %update_icon_cache hicolor
82 %update_desktop_database_postun
83 %glib_compile_schemas
84
85 %files
86 %defattr(644,root,root,755)
87 %doc steam_subscriber_agreement.txt
88 %attr(755,root,root) %{_bindir}/steam
89 %attr(755,root,root) %{_bindir}/steamdeps
90 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
91 %dir /usr/lib/steam
92 %attr(755,root,root) /usr/lib/steam/bin_steam.sh
93 %attr(755,root,root) /usr/lib/steam/bin_steamdeps.py
94 /usr/lib/steam/bootstraplinux*.tar.xz
95 %{_desktopdir}/steam.desktop
96 %{_iconsdir}/hicolor/*/*/*.png
97 %{_mandir}/man6/steam.6*
98 %{_pixmapsdir}/*.png
This page took 0.076153 seconds and 2 git commands to generate.