]> git.pld-linux.org Git - packages/sssd.git/commitdiff
up to 1.13.4
authorElan Ruusamäe <glen@delfi.ee>
Sun, 1 May 2016 09:22:54 +0000 (12:22 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sun, 1 May 2016 09:52:15 +0000 (12:52 +0300)
outated sssd-python-config.patch
updated sssd-heimdal.patch, sssd-link.patch
python2/python3 possible

sssd-heimdal.patch
sssd-link.patch
sssd-python-config.patch [deleted file]
sssd.init [changed mode: 0644->0755]
sssd.spec

index 7be6c4227ce93b3044876d46874b9840a4c77988..5218cf77488807e0d0fd1edb843e7d9f375b3a42 100644 (file)
@@ -788,10 +788,8 @@ index f8a7e6f..a954d10 100644
 +    return 0;
 +#endif
 +}
-diff --git a/src/util/sss_krb5.h b/src/util/sss_krb5.h
-index db47e0a..c7b9a69 100644
---- a/src/util/sss_krb5.h
-+++ b/src/util/sss_krb5.h
+--- sssd-1.13.4/src/util/sss_krb5.h~   2016-05-01 12:23:18.000000000 +0300
++++ sssd-1.13.4/src/util/sss_krb5.h    2016-05-01 12:24:04.615247459 +0300
 @@ -70,6 +70,8 @@ void KRB5_CALLCONV sss_krb5_get_init_cre
  
  void KRB5_CALLCONV sss_krb5_free_unparsed_name(krb5_context context, char *name);
@@ -822,10 +820,10 @@ index db47e0a..c7b9a69 100644
  krb5_error_code sss_krb5_find_authdata(krb5_context context,
                                         krb5_authdata *const *ticket_authdata,
                                         krb5_authdata *const *ap_req_authdata,
-@@ -189,4 +196,14 @@ sss_krb5_get_primary(TALLOC_CTX *mem_ctx
- krb5_error_code sss_krb5_kt_have_content(krb5_context context,
+@@ -193,4 +193,14 @@
                                           krb5_keytab keytab);
+ bool sss_krb5_realm_has_proxy(const char *realm);
 +
 +krb5_error_code KRB5_CALLCONV
 +sss_krb5_unparse_name_ext(krb5_context ctx,
index de3d6a53a5b401cf5ccaa752b28e8dc2108efbed..d9a226e6b23e9626d787e86ed7708cc93e876b7f 100644 (file)
@@ -1,11 +1,11 @@
---- sssd-1.12.3/Makefile.am.orig       2015-01-12 18:49:06.135356150 +0100
-+++ sssd-1.12.3/Makefile.am    2015-01-12 19:16:19.545287606 +0100
-@@ -870,7 +870,7 @@
-     src/sss_client/libwbclient/wbc_util_sssd.c
+--- sssd-1.13.4/Makefile.am~   2016-05-01 12:25:42.000000000 +0300
++++ sssd-1.13.4/Makefile.am    2016-05-01 12:26:04.028031558 +0300
+@@ -1010,7 +1010,7 @@
+     $(NULL)
  libwbclient_la_LIBADD = \
      libsss_nss_idmap.la \
--    $(CLIENT_LIBS)
-+    $(CLIENT_LIBS) -ldl
+-    $(CLIENT_LIBS) \
++    $(CLIENT_LIBS) -ldl \
+     $(NULL)
  libwbclient_la_LDFLAGS = \
-     -Wl,--version-script,$(srcdir)/src/sss_client/libwbclient/wbclient.exports \
-     -version-info 11:0:11
diff --git a/sssd-python-config.patch b/sssd-python-config.patch
deleted file mode 100644 (file)
index bb62d08..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- sssd-1.11.4/src/external/python.m4.orig    2014-03-12 18:24:31.013871791 +0100
-+++ sssd-1.11.4/src/external/python.m4 2014-03-12 19:55:39.160308983 +0100
-@@ -12,15 +12,8 @@
-     AC_PATH_PROG(PYTHON, python)
-     AC_MSG_CHECKING([for working python])
-     if test -x "$PYTHON"; then
--        PYTHON_CFLAGS="`$PYTHON -c \"from distutils import sysconfig; \
--            print '-I' + sysconfig.get_python_inc() + \
--            ' -I' + sysconfig.get_python_inc(plat_specific=True) + ' ' + \
--            sysconfig.get_config_var('BASECFLAGS')\"`"
--        PYTHON_LIBS="`$PYTHON -c \"from distutils import sysconfig; \
--            print \\\" \\\".join(sysconfig.get_config_var('LIBS').split() + \
--            sysconfig.get_config_var('SYSLIBS').split()) + \
--            ' -lpython' + sysconfig.get_config_var('VERSION') + \
--            ' -L' + sysconfig.get_config_var('LIBDIR')\"`"
-+        PYTHON_CFLAGS="`python-config --cflags`"
-+        PYTHON_LIBS="`python-config --libs`"
-             AC_MSG_RESULT([yes])
-     else
-         AC_MSG_RESULT([no])
old mode 100644 (file)
new mode 100755 (executable)
index 745283f..3603976
--- a/sssd.init
+++ b/sssd.init
@@ -10,7 +10,6 @@
 # config:      /etc/sssd/sssd.conf
 # pidfile:     /var/lib/sssd/sssd.pid
 #
-# $Id$
 
 # Source function library
 . /etc/rc.d/init.d/functions
index e1c43234b466f290c8650af8a1f04835e4e89afe..5382dcc5dc58d9efbc1c357e593f6b1f1c6af3d5 100644 (file)
--- a/sssd.spec
+++ b/sssd.spec
@@ -1,19 +1,24 @@
 # TODO
+# - python3 packages
 # - pac-responder (currently relies on MIT krb5 >= 1.9)
 # - fix stripping before rpm:
 #   *** WARNING: no sources found for /usr/lib64/libipa_hbac.so.0.0.0 (stripped without sourcefile information?)
+#
+# Conditional build:
+%bcond_without python2 # CPython 2.x module
+%bcond_with    python3 # CPython 3.x module
+
 %define                ldb_version 1.1.0
 Summary:       System Security Services Daemon
 Summary(pl.UTF-8):     System Security Services Daemon - demon usług bezpieczeństwa systemu
 Name:          sssd
-Version:       1.12.3
+Version:       1.13.4
 Release:       0.1
 License:       GPL v3+
 Group:         Applications/System
 Source0:       https://fedorahosted.org/released/sssd/%{name}-%{version}.tar.gz
-# Source0-md5: b891c263819a1dde062d7065448a4d58
+# Source0-md5: d147e0a4f4719d993693c6a99370b350
 Source1:       %{name}.init
-Patch0:                %{name}-python-config.patch
 Patch1:                %{name}-heimdal.patch
 Patch2:                %{name}-systemd.patch
 Patch3:                %{name}-link.patch
@@ -32,7 +37,7 @@ BuildRequires:        dbus-devel >= 1.0.0
 BuildRequires: docbook-dtd44-xml
 BuildRequires: docbook-style-xsl
 BuildRequires: doxygen
-BuildRequires: gettext-tools >= 0.14
+BuildRequires: gettext-tools >= 0.14.4
 BuildRequires: glib2-devel >= 2.0
 BuildRequires: heimdal-devel
 BuildRequires: keyutils-devel
@@ -303,7 +308,6 @@ Pliki nagłówkowe biblioteki libsss_simpleifp.
 
 %prep
 %setup -q
-%patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
@@ -326,6 +330,8 @@ Pliki nagłówkowe biblioteki libsss_simpleifp.
        --with-initscript=sysv,systemd \
        --with-pipe-path=%{pipepath} \
        --with-pubconf-path=%{pubconfpath} \
+       --with%{!?with_python2:out}-python2-bindings \
+       --with%{!?with_python3:out}-python3-bindings \
        --with-systemdunitdir=%{systemdunitdir} \
        --with-test-dir=/dev/shm
 
This page took 0.076208 seconds and 4 git commands to generate.