]> git.pld-linux.org Git - packages/sssd.git/commitdiff
- rel 5; build fixed auto/th/sssd-1.13.4-5
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 4 Jul 2018 17:39:20 +0000 (19:39 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 4 Jul 2018 17:39:20 +0000 (19:39 +0200)
format.patch [new file with mode: 0644]
sssd.spec

diff --git a/format.patch b/format.patch
new file mode 100644 (file)
index 0000000..8fb8d3a
--- /dev/null
@@ -0,0 +1,33 @@
+From 038011b9121fff5ce0801e7ab3b49791079b91ac Mon Sep 17 00:00:00 2001
+From: Lukas Slebodnik <lslebodn@redhat.com>
+Date: Thu, 1 Dec 2016 13:13:21 +0100
+Subject: [PATCH] SIFP: Fix warning format-security
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+dbus-1.11.8 added attributes for format string check to
+few functions in public header files. And therefore there is a warning.
+
+src/lib/sifp/sss_sifp_utils.c: In function ‘sss_sifp_set_io_error’:
+src/lib/sifp/sss_sifp_utils.c:44:5: error: format not a string literal
+and no format arguments [-Werror=format-security]
+     dbus_set_error(ctx->io_error, error->name, error->message);
+          ^~~~~~~~~~~~~~
+---
+ src/lib/sifp/sss_sifp_utils.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/lib/sifp/sss_sifp_utils.c b/src/lib/sifp/sss_sifp_utils.c
+index ccd0518..dcac71f 100644
+--- a/src/lib/sifp/sss_sifp_utils.c
++++ b/src/lib/sifp/sss_sifp_utils.c
+@@ -41,7 +41,7 @@ void sss_sifp_set_io_error(sss_sifp_ctx *ctx, DBusError *error)
+ {
+     dbus_error_free(ctx->io_error);
+     dbus_error_init(ctx->io_error);
+-    dbus_set_error(ctx->io_error, error->name, error->message);
++    dbus_set_error(ctx->io_error, error->name, "%s", error->message);
+ }
+ char * sss_sifp_strdup(sss_sifp_ctx *ctx, const char *str)
index a3156b59eb540a2b7e805a1613189d56677d9ee1..bb9c4fae8eb35105918e4b41ca9edafb9e26ef6c 100644 (file)
--- a/sssd.spec
+++ b/sssd.spec
@@ -14,7 +14,7 @@ Summary:      System Security Services Daemon
 Summary(pl.UTF-8):     System Security Services Daemon - demon usług bezpieczeństwa systemu
 Name:          sssd
 Version:       1.13.4
-Release:       4
+Release:       5
 License:       GPL v3+
 Group:         Applications/System
 Source0:       https://fedorahosted.org/released/sssd/%{name}-%{version}.tar.gz
@@ -24,6 +24,7 @@ Patch0:               %{name}-python.patch
 Patch1:                %{name}-heimdal.patch
 Patch2:                %{name}-systemd.patch
 Patch3:                %{name}-link.patch
+Patch4:                format.patch
 URL:           https://fedorahosted.org/sssd/
 BuildRequires: augeas-devel >= 1.0.0
 BuildRequires: autoconf >= 2.59
@@ -460,6 +461,7 @@ Pliki nagłówkowe biblioteki libsss_simpleifp.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 %{__libtoolize}
This page took 0.076856 seconds and 4 git commands to generate.