]> git.pld-linux.org Git - packages/sssd.git/blob - sssd.spec
rebuild with separate debuginfo build-ids
[packages/sssd.git] / sssd.spec
1 # TODO
2 # - fix stripping before rpm:
3 #   *** WARNING: no sources found for /usr/lib64/libipa_hbac.so.0.0.0 (stripped without sourcefile information?)
4 # - add info how sssd-heimdal.patch is updated, where is it's origin?
5 #
6 # Conditional build:
7 %bcond_with     tests   # check target
8 %bcond_without  python2 # CPython 2.x module
9 %bcond_without  python3 # CPython 3.x module
10 %bcond_with     krb5    # MIT Kerberos V instead of Heimdal (enables locator plugin, profile support and pac-responder)
11
12 %define         ldb_version 1.1.0
13 Summary:        System Security Services Daemon
14 Summary(pl.UTF-8):      System Security Services Daemon - demon usług bezpieczeństwa systemu
15 Name:           sssd
16 Version:        1.13.4
17 Release:        12
18 License:        GPL v3+
19 Group:          Applications/System
20 Source0:        https://fedorahosted.org/released/sssd/%{name}-%{version}.tar.gz
21 # Source0-md5:  d147e0a4f4719d993693c6a99370b350
22 Source1:        %{name}.init
23 Patch0:         %{name}-python.patch
24 Patch1:         %{name}-heimdal.patch
25 Patch2:         %{name}-systemd.patch
26 Patch3:         %{name}-link.patch
27 Patch4:         format.patch
28 Patch5:         array-size.patch
29 Patch6:         samba-4.12.patch
30 URL:            https://fedorahosted.org/sssd/
31 BuildRequires:  augeas-devel >= 1.0.0
32 BuildRequires:  autoconf >= 2.59
33 BuildRequires:  automake
34 # nsupdate utility
35 BuildRequires:  bind-utils
36 BuildRequires:  c-ares-devel
37 BuildRequires:  check-devel >= 0.9.5
38 BuildRequires:  cifs-utils-devel
39 %{?with_tests:BuildRequires:    cmocka-devel >= 1.0.0}
40 BuildRequires:  cyrus-sasl-devel >= 2
41 BuildRequires:  dbus-devel >= 1.0.0
42 BuildRequires:  docbook-dtd44-xml
43 BuildRequires:  docbook-style-xsl
44 BuildRequires:  doxygen
45 %{?with_tests:BuildRequires:    fakeroot}
46 BuildRequires:  gettext-tools >= 0.14.4
47 BuildRequires:  glib2-devel >= 2.0
48 %{!?with_krb5:BuildRequires:    heimdal-devel}
49 BuildRequires:  keyutils-devel
50 %{?with_krb5:BuildRequires:     krb5-devel >= 1.9}
51 BuildRequires:  ldb-devel >= %{ldb_version}
52 BuildRequires:  libcollection-devel >= 0.5.1
53 BuildRequires:  libdhash-devel >= 0.4.2
54 BuildRequires:  libini_config-devel >= 1.1.0
55 BuildRequires:  libltdl-devel
56 BuildRequires:  libnfsidmap-devel
57 BuildRequires:  libnl-devel >= 3.2
58 BuildRequires:  libselinux-devel
59 BuildRequires:  libsemanage-devel
60 BuildRequires:  libsmbclient-devel
61 BuildRequires:  libtool >= 2:2
62 BuildRequires:  libxml2-progs
63 BuildRequires:  libxslt-progs
64 BuildRequires:  m4
65 BuildRequires:  nspr-devel
66 BuildRequires:  nss-devel
67 %{?with_tests:BuildRequires:    nss_wrapper}
68 BuildRequires:  openldap-devel
69 BuildRequires:  pam-devel
70 BuildRequires:  pcre-devel >= 7
71 BuildRequires:  pkgconfig
72 BuildRequires:  po4a
73 BuildRequires:  popt-devel
74 %{?with_python2:BuildRequires:  python-devel >= 1:2.6}
75 %{?with_tests:BuildRequires:    python-pytest}
76 %{?with_python3:BuildRequires:  python3-devel >= 1:3.3}
77 BuildRequires:  rpm-pythonprov
78 BuildRequires:  rpmbuild(macros) >= 1.612
79 # pkgconfig(ndr_nbt), pkgconfig(ndr_krb5pac) if with krb5
80 BuildRequires:  samba-devel >= 4
81 BuildRequires:  systemd-devel >= 1:209
82 BuildRequires:  systemd-units
83 BuildRequires:  talloc-devel
84 BuildRequires:  tdb-devel >= 1.1.3
85 BuildRequires:  tevent-devel
86 %{?with_tests:BuildRequires:    uid_wrapper}
87 Requires(post): /sbin/ldconfig
88 Requires(post,preun):   /sbin/chkconfig
89 Requires:       %{name}-client = %{version}-%{release}
90 Requires:       cyrus-sasl-gssapi
91 Requires:       ldb >= %{ldb_version}
92 Requires:       libcollection >= 0.5.1
93 Requires:       libdhash >= 0.4.2
94 Requires:       libini_config >= 1.1.0
95 Requires:       libsss_idmap = %{version}-%{release}
96 Requires:       pcre >= 7
97 Requires:       rc-scripts >= 0.4.0.10
98 Requires:       tdb >= 1.1.3
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %define         sssdstatedir            %{_localstatedir}/lib/sss
102 %define         dbpath                  %{sssdstatedir}/db
103 %define         pipepath                %{sssdstatedir}/pipes
104 %define         pubconfpath             %{sssdstatedir}/pubconf
105
106 # Determine the location of the LDB modules directory
107 %define         ldb_modulesdir  %(pkg-config --variable=modulesdir ldb)
108
109 %description
110 Provides a set of daemons to manage access to remote directories and
111 authentication mechanisms. It provides an NSS and PAM interface toward
112 the system and a pluggable backend system to connect to multiple
113 different account sources. It is also the basis to provide client
114 auditing and policy services for projects like FreeIPA.
115
116 %description -l pl.UTF-8
117 Ten pakiet dostarcza zbiór demonów do zarządzania dostępem do zdalnych
118 katalogów i mechanizmów uwierzytelniania. Udostępnia interfejsy NSS i
119 PAM dla systemu oraz system backendu z wtyczkami w celu łączenia się z
120 wieloma różnymi źródłami kont. Jest także podstawą zapewniającą audyt
121 klientów oraz usługi polityk dla projektów takich jak FreeIPA.
122
123 %package client
124 Summary:        SSSD Client libraries for NSS and PAM
125 Summary(pl.UTF-8):      Biblioteki klienckie SSSD dla NSS i PAM
126 License:        LGPL v3+
127 Group:          Applications/System
128 Requires:       libsss_idmap = %{version}-%{release}
129 Requires:       libsss_nss_idmap = %{version}-%{release}
130
131 %description client
132 Provides the libraries needed by the PAM and NSS stacks to connect to
133 the SSSD service.
134
135 %description client -l pl.UTF-8
136 Ten pakiet dostarcza biblioteki wymagane przez stosy PAM i NSS w celu
137 łączenia się z usługą SSSD.
138
139 %package tools
140 Summary:        Userspace tools for use with the SSSD
141 Summary(pl.UTF-8):      Narzędzia przestrzeni użytkownika do używania z SSSD
142 License:        GPL v3+
143 Group:          Applications/System
144 Requires:       %{name} = %{version}-%{release}
145
146 %description tools
147 Provides userspace tools for manipulating users, groups, and nested
148 groups in SSSD when using id_provider = local in /etc/sssd/sssd.conf.
149
150 Also provides several other administrative tools:
151  - sss_debuglevel to change the debug level on the fly,
152  - sss_seed which pre-creates a user entry for use in kickstarts,
153  - sss_obfuscate for generating an obfuscated LDAP password.
154
155 %description tools -l pl.UTF-8
156 Ten pakiet dostarcza narzędzia przestrzeni poleceń do operowania na
157 użytkownikach, grupach oraz zagnieżdżonych grupach w SSSD w przypadku
158 używania id_provider = local w /etc/sssd/sssd.conf.
159
160 Pakiet zawiera także kilka innych narzędzi administracyjnych:
161  - sss_debuglevel do zmiany poziomu diagnostyki w locie,
162  - sss_seed tworzący wpis użytkownika do szybkiego rozruchu,
163  - sss_obfuscate do generowania utajnionego hasła LDAP.
164
165 %package -n python-sss
166 Summary:        Python 2 bindings for sssd
167 Summary(pl.UTF-8):      Wiązania Pythona 2 do sssd
168 License:        LGPL v3+
169 Group:          Libraries/Python
170 Requires:       %{name} = %{version}-%{release}
171
172 %description -n python-sss
173 Python 2 module for manipulating users, groups, and nested groups in
174 SSSD when using id_provider = local in /etc/sssd/sssd.conf.
175
176 This module also provides several other useful Python 2 bindings:
177  - function for retrieving list of groups user belongs to.
178  - class for obfuscation of passwords
179
180 %description -n python-sss -l pl.UTF-8
181 Moduł Pythona 2 do operowania na użytkownikach, grupach i
182 zagnieżdżonych grupach w SSSD w przypadku używania id_provider = local
183 w /etc/sssd/sssd.conf.
184
185 Ten moduł dostarcza także kilka innych przydatnych wiązań Pythona 2:
186  - funkcję do użyskiwania list grup, do których należy użytkownik,
187  - klasę do ukrywania haseł.
188
189 %package -n python-sss-murmur
190 Summary:        Python 2 bindings for murmur hash function
191 Summary(pl.UTF-8):      Wiązania Pythona 2 do funkcji mieszającej murmur
192 License:        LGPL v3+
193 Group:          Libraries/Python
194
195 %description -n python-sss-murmur
196 Python 2 module for calculating the murmur hash version 3.
197
198 %description -n python-sss-murmur -l pl.UTF-8
199 Moduł Pythona 2 do obliczania skrótu murmur w wersji 3.
200
201 %package -n python-sssdconfig
202 Summary:        SSSD and IPA configuration file manipulation classes and functions for Python 2
203 Summary(pl.UTF-8):      Klasy i funkcje Pythona 2 do operowania na plikach konfiguracyjnych SSSD oraz IPA
204 License:        GPL v3+
205 Group:          Libraries/Python
206 BuildArch:      noarch
207
208 %description -n python-sssdconfig
209 SSSD and IPA configuration file manipulation classes and functions for
210 Python 2.
211
212 %description -n python-sssdconfig -l pl.UTF-8
213 Klasy i funkcje Pythona 2 do operowania na plikach konfiguracyjnych
214 SSSD oraz IPA.
215
216 %package -n python3-sss
217 Summary:        Python 3 bindings for sssd
218 Summary(pl.UTF-8):      Wiązania Pythona 3 do sssd
219 License:        LGPL v3+
220 Group:          Libraries/Python
221 Requires:       %{name} = %{version}-%{release}
222
223 %description -n python3-sss
224 Python 3 module for manipulating users, groups, and nested groups in
225 SSSD when using id_provider = local in /etc/sssd/sssd.conf.
226
227 This module also provides several other useful Python 3 bindings:
228  - function for retrieving list of groups user belongs to.
229  - class for obfuscation of passwords
230
231 %description -n python3-sss -l pl.UTF-8
232 Moduł Pythona 3 do operowania na użytkownikach, grupach i
233 zagnieżdżonych grupach w SSSD w przypadku używania id_provider = local
234 w /etc/sssd/sssd.conf.
235
236 Ten moduł dostarcza także kilka innych przydatnych wiązań Pythona 3:
237  - funkcję do użyskiwania list grup, do których należy użytkownik,
238  - klasę do ukrywania haseł.
239
240 %package -n python3-sss-murmur
241 Summary:        Python 3 bindings for murmur hash function
242 Summary(pl.UTF-8):      Wiązania Pythona 3 do funkcji mieszającej murmur
243 License:        LGPL v3+
244 Group:          Libraries/Python
245
246 %description -n python3-sss-murmur
247 Python 3 module for calculating the murmur hash version 3.
248
249 %description -n python3-sss-murmur -l pl.UTF-8
250 Moduł Pythona 3 do obliczania skrótu murmur w wersji 3.
251
252 %package -n python3-sssdconfig
253 Summary:        SSSD and IPA configuration file manipulation classes and functions for Python 3
254 Summary(pl.UTF-8):      Klasy i funkcje Pythona 3 do operowania na plikach konfiguracyjnych SSSD oraz IPA
255 License:        GPL v3+
256 Group:          Libraries/Python
257 BuildArch:      noarch
258
259 %description -n python3-sssdconfig
260 SSSD and IPA configuration file manipulation classes and functions for
261 Python 3.
262
263 %description -n python3-sssdconfig -l pl.UTF-8
264 Klasy i funkcje Pythona 3 do operowania na plikach konfiguracyjnych
265 SSSD oraz IPA.
266
267 %package libwbclient
268 Summary:        The SSSD libwbclient implementation
269 Summary(pl.UTF-8):      Implementacja libwbclient oparta na SSSD
270 Group:          Libraries
271 License:        LGPL v3+
272 Requires:       libsss_nss_idmap = %{version}-%{release}
273
274 %description libwbclient
275 The SSSD implementation of Samba wbclient library.
276
277 %description libwbclient -l pl.UTF-8
278 Implementacja biblioteki Samba wbclient oparta na SSSD.
279
280 %package libwbclient-devel
281 Summary:        Development files of the SSSD libwbclient implementation
282 Summary(pl.UTF-8):      Pliki programistyczne implementacja libwbclient oparta na SSSD
283 Group:          Development/Libraries
284 License:        LGPL v3+
285 Requires:       %{name}-libwbclient = %{version}-%{release}
286
287 %description libwbclient-devel
288 Development files for the SSSD implementation of Samba wbclient
289 library.
290
291 %description libwbclient-devel -l pl.UTF-8
292 Pliki programistyczne implementacji biblioteki Samba wbclient opartej
293 na SSSD.
294
295 %package -n libipa_hbac
296 Summary:        FreeIPA HBAC Evaluator library
297 Summary(pl.UTF-8):      Biblioteka oceniająca FreeIPA HBAC
298 License:        LGPL v3+
299 Group:          Libraries
300
301 %description -n libipa_hbac
302 Utility library to validate FreeIPA HBAC rules for authorization
303 requests.
304
305 %description -n libipa_hbac
306 Biblioteka narzędziowa do sprawdzania poprawności reguł FreeIPA HBAC
307 dla żądań autoryzacji.
308
309 %package -n libipa_hbac-devel
310 Summary:        Development files for FreeIPA HBAC Evaluator library
311 Summary(pl.UTF-8):      Pliki programistyczne biblioteki oceniająca FreeIPA HBAC
312 License:        LGPL v3+
313 Group:          Development/Libraries
314 Requires:       libipa_hbac = %{version}-%{release}
315
316 %description -n libipa_hbac-devel
317 Development files for FreeIPA HBAC Evaluator library.
318
319 %description -n libipa_hbac-devel -l pl.UTF-8
320 Pliki programistyczne biblioteki oceniająca FreeIPA HBAC.
321
322 %package -n python-libipa_hbac
323 Summary:        Python 2 bindings for the FreeIPA HBAC Evaluator library
324 Summary(pl.UTF-8):      Wiązania Pythona 2 do biblioteki oceniającej FreeIPA HBAC
325 License:        LGPL v3+
326 Group:          Libraries/Python
327 Requires:       libipa_hbac = %{version}-%{release}
328 Obsoletes:      libipa_hbac-python
329
330 %description -n python-libipa_hbac
331 This package contains the bindings so that libipa_hbac can be used by
332 Python 2 applications.
333
334 %description -n python-libipa_hbac -l pl.UTF-8
335 Ten pakiet zawiera wiązania pozwalające na używanie libipa_hbac w
336 aplikacjach Pythona 2.
337
338 %package -n python3-libipa_hbac
339 Summary:        Python 3 bindings for the FreeIPA HBAC Evaluator library
340 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki oceniającej FreeIPA HBAC
341 License:        LGPL v3+
342 Group:          Libraries/Python
343 Requires:       libipa_hbac = %{version}-%{release}
344
345 %description -n python3-libipa_hbac
346 This package contains the bindings so that libipa_hbac can be used by
347 Python 3 applications.
348
349 %description -n python3-libipa_hbac -l pl.UTF-8
350 Ten pakiet zawiera wiązania pozwalające na używanie libipa_hbac w
351 aplikacjach Pythona 3.
352
353 %package -n libsss_idmap
354 Summary:        FreeIPA Idmap library
355 Summary(pl.UTF-8):      Biblioteka FreeIPA Idmap
356 Group:          Libraries
357 License:        LGPL v3+
358
359 %description -n libsss_idmap
360 Utility library to convert SIDs to Unix uids and gids.
361
362 %description -n libsss_idmap -l pl.UTF-8
363 Biblioteka narzędziowa konwertująca SID-y na uniksowe uidy i gidy.
364
365 %package -n libsss_idmap-devel
366 Summary:        Development files for FreeIPA Idmap library
367 Summary(pl.UTF-8):      Pliki programistyczne biblioteki FreeIPA Idmap
368 Group:          Development/Libraries
369 License:        LGPL v3+
370 Requires:       libsss_idmap = %{version}-%{release}
371
372 %description -n libsss_idmap-devel
373 Development files for FreeIPA Idmap library.
374
375 %description -n libsss_idmap-devel -l pl.UTF-8
376 Pliki programistyczne biblioteki FreeIPA Idmap.
377
378 %package -n libsss_nss_idmap
379 Summary:        Library for SID based lookups
380 Summary(pl.UTF-8):      Biblioteka do wyszukiwań w oparciu o SID
381 Group:          Libraries
382 License:        LGPL v3+
383
384 %description -n libsss_nss_idmap
385 Utility library for SID based lookups.
386
387 %description -n libsss_nss_idmap -l pl.UTF-8
388 Biblioteka do wyszukiwań w oparciu o SID.
389
390 %package -n libsss_nss_idmap-devel
391 Summary:        Development files for sss_nss_idmap library
392 Summary(pl.UTF-8):      Pliki programistyczne biblioteki sss_nss_idmap
393 Group:          Development/Libraries
394 License:        LGPL v3+
395 Requires:       libsss_nss_idmap = %{version}-%{release}
396
397 %description -n libsss_nss_idmap-devel
398 Development files for sss_nss_idmap library.
399
400 %description -n libsss_nss_idmap-devel -l pl.UTF-8
401 Pliki programistyczne biblioteki sss_nss_idmap.
402
403 %package -n python-libsss_nss_idmap
404 Summary:        Python 2 bindings for libsss_nss_idmap
405 Summary(pl.UTF-8):      Wiązania Pythona 2 do biblioteki libsss_nss_idmap
406 Group:          Libraries/Python
407 License:        LGPL v3+
408 Requires:       libsss_nss_idmap = %{version}-%{release}
409
410 %description -n python-libsss_nss_idmap
411 This package contains the bindings so that libsss_nss_idmap can be
412 used by Python 2 applications.
413
414 %description -n python-libsss_nss_idmap -l pl.UTF-8
415 Ten pakiet zawiera wiązania umożliwiające korzystanie z biblioteki
416 libsss_nss_idmap w aplikacjach Pythona 2.
417
418 %package -n python3-libsss_nss_idmap
419 Summary:        Python 3 bindings for libsss_nss_idmap
420 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki libsss_nss_idmap
421 Group:          Libraries/Python
422 License:        LGPL v3+
423 Requires:       libsss_nss_idmap = %{version}-%{release}
424
425 %description -n python3-libsss_nss_idmap
426 This package contains the bindings so that libsss_nss_idmap can be
427 used by Python 3 applications.
428
429 %description -n python3-libsss_nss_idmap -l pl.UTF-8
430 Ten pakiet zawiera wiązania umożliwiające korzystanie z biblioteki
431 libsss_nss_idmap w aplikacjach Pythona 3.
432
433 %package -n libsss_simpleifp
434 Summary:        A library that simplifies work with the InfoPipe responder
435 Summary(pl.UTF-8):      Biblioteka upraszczająca pracę z responderem InfoPipe
436 Group:          Libraries
437 Requires:       dbus-libs >= 1.0.0
438 Requires:       libdhash >= 0.4.2
439
440 %description -n libsss_simpleifp
441 A library that simplifies work with the InfoPipe responder.
442
443 %description -n libsss_simpleifp -l pl.UTF-8
444 Biblioteka upraszczająca pracę z responderem InfoPipe.
445
446 %package -n libsss_simpleifp-devel
447 Summary:        Header files for libsss_simpleifp library
448 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsss_simpleifp
449 Group:          Development/Libraries
450 Requires:       dbus-devel >= 1.0.0
451 Requires:       libdhash-devel >= 0.4.2
452 Requires:       libsss_simpleifp = %{version}-%{release}
453
454 %description -n libsss_simpleifp-devel
455 Header files for libsss_simpleifp library.
456
457 %description -n libsss_simpleifp-devel -l pl.UTF-8
458 Pliki nagłówkowe biblioteki libsss_simpleifp.
459
460 %prep
461 %setup -q
462 %patch0 -p1
463 %patch1 -p1
464 %patch2 -p1
465 %patch3 -p1
466 %patch4 -p1
467 %patch5 -p1
468 %patch6 -p1
469
470 %{__sed} -E -i -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
471       src/tools/sss_obfuscate
472
473 %build
474 %{__libtoolize}
475 %{__gettextize}
476 %{__aclocal} -I m4
477 %{__autoconf}
478 %{__automake}
479 %configure \
480         NSCD=/usr/sbin/nscd \
481         %{!?with_krb5:--disable-krb5-locator-plugin} \
482         --enable-nfsidmaplibdir=/%{_lib}/libnfsidmap \
483         --enable-nsslibdir=/%{_lib} \
484         %{!?with_krb5:--disable-pac-responder} \
485         --enable-pammoddir=/%{_lib}/security \
486         --disable-rpath \
487         --with-db-path=%{dbpath} \
488         --with-init-dir=/etc/rc.d/init.d \
489         --with-initscript=sysv,systemd \
490         --with-pipe-path=%{pipepath} \
491         --with-pubconf-path=%{pubconfpath} \
492         --with-python2-bindings%{!?with_python2:=no} \
493         --with-python3-bindings%{!?with_python3:=no} \
494         --with-systemdunitdir=%{systemdunitdir} \
495         --with-test-dir=/dev/shm
496
497 %{__make}
498
499 %if %{with tests}
500 export CK_TIMEOUT_MULTIPLIER=10
501 %{__make} check
502 unset CK_TIMEOUT_MULTIPLIER
503 %endif
504
505 %install
506 rm -rf $RPM_BUILD_ROOT
507
508 %{__make} -j1 install \
509         DESTDIR=$RPM_BUILD_ROOT \
510         python3dir=%{py3_sitescriptdir}
511
512 # Prepare language files
513 %find_lang %{name}
514
515 # Copy default sssd.conf file
516 install -d $RPM_BUILD_ROOT%{_sysconfdir}/sssd/sssd.api.d
517 cp -p src/examples/sssd-example.conf $RPM_BUILD_ROOT%{_sysconfdir}/sssd/sssd.conf
518
519 # Copy default logrotate file
520 install -d $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
521 cp -p src/examples/logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/sssd
522
523 # Make sure SSSD is able to run on read-only root
524 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rwtab.d
525 #cp -p src/examples/rwtab $RPM_BUILD_ROOT%{_sysconfdir}/rwtab.d/sssd
526
527 # Remove .la files created by libtool
528 %{__rm} \
529         $RPM_BUILD_ROOT/%{_lib}/libnss_sss.la \
530         $RPM_BUILD_ROOT/%{_lib}/libnfsidmap/sss.la \
531         $RPM_BUILD_ROOT/%{_lib}/security/pam_sss.la \
532         $RPM_BUILD_ROOT%{ldb_modulesdir}/memberof.la \
533         $RPM_BUILD_ROOT%{_libdir}/cifs-utils/*.la \
534         %{?with_krb5:$RPM_BUILD_ROOT%{_libdir}/krb5/plugins/libkrb5/sss*.la} \
535         $RPM_BUILD_ROOT%{_libdir}/sssd/libsss_*.la \
536         $RPM_BUILD_ROOT%{_libdir}/sssd/modules/lib*.la \
537         $RPM_BUILD_ROOT%{_libdir}/lib*.la
538 %if %{with python2}
539 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.la
540 %py_postclean
541 %endif
542 %if %{with python3}
543 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/*.la
544 %endif
545
546 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
547
548 echo '%%defattr(644,root,root,755)' > sssd_client.lang
549 echo '%%defattr(644,root,root,755)' > sssd_tools.lang
550 for man in $(find $RPM_BUILD_ROOT%{_mandir}/??/man? -type f | sed -e "s#$RPM_BUILD_ROOT%{_mandir}/##"); do
551         lang=$(echo $man | cut -c 1-2)
552         case $(basename $man) in
553         pam_sss.8|sssd_krb5_locator_plugin.8)
554                 echo "%lang(${lang}) %{_mandir}/${man}*" >> sssd_client.lang
555                 ;;
556         sss_debuglevel.8|sss_group*.8|sss_obfuscate.8|sss_seed.8|sss_user*.8)
557                 echo "%lang(${lang}) %{_mandir}/${man}*" >> sssd_tools.lang
558                 ;;
559         *)
560                 echo "%lang(${lang}) %{_mandir}/${man}*" >> sssd.lang
561                 ;;
562         esac
563 done
564
565 %clean
566 rm -rf $RPM_BUILD_ROOT
567
568 %post
569 /sbin/ldconfig
570 /sbin/chkconfig --add %{name}
571 %service %{name} restart
572
573 %preun
574 if [ "$1" = "0" ]; then
575         %service -q %{name} stop
576         /sbin/chkconfig --del %{name}
577 fi
578
579 %postun -p /sbin/ldconfig
580
581 %post   client -p /sbin/ldconfig
582 %postun client -p /sbin/ldconfig
583
584 %post   -n libipa_hbac -p /sbin/ldconfig
585 %postun -n libipa_hbac -p /sbin/ldconfig
586
587 %post   -n libsss_idmap -p /sbin/ldconfig
588 %postun -n libsss_idmap -p /sbin/ldconfig
589
590 %post   -n libsss_nss_idmap -p /sbin/ldconfig
591 %postun -n libsss_nss_idmap -p /sbin/ldconfig
592
593 %post   -n libsss_simpleifp -p /sbin/ldconfig
594 %postun -n libsss_simpleifp -p /sbin/ldconfig
595
596 %files -f sssd.lang
597 %defattr(644,root,root,755)
598 %attr(755,root,root) %{_bindir}/sss_ssh_authorizedkeys
599 %attr(755,root,root) %{_bindir}/sss_ssh_knownhostsproxy
600 %attr(755,root,root) %{_sbindir}/sss_cache
601 %attr(755,root,root) %{_sbindir}/sssd
602 # sudo plugin
603 %attr(755,root,root) %{_libdir}/libsss_sudo.so
604 %dir %{_libdir}/sssd
605 # internal shared libraries
606 %attr(755,root,root) %{_libdir}/sssd/libsss_cert.so
607 %attr(755,root,root) %{_libdir}/sssd/libsss_child.so
608 %attr(755,root,root) %{_libdir}/sssd/libsss_config.so
609 %attr(755,root,root) %{_libdir}/sssd/libsss_crypt.so
610 %attr(755,root,root) %{_libdir}/sssd/libsss_debug.so
611 %attr(755,root,root) %{_libdir}/sssd/libsss_krb5_common.so
612 %attr(755,root,root) %{_libdir}/sssd/libsss_ldap_common.so
613 %attr(755,root,root) %{_libdir}/sssd/libsss_semanage.so
614 %attr(755,root,root) %{_libdir}/sssd/libsss_util.so
615 # modules
616 %attr(755,root,root) %{_libdir}/sssd/libsss_simple.so
617 %attr(755,root,root) %{_libdir}/sssd/libsss_ad.so
618 %attr(755,root,root) %{_libdir}/sssd/libsss_ipa.so
619 %attr(755,root,root) %{_libdir}/sssd/libsss_krb5.so
620 %attr(755,root,root) %{_libdir}/sssd/libsss_ldap.so
621 %attr(755,root,root) %{_libdir}/sssd/libsss_proxy.so
622 %dir %{_libdir}/sssd/modules
623 %attr(755,root,root) %{_libdir}/sssd/modules/libsss_autofs.so
624 %if "%{_libdir}" != "%{_libexecdir}"
625 %dir %{_libexecdir}/sssd
626 %endif
627 %attr(755,root,root) %{_libexecdir}/sssd/gpo_child
628 %attr(755,root,root) %{_libexecdir}/sssd/krb5_child
629 %attr(755,root,root) %{_libexecdir}/sssd/ldap_child
630 %attr(755,root,root) %{_libexecdir}/sssd/p11_child
631 %attr(755,root,root) %{_libexecdir}/sssd/proxy_child
632 %attr(755,root,root) %{_libexecdir}/sssd/selinux_child
633 %attr(755,root,root) %{_libexecdir}/sssd/sss_signal
634 %attr(755,root,root) %{_libexecdir}/sssd/sssd_autofs
635 %attr(755,root,root) %{_libexecdir}/sssd/sssd_be
636 %attr(755,root,root) %{_libexecdir}/sssd/sssd_ifp
637 %attr(755,root,root) %{_libexecdir}/sssd/sssd_nss
638 %if %{with krb5}
639 %attr(755,root,root) %{_libexecdir}/sssd/sssd_pac
640 %endif
641 %attr(755,root,root) %{_libexecdir}/sssd/sssd_pam
642 %attr(755,root,root) %{_libexecdir}/sssd/sssd_ssh
643 %attr(755,root,root) %{_libexecdir}/sssd/sssd_sudo
644 %dir %{_datadir}/sssd
645 %{_datadir}/sssd/sssd.api.conf
646 %dir %{_datadir}/sssd/sssd.api.d
647 %{_datadir}/sssd/sssd.api.d/sssd-ad.conf
648 %{_datadir}/sssd/sssd.api.d/sssd-ipa.conf
649 %{_datadir}/sssd/sssd.api.d/sssd-krb5.conf
650 %{_datadir}/sssd/sssd.api.d/sssd-ldap.conf
651 %{_datadir}/sssd/sssd.api.d/sssd-local.conf
652 %{_datadir}/sssd/sssd.api.d/sssd-proxy.conf
653 %{_datadir}/sssd/sssd.api.d/sssd-simple.conf
654 %attr(755,root,root) /%{_lib}/libnfsidmap/sss.so
655 %attr(755,root,root) %{ldb_modulesdir}/memberof.so
656 %dir %{sssdstatedir}
657 %attr(700,root,root) %dir %{dbpath}
658 %dir %{pipepath}
659 %dir %{pubconfpath}
660 %attr(700,root,root) %dir %{pipepath}/private
661 %attr(750,root,root) %dir %{_var}/log/%{name}
662 %attr(700,root,root) %dir %{_sysconfdir}/sssd
663 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sssd/sssd.conf
664 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/sssd
665 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rwtab.d/sssd
666 %attr(754,root,root) /etc/rc.d/init.d/sssd
667 %{systemdunitdir}/sssd.service
668 /etc/dbus-1/system.d/org.freedesktop.sssd.infopipe.conf
669 %{_datadir}/dbus-1/system-services/org.freedesktop.sssd.infopipe.service
670 %{_mandir}/man1/sss_ssh_authorizedkeys.1*
671 %{_mandir}/man1/sss_ssh_knownhostsproxy.1*
672 %{_mandir}/man5/sss_rpcidmapd.5*
673 %{_mandir}/man5/sssd.conf.5*
674 %{_mandir}/man5/sssd-ad.5*
675 %{_mandir}/man5/sssd-ifp.5*
676 %{_mandir}/man5/sssd-ipa.5*
677 %{_mandir}/man5/sssd-krb5.5*
678 %{_mandir}/man5/sssd-ldap.5*
679 %{_mandir}/man5/sssd-simple.5*
680 %{_mandir}/man5/sssd-sudo.5*
681 %{_mandir}/man8/sss_cache.8*
682 %{_mandir}/man8/sssd.8*
683
684 %files client -f sssd_client.lang
685 %defattr(644,root,root,755)
686 %attr(755,root,root) /%{_lib}/libnss_sss.so.2
687 %attr(755,root,root) /%{_lib}/security/pam_sss.so
688 %attr(755,root,root) %{_libdir}/cifs-utils/cifs_idmap_sss.so
689 %if %{with krb5}
690 # XXX: verify locations
691 %attr(755,root,root) %{_libdir}/krb5/plugins/libkrb5/sssd_krb5_localauth_plugin.so
692 %attr(755,root,root) %{_libdir}/krb5/plugins/libkrb5/sssd_krb5_locator_plugin.so
693 %attr(755,root,root) %{_libdir}/krb5/plugins/libkrb5/sssd_pac_plugin.so
694 %endif
695 %{_mandir}/man8/pam_sss.8*
696 %{_mandir}/man8/sssd_krb5_locator_plugin.8*
697
698 %files tools -f sssd_tools.lang
699 %defattr(644,root,root,755)
700 %attr(755,root,root) %{_sbindir}/sss_debuglevel
701 %attr(755,root,root) %{_sbindir}/sss_groupadd
702 %attr(755,root,root) %{_sbindir}/sss_groupdel
703 %attr(755,root,root) %{_sbindir}/sss_groupmod
704 %attr(755,root,root) %{_sbindir}/sss_groupshow
705 %attr(755,root,root) %{_sbindir}/sss_obfuscate
706 %attr(755,root,root) %{_sbindir}/sss_override
707 %attr(755,root,root) %{_sbindir}/sss_seed
708 %attr(755,root,root) %{_sbindir}/sss_useradd
709 %attr(755,root,root) %{_sbindir}/sss_userdel
710 %attr(755,root,root) %{_sbindir}/sss_usermod
711 %{_mandir}/man8/sss_debuglevel.8*
712 %{_mandir}/man8/sss_groupadd.8*
713 %{_mandir}/man8/sss_groupdel.8*
714 %{_mandir}/man8/sss_groupmod.8*
715 %{_mandir}/man8/sss_groupshow.8*
716 %{_mandir}/man8/sss_obfuscate.8*
717 %{_mandir}/man8/sss_override.8*
718 %{_mandir}/man8/sss_seed.8*
719 %{_mandir}/man8/sss_useradd.8*
720 %{_mandir}/man8/sss_userdel.8*
721 %{_mandir}/man8/sss_usermod.8*
722
723 %if %{with python2}
724 %files -n python-sss
725 %defattr(644,root,root,755)
726 %attr(755,root,root) %{py_sitedir}/pysss.so
727
728 %files -n python-sss-murmur
729 %defattr(644,root,root,755)
730 %attr(755,root,root) %{py_sitedir}/pysss_murmur.so
731
732 %files -n python-sssdconfig
733 %defattr(644,root,root,755)
734 %dir %{py_sitescriptdir}/SSSDConfig
735 %{py_sitescriptdir}/SSSDConfig/*.py[co]
736 %{py_sitescriptdir}/SSSDConfig-%{version}-py*.egg-info
737 %endif
738
739 %if %{with python3}
740 %files -n python3-sss
741 %defattr(644,root,root,755)
742 %attr(755,root,root) %{py3_sitedir}/pysss.so
743
744 %files -n python3-sss-murmur
745 %defattr(644,root,root,755)
746 %attr(755,root,root) %{py3_sitedir}/pysss_murmur.so
747
748 %files -n python3-sssdconfig
749 %defattr(644,root,root,755)
750 %dir %{py3_sitescriptdir}/SSSDConfig
751 %{py3_sitescriptdir}/SSSDConfig/*.py
752 %{py3_sitescriptdir}/SSSDConfig/__pycache__
753 %{py3_sitescriptdir}/SSSDConfig-%{version}-py*.egg-info
754 %endif
755
756 %files libwbclient
757 %defattr(644,root,root,755)
758 %attr(755,root,root) %{_libdir}/sssd/modules/libwbclient.so.*
759
760 %files libwbclient-devel
761 %defattr(644,root,root,755)
762 %attr(755,root,root) %{_libdir}/sssd/modules/libwbclient.so
763 %{_includedir}/wbclient_sssd.h
764 %{_pkgconfigdir}/wbclient_sssd.pc
765
766 %files -n libipa_hbac
767 %defattr(644,root,root,755)
768 %attr(755,root,root) %{_libdir}/libipa_hbac.so.*.*.*
769 %attr(755,root,root) %ghost %{_libdir}/libipa_hbac.so.0
770
771 %files -n libipa_hbac-devel
772 %defattr(644,root,root,755)
773 %attr(755,root,root) %{_libdir}/libipa_hbac.so
774 %{_includedir}/ipa_hbac.h
775 %{_pkgconfigdir}/ipa_hbac.pc
776
777 %if %{with python2}
778 %files -n python-libipa_hbac
779 %defattr(644,root,root,755)
780 %attr(755,root,root) %{py_sitedir}/pyhbac.so
781 %endif
782
783 %if %{with python3}
784 %files -n python3-libipa_hbac
785 %defattr(644,root,root,755)
786 %attr(755,root,root) %{py3_sitedir}/pyhbac.so
787 %endif
788
789 %files -n libsss_idmap
790 %defattr(644,root,root,755)
791 %attr(755,root,root) %{_libdir}/libsss_idmap.so.*.*.*
792 %attr(755,root,root) %ghost %{_libdir}/libsss_idmap.so.0
793
794 %files -n libsss_idmap-devel
795 %defattr(644,root,root,755)
796 %attr(755,root,root) %{_libdir}/libsss_idmap.so
797 %{_includedir}/sss_idmap.h
798 %{_pkgconfigdir}/sss_idmap.pc
799
800 %files -n libsss_nss_idmap
801 %defattr(644,root,root,755)
802 %attr(755,root,root) %{_libdir}/libsss_nss_idmap.so.*.*.*
803 %attr(755,root,root) %ghost %{_libdir}/libsss_nss_idmap.so.0
804
805 %files -n libsss_nss_idmap-devel
806 %defattr(644,root,root,755)
807 %attr(755,root,root) %{_libdir}/libsss_nss_idmap.so
808 %{_includedir}/sss_nss_idmap.h
809 %{_pkgconfigdir}/sss_nss_idmap.pc
810
811 %if %{with python2}
812 %files -n python-libsss_nss_idmap
813 %defattr(644,root,root,755)
814 %attr(755,root,root) %{py_sitedir}/pysss_nss_idmap.so
815 %endif
816
817 %if %{with python3}
818 %files -n python3-libsss_nss_idmap
819 %defattr(644,root,root,755)
820 %attr(755,root,root) %{py3_sitedir}/pysss_nss_idmap.so
821 %endif
822
823 %files -n libsss_simpleifp
824 %defattr(644,root,root,755)
825 %attr(755,root,root) %{_libdir}/libsss_simpleifp.so.*.*.*
826 %attr(755,root,root) %ghost %{_libdir}/libsss_simpleifp.so.0
827
828 %files -n libsss_simpleifp-devel
829 %defattr(644,root,root,755)
830 %attr(755,root,root) %{_libdir}/libsss_simpleifp.so
831 %{_includedir}/sss_sifp.h
832 %{_includedir}/sss_sifp_dbus.h
833 %{_pkgconfigdir}/sss_simpleifp.pc
This page took 0.118123 seconds and 4 git commands to generate.