]> git.pld-linux.org Git - packages/sssd.git/blob - sssd.spec
why not rel 1 if it builds
[packages/sssd.git] / sssd.spec
1 # TODO
2 # - fix stripping before rpm:
3 #   *** WARNING: no sources found for /usr/lib64/libipa_hbac.so.0.0.0 (stripped without sourcefile information?)
4 #
5 # Conditional build:
6 %bcond_with     tests   # check target
7 %bcond_without  python2 # CPython 2.x module
8 %bcond_without  python3 # CPython 3.x module
9 %bcond_with     krb5    # MIT Kerberos V instead of Heimdal (enables locator plugin, profile support and pac-responder)
10
11 %define         ldb_version 1.1.0
12 Summary:        System Security Services Daemon
13 Summary(pl.UTF-8):      System Security Services Daemon - demon usług bezpieczeństwa systemu
14 Name:           sssd
15 Version:        1.13.4
16 Release:        1
17 License:        GPL v3+
18 Group:          Applications/System
19 Source0:        https://fedorahosted.org/released/sssd/%{name}-%{version}.tar.gz
20 # Source0-md5:  d147e0a4f4719d993693c6a99370b350
21 Source1:        %{name}.init
22 Patch0:         %{name}-python.patch
23 Patch1:         %{name}-heimdal.patch
24 Patch2:         %{name}-systemd.patch
25 Patch3:         %{name}-link.patch
26 URL:            https://fedorahosted.org/sssd/
27 BuildRequires:  augeas-devel >= 1.0.0
28 BuildRequires:  autoconf >= 2.59
29 BuildRequires:  automake
30 # nsupdate utility
31 BuildRequires:  bind-utils
32 BuildRequires:  c-ares-devel
33 BuildRequires:  check-devel >= 0.9.5
34 BuildRequires:  cifs-utils-devel
35 %{?with_tests:BuildRequires:    cmocka-devel >= 1.0.0}
36 BuildRequires:  cyrus-sasl-devel >= 2
37 BuildRequires:  dbus-devel >= 1.0.0
38 BuildRequires:  docbook-dtd44-xml
39 BuildRequires:  docbook-style-xsl
40 BuildRequires:  doxygen
41 %{?with_tests:BuildRequires:    fakeroot}
42 BuildRequires:  gettext-tools >= 0.14.4
43 BuildRequires:  glib2-devel >= 2.0
44 %{!?with_krb5:BuildRequires:    heimdal-devel}
45 BuildRequires:  keyutils-devel
46 %{?with_krb5:BuildRequires:     krb5-devel >= 1.9}
47 BuildRequires:  ldb-devel >= %{ldb_version}
48 BuildRequires:  libcollection-devel >= 0.5.1
49 BuildRequires:  libdhash-devel >= 0.4.2
50 BuildRequires:  libini_config-devel >= 1.1.0
51 BuildRequires:  libltdl-devel
52 BuildRequires:  libnfsidmap-devel
53 BuildRequires:  libnl-devel >= 3.2
54 BuildRequires:  libselinux-devel
55 BuildRequires:  libsemanage-devel
56 BuildRequires:  libsmbclient-devel
57 BuildRequires:  libtool >= 2:2
58 BuildRequires:  libxml2-progs
59 BuildRequires:  libxslt-progs
60 BuildRequires:  m4
61 BuildRequires:  nspr-devel
62 BuildRequires:  nss-devel
63 %{?with_tests:BuildRequires:    nss_wrapper}
64 BuildRequires:  openldap-devel
65 BuildRequires:  pam-devel
66 BuildRequires:  pcre-devel >= 7
67 BuildRequires:  pkgconfig
68 BuildRequires:  po4a
69 BuildRequires:  popt-devel
70 %{?with_python2:BuildRequires:  python-devel >= 1:2.6}
71 %{?with_tests:BuildRequires:    python-pytest}
72 %{?with_python3:BuildRequires:  python3-devel >= 1:3.3}
73 BuildRequires:  rpm-pythonprov
74 BuildRequires:  rpmbuild(macros) >= 1.612
75 # pkgconfig(ndr_nbt), pkgconfig(ndr_krb5pac) if with krb5
76 BuildRequires:  samba-devel >= 4
77 BuildRequires:  systemd-devel >= 1:209
78 BuildRequires:  systemd-units
79 BuildRequires:  talloc-devel
80 BuildRequires:  tdb-devel >= 1.1.3
81 BuildRequires:  tevent-devel
82 %{?with_tests:BuildRequires:    uid_wrapper}
83 Requires(post): /sbin/ldconfig
84 Requires(post,preun):   /sbin/chkconfig
85 Requires:       %{name}-client = %{version}-%{release}
86 Requires:       cyrus-sasl-gssapi
87 Requires:       ldb >= %{ldb_version}
88 Requires:       libcollection >= 0.5.1
89 Requires:       libdhash >= 0.4.2
90 Requires:       libini_config >= 1.1.0
91 Requires:       libsss_idmap = %{version}-%{release}
92 Requires:       pcre >= 7
93 Requires:       rc-scripts >= 0.4.0.10
94 Requires:       tdb >= 1.1.3
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %define         sssdstatedir            %{_localstatedir}/lib/sss
98 %define         dbpath                  %{sssdstatedir}/db
99 %define         pipepath                %{sssdstatedir}/pipes
100 %define         pubconfpath             %{sssdstatedir}/pubconf
101
102 # Determine the location of the LDB modules directory
103 %define         ldb_modulesdir  %(pkg-config --variable=modulesdir ldb)
104
105 %description
106 Provides a set of daemons to manage access to remote directories and
107 authentication mechanisms. It provides an NSS and PAM interface toward
108 the system and a pluggable backend system to connect to multiple
109 different account sources. It is also the basis to provide client
110 auditing and policy services for projects like FreeIPA.
111
112 %description -l pl.UTF-8
113 Ten pakiet dostarcza zbiór demonów do zarządzania dostępem do zdalnych
114 katalogów i mechanizmów uwierzytelniania. Udostępnia interfejsy NSS i
115 PAM dla systemu oraz system backendu z wtyczkami w celu łączenia się z
116 wieloma różnymi źródłami kont. Jest także podstawą zapewniającą audyt
117 klientów oraz usługi polityk dla projektów takich jak FreeIPA.
118
119 %package client
120 Summary:        SSSD Client libraries for NSS and PAM
121 Summary(pl.UTF-8):      Biblioteki klienckie SSSD dla NSS i PAM
122 License:        LGPL v3+
123 Group:          Applications/System
124 Requires:       libsss_idmap = %{version}-%{release}
125 Requires:       libsss_nss_idmap = %{version}-%{release}
126
127 %description client
128 Provides the libraries needed by the PAM and NSS stacks to connect to
129 the SSSD service.
130
131 %description client -l pl.UTF-8
132 Ten pakiet dostarcza biblioteki wymagane przez stosy PAM i NSS w celu
133 łączenia się z usługą SSSD.
134
135 %package tools
136 Summary:        Userspace tools for use with the SSSD
137 Summary(pl.UTF-8):      Narzędzia przestrzeni użytkownika do używania z SSSD
138 License:        GPL v3+
139 Group:          Applications/System
140 Requires:       %{name} = %{version}-%{release}
141
142 %description tools
143 Provides userspace tools for manipulating users, groups, and nested
144 groups in SSSD when using id_provider = local in /etc/sssd/sssd.conf.
145
146 Also provides several other administrative tools:
147  - sss_debuglevel to change the debug level on the fly,
148  - sss_seed which pre-creates a user entry for use in kickstarts,
149  - sss_obfuscate for generating an obfuscated LDAP password.
150
151 %description tools -l pl.UTF-8
152 Ten pakiet dostarcza narzędzia przestrzeni poleceń do operowania na
153 użytkownikach, grupach oraz zagnieżdżonych grupach w SSSD w przypadku
154 używania id_provider = local w /etc/sssd/sssd.conf.
155
156 Pakiet zawiera także kilka innych narzędzi administracyjnych:
157  - sss_debuglevel do zmiany poziomu diagnostyki w locie,
158  - sss_seed tworzący wpis użytkownika do szybkiego rozruchu,
159  - sss_obfuscate do generowania utajnionego hasła LDAP.
160
161 %package -n python-sss
162 Summary:        Python 2 bindings for sssd
163 Summary(pl.UTF-8):      Wiązania Pythona 2 do sssd
164 License:        LGPL v3+
165 Group:          Libraries/Python
166 Requires:       %{name} = %{version}-%{release}
167
168 %description -n python-sss
169 Python 2 module for manipulating users, groups, and nested groups in
170 SSSD when using id_provider = local in /etc/sssd/sssd.conf.
171
172 This module also provides several other useful Python 2 bindings:
173  - function for retrieving list of groups user belongs to.
174  - class for obfuscation of passwords
175
176 %description -n python-sss -l pl.UTF-8
177 Moduł Pythona 2 do operowania na użytkownikach, grupach i
178 zagnieżdżonych grupach w SSSD w przypadku używania id_provider = local
179 w /etc/sssd/sssd.conf.
180
181 Ten moduł dostarcza także kilka innych przydatnych wiązań Pythona 2:
182  - funkcję do użyskiwania list grup, do których należy użytkownik,
183  - klasę do ukrywania haseł.
184
185 %package -n python-sss-murmur
186 Summary:        Python 2 bindings for murmur hash function
187 Summary(pl.UTF-8):      Wiązania Pythona 2 do funkcji mieszającej murmur
188 License:        LGPL v3+
189 Group:          Libraries/Python
190
191 %description -n python-sss-murmur
192 Python 2 module for calculating the murmur hash version 3.
193
194 %description -n python-sss-murmur -l pl.UTF-8
195 Moduł Pythona 2 do obliczania skrótu murmur w wersji 3.
196
197 %package -n python-sssdconfig
198 Summary:        SSSD and IPA configuration file manipulation classes and functions for Python 2
199 Summary(pl.UTF-8):      Klasy i funkcje Pythona 2 do operowania na plikach konfiguracyjnych SSSD oraz IPA
200 License:        GPL v3+
201 Group:          Libraries/Python
202 BuildArch:      noarch
203
204 %description -n python-sssdconfig
205 SSSD and IPA configuration file manipulation classes and functions for
206 Python 2.
207
208 %description -n python-sssdconfig -l pl.UTF-8
209 Klasy i funkcje Pythona 2 do operowania na plikach konfiguracyjnych
210 SSSD oraz IPA.
211
212 %package -n python3-sss
213 Summary:        Python 3 bindings for sssd
214 Summary(pl.UTF-8):      Wiązania Pythona 3 do sssd
215 License:        LGPL v3+
216 Group:          Libraries/Python
217 Requires:       %{name} = %{version}-%{release}
218
219 %description -n python3-sss
220 Python 3 module for manipulating users, groups, and nested groups in
221 SSSD when using id_provider = local in /etc/sssd/sssd.conf.
222
223 This module also provides several other useful Python 3 bindings:
224  - function for retrieving list of groups user belongs to.
225  - class for obfuscation of passwords
226
227 %description -n python3-sss -l pl.UTF-8
228 Moduł Pythona 3 do operowania na użytkownikach, grupach i
229 zagnieżdżonych grupach w SSSD w przypadku używania id_provider = local
230 w /etc/sssd/sssd.conf.
231
232 Ten moduł dostarcza także kilka innych przydatnych wiązań Pythona 3:
233  - funkcję do użyskiwania list grup, do których należy użytkownik,
234  - klasę do ukrywania haseł.
235
236 %package -n python3-sss-murmur
237 Summary:        Python 3 bindings for murmur hash function
238 Summary(pl.UTF-8):      Wiązania Pythona 3 do funkcji mieszającej murmur
239 License:        LGPL v3+
240 Group:          Libraries/Python
241
242 %description -n python3-sss-murmur
243 Python 3 module for calculating the murmur hash version 3.
244
245 %description -n python3-sss-murmur -l pl.UTF-8
246 Moduł Pythona 3 do obliczania skrótu murmur w wersji 3.
247
248 %package -n python3-sssdconfig
249 Summary:        SSSD and IPA configuration file manipulation classes and functions for Python 3
250 Summary(pl.UTF-8):      Klasy i funkcje Pythona 3 do operowania na plikach konfiguracyjnych SSSD oraz IPA
251 License:        GPL v3+
252 Group:          Libraries/Python
253 BuildArch:      noarch
254
255 %description -n python3-sssdconfig
256 SSSD and IPA configuration file manipulation classes and functions for
257 Python 3.
258
259 %description -n python3-sssdconfig -l pl.UTF-8
260 Klasy i funkcje Pythona 3 do operowania na plikach konfiguracyjnych
261 SSSD oraz IPA.
262
263 %package libwbclient
264 Summary:        The SSSD libwbclient implementation
265 Summary(pl.UTF-8):      Implementacja libwbclient oparta na SSSD
266 Group:          Libraries
267 License:        LGPL v3+
268 Requires:       libsss_nss_idmap = %{version}-%{release}
269
270 %description libwbclient
271 The SSSD implementation of Samba wbclient library.
272
273 %description libwbclient -l pl.UTF-8
274 Implementacja biblioteki Samba wbclient oparta na SSSD.
275
276 %package libwbclient-devel
277 Summary:        Development files of the SSSD libwbclient implementation
278 Summary(pl.UTF-8):      Pliki programistyczne implementacja libwbclient oparta na SSSD
279 Group:          Development/Libraries
280 License:        LGPL v3+
281 Requires:       %{name}-libwbclient = %{version}-%{release}
282
283 %description libwbclient-devel
284 Development files for the SSSD implementation of Samba wbclient
285 library.
286
287 %description libwbclient-devel -l pl.UTF-8
288 Pliki programistyczne implementacji biblioteki Samba wbclient opartej
289 na SSSD.
290
291 %package -n libipa_hbac
292 Summary:        FreeIPA HBAC Evaluator library
293 Summary(pl.UTF-8):      Biblioteka oceniająca FreeIPA HBAC
294 License:        LGPL v3+
295 Group:          Libraries
296
297 %description -n libipa_hbac
298 Utility library to validate FreeIPA HBAC rules for authorization
299 requests.
300
301 %description -n libipa_hbac
302 Biblioteka narzędziowa do sprawdzania poprawności reguł FreeIPA HBAC
303 dla żądań autoryzacji.
304
305 %package -n libipa_hbac-devel
306 Summary:        Development files for FreeIPA HBAC Evaluator library
307 Summary(pl.UTF-8):      Pliki programistyczne biblioteki oceniająca FreeIPA HBAC
308 License:        LGPL v3+
309 Group:          Development/Libraries
310 Requires:       libipa_hbac = %{version}-%{release}
311
312 %description -n libipa_hbac-devel
313 Development files for FreeIPA HBAC Evaluator library.
314
315 %description -n libipa_hbac-devel -l pl.UTF-8
316 Pliki programistyczne biblioteki oceniająca FreeIPA HBAC.
317
318 %package -n python-libipa_hbac
319 Summary:        Python 2 bindings for the FreeIPA HBAC Evaluator library
320 Summary(pl.UTF-8):      Wiązania Pythona 2 do biblioteki oceniającej FreeIPA HBAC
321 License:        LGPL v3+
322 Group:          Libraries/Python
323 Requires:       libipa_hbac = %{version}-%{release}
324 Obsoletes:      libipa_hbac-python
325
326 %description -n python-libipa_hbac
327 This package contains the bindings so that libipa_hbac can be used by
328 Python 2 applications.
329
330 %description -n python-libipa_hbac -l pl.UTF-8
331 Ten pakiet zawiera wiązania pozwalające na używanie libipa_hbac w
332 aplikacjach Pythona 2.
333
334 %package -n python3-libipa_hbac
335 Summary:        Python 3 bindings for the FreeIPA HBAC Evaluator library
336 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki oceniającej FreeIPA HBAC
337 License:        LGPL v3+
338 Group:          Libraries/Python
339 Requires:       libipa_hbac = %{version}-%{release}
340
341 %description -n python3-libipa_hbac
342 This package contains the bindings so that libipa_hbac can be used by
343 Python 3 applications.
344
345 %description -n python3-libipa_hbac -l pl.UTF-8
346 Ten pakiet zawiera wiązania pozwalające na używanie libipa_hbac w
347 aplikacjach Pythona 3.
348
349 %package -n libsss_idmap
350 Summary:        FreeIPA Idmap library
351 Summary(pl.UTF-8):      Biblioteka FreeIPA Idmap
352 Group:          Libraries
353 License:        LGPL v3+
354
355 %description -n libsss_idmap
356 Utility library to convert SIDs to Unix uids and gids.
357
358 %description -n libsss_idmap -l pl.UTF-8
359 Biblioteka narzędziowa konwertująca SID-y na uniksowe uidy i gidy.
360
361 %package -n libsss_idmap-devel
362 Summary:        Development files for FreeIPA Idmap library
363 Summary(pl.UTF-8):      Pliki programistyczne biblioteki FreeIPA Idmap
364 Group:          Development/Libraries
365 License:        LGPL v3+
366 Requires:       libsss_idmap = %{version}-%{release}
367
368 %description -n libsss_idmap-devel
369 Development files for FreeIPA Idmap library.
370
371 %description -n libsss_idmap-devel -l pl.UTF-8
372 Pliki programistyczne biblioteki FreeIPA Idmap.
373
374 %package -n libsss_nss_idmap
375 Summary:        Library for SID based lookups
376 Summary(pl.UTF-8):      Biblioteka do wyszukiwań w oparciu o SID
377 Group:          Libraries
378 License:        LGPL v3+
379
380 %description -n libsss_nss_idmap
381 Utility library for SID based lookups.
382
383 %description -n libsss_nss_idmap -l pl.UTF-8
384 Biblioteka do wyszukiwań w oparciu o SID.
385
386 %package -n libsss_nss_idmap-devel
387 Summary:        Development files for sss_nss_idmap library
388 Summary(pl.UTF-8):      Pliki programistyczne biblioteki sss_nss_idmap
389 Group:          Development/Libraries
390 License:        LGPL v3+
391 Requires:       libsss_nss_idmap = %{version}-%{release}
392
393 %description -n libsss_nss_idmap-devel
394 Development files for sss_nss_idmap library.
395
396 %description -n libsss_nss_idmap-devel -l pl.UTF-8
397 Pliki programistyczne biblioteki sss_nss_idmap.
398
399 %package -n python-libsss_nss_idmap
400 Summary:        Python 2 bindings for libsss_nss_idmap
401 Summary(pl.UTF-8):      Wiązania Pythona 2 do biblioteki libsss_nss_idmap
402 Group:          Libraries/Python
403 License:        LGPL v3+
404 Requires:       libsss_nss_idmap = %{version}-%{release}
405
406 %description -n python-libsss_nss_idmap
407 This package contains the bindings so that libsss_nss_idmap can be
408 used by Python 2 applications.
409
410 %description -n python-libsss_nss_idmap -l pl.UTF-8
411 Ten pakiet zawiera wiązania umożliwiające korzystanie z biblioteki
412 libsss_nss_idmap w aplikacjach Pythona 2.
413
414 %package -n python3-libsss_nss_idmap
415 Summary:        Python 3 bindings for libsss_nss_idmap
416 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki libsss_nss_idmap
417 Group:          Libraries/Python
418 License:        LGPL v3+
419 Requires:       libsss_nss_idmap = %{version}-%{release}
420
421 %description -n python3-libsss_nss_idmap
422 This package contains the bindings so that libsss_nss_idmap can be
423 used by Python 3 applications.
424
425 %description -n python3-libsss_nss_idmap -l pl.UTF-8
426 Ten pakiet zawiera wiązania umożliwiające korzystanie z biblioteki
427 libsss_nss_idmap w aplikacjach Pythona 3.
428
429 %package -n libsss_simpleifp
430 Summary:        A library that simplifies work with the InfoPipe responder
431 Summary(pl.UTF-8):      Biblioteka upraszczająca pracę z responderem InfoPipe
432 Group:          Libraries
433 Requires:       dbus-libs >= 1.0.0
434 Requires:       libdhash >= 0.4.2
435
436 %description -n libsss_simpleifp
437 A library that simplifies work with the InfoPipe responder.
438
439 %description -n libsss_simpleifp -l pl.UTF-8
440 Biblioteka upraszczająca pracę z responderem InfoPipe.
441
442 %package -n libsss_simpleifp-devel
443 Summary:        Header files for libsss_simpleifp library
444 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsss_simpleifp
445 Group:          Development/Libraries
446 Requires:       dbus-devel >= 1.0.0
447 Requires:       libdhash-devel >= 0.4.2
448 Requires:       libsss_simpleifp = %{version}-%{release}
449
450 %description -n libsss_simpleifp-devel
451 Header files for libsss_simpleifp library.
452
453 %description -n libsss_simpleifp-devel -l pl.UTF-8
454 Pliki nagłówkowe biblioteki libsss_simpleifp.
455
456 %prep
457 %setup -q
458 %patch0 -p1
459 %patch1 -p1
460 %patch2 -p1
461 %patch3 -p1
462
463 %build
464 %{__libtoolize}
465 %{__gettextize}
466 %{__aclocal} -I m4
467 %{__autoconf}
468 %{__automake}
469 %configure \
470         NSCD=/usr/sbin/nscd \
471         %{!?with_krb5:--disable-krb5-locator-plugin} \
472         --enable-nfsidmaplibdir=/%{_lib}/libnfsidmap \
473         --enable-nsslibdir=/%{_lib} \
474         %{!?with_krb5:--disable-pac-responder} \
475         --enable-pammoddir=/%{_lib}/security \
476         --disable-rpath \
477         --with-db-path=%{dbpath} \
478         --with-init-dir=/etc/rc.d/init.d \
479         --with-initscript=sysv,systemd \
480         --with-pipe-path=%{pipepath} \
481         --with-pubconf-path=%{pubconfpath} \
482         --with-python2-bindings%{!?with_python2:=no} \
483         --with-python3-bindings%{!?with_python3:=no} \
484         --with-systemdunitdir=%{systemdunitdir} \
485         --with-test-dir=/dev/shm
486
487 %{__make}
488
489 %if %{with tests}
490 export CK_TIMEOUT_MULTIPLIER=10
491 %{__make} check
492 unset CK_TIMEOUT_MULTIPLIER
493 %endif
494
495 %install
496 rm -rf $RPM_BUILD_ROOT
497
498 %{__make} -j1 install \
499         DESTDIR=$RPM_BUILD_ROOT \
500         python3dir=%{py3_sitescriptdir}
501
502 # Prepare language files
503 %find_lang %{name}
504
505 # Copy default sssd.conf file
506 install -d $RPM_BUILD_ROOT%{_sysconfdir}/sssd/sssd.api.d
507 cp -p src/examples/sssd-example.conf $RPM_BUILD_ROOT%{_sysconfdir}/sssd/sssd.conf
508
509 # Copy default logrotate file
510 install -d $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
511 cp -p src/examples/logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/sssd
512
513 # Make sure SSSD is able to run on read-only root
514 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rwtab.d
515 cp -p src/examples/rwtab $RPM_BUILD_ROOT%{_sysconfdir}/rwtab.d/sssd
516
517 # Remove .la files created by libtool
518 %{__rm} \
519         $RPM_BUILD_ROOT/%{_lib}/libnss_sss.la \
520         $RPM_BUILD_ROOT/%{_lib}/libnfsidmap/sss.la \
521         $RPM_BUILD_ROOT/%{_lib}/security/pam_sss.la \
522         $RPM_BUILD_ROOT%{ldb_modulesdir}/memberof.la \
523         $RPM_BUILD_ROOT%{_libdir}/cifs-utils/*.la \
524         %{?with_krb5:$RPM_BUILD_ROOT%{_libdir}/krb5/plugins/libkrb5/sss*.la} \
525         $RPM_BUILD_ROOT%{_libdir}/sssd/libsss_*.la \
526         $RPM_BUILD_ROOT%{_libdir}/sssd/modules/lib*.la \
527         $RPM_BUILD_ROOT%{_libdir}/lib*.la
528 %if %{with python2}
529 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.la
530 %py_postclean
531 %endif
532 %if %{with python3}
533 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/*.la
534 %endif
535
536 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
537
538 echo '%%defattr(644,root,root,755)' > sssd_client.lang
539 echo '%%defattr(644,root,root,755)' > sssd_tools.lang
540 for man in $(find $RPM_BUILD_ROOT%{_mandir}/??/man? -type f | sed -e "s#$RPM_BUILD_ROOT%{_mandir}/##"); do
541         lang=$(echo $man | cut -c 1-2)
542         case $(basename $man) in
543         pam_sss.8|sssd_krb5_locator_plugin.8)
544                 echo "%lang(${lang}) %{_mandir}/${man}*" >> sssd_client.lang
545                 ;;
546         sss_debuglevel.8|sss_group*.8|sss_obfuscate.8|sss_seed.8|sss_user*.8)
547                 echo "%lang(${lang}) %{_mandir}/${man}*" >> sssd_tools.lang
548                 ;;
549         *)
550                 echo "%lang(${lang}) %{_mandir}/${man}*" >> sssd.lang
551                 ;;
552         esac
553 done
554
555 %clean
556 rm -rf $RPM_BUILD_ROOT
557
558 %post
559 /sbin/ldconfig
560 /sbin/chkconfig --add %{name}
561 %service %{name} restart
562
563 %preun
564 if [ "$1" = "0" ]; then
565         %service -q %{name} stop
566         /sbin/chkconfig --del %{name}
567 fi
568
569 %postun -p /sbin/ldconfig
570
571 %post   client -p /sbin/ldconfig
572 %postun client -p /sbin/ldconfig
573
574 %post   -n libipa_hbac -p /sbin/ldconfig
575 %postun -n libipa_hbac -p /sbin/ldconfig
576
577 %post   -n libsss_idmap -p /sbin/ldconfig
578 %postun -n libsss_idmap -p /sbin/ldconfig
579
580 %post   -n libsss_nss_idmap -p /sbin/ldconfig
581 %postun -n libsss_nss_idmap -p /sbin/ldconfig
582
583 %post   -n libsss_simpleifp -p /sbin/ldconfig
584 %postun -n libsss_simpleifp -p /sbin/ldconfig
585
586 %files -f sssd.lang
587 %defattr(644,root,root,755)
588 %attr(755,root,root) %{_bindir}/sss_ssh_authorizedkeys
589 %attr(755,root,root) %{_bindir}/sss_ssh_knownhostsproxy
590 %attr(755,root,root) %{_sbindir}/sss_cache
591 %attr(755,root,root) %{_sbindir}/sssd
592 # sudo plugin
593 %attr(755,root,root) %{_libdir}/libsss_sudo.so
594 %dir %{_libdir}/sssd
595 # internal shared libraries
596 %attr(755,root,root) %{_libdir}/sssd/libsss_cert.so
597 %attr(755,root,root) %{_libdir}/sssd/libsss_child.so
598 %attr(755,root,root) %{_libdir}/sssd/libsss_config.so
599 %attr(755,root,root) %{_libdir}/sssd/libsss_crypt.so
600 %attr(755,root,root) %{_libdir}/sssd/libsss_debug.so
601 %attr(755,root,root) %{_libdir}/sssd/libsss_krb5_common.so
602 %attr(755,root,root) %{_libdir}/sssd/libsss_ldap_common.so
603 %attr(755,root,root) %{_libdir}/sssd/libsss_semanage.so
604 %attr(755,root,root) %{_libdir}/sssd/libsss_util.so
605 # modules
606 %attr(755,root,root) %{_libdir}/sssd/libsss_simple.so
607 %attr(755,root,root) %{_libdir}/sssd/libsss_ad.so
608 %attr(755,root,root) %{_libdir}/sssd/libsss_ipa.so
609 %attr(755,root,root) %{_libdir}/sssd/libsss_krb5.so
610 %attr(755,root,root) %{_libdir}/sssd/libsss_ldap.so
611 %attr(755,root,root) %{_libdir}/sssd/libsss_proxy.so
612 %dir %{_libdir}/sssd/modules
613 %attr(755,root,root) %{_libdir}/sssd/modules/libsss_autofs.so
614 %if "%{_libdir}" != "%{_libexecdir}"
615 %dir %{_libexecdir}/sssd
616 %endif
617 %attr(755,root,root) %{_libexecdir}/sssd/gpo_child
618 %attr(755,root,root) %{_libexecdir}/sssd/krb5_child
619 %attr(755,root,root) %{_libexecdir}/sssd/ldap_child
620 %attr(755,root,root) %{_libexecdir}/sssd/p11_child
621 %attr(755,root,root) %{_libexecdir}/sssd/proxy_child
622 %attr(755,root,root) %{_libexecdir}/sssd/selinux_child
623 %attr(755,root,root) %{_libexecdir}/sssd/sss_signal
624 %attr(755,root,root) %{_libexecdir}/sssd/sssd_autofs
625 %attr(755,root,root) %{_libexecdir}/sssd/sssd_be
626 %attr(755,root,root) %{_libexecdir}/sssd/sssd_ifp
627 %attr(755,root,root) %{_libexecdir}/sssd/sssd_nss
628 %if %{with krb5}
629 %attr(755,root,root) %{_libexecdir}/sssd/sssd_pac
630 %endif
631 %attr(755,root,root) %{_libexecdir}/sssd/sssd_pam
632 %attr(755,root,root) %{_libexecdir}/sssd/sssd_ssh
633 %attr(755,root,root) %{_libexecdir}/sssd/sssd_sudo
634 %dir %{_datadir}/sssd
635 %{_datadir}/sssd/sssd.api.conf
636 %dir %{_datadir}/sssd/sssd.api.d
637 %{_datadir}/sssd/sssd.api.d/sssd-ad.conf
638 %{_datadir}/sssd/sssd.api.d/sssd-ipa.conf
639 %{_datadir}/sssd/sssd.api.d/sssd-krb5.conf
640 %{_datadir}/sssd/sssd.api.d/sssd-ldap.conf
641 %{_datadir}/sssd/sssd.api.d/sssd-local.conf
642 %{_datadir}/sssd/sssd.api.d/sssd-proxy.conf
643 %{_datadir}/sssd/sssd.api.d/sssd-simple.conf
644 %attr(755,root,root) /%{_lib}/libnfsidmap/sss.so
645 %attr(755,root,root) %{ldb_modulesdir}/memberof.so
646 %dir %{sssdstatedir}
647 %attr(700,root,root) %dir %{dbpath}
648 %dir %{pipepath}
649 %dir %{pubconfpath}
650 %attr(700,root,root) %dir %{pipepath}/private
651 %attr(750,root,root) %dir %{_var}/log/%{name}
652 %attr(700,root,root) %dir %{_sysconfdir}/sssd
653 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sssd/sssd.conf
654 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/sssd
655 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rwtab.d/sssd
656 %attr(754,root,root) /etc/rc.d/init.d/sssd
657 %{systemdunitdir}/sssd.service
658 /etc/dbus-1/system.d/org.freedesktop.sssd.infopipe.conf
659 %{_datadir}/dbus-1/system-services/org.freedesktop.sssd.infopipe.service
660 %{_mandir}/man1/sss_ssh_authorizedkeys.1*
661 %{_mandir}/man1/sss_ssh_knownhostsproxy.1*
662 %{_mandir}/man5/sss_rpcidmapd.5*
663 %{_mandir}/man5/sssd.conf.5*
664 %{_mandir}/man5/sssd-ad.5*
665 %{_mandir}/man5/sssd-ifp.5*
666 %{_mandir}/man5/sssd-ipa.5*
667 %{_mandir}/man5/sssd-krb5.5*
668 %{_mandir}/man5/sssd-ldap.5*
669 %{_mandir}/man5/sssd-simple.5*
670 %{_mandir}/man5/sssd-sudo.5*
671 %{_mandir}/man8/sss_cache.8*
672 %{_mandir}/man8/sssd.8*
673
674 %files client -f sssd_client.lang
675 %defattr(644,root,root,755)
676 %attr(755,root,root) /%{_lib}/libnss_sss.so.2
677 %attr(755,root,root) /%{_lib}/security/pam_sss.so
678 %attr(755,root,root) %{_libdir}/cifs-utils/cifs_idmap_sss.so
679 %if %{with krb5}
680 # XXX: verify locations
681 %attr(755,root,root) %{_libdir}/krb5/plugins/libkrb5/sssd_krb5_localauth_plugin.so
682 %attr(755,root,root) %{_libdir}/krb5/plugins/libkrb5/sssd_krb5_locator_plugin.so
683 %attr(755,root,root) %{_libdir}/krb5/plugins/libkrb5/sssd_pac_plugin.so
684 %endif
685 %{_mandir}/man8/pam_sss.8*
686 %{_mandir}/man8/sssd_krb5_locator_plugin.8*
687
688 %files tools -f sssd_tools.lang
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_sbindir}/sss_debuglevel
691 %attr(755,root,root) %{_sbindir}/sss_groupadd
692 %attr(755,root,root) %{_sbindir}/sss_groupdel
693 %attr(755,root,root) %{_sbindir}/sss_groupmod
694 %attr(755,root,root) %{_sbindir}/sss_groupshow
695 %attr(755,root,root) %{_sbindir}/sss_obfuscate
696 %attr(755,root,root) %{_sbindir}/sss_override
697 %attr(755,root,root) %{_sbindir}/sss_seed
698 %attr(755,root,root) %{_sbindir}/sss_useradd
699 %attr(755,root,root) %{_sbindir}/sss_userdel
700 %attr(755,root,root) %{_sbindir}/sss_usermod
701 %{_mandir}/man8/sss_debuglevel.8*
702 %{_mandir}/man8/sss_groupadd.8*
703 %{_mandir}/man8/sss_groupdel.8*
704 %{_mandir}/man8/sss_groupmod.8*
705 %{_mandir}/man8/sss_groupshow.8*
706 %{_mandir}/man8/sss_obfuscate.8*
707 %{_mandir}/man8/sss_override.8*
708 %{_mandir}/man8/sss_seed.8*
709 %{_mandir}/man8/sss_useradd.8*
710 %{_mandir}/man8/sss_userdel.8*
711 %{_mandir}/man8/sss_usermod.8*
712
713 %if %{with python2}
714 %files -n python-sss
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{py_sitedir}/pysss.so
717
718 %files -n python-sss-murmur
719 %defattr(644,root,root,755)
720 %attr(755,root,root) %{py_sitedir}/pysss_murmur.so
721
722 %files -n python-sssdconfig
723 %defattr(644,root,root,755)
724 %dir %{py_sitescriptdir}/SSSDConfig
725 %{py_sitescriptdir}/SSSDConfig/*.py[co]
726 %{py_sitescriptdir}/SSSDConfig-%{version}-py*.egg-info
727 %endif
728
729 %if %{with python3}
730 %files -n python3-sss
731 %defattr(644,root,root,755)
732 %attr(755,root,root) %{py3_sitedir}/pysss.so
733
734 %files -n python3-sss-murmur
735 %defattr(644,root,root,755)
736 %attr(755,root,root) %{py3_sitedir}/pysss_murmur.so
737
738 %files -n python3-sssdconfig
739 %defattr(644,root,root,755)
740 %dir %{py3_sitescriptdir}/SSSDConfig
741 %{py3_sitescriptdir}/SSSDConfig/*.py
742 %{py3_sitescriptdir}/SSSDConfig/__pycache__
743 %{py3_sitescriptdir}/SSSDConfig-%{version}-py*.egg-info
744 %endif
745
746 %files libwbclient
747 %defattr(644,root,root,755)
748 %attr(755,root,root) %{_libdir}/sssd/modules/libwbclient.so.*
749
750 %files libwbclient-devel
751 %defattr(644,root,root,755)
752 %attr(755,root,root) %{_libdir}/sssd/modules/libwbclient.so
753 %{_includedir}/wbclient_sssd.h
754 %{_pkgconfigdir}/wbclient_sssd.pc
755
756 %files -n libipa_hbac
757 %defattr(644,root,root,755)
758 %attr(755,root,root) %{_libdir}/libipa_hbac.so.*.*.*
759 %attr(755,root,root) %ghost %{_libdir}/libipa_hbac.so.0
760
761 %files -n libipa_hbac-devel
762 %defattr(644,root,root,755)
763 %attr(755,root,root) %{_libdir}/libipa_hbac.so
764 %{_includedir}/ipa_hbac.h
765 %{_pkgconfigdir}/ipa_hbac.pc
766
767 %if %{with python2}
768 %files -n python-libipa_hbac
769 %defattr(644,root,root,755)
770 %attr(755,root,root) %{py_sitedir}/pyhbac.so
771 %endif
772
773 %if %{with python3}
774 %files -n python3-libipa_hbac
775 %defattr(644,root,root,755)
776 %attr(755,root,root) %{py3_sitedir}/pyhbac.so
777 %endif
778
779 %files -n libsss_idmap
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{_libdir}/libsss_idmap.so.*.*.*
782 %attr(755,root,root) %ghost %{_libdir}/libsss_idmap.so.0
783
784 %files -n libsss_idmap-devel
785 %defattr(644,root,root,755)
786 %attr(755,root,root) %{_libdir}/libsss_idmap.so
787 %{_includedir}/sss_idmap.h
788 %{_pkgconfigdir}/sss_idmap.pc
789
790 %files -n libsss_nss_idmap
791 %defattr(644,root,root,755)
792 %attr(755,root,root) %{_libdir}/libsss_nss_idmap.so.*.*.*
793 %attr(755,root,root) %ghost %{_libdir}/libsss_nss_idmap.so.0
794
795 %files -n libsss_nss_idmap-devel
796 %defattr(644,root,root,755)
797 %attr(755,root,root) %{_libdir}/libsss_nss_idmap.so
798 %{_includedir}/sss_nss_idmap.h
799 %{_pkgconfigdir}/sss_nss_idmap.pc
800
801 %if %{with python2}
802 %files -n python-libsss_nss_idmap
803 %defattr(644,root,root,755)
804 %attr(755,root,root) %{py_sitedir}/pysss_nss_idmap.so
805 %endif
806
807 %if %{with python3}
808 %files -n python3-libsss_nss_idmap
809 %defattr(644,root,root,755)
810 %attr(755,root,root) %{py3_sitedir}/pysss_nss_idmap.so
811 %endif
812
813 %files -n libsss_simpleifp
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{_libdir}/libsss_simpleifp.so.*.*.*
816 %attr(755,root,root) %ghost %{_libdir}/libsss_simpleifp.so.0
817
818 %files -n libsss_simpleifp-devel
819 %defattr(644,root,root,755)
820 %attr(755,root,root) %{_libdir}/libsss_simpleifp.so
821 %{_includedir}/sss_sifp.h
822 %{_includedir}/sss_sifp_dbus.h
823 %{_pkgconfigdir}/sss_simpleifp.pc
This page took 0.115318 seconds and 4 git commands to generate.