]> git.pld-linux.org Git - packages/sssd.git/blob - sssd.spec
bb9c4fae8eb35105918e4b41ca9edafb9e26ef6c
[packages/sssd.git] / sssd.spec
1 # TODO
2 # - fix stripping before rpm:
3 #   *** WARNING: no sources found for /usr/lib64/libipa_hbac.so.0.0.0 (stripped without sourcefile information?)
4 # - add info how sssd-heimdal.patch is updated, where is it's origin?
5 #
6 # Conditional build:
7 %bcond_with     tests   # check target
8 %bcond_without  python2 # CPython 2.x module
9 %bcond_without  python3 # CPython 3.x module
10 %bcond_with     krb5    # MIT Kerberos V instead of Heimdal (enables locator plugin, profile support and pac-responder)
11
12 %define         ldb_version 1.1.0
13 Summary:        System Security Services Daemon
14 Summary(pl.UTF-8):      System Security Services Daemon - demon usług bezpieczeństwa systemu
15 Name:           sssd
16 Version:        1.13.4
17 Release:        5
18 License:        GPL v3+
19 Group:          Applications/System
20 Source0:        https://fedorahosted.org/released/sssd/%{name}-%{version}.tar.gz
21 # Source0-md5:  d147e0a4f4719d993693c6a99370b350
22 Source1:        %{name}.init
23 Patch0:         %{name}-python.patch
24 Patch1:         %{name}-heimdal.patch
25 Patch2:         %{name}-systemd.patch
26 Patch3:         %{name}-link.patch
27 Patch4:         format.patch
28 URL:            https://fedorahosted.org/sssd/
29 BuildRequires:  augeas-devel >= 1.0.0
30 BuildRequires:  autoconf >= 2.59
31 BuildRequires:  automake
32 # nsupdate utility
33 BuildRequires:  bind-utils
34 BuildRequires:  c-ares-devel
35 BuildRequires:  check-devel >= 0.9.5
36 BuildRequires:  cifs-utils-devel
37 %{?with_tests:BuildRequires:    cmocka-devel >= 1.0.0}
38 BuildRequires:  cyrus-sasl-devel >= 2
39 BuildRequires:  dbus-devel >= 1.0.0
40 BuildRequires:  docbook-dtd44-xml
41 BuildRequires:  docbook-style-xsl
42 BuildRequires:  doxygen
43 %{?with_tests:BuildRequires:    fakeroot}
44 BuildRequires:  gettext-tools >= 0.14.4
45 BuildRequires:  glib2-devel >= 2.0
46 %{!?with_krb5:BuildRequires:    heimdal-devel}
47 BuildRequires:  keyutils-devel
48 %{?with_krb5:BuildRequires:     krb5-devel >= 1.9}
49 BuildRequires:  ldb-devel >= %{ldb_version}
50 BuildRequires:  libcollection-devel >= 0.5.1
51 BuildRequires:  libdhash-devel >= 0.4.2
52 BuildRequires:  libini_config-devel >= 1.1.0
53 BuildRequires:  libltdl-devel
54 BuildRequires:  libnfsidmap-devel
55 BuildRequires:  libnl-devel >= 3.2
56 BuildRequires:  libselinux-devel
57 BuildRequires:  libsemanage-devel
58 BuildRequires:  libsmbclient-devel
59 BuildRequires:  libtool >= 2:2
60 BuildRequires:  libxml2-progs
61 BuildRequires:  libxslt-progs
62 BuildRequires:  m4
63 BuildRequires:  nspr-devel
64 BuildRequires:  nss-devel
65 %{?with_tests:BuildRequires:    nss_wrapper}
66 BuildRequires:  openldap-devel
67 BuildRequires:  pam-devel
68 BuildRequires:  pcre-devel >= 7
69 BuildRequires:  pkgconfig
70 BuildRequires:  po4a
71 BuildRequires:  popt-devel
72 %{?with_python2:BuildRequires:  python-devel >= 1:2.6}
73 %{?with_tests:BuildRequires:    python-pytest}
74 %{?with_python3:BuildRequires:  python3-devel >= 1:3.3}
75 BuildRequires:  rpm-pythonprov
76 BuildRequires:  rpmbuild(macros) >= 1.612
77 # pkgconfig(ndr_nbt), pkgconfig(ndr_krb5pac) if with krb5
78 BuildRequires:  samba-devel >= 4
79 BuildRequires:  systemd-devel >= 1:209
80 BuildRequires:  systemd-units
81 BuildRequires:  talloc-devel
82 BuildRequires:  tdb-devel >= 1.1.3
83 BuildRequires:  tevent-devel
84 %{?with_tests:BuildRequires:    uid_wrapper}
85 Requires(post): /sbin/ldconfig
86 Requires(post,preun):   /sbin/chkconfig
87 Requires:       %{name}-client = %{version}-%{release}
88 Requires:       cyrus-sasl-gssapi
89 Requires:       ldb >= %{ldb_version}
90 Requires:       libcollection >= 0.5.1
91 Requires:       libdhash >= 0.4.2
92 Requires:       libini_config >= 1.1.0
93 Requires:       libsss_idmap = %{version}-%{release}
94 Requires:       pcre >= 7
95 Requires:       rc-scripts >= 0.4.0.10
96 Requires:       tdb >= 1.1.3
97 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
98
99 %define         sssdstatedir            %{_localstatedir}/lib/sss
100 %define         dbpath                  %{sssdstatedir}/db
101 %define         pipepath                %{sssdstatedir}/pipes
102 %define         pubconfpath             %{sssdstatedir}/pubconf
103
104 # Determine the location of the LDB modules directory
105 %define         ldb_modulesdir  %(pkg-config --variable=modulesdir ldb)
106
107 %description
108 Provides a set of daemons to manage access to remote directories and
109 authentication mechanisms. It provides an NSS and PAM interface toward
110 the system and a pluggable backend system to connect to multiple
111 different account sources. It is also the basis to provide client
112 auditing and policy services for projects like FreeIPA.
113
114 %description -l pl.UTF-8
115 Ten pakiet dostarcza zbiór demonów do zarządzania dostępem do zdalnych
116 katalogów i mechanizmów uwierzytelniania. Udostępnia interfejsy NSS i
117 PAM dla systemu oraz system backendu z wtyczkami w celu łączenia się z
118 wieloma różnymi źródłami kont. Jest także podstawą zapewniającą audyt
119 klientów oraz usługi polityk dla projektów takich jak FreeIPA.
120
121 %package client
122 Summary:        SSSD Client libraries for NSS and PAM
123 Summary(pl.UTF-8):      Biblioteki klienckie SSSD dla NSS i PAM
124 License:        LGPL v3+
125 Group:          Applications/System
126 Requires:       libsss_idmap = %{version}-%{release}
127 Requires:       libsss_nss_idmap = %{version}-%{release}
128
129 %description client
130 Provides the libraries needed by the PAM and NSS stacks to connect to
131 the SSSD service.
132
133 %description client -l pl.UTF-8
134 Ten pakiet dostarcza biblioteki wymagane przez stosy PAM i NSS w celu
135 łączenia się z usługą SSSD.
136
137 %package tools
138 Summary:        Userspace tools for use with the SSSD
139 Summary(pl.UTF-8):      Narzędzia przestrzeni użytkownika do używania z SSSD
140 License:        GPL v3+
141 Group:          Applications/System
142 Requires:       %{name} = %{version}-%{release}
143
144 %description tools
145 Provides userspace tools for manipulating users, groups, and nested
146 groups in SSSD when using id_provider = local in /etc/sssd/sssd.conf.
147
148 Also provides several other administrative tools:
149  - sss_debuglevel to change the debug level on the fly,
150  - sss_seed which pre-creates a user entry for use in kickstarts,
151  - sss_obfuscate for generating an obfuscated LDAP password.
152
153 %description tools -l pl.UTF-8
154 Ten pakiet dostarcza narzędzia przestrzeni poleceń do operowania na
155 użytkownikach, grupach oraz zagnieżdżonych grupach w SSSD w przypadku
156 używania id_provider = local w /etc/sssd/sssd.conf.
157
158 Pakiet zawiera także kilka innych narzędzi administracyjnych:
159  - sss_debuglevel do zmiany poziomu diagnostyki w locie,
160  - sss_seed tworzący wpis użytkownika do szybkiego rozruchu,
161  - sss_obfuscate do generowania utajnionego hasła LDAP.
162
163 %package -n python-sss
164 Summary:        Python 2 bindings for sssd
165 Summary(pl.UTF-8):      Wiązania Pythona 2 do sssd
166 License:        LGPL v3+
167 Group:          Libraries/Python
168 Requires:       %{name} = %{version}-%{release}
169
170 %description -n python-sss
171 Python 2 module for manipulating users, groups, and nested groups in
172 SSSD when using id_provider = local in /etc/sssd/sssd.conf.
173
174 This module also provides several other useful Python 2 bindings:
175  - function for retrieving list of groups user belongs to.
176  - class for obfuscation of passwords
177
178 %description -n python-sss -l pl.UTF-8
179 Moduł Pythona 2 do operowania na użytkownikach, grupach i
180 zagnieżdżonych grupach w SSSD w przypadku używania id_provider = local
181 w /etc/sssd/sssd.conf.
182
183 Ten moduł dostarcza także kilka innych przydatnych wiązań Pythona 2:
184  - funkcję do użyskiwania list grup, do których należy użytkownik,
185  - klasę do ukrywania haseł.
186
187 %package -n python-sss-murmur
188 Summary:        Python 2 bindings for murmur hash function
189 Summary(pl.UTF-8):      Wiązania Pythona 2 do funkcji mieszającej murmur
190 License:        LGPL v3+
191 Group:          Libraries/Python
192
193 %description -n python-sss-murmur
194 Python 2 module for calculating the murmur hash version 3.
195
196 %description -n python-sss-murmur -l pl.UTF-8
197 Moduł Pythona 2 do obliczania skrótu murmur w wersji 3.
198
199 %package -n python-sssdconfig
200 Summary:        SSSD and IPA configuration file manipulation classes and functions for Python 2
201 Summary(pl.UTF-8):      Klasy i funkcje Pythona 2 do operowania na plikach konfiguracyjnych SSSD oraz IPA
202 License:        GPL v3+
203 Group:          Libraries/Python
204 BuildArch:      noarch
205
206 %description -n python-sssdconfig
207 SSSD and IPA configuration file manipulation classes and functions for
208 Python 2.
209
210 %description -n python-sssdconfig -l pl.UTF-8
211 Klasy i funkcje Pythona 2 do operowania na plikach konfiguracyjnych
212 SSSD oraz IPA.
213
214 %package -n python3-sss
215 Summary:        Python 3 bindings for sssd
216 Summary(pl.UTF-8):      Wiązania Pythona 3 do sssd
217 License:        LGPL v3+
218 Group:          Libraries/Python
219 Requires:       %{name} = %{version}-%{release}
220
221 %description -n python3-sss
222 Python 3 module for manipulating users, groups, and nested groups in
223 SSSD when using id_provider = local in /etc/sssd/sssd.conf.
224
225 This module also provides several other useful Python 3 bindings:
226  - function for retrieving list of groups user belongs to.
227  - class for obfuscation of passwords
228
229 %description -n python3-sss -l pl.UTF-8
230 Moduł Pythona 3 do operowania na użytkownikach, grupach i
231 zagnieżdżonych grupach w SSSD w przypadku używania id_provider = local
232 w /etc/sssd/sssd.conf.
233
234 Ten moduł dostarcza także kilka innych przydatnych wiązań Pythona 3:
235  - funkcję do użyskiwania list grup, do których należy użytkownik,
236  - klasę do ukrywania haseł.
237
238 %package -n python3-sss-murmur
239 Summary:        Python 3 bindings for murmur hash function
240 Summary(pl.UTF-8):      Wiązania Pythona 3 do funkcji mieszającej murmur
241 License:        LGPL v3+
242 Group:          Libraries/Python
243
244 %description -n python3-sss-murmur
245 Python 3 module for calculating the murmur hash version 3.
246
247 %description -n python3-sss-murmur -l pl.UTF-8
248 Moduł Pythona 3 do obliczania skrótu murmur w wersji 3.
249
250 %package -n python3-sssdconfig
251 Summary:        SSSD and IPA configuration file manipulation classes and functions for Python 3
252 Summary(pl.UTF-8):      Klasy i funkcje Pythona 3 do operowania na plikach konfiguracyjnych SSSD oraz IPA
253 License:        GPL v3+
254 Group:          Libraries/Python
255 BuildArch:      noarch
256
257 %description -n python3-sssdconfig
258 SSSD and IPA configuration file manipulation classes and functions for
259 Python 3.
260
261 %description -n python3-sssdconfig -l pl.UTF-8
262 Klasy i funkcje Pythona 3 do operowania na plikach konfiguracyjnych
263 SSSD oraz IPA.
264
265 %package libwbclient
266 Summary:        The SSSD libwbclient implementation
267 Summary(pl.UTF-8):      Implementacja libwbclient oparta na SSSD
268 Group:          Libraries
269 License:        LGPL v3+
270 Requires:       libsss_nss_idmap = %{version}-%{release}
271
272 %description libwbclient
273 The SSSD implementation of Samba wbclient library.
274
275 %description libwbclient -l pl.UTF-8
276 Implementacja biblioteki Samba wbclient oparta na SSSD.
277
278 %package libwbclient-devel
279 Summary:        Development files of the SSSD libwbclient implementation
280 Summary(pl.UTF-8):      Pliki programistyczne implementacja libwbclient oparta na SSSD
281 Group:          Development/Libraries
282 License:        LGPL v3+
283 Requires:       %{name}-libwbclient = %{version}-%{release}
284
285 %description libwbclient-devel
286 Development files for the SSSD implementation of Samba wbclient
287 library.
288
289 %description libwbclient-devel -l pl.UTF-8
290 Pliki programistyczne implementacji biblioteki Samba wbclient opartej
291 na SSSD.
292
293 %package -n libipa_hbac
294 Summary:        FreeIPA HBAC Evaluator library
295 Summary(pl.UTF-8):      Biblioteka oceniająca FreeIPA HBAC
296 License:        LGPL v3+
297 Group:          Libraries
298
299 %description -n libipa_hbac
300 Utility library to validate FreeIPA HBAC rules for authorization
301 requests.
302
303 %description -n libipa_hbac
304 Biblioteka narzędziowa do sprawdzania poprawności reguł FreeIPA HBAC
305 dla żądań autoryzacji.
306
307 %package -n libipa_hbac-devel
308 Summary:        Development files for FreeIPA HBAC Evaluator library
309 Summary(pl.UTF-8):      Pliki programistyczne biblioteki oceniająca FreeIPA HBAC
310 License:        LGPL v3+
311 Group:          Development/Libraries
312 Requires:       libipa_hbac = %{version}-%{release}
313
314 %description -n libipa_hbac-devel
315 Development files for FreeIPA HBAC Evaluator library.
316
317 %description -n libipa_hbac-devel -l pl.UTF-8
318 Pliki programistyczne biblioteki oceniająca FreeIPA HBAC.
319
320 %package -n python-libipa_hbac
321 Summary:        Python 2 bindings for the FreeIPA HBAC Evaluator library
322 Summary(pl.UTF-8):      Wiązania Pythona 2 do biblioteki oceniającej FreeIPA HBAC
323 License:        LGPL v3+
324 Group:          Libraries/Python
325 Requires:       libipa_hbac = %{version}-%{release}
326 Obsoletes:      libipa_hbac-python
327
328 %description -n python-libipa_hbac
329 This package contains the bindings so that libipa_hbac can be used by
330 Python 2 applications.
331
332 %description -n python-libipa_hbac -l pl.UTF-8
333 Ten pakiet zawiera wiązania pozwalające na używanie libipa_hbac w
334 aplikacjach Pythona 2.
335
336 %package -n python3-libipa_hbac
337 Summary:        Python 3 bindings for the FreeIPA HBAC Evaluator library
338 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki oceniającej FreeIPA HBAC
339 License:        LGPL v3+
340 Group:          Libraries/Python
341 Requires:       libipa_hbac = %{version}-%{release}
342
343 %description -n python3-libipa_hbac
344 This package contains the bindings so that libipa_hbac can be used by
345 Python 3 applications.
346
347 %description -n python3-libipa_hbac -l pl.UTF-8
348 Ten pakiet zawiera wiązania pozwalające na używanie libipa_hbac w
349 aplikacjach Pythona 3.
350
351 %package -n libsss_idmap
352 Summary:        FreeIPA Idmap library
353 Summary(pl.UTF-8):      Biblioteka FreeIPA Idmap
354 Group:          Libraries
355 License:        LGPL v3+
356
357 %description -n libsss_idmap
358 Utility library to convert SIDs to Unix uids and gids.
359
360 %description -n libsss_idmap -l pl.UTF-8
361 Biblioteka narzędziowa konwertująca SID-y na uniksowe uidy i gidy.
362
363 %package -n libsss_idmap-devel
364 Summary:        Development files for FreeIPA Idmap library
365 Summary(pl.UTF-8):      Pliki programistyczne biblioteki FreeIPA Idmap
366 Group:          Development/Libraries
367 License:        LGPL v3+
368 Requires:       libsss_idmap = %{version}-%{release}
369
370 %description -n libsss_idmap-devel
371 Development files for FreeIPA Idmap library.
372
373 %description -n libsss_idmap-devel -l pl.UTF-8
374 Pliki programistyczne biblioteki FreeIPA Idmap.
375
376 %package -n libsss_nss_idmap
377 Summary:        Library for SID based lookups
378 Summary(pl.UTF-8):      Biblioteka do wyszukiwań w oparciu o SID
379 Group:          Libraries
380 License:        LGPL v3+
381
382 %description -n libsss_nss_idmap
383 Utility library for SID based lookups.
384
385 %description -n libsss_nss_idmap -l pl.UTF-8
386 Biblioteka do wyszukiwań w oparciu o SID.
387
388 %package -n libsss_nss_idmap-devel
389 Summary:        Development files for sss_nss_idmap library
390 Summary(pl.UTF-8):      Pliki programistyczne biblioteki sss_nss_idmap
391 Group:          Development/Libraries
392 License:        LGPL v3+
393 Requires:       libsss_nss_idmap = %{version}-%{release}
394
395 %description -n libsss_nss_idmap-devel
396 Development files for sss_nss_idmap library.
397
398 %description -n libsss_nss_idmap-devel -l pl.UTF-8
399 Pliki programistyczne biblioteki sss_nss_idmap.
400
401 %package -n python-libsss_nss_idmap
402 Summary:        Python 2 bindings for libsss_nss_idmap
403 Summary(pl.UTF-8):      Wiązania Pythona 2 do biblioteki libsss_nss_idmap
404 Group:          Libraries/Python
405 License:        LGPL v3+
406 Requires:       libsss_nss_idmap = %{version}-%{release}
407
408 %description -n python-libsss_nss_idmap
409 This package contains the bindings so that libsss_nss_idmap can be
410 used by Python 2 applications.
411
412 %description -n python-libsss_nss_idmap -l pl.UTF-8
413 Ten pakiet zawiera wiązania umożliwiające korzystanie z biblioteki
414 libsss_nss_idmap w aplikacjach Pythona 2.
415
416 %package -n python3-libsss_nss_idmap
417 Summary:        Python 3 bindings for libsss_nss_idmap
418 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki libsss_nss_idmap
419 Group:          Libraries/Python
420 License:        LGPL v3+
421 Requires:       libsss_nss_idmap = %{version}-%{release}
422
423 %description -n python3-libsss_nss_idmap
424 This package contains the bindings so that libsss_nss_idmap can be
425 used by Python 3 applications.
426
427 %description -n python3-libsss_nss_idmap -l pl.UTF-8
428 Ten pakiet zawiera wiązania umożliwiające korzystanie z biblioteki
429 libsss_nss_idmap w aplikacjach Pythona 3.
430
431 %package -n libsss_simpleifp
432 Summary:        A library that simplifies work with the InfoPipe responder
433 Summary(pl.UTF-8):      Biblioteka upraszczająca pracę z responderem InfoPipe
434 Group:          Libraries
435 Requires:       dbus-libs >= 1.0.0
436 Requires:       libdhash >= 0.4.2
437
438 %description -n libsss_simpleifp
439 A library that simplifies work with the InfoPipe responder.
440
441 %description -n libsss_simpleifp -l pl.UTF-8
442 Biblioteka upraszczająca pracę z responderem InfoPipe.
443
444 %package -n libsss_simpleifp-devel
445 Summary:        Header files for libsss_simpleifp library
446 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsss_simpleifp
447 Group:          Development/Libraries
448 Requires:       dbus-devel >= 1.0.0
449 Requires:       libdhash-devel >= 0.4.2
450 Requires:       libsss_simpleifp = %{version}-%{release}
451
452 %description -n libsss_simpleifp-devel
453 Header files for libsss_simpleifp library.
454
455 %description -n libsss_simpleifp-devel -l pl.UTF-8
456 Pliki nagłówkowe biblioteki libsss_simpleifp.
457
458 %prep
459 %setup -q
460 %patch0 -p1
461 %patch1 -p1
462 %patch2 -p1
463 %patch3 -p1
464 %patch4 -p1
465
466 %build
467 %{__libtoolize}
468 %{__gettextize}
469 %{__aclocal} -I m4
470 %{__autoconf}
471 %{__automake}
472 %configure \
473         NSCD=/usr/sbin/nscd \
474         %{!?with_krb5:--disable-krb5-locator-plugin} \
475         --enable-nfsidmaplibdir=/%{_lib}/libnfsidmap \
476         --enable-nsslibdir=/%{_lib} \
477         %{!?with_krb5:--disable-pac-responder} \
478         --enable-pammoddir=/%{_lib}/security \
479         --disable-rpath \
480         --with-db-path=%{dbpath} \
481         --with-init-dir=/etc/rc.d/init.d \
482         --with-initscript=sysv,systemd \
483         --with-pipe-path=%{pipepath} \
484         --with-pubconf-path=%{pubconfpath} \
485         --with-python2-bindings%{!?with_python2:=no} \
486         --with-python3-bindings%{!?with_python3:=no} \
487         --with-systemdunitdir=%{systemdunitdir} \
488         --with-test-dir=/dev/shm
489
490 %{__make}
491
492 %if %{with tests}
493 export CK_TIMEOUT_MULTIPLIER=10
494 %{__make} check
495 unset CK_TIMEOUT_MULTIPLIER
496 %endif
497
498 %install
499 rm -rf $RPM_BUILD_ROOT
500
501 %{__make} -j1 install \
502         DESTDIR=$RPM_BUILD_ROOT \
503         python3dir=%{py3_sitescriptdir}
504
505 # Prepare language files
506 %find_lang %{name}
507
508 # Copy default sssd.conf file
509 install -d $RPM_BUILD_ROOT%{_sysconfdir}/sssd/sssd.api.d
510 cp -p src/examples/sssd-example.conf $RPM_BUILD_ROOT%{_sysconfdir}/sssd/sssd.conf
511
512 # Copy default logrotate file
513 install -d $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
514 cp -p src/examples/logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/sssd
515
516 # Make sure SSSD is able to run on read-only root
517 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rwtab.d
518 #cp -p src/examples/rwtab $RPM_BUILD_ROOT%{_sysconfdir}/rwtab.d/sssd
519
520 # Remove .la files created by libtool
521 %{__rm} \
522         $RPM_BUILD_ROOT/%{_lib}/libnss_sss.la \
523         $RPM_BUILD_ROOT/%{_lib}/libnfsidmap/sss.la \
524         $RPM_BUILD_ROOT/%{_lib}/security/pam_sss.la \
525         $RPM_BUILD_ROOT%{ldb_modulesdir}/memberof.la \
526         $RPM_BUILD_ROOT%{_libdir}/cifs-utils/*.la \
527         %{?with_krb5:$RPM_BUILD_ROOT%{_libdir}/krb5/plugins/libkrb5/sss*.la} \
528         $RPM_BUILD_ROOT%{_libdir}/sssd/libsss_*.la \
529         $RPM_BUILD_ROOT%{_libdir}/sssd/modules/lib*.la \
530         $RPM_BUILD_ROOT%{_libdir}/lib*.la
531 %if %{with python2}
532 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.la
533 %py_postclean
534 %endif
535 %if %{with python3}
536 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/*.la
537 %endif
538
539 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
540
541 echo '%%defattr(644,root,root,755)' > sssd_client.lang
542 echo '%%defattr(644,root,root,755)' > sssd_tools.lang
543 for man in $(find $RPM_BUILD_ROOT%{_mandir}/??/man? -type f | sed -e "s#$RPM_BUILD_ROOT%{_mandir}/##"); do
544         lang=$(echo $man | cut -c 1-2)
545         case $(basename $man) in
546         pam_sss.8|sssd_krb5_locator_plugin.8)
547                 echo "%lang(${lang}) %{_mandir}/${man}*" >> sssd_client.lang
548                 ;;
549         sss_debuglevel.8|sss_group*.8|sss_obfuscate.8|sss_seed.8|sss_user*.8)
550                 echo "%lang(${lang}) %{_mandir}/${man}*" >> sssd_tools.lang
551                 ;;
552         *)
553                 echo "%lang(${lang}) %{_mandir}/${man}*" >> sssd.lang
554                 ;;
555         esac
556 done
557
558 %clean
559 rm -rf $RPM_BUILD_ROOT
560
561 %post
562 /sbin/ldconfig
563 /sbin/chkconfig --add %{name}
564 %service %{name} restart
565
566 %preun
567 if [ "$1" = "0" ]; then
568         %service -q %{name} stop
569         /sbin/chkconfig --del %{name}
570 fi
571
572 %postun -p /sbin/ldconfig
573
574 %post   client -p /sbin/ldconfig
575 %postun client -p /sbin/ldconfig
576
577 %post   -n libipa_hbac -p /sbin/ldconfig
578 %postun -n libipa_hbac -p /sbin/ldconfig
579
580 %post   -n libsss_idmap -p /sbin/ldconfig
581 %postun -n libsss_idmap -p /sbin/ldconfig
582
583 %post   -n libsss_nss_idmap -p /sbin/ldconfig
584 %postun -n libsss_nss_idmap -p /sbin/ldconfig
585
586 %post   -n libsss_simpleifp -p /sbin/ldconfig
587 %postun -n libsss_simpleifp -p /sbin/ldconfig
588
589 %files -f sssd.lang
590 %defattr(644,root,root,755)
591 %attr(755,root,root) %{_bindir}/sss_ssh_authorizedkeys
592 %attr(755,root,root) %{_bindir}/sss_ssh_knownhostsproxy
593 %attr(755,root,root) %{_sbindir}/sss_cache
594 %attr(755,root,root) %{_sbindir}/sssd
595 # sudo plugin
596 %attr(755,root,root) %{_libdir}/libsss_sudo.so
597 %dir %{_libdir}/sssd
598 # internal shared libraries
599 %attr(755,root,root) %{_libdir}/sssd/libsss_cert.so
600 %attr(755,root,root) %{_libdir}/sssd/libsss_child.so
601 %attr(755,root,root) %{_libdir}/sssd/libsss_config.so
602 %attr(755,root,root) %{_libdir}/sssd/libsss_crypt.so
603 %attr(755,root,root) %{_libdir}/sssd/libsss_debug.so
604 %attr(755,root,root) %{_libdir}/sssd/libsss_krb5_common.so
605 %attr(755,root,root) %{_libdir}/sssd/libsss_ldap_common.so
606 %attr(755,root,root) %{_libdir}/sssd/libsss_semanage.so
607 %attr(755,root,root) %{_libdir}/sssd/libsss_util.so
608 # modules
609 %attr(755,root,root) %{_libdir}/sssd/libsss_simple.so
610 %attr(755,root,root) %{_libdir}/sssd/libsss_ad.so
611 %attr(755,root,root) %{_libdir}/sssd/libsss_ipa.so
612 %attr(755,root,root) %{_libdir}/sssd/libsss_krb5.so
613 %attr(755,root,root) %{_libdir}/sssd/libsss_ldap.so
614 %attr(755,root,root) %{_libdir}/sssd/libsss_proxy.so
615 %dir %{_libdir}/sssd/modules
616 %attr(755,root,root) %{_libdir}/sssd/modules/libsss_autofs.so
617 %if "%{_libdir}" != "%{_libexecdir}"
618 %dir %{_libexecdir}/sssd
619 %endif
620 %attr(755,root,root) %{_libexecdir}/sssd/gpo_child
621 %attr(755,root,root) %{_libexecdir}/sssd/krb5_child
622 %attr(755,root,root) %{_libexecdir}/sssd/ldap_child
623 %attr(755,root,root) %{_libexecdir}/sssd/p11_child
624 %attr(755,root,root) %{_libexecdir}/sssd/proxy_child
625 %attr(755,root,root) %{_libexecdir}/sssd/selinux_child
626 %attr(755,root,root) %{_libexecdir}/sssd/sss_signal
627 %attr(755,root,root) %{_libexecdir}/sssd/sssd_autofs
628 %attr(755,root,root) %{_libexecdir}/sssd/sssd_be
629 %attr(755,root,root) %{_libexecdir}/sssd/sssd_ifp
630 %attr(755,root,root) %{_libexecdir}/sssd/sssd_nss
631 %if %{with krb5}
632 %attr(755,root,root) %{_libexecdir}/sssd/sssd_pac
633 %endif
634 %attr(755,root,root) %{_libexecdir}/sssd/sssd_pam
635 %attr(755,root,root) %{_libexecdir}/sssd/sssd_ssh
636 %attr(755,root,root) %{_libexecdir}/sssd/sssd_sudo
637 %dir %{_datadir}/sssd
638 %{_datadir}/sssd/sssd.api.conf
639 %dir %{_datadir}/sssd/sssd.api.d
640 %{_datadir}/sssd/sssd.api.d/sssd-ad.conf
641 %{_datadir}/sssd/sssd.api.d/sssd-ipa.conf
642 %{_datadir}/sssd/sssd.api.d/sssd-krb5.conf
643 %{_datadir}/sssd/sssd.api.d/sssd-ldap.conf
644 %{_datadir}/sssd/sssd.api.d/sssd-local.conf
645 %{_datadir}/sssd/sssd.api.d/sssd-proxy.conf
646 %{_datadir}/sssd/sssd.api.d/sssd-simple.conf
647 %attr(755,root,root) /%{_lib}/libnfsidmap/sss.so
648 %attr(755,root,root) %{ldb_modulesdir}/memberof.so
649 %dir %{sssdstatedir}
650 %attr(700,root,root) %dir %{dbpath}
651 %dir %{pipepath}
652 %dir %{pubconfpath}
653 %attr(700,root,root) %dir %{pipepath}/private
654 %attr(750,root,root) %dir %{_var}/log/%{name}
655 %attr(700,root,root) %dir %{_sysconfdir}/sssd
656 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sssd/sssd.conf
657 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/sssd
658 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rwtab.d/sssd
659 %attr(754,root,root) /etc/rc.d/init.d/sssd
660 %{systemdunitdir}/sssd.service
661 /etc/dbus-1/system.d/org.freedesktop.sssd.infopipe.conf
662 %{_datadir}/dbus-1/system-services/org.freedesktop.sssd.infopipe.service
663 %{_mandir}/man1/sss_ssh_authorizedkeys.1*
664 %{_mandir}/man1/sss_ssh_knownhostsproxy.1*
665 %{_mandir}/man5/sss_rpcidmapd.5*
666 %{_mandir}/man5/sssd.conf.5*
667 %{_mandir}/man5/sssd-ad.5*
668 %{_mandir}/man5/sssd-ifp.5*
669 %{_mandir}/man5/sssd-ipa.5*
670 %{_mandir}/man5/sssd-krb5.5*
671 %{_mandir}/man5/sssd-ldap.5*
672 %{_mandir}/man5/sssd-simple.5*
673 %{_mandir}/man5/sssd-sudo.5*
674 %{_mandir}/man8/sss_cache.8*
675 %{_mandir}/man8/sssd.8*
676
677 %files client -f sssd_client.lang
678 %defattr(644,root,root,755)
679 %attr(755,root,root) /%{_lib}/libnss_sss.so.2
680 %attr(755,root,root) /%{_lib}/security/pam_sss.so
681 %attr(755,root,root) %{_libdir}/cifs-utils/cifs_idmap_sss.so
682 %if %{with krb5}
683 # XXX: verify locations
684 %attr(755,root,root) %{_libdir}/krb5/plugins/libkrb5/sssd_krb5_localauth_plugin.so
685 %attr(755,root,root) %{_libdir}/krb5/plugins/libkrb5/sssd_krb5_locator_plugin.so
686 %attr(755,root,root) %{_libdir}/krb5/plugins/libkrb5/sssd_pac_plugin.so
687 %endif
688 %{_mandir}/man8/pam_sss.8*
689 %{_mandir}/man8/sssd_krb5_locator_plugin.8*
690
691 %files tools -f sssd_tools.lang
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{_sbindir}/sss_debuglevel
694 %attr(755,root,root) %{_sbindir}/sss_groupadd
695 %attr(755,root,root) %{_sbindir}/sss_groupdel
696 %attr(755,root,root) %{_sbindir}/sss_groupmod
697 %attr(755,root,root) %{_sbindir}/sss_groupshow
698 %attr(755,root,root) %{_sbindir}/sss_obfuscate
699 %attr(755,root,root) %{_sbindir}/sss_override
700 %attr(755,root,root) %{_sbindir}/sss_seed
701 %attr(755,root,root) %{_sbindir}/sss_useradd
702 %attr(755,root,root) %{_sbindir}/sss_userdel
703 %attr(755,root,root) %{_sbindir}/sss_usermod
704 %{_mandir}/man8/sss_debuglevel.8*
705 %{_mandir}/man8/sss_groupadd.8*
706 %{_mandir}/man8/sss_groupdel.8*
707 %{_mandir}/man8/sss_groupmod.8*
708 %{_mandir}/man8/sss_groupshow.8*
709 %{_mandir}/man8/sss_obfuscate.8*
710 %{_mandir}/man8/sss_override.8*
711 %{_mandir}/man8/sss_seed.8*
712 %{_mandir}/man8/sss_useradd.8*
713 %{_mandir}/man8/sss_userdel.8*
714 %{_mandir}/man8/sss_usermod.8*
715
716 %if %{with python2}
717 %files -n python-sss
718 %defattr(644,root,root,755)
719 %attr(755,root,root) %{py_sitedir}/pysss.so
720
721 %files -n python-sss-murmur
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{py_sitedir}/pysss_murmur.so
724
725 %files -n python-sssdconfig
726 %defattr(644,root,root,755)
727 %dir %{py_sitescriptdir}/SSSDConfig
728 %{py_sitescriptdir}/SSSDConfig/*.py[co]
729 %{py_sitescriptdir}/SSSDConfig-%{version}-py*.egg-info
730 %endif
731
732 %if %{with python3}
733 %files -n python3-sss
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{py3_sitedir}/pysss.so
736
737 %files -n python3-sss-murmur
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{py3_sitedir}/pysss_murmur.so
740
741 %files -n python3-sssdconfig
742 %defattr(644,root,root,755)
743 %dir %{py3_sitescriptdir}/SSSDConfig
744 %{py3_sitescriptdir}/SSSDConfig/*.py
745 %{py3_sitescriptdir}/SSSDConfig/__pycache__
746 %{py3_sitescriptdir}/SSSDConfig-%{version}-py*.egg-info
747 %endif
748
749 %files libwbclient
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{_libdir}/sssd/modules/libwbclient.so.*
752
753 %files libwbclient-devel
754 %defattr(644,root,root,755)
755 %attr(755,root,root) %{_libdir}/sssd/modules/libwbclient.so
756 %{_includedir}/wbclient_sssd.h
757 %{_pkgconfigdir}/wbclient_sssd.pc
758
759 %files -n libipa_hbac
760 %defattr(644,root,root,755)
761 %attr(755,root,root) %{_libdir}/libipa_hbac.so.*.*.*
762 %attr(755,root,root) %ghost %{_libdir}/libipa_hbac.so.0
763
764 %files -n libipa_hbac-devel
765 %defattr(644,root,root,755)
766 %attr(755,root,root) %{_libdir}/libipa_hbac.so
767 %{_includedir}/ipa_hbac.h
768 %{_pkgconfigdir}/ipa_hbac.pc
769
770 %if %{with python2}
771 %files -n python-libipa_hbac
772 %defattr(644,root,root,755)
773 %attr(755,root,root) %{py_sitedir}/pyhbac.so
774 %endif
775
776 %if %{with python3}
777 %files -n python3-libipa_hbac
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{py3_sitedir}/pyhbac.so
780 %endif
781
782 %files -n libsss_idmap
783 %defattr(644,root,root,755)
784 %attr(755,root,root) %{_libdir}/libsss_idmap.so.*.*.*
785 %attr(755,root,root) %ghost %{_libdir}/libsss_idmap.so.0
786
787 %files -n libsss_idmap-devel
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{_libdir}/libsss_idmap.so
790 %{_includedir}/sss_idmap.h
791 %{_pkgconfigdir}/sss_idmap.pc
792
793 %files -n libsss_nss_idmap
794 %defattr(644,root,root,755)
795 %attr(755,root,root) %{_libdir}/libsss_nss_idmap.so.*.*.*
796 %attr(755,root,root) %ghost %{_libdir}/libsss_nss_idmap.so.0
797
798 %files -n libsss_nss_idmap-devel
799 %defattr(644,root,root,755)
800 %attr(755,root,root) %{_libdir}/libsss_nss_idmap.so
801 %{_includedir}/sss_nss_idmap.h
802 %{_pkgconfigdir}/sss_nss_idmap.pc
803
804 %if %{with python2}
805 %files -n python-libsss_nss_idmap
806 %defattr(644,root,root,755)
807 %attr(755,root,root) %{py_sitedir}/pysss_nss_idmap.so
808 %endif
809
810 %if %{with python3}
811 %files -n python3-libsss_nss_idmap
812 %defattr(644,root,root,755)
813 %attr(755,root,root) %{py3_sitedir}/pysss_nss_idmap.so
814 %endif
815
816 %files -n libsss_simpleifp
817 %defattr(644,root,root,755)
818 %attr(755,root,root) %{_libdir}/libsss_simpleifp.so.*.*.*
819 %attr(755,root,root) %ghost %{_libdir}/libsss_simpleifp.so.0
820
821 %files -n libsss_simpleifp-devel
822 %defattr(644,root,root,755)
823 %attr(755,root,root) %{_libdir}/libsss_simpleifp.so
824 %{_includedir}/sss_sifp.h
825 %{_includedir}/sss_sifp_dbus.h
826 %{_pkgconfigdir}/sss_simpleifp.pc
This page took 0.099258 seconds and 2 git commands to generate.