]> git.pld-linux.org Git - packages/sssd.git/blob - sssd.spec
add tests, krb5 bcond
[packages/sssd.git] / sssd.spec
1 # TODO
2 # - python3 packages
3 # - pac-responder (currently relies on MIT krb5 >= 1.9)
4 # - fix stripping before rpm:
5 #   *** WARNING: no sources found for /usr/lib64/libipa_hbac.so.0.0.0 (stripped without sourcefile information?)
6 #
7 # Conditional build:
8 %bcond_with     tests           # build with tests
9 %bcond_without  python2 # CPython 2.x module
10 %bcond_with     python3 # CPython 3.x module
11 %bcond_without  krb5 # Build without krb5 support
12
13 %define         ldb_version 1.1.0
14 Summary:        System Security Services Daemon
15 Summary(pl.UTF-8):      System Security Services Daemon - demon usług bezpieczeństwa systemu
16 Name:           sssd
17 Version:        1.13.4
18 Release:        0.1
19 License:        GPL v3+
20 Group:          Applications/System
21 Source0:        https://fedorahosted.org/released/sssd/%{name}-%{version}.tar.gz
22 # Source0-md5:  d147e0a4f4719d993693c6a99370b350
23 Source1:        %{name}.init
24 Patch1:         %{name}-heimdal.patch
25 Patch2:         %{name}-systemd.patch
26 Patch3:         %{name}-link.patch
27 URL:            https://fedorahosted.org/sssd/
28 BuildRequires:  augeas-devel >= 1.0.0
29 BuildRequires:  autoconf >= 2.59
30 BuildRequires:  automake
31 # nsupdate utility
32 BuildRequires:  bind-utils
33 BuildRequires:  c-ares-devel
34 BuildRequires:  check-devel >= 0.9.5
35 BuildRequires:  cifs-utils-devel
36 BuildRequires:  cmocka-devel
37 BuildRequires:  cyrus-sasl-devel >= 2
38 BuildRequires:  dbus-devel >= 1.0.0
39 BuildRequires:  docbook-dtd44-xml
40 BuildRequires:  docbook-style-xsl
41 BuildRequires:  doxygen
42 BuildRequires:  gettext-tools >= 0.14.4
43 BuildRequires:  glib2-devel >= 2.0
44 BuildRequires:  heimdal-devel
45 BuildRequires:  keyutils-devel
46 BuildRequires:  libcollection-devel >= 0.5.1
47 BuildRequires:  libdhash-devel >= 0.4.2
48 BuildRequires:  libini_config-devel >= 1.0.0
49 BuildRequires:  ldb-devel >= %{ldb_version}
50 BuildRequires:  libltdl-devel
51 BuildRequires:  libnfsidmap-devel
52 BuildRequires:  libnl-devel >= 3.2
53 BuildRequires:  libselinux-devel
54 BuildRequires:  libsemanage-devel
55 BuildRequires:  libtool >= 2:2
56 BuildRequires:  libxml2-progs
57 BuildRequires:  libxslt-progs
58 BuildRequires:  m4
59 BuildRequires:  nspr-devel
60 BuildRequires:  nss-devel
61 BuildRequires:  openldap-devel
62 BuildRequires:  pam-devel
63 BuildRequires:  pcre-devel >= 7
64 BuildRequires:  pkgconfig
65 BuildRequires:  po4a
66 BuildRequires:  popt-devel
67 BuildRequires:  python-devel >= 1:2.4
68 BuildRequires:  rpm-pythonprov
69 BuildRequires:  rpmbuild(macros) >= 1.228
70 # pkgconfig(ndr_nbt)
71 BuildRequires:  samba-devel >= 4
72 BuildRequires:  systemd-units
73 BuildRequires:  talloc-devel
74 BuildRequires:  tdb-devel >= 1.1.3
75 BuildRequires:  tevent-devel
76 Requires(post): /sbin/ldconfig
77 Requires(post,preun):   /sbin/chkconfig
78 Requires:       %{name}-client = %{version}-%{release}
79 Requires:       cyrus-sasl-gssapi
80 Requires:       ldb >= %{ldb_version}
81 Requires:       libsss_idmap = %{version}-%{release}
82 Requires:       rc-scripts >= 0.4.0.10
83 Requires:       tdb >= 1.1.3
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 %define         sssdstatedir            %{_localstatedir}/lib/sss
87 %define         dbpath                  %{sssdstatedir}/db
88 %define         pipepath                %{sssdstatedir}/pipes
89 %define         pubconfpath             %{sssdstatedir}/pubconf
90
91 # Determine the location of the LDB modules directory
92 %define         ldb_modulesdir  %(pkg-config --variable=modulesdir ldb)
93
94 %description
95 Provides a set of daemons to manage access to remote directories and
96 authentication mechanisms. It provides an NSS and PAM interface toward
97 the system and a pluggable backend system to connect to multiple
98 different account sources. It is also the basis to provide client
99 auditing and policy services for projects like FreeIPA.
100
101 %description -l pl.UTF-8
102 Ten pakiet dostarcza zbiór demonów do zarządzania dostępem do zdalnych
103 katalogów i mechanizmów uwierzytelniania. Udostępnia interfejsy NSS i
104 PAM dla systemu oraz system backendu z wtyczkami w celu łączenia się z
105 wieloma różnymi źródłami kont. Jest także podstawą zapewniającą audyt
106 klientów oraz usługi polityk dla projektów takich jak FreeIPA.
107
108 %package client
109 Summary:        SSSD Client libraries for NSS and PAM
110 Summary(pl.UTF-8):      Biblioteki klienckie SSSD dla NSS i PAM
111 License:        LGPL v3+
112 Group:          Applications/System
113
114 %description client
115 Provides the libraries needed by the PAM and NSS stacks to connect to
116 the SSSD service.
117
118 %description client -l pl.UTF-8
119 Ten pakiet dostarcza biblioteki wymagane przez stosy PAM i NSS w celu
120 łączenia się z usługą SSSD.
121
122 %package tools
123 Summary:        Userspace tools for use with the SSSD
124 Summary(pl.UTF-8):      Narzędzia przestrzeni użytkownika do używania z SSSD
125 License:        GPL v3+
126 Group:          Applications/System
127 Requires:       %{name} = %{version}-%{release}
128
129 %description tools
130 Provides userspace tools for manipulating users, groups, and nested
131 groups in SSSD when using id_provider = local in /etc/sssd/sssd.conf.
132
133 Also provides several other administrative tools:
134  - sss_debuglevel to change the debug level on the fly,
135  - sss_seed which pre-creates a user entry for use in kickstarts,
136  - sss_obfuscate for generating an obfuscated LDAP password.
137
138 %description tools -l pl.UTF-8
139 Ten pakiet dostarcza narzędzia przestrzeni poleceń do operowania na
140 użytkownikach, grupach oraz zagnieżdżonych grupach w SSSD w przypadku
141 używania id_provider = local w /etc/sssd/sssd.conf.
142
143 Pakiet zawiera także kilka innych narzędzi administracyjnych:
144  - sss_debuglevel do zmiany poziomu diagnostyki w locie,
145  - sss_seed tworzący wpis użytkownika do szybkiego rozruchu,
146  - sss_obfuscate do generowania utajnionego hasła LDAP.
147
148 %package libwbclient
149 Summary:        The SSSD libwbclient implementation
150 Summary(pl.UTF-8):      Implementacja libwbclient oparta na SSSD
151 Group:          Libraries
152 License:        LGPL v3+
153 Requires:       libsss_nss_idmap = %{version}-%{release}
154
155 %description libwbclient
156 The SSSD implementation of Samba wbclient library.
157
158 %description libwbclient -l pl.UTF-8
159 Implementacja biblioteki Samba wbclient oparta na SSSD.
160
161 %package libwbclient-devel
162 Summary:        Development files of the SSSD libwbclient implementation
163 Summary(pl.UTF-8):      Pliki programistyczne implementacja libwbclient oparta na SSSD
164 Group:          Development/Libraries
165 License:        LGPL v3+
166 Requires:       %{name}-libwbclient = %{version}-%{release}
167
168 %description libwbclient-devel
169 Development files for the SSSD implementation of Samba wbclient
170 library.
171
172 %description libwbclient-devel -l pl.UTF-8
173 Pliki programistyczne implementacji biblioteki Samba wbclient opartej
174 na SSSD.
175
176 %package -n libipa_hbac
177 Summary:        FreeIPA HBAC Evaluator library
178 Summary(pl.UTF-8):      Biblioteka oceniająca FreeIPA HBAC
179 License:        LGPL v3+
180 Group:          Libraries
181
182 %description -n libipa_hbac
183 Utility library to validate FreeIPA HBAC rules for authorization
184 requests.
185
186 %description -n libipa_hbac
187 Biblioteka narzędziowa do sprawdzania poprawności reguł FreeIPA HBAC
188 dla żądań autoryzacji.
189
190 %package -n libipa_hbac-devel
191 Summary:        Development files for FreeIPA HBAC Evaluator library
192 Summary(pl.UTF-8):      Pliki programistyczne biblioteki oceniająca FreeIPA HBAC
193 License:        LGPL v3+
194 Group:          Development/Libraries
195 Requires:       libipa_hbac = %{version}-%{release}
196
197 %description -n libipa_hbac-devel
198 Development files for FreeIPA HBAC Evaluator library.
199
200 %description -n libipa_hbac-devel -l pl.UTF-8
201 Pliki programistyczne biblioteki oceniająca FreeIPA HBAC.
202
203 %package -n python-libipa_hbac
204 Summary:        Python bindings for the FreeIPA HBAC Evaluator library
205 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki oceniającej FreeIPA HBAC
206 License:        LGPL v3+
207 Group:          Libraries/Python
208 Requires:       libipa_hbac = %{version}-%{release}
209 Obsoletes:      libipa_hbac-python
210
211 %description -n python-libipa_hbac
212 This package contains the bindings so that libipa_hbac can be used by
213 Python applications.
214
215 %description -n python-libipa_hbac -l pl.UTF-8
216 Ten pakiet zawiera wiązania pozwalające na używanie libipa_hbac w
217 aplikacjach Pythona.
218
219 %package -n libsss_idmap
220 Summary:        FreeIPA Idmap library
221 Summary(pl.UTF-8):      Biblioteka FreeIPA Idmap
222 Group:          Libraries
223 License:        LGPL v3+
224
225 %description -n libsss_idmap
226 Utility library to convert SIDs to Unix uids and gids.
227
228 %description -n libsss_idmap -l pl.UTF-8
229 Biblioteka narzędziowa konwertująca SID-y na uniksowe uidy i gidy.
230
231 %package -n libsss_idmap-devel
232 Summary:        Development files for FreeIPA Idmap library
233 Summary(pl.UTF-8):      Pliki programistyczne biblioteki FreeIPA Idmap
234 Group:          Development/Libraries
235 License:        LGPL v3+
236 Requires:       libsss_idmap = %{version}-%{release}
237
238 %description -n libsss_idmap-devel
239 Development files for FreeIPA Idmap library.
240
241 %description -n libsss_idmap-devel -l pl.UTF-8
242 Pliki programistyczne biblioteki FreeIPA Idmap.
243
244 %package -n libsss_nss_idmap
245 Summary:        Library for SID based lookups
246 Summary(pl.UTF-8):      Biblioteka do wyszukiwań w oparciu o SID
247 Group:          Libraries
248 License:        LGPL v3+
249
250 %description -n libsss_nss_idmap
251 Utility library for SID based lookups.
252
253 %description -n libsss_nss_idmap -l pl.UTF-8
254 Biblioteka do wyszukiwań w oparciu o SID.
255
256 %package -n libsss_nss_idmap-devel
257 Summary:        Development files for sss_nss_idmap library
258 Summary(pl.UTF-8):      Pliki programistyczne biblioteki sss_nss_idmap
259 Group:          Development/Libraries
260 License:        LGPL v3+
261 Requires:       libsss_nss_idmap = %{version}-%{release}
262
263 %description -n libsss_nss_idmap-devel
264 Development files for sss_nss_idmap library.
265
266 %description -n libsss_nss_idmap-devel -l pl.UTF-8
267 Pliki programistyczne biblioteki sss_nss_idmap.
268
269 %package -n python-libsss_nss_idmap
270 Summary:        Python bindings for libsss_nss_idmap
271 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libsss_nss_idmap
272 Group:          Libraries/Python
273 License:        LGPL v3+
274 Requires:       libsss_nss_idmap = %{version}-%{release}
275
276 %description -n python-libsss_nss_idmap
277 This package contains the bindings so that libsss_nss_idmap can be
278 used by Python applications.
279
280 %description -n python-libsss_nss_idmap -l pl.UTF-8
281 Ten pakiet zawiera wiązania umożliwiające korzystanie z biblioteki
282 libsss_nss_idmap w aplikacjach Pythona.
283
284 %package -n libsss_simpleifp
285 Summary:        A library that simplifies work with the InfoPipe responder
286 Summary(pl.UTF-8):      Biblioteka upraszczająca pracę z responderem InfoPipe
287 Group:          Libraries
288 Requires:       dbus-libs >= 1.0.0
289 Requires:       libdhash >= 0.4.2
290
291 %description -n libsss_simpleifp
292 A library that simplifies work with the InfoPipe responder.
293
294 %description -n libsss_simpleifp -l pl.UTF-8
295 Biblioteka upraszczająca pracę z responderem InfoPipe.
296
297 %package -n libsss_simpleifp-devel
298 Summary:        Header files for libsss_simpleifp library
299 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsss_simpleifp
300 Group:          Development/Libraries
301 Requires:       dbus-devel >= 1.0.0
302 Requires:       libdhash-devel >= 0.4.2
303 Requires:       libsss_simpleifp = %{version}-%{release}
304
305 %description -n libsss_simpleifp-devel
306 Header files for libsss_simpleifp library.
307
308 %description -n libsss_simpleifp-devel -l pl.UTF-8
309 Pliki nagłówkowe biblioteki libsss_simpleifp.
310
311 %prep
312 %setup -q
313 %patch1 -p1
314 %patch2 -p1
315 %patch3 -p1
316
317 %build
318 %{__libtoolize}
319 %{__gettextize}
320 %{__aclocal}
321 %{__automake}
322 %{__autoconf}
323 #CFLAGS="-Wno-deprecated-declarations"
324 %configure \
325         NSCD=/usr/sbin/nscd \
326         --enable-nfsidmaplibdir=/%{_lib}/libnfsidmap \
327         --enable-nsslibdir=/%{_lib} \
328         --enable-pammoddir=/%{_lib}/security \
329         --disable-rpath \
330         --with-db-path=%{dbpath} \
331         --with-init-dir=/etc/rc.d/init.d \
332         --with-initscript=sysv,systemd \
333         --with-pipe-path=%{pipepath} \
334         --with-pubconf-path=%{pubconfpath} \
335         --with%{!?with_python2:out}-python2-bindings \
336         --with%{!?with_python3:out}-python3-bindings \
337         --with-systemdunitdir=%{systemdunitdir} \
338 %if %{without krb5}
339         --disable-krb5-locator-plugin \
340 %endif
341         --with-test-dir=/dev/shm
342
343 %{__make}
344
345 %if %{with tests}
346 export CK_TIMEOUT_MULTIPLIER=10
347 %{__make} check
348 unset CK_TIMEOUT_MULTIPLIER
349 %endif
350
351 %install
352 rm -rf $RPM_BUILD_ROOT
353 %{__make} install \
354         DESTDIR=$RPM_BUILD_ROOT
355
356 # Prepare language files
357 %find_lang %{name}
358
359 # Copy default sssd.conf file
360 install -d $RPM_BUILD_ROOT%{_sysconfdir}/sssd/sssd.api.d
361 cp -p src/examples/sssd-example.conf $RPM_BUILD_ROOT%{_sysconfdir}/sssd/sssd.conf
362
363 # Copy default logrotate file
364 install -d $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
365 cp -p src/examples/logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/sssd
366
367 # Make sure SSSD is able to run on read-only root
368 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rwtab.d
369 cp -p src/examples/rwtab $RPM_BUILD_ROOT%{_sysconfdir}/rwtab.d/sssd
370
371 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
372 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
373 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
374 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
375 %py_postclean
376
377 # Remove .la files created by libtool
378 %{__rm} \
379         $RPM_BUILD_ROOT/%{_lib}/libnss_sss.la \
380         $RPM_BUILD_ROOT/%{_lib}/libnfsidmap/sss.la \
381         $RPM_BUILD_ROOT/%{_lib}/security/pam_sss.la \
382         $RPM_BUILD_ROOT%{ldb_modulesdir}/memberof.la \
383         $RPM_BUILD_ROOT%{_libdir}/cifs-utils/*.la \
384         $RPM_BUILD_ROOT%{_libdir}/krb5/plugins/libkrb5/sss*.la \
385         $RPM_BUILD_ROOT%{_libdir}/sssd/libsss_*.la \
386         $RPM_BUILD_ROOT%{_libdir}/sssd/modules/lib*.la \
387         $RPM_BUILD_ROOT%{_libdir}/lib*.la \
388         $RPM_BUILD_ROOT%{py_sitedir}/*.la
389
390 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
391
392 echo '%%defattr(644,root,root,755)' > sssd_client.lang
393 echo '%%defattr(644,root,root,755)' > sssd_tools.lang
394 for man in $(find $RPM_BUILD_ROOT%{_mandir}/??/man? -type f | sed -e "s#$RPM_BUILD_ROOT%{_mandir}/##"); do
395         lang=$(echo $man | cut -c 1-2)
396         case $(basename $man) in
397         pam_sss.8|sssd_krb5_locator_plugin.8)
398                 echo "%lang(${lang}) %{_mandir}/${man}*" >> sssd_client.lang
399                 ;;
400         sss_debuglevel.8|sss_group*.8|sss_obfuscate.8|sss_seed.8|sss_user*.8)
401                 echo "%lang(${lang}) %{_mandir}/${man}*" >> sssd_tools.lang
402                 ;;
403         *)
404                 echo "%lang(${lang}) %{_mandir}/${man}*" >> sssd.lang
405                 ;;
406         esac
407 done
408
409 %clean
410 rm -rf $RPM_BUILD_ROOT
411
412 %post
413 /sbin/ldconfig
414 /sbin/chkconfig --add %{name}
415 %service %{name} restart
416
417 %preun
418 if [ "$1" = "0" ]; then
419         %service -q %{name} stop
420         /sbin/chkconfig --del %{name}
421 fi
422
423 %postun -p /sbin/ldconfig
424
425 %post   client -p /sbin/ldconfig
426 %postun client -p /sbin/ldconfig
427
428 %post   -n libipa_hbac -p /sbin/ldconfig
429 %postun -n libipa_hbac -p /sbin/ldconfig
430
431 %post   -n libsss_idmap -p /sbin/ldconfig
432 %postun -n libsss_idmap -p /sbin/ldconfig
433
434 %post   -n libsss_nss_idmap -p /sbin/ldconfig
435 %postun -n libsss_nss_idmap -p /sbin/ldconfig
436
437 %post   -n libsss_simpleifp -p /sbin/ldconfig
438 %postun -n libsss_simpleifp -p /sbin/ldconfig
439
440 %files -f sssd.lang
441 %defattr(644,root,root,755)
442 %attr(755,root,root) %{_bindir}/sss_ssh_authorizedkeys
443 %attr(755,root,root) %{_bindir}/sss_ssh_knownhostsproxy
444 %attr(755,root,root) %{_sbindir}/sss_cache
445 %attr(755,root,root) %{_sbindir}/sssd
446 %attr(755,root,root) %{_libdir}/libsss_sudo.so
447 %dir %{_libdir}/sssd
448 # internal shared libraries
449 %attr(755,root,root) %{_libdir}/sssd/libsss_ad_common.so
450 %attr(755,root,root) %{_libdir}/sssd/libsss_child.so
451 %attr(755,root,root) %{_libdir}/sssd/libsss_config.so
452 %attr(755,root,root) %{_libdir}/sssd/libsss_crypt.so
453 %attr(755,root,root) %{_libdir}/sssd/libsss_debug.so
454 %attr(755,root,root) %{_libdir}/sssd/libsss_ldap_common.so
455 %attr(755,root,root) %{_libdir}/sssd/libsss_semanage.so
456 %attr(755,root,root) %{_libdir}/sssd/libsss_util.so
457 # modules
458 %attr(755,root,root) %{_libdir}/sssd/libsss_simple.so
459 %attr(755,root,root) %{_libdir}/sssd/libsss_ad.so
460 %attr(755,root,root) %{_libdir}/sssd/libsss_ipa.so
461 %attr(755,root,root) %{_libdir}/sssd/libsss_krb5.so
462 %attr(755,root,root) %{_libdir}/sssd/libsss_krb5_common.so
463 %attr(755,root,root) %{_libdir}/sssd/libsss_ldap.so
464 %attr(755,root,root) %{_libdir}/sssd/libsss_proxy.so
465 %dir %{_libdir}/sssd/modules
466 %attr(755,root,root) %{_libdir}/sssd/modules/libsss_autofs.so
467 %if "%{_libdir}" != "%{_libexecdir}"
468 %dir %{_libexecdir}/sssd
469 %endif
470 %attr(755,root,root) %{_libexecdir}/sssd/gpo_child
471 %attr(755,root,root) %{_libexecdir}/sssd/krb5_child
472 %attr(755,root,root) %{_libexecdir}/sssd/ldap_child
473 %attr(755,root,root) %{_libexecdir}/sssd/proxy_child
474 %attr(755,root,root) %{_libexecdir}/sssd/selinux_child
475 %attr(755,root,root) %{_libexecdir}/sssd/sss_signal
476 %attr(755,root,root) %{_libexecdir}/sssd/sssd_autofs
477 %attr(755,root,root) %{_libexecdir}/sssd/sssd_be
478 %attr(755,root,root) %{_libexecdir}/sssd/sssd_ifp
479 %attr(755,root,root) %{_libexecdir}/sssd/sssd_nss
480 %attr(755,root,root) %{_libexecdir}/sssd/sssd_pam
481 %attr(755,root,root) %{_libexecdir}/sssd/sssd_ssh
482 %attr(755,root,root) %{_libexecdir}/sssd/sssd_sudo
483 %dir %{_datadir}/sssd
484 %{_datadir}/sssd/sssd.api.conf
485 %dir %{_datadir}/sssd/sssd.api.d
486 %{_datadir}/sssd/sssd.api.d/sssd-ad.conf
487 %{_datadir}/sssd/sssd.api.d/sssd-ipa.conf
488 %{_datadir}/sssd/sssd.api.d/sssd-krb5.conf
489 %{_datadir}/sssd/sssd.api.d/sssd-ldap.conf
490 %{_datadir}/sssd/sssd.api.d/sssd-local.conf
491 %{_datadir}/sssd/sssd.api.d/sssd-proxy.conf
492 %{_datadir}/sssd/sssd.api.d/sssd-simple.conf
493 %attr(755,root,root) /%{_lib}/libnfsidmap/sss.so
494 %attr(755,root,root) %{ldb_modulesdir}/memberof.so
495 %dir %{sssdstatedir}
496 %attr(700,root,root) %dir %{dbpath}
497 %dir %{pipepath}
498 %dir %{pubconfpath}
499 %attr(700,root,root) %dir %{pipepath}/private
500 %attr(750,root,root) %dir %{_var}/log/%{name}
501 %attr(700,root,root) %dir %{_sysconfdir}/sssd
502 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sssd/sssd.conf
503 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/sssd
504 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rwtab.d/sssd
505 %attr(754,root,root) /etc/rc.d/init.d/sssd
506 %{systemdunitdir}/sssd.service
507 /etc/dbus-1/system.d/org.freedesktop.sssd.infopipe.conf
508 %{_datadir}/dbus-1/system-services/org.freedesktop.sssd.infopipe.service
509 %{_mandir}/man1/sss_ssh_authorizedkeys.1*
510 %{_mandir}/man1/sss_ssh_knownhostsproxy.1*
511 %{_mandir}/man5/sss_rpcidmapd.5*
512 %{_mandir}/man5/sssd.conf.5*
513 %{_mandir}/man5/sssd-ad.5*
514 %{_mandir}/man5/sssd-ifp.5*
515 %{_mandir}/man5/sssd-ipa.5*
516 %{_mandir}/man5/sssd-krb5.5*
517 %{_mandir}/man5/sssd-ldap.5*
518 %{_mandir}/man5/sssd-simple.5*
519 %{_mandir}/man5/sssd-sudo.5*
520 %{_mandir}/man8/sss_cache.8*
521 %{_mandir}/man8/sssd.8*
522 %attr(755,root,root) %{py_sitedir}/pysss.so
523 %attr(755,root,root) %{py_sitedir}/pysss_murmur.so
524 %dir %{py_sitescriptdir}/SSSDConfig
525 %{py_sitescriptdir}/SSSDConfig/*.py[co]
526 %{py_sitescriptdir}/SSSDConfig-%{version}-py*.egg-info
527
528 %files client -f sssd_client.lang
529 %defattr(644,root,root,755)
530 %attr(755,root,root) /%{_lib}/libnss_sss.so.2
531 %attr(755,root,root) /%{_lib}/security/pam_sss.so
532 %attr(755,root,root) %{_libdir}/cifs-utils/cifs_idmap_sss.so
533 # FIXME: is it proper path for heimdal? where to package parent dirs?
534 #%attr(755,root,root) %{_libdir}/krb5/plugins/libkrb5/sssd_krb5_locator_plugin.so
535 %{_mandir}/man8/pam_sss.8*
536 %{_mandir}/man8/sssd_krb5_locator_plugin.8*
537
538 %files tools -f sssd_tools.lang
539 %defattr(644,root,root,755)
540 %attr(755,root,root) %{_sbindir}/sss_debuglevel
541 %attr(755,root,root) %{_sbindir}/sss_groupadd
542 %attr(755,root,root) %{_sbindir}/sss_groupdel
543 %attr(755,root,root) %{_sbindir}/sss_groupmod
544 %attr(755,root,root) %{_sbindir}/sss_groupshow
545 %attr(755,root,root) %{_sbindir}/sss_obfuscate
546 %attr(755,root,root) %{_sbindir}/sss_seed
547 %attr(755,root,root) %{_sbindir}/sss_useradd
548 %attr(755,root,root) %{_sbindir}/sss_userdel
549 %attr(755,root,root) %{_sbindir}/sss_usermod
550 %{_mandir}/man8/sss_debuglevel.8*
551 %{_mandir}/man8/sss_groupadd.8*
552 %{_mandir}/man8/sss_groupdel.8*
553 %{_mandir}/man8/sss_groupmod.8*
554 %{_mandir}/man8/sss_groupshow.8*
555 %{_mandir}/man8/sss_obfuscate.8*
556 %{_mandir}/man8/sss_seed.8*
557 %{_mandir}/man8/sss_useradd.8*
558 %{_mandir}/man8/sss_userdel.8*
559 %{_mandir}/man8/sss_usermod.8*
560
561 %files -n libipa_hbac
562 %defattr(644,root,root,755)
563 %attr(755,root,root) %{_libdir}/libipa_hbac.so.*.*.*
564 %attr(755,root,root) %ghost %{_libdir}/libipa_hbac.so.0
565
566 %files -n libipa_hbac-devel
567 %defattr(644,root,root,755)
568 %attr(755,root,root) %{_libdir}/libipa_hbac.so
569 %{_includedir}/ipa_hbac.h
570 %{_pkgconfigdir}/ipa_hbac.pc
571
572 %files -n python-libipa_hbac
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{py_sitedir}/pyhbac.so
575
576 %files -n libsss_idmap
577 %defattr(644,root,root,755)
578 %attr(755,root,root) %{_libdir}/libsss_idmap.so.*.*.*
579 %attr(755,root,root) %ghost %{_libdir}/libsss_idmap.so.0
580
581 %files -n libsss_idmap-devel
582 %defattr(644,root,root,755)
583 %attr(755,root,root) %{_libdir}/libsss_idmap.so
584 %{_includedir}/sss_idmap.h
585 %{_pkgconfigdir}/sss_idmap.pc
586
587 %files -n libsss_nss_idmap
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{_libdir}/libsss_nss_idmap.so.*.*.*
590 %attr(755,root,root) %ghost %{_libdir}/libsss_nss_idmap.so.0
591
592 %files -n libsss_nss_idmap-devel
593 %defattr(644,root,root,755)
594 %attr(755,root,root) %{_libdir}/libsss_nss_idmap.so
595 %{_includedir}/sss_nss_idmap.h
596 %{_pkgconfigdir}/sss_nss_idmap.pc
597
598 %files -n python-libsss_nss_idmap
599 %defattr(644,root,root,755)
600 %attr(755,root,root) %{py_sitedir}/pysss_nss_idmap.so
601
602 %files -n libsss_simpleifp
603 %defattr(644,root,root,755)
604 %attr(755,root,root) %{_libdir}/libsss_simpleifp.so.*.*.*
605 %attr(755,root,root) %ghost %{_libdir}/libsss_simpleifp.so.0
606
607 %files -n libsss_simpleifp-devel
608 %defattr(644,root,root,755)
609 %attr(755,root,root) %{_libdir}/libsss_simpleifp.so
610 %{_includedir}/sss_sifp.h
611 %{_includedir}/sss_sifp_dbus.h
612 %{_pkgconfigdir}/sss_simpleifp.pc
613
614 %files libwbclient
615 %defattr(644,root,root,755)
616 %attr(755,root,root) %{_libdir}/sssd/modules/libwbclient.so.*
617
618 %files libwbclient-devel
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{_libdir}/sssd/modules/libwbclient.so
621 %{_includedir}/wbclient_sssd.h
622 %{_pkgconfigdir}/wbclient_sssd.pc
This page took 0.065664 seconds and 3 git commands to generate.