]> git.pld-linux.org Git - packages/sssd.git/blob - sssd.spec
- fix build, why do eve even keep this outdated piece of fedora?
[packages/sssd.git] / sssd.spec
1 # TODO
2 # - fix stripping before rpm:
3 #   *** WARNING: no sources found for /usr/lib64/libipa_hbac.so.0.0.0 (stripped without sourcefile information?)
4 # - add info how sssd-heimdal.patch is updated, where is it's origin?
5 #
6 # Conditional build:
7 %bcond_with     tests   # check target
8 %bcond_without  python2 # CPython 2.x module
9 %bcond_without  python3 # CPython 3.x module
10 %bcond_with     krb5    # MIT Kerberos V instead of Heimdal (enables locator plugin, profile support and pac-responder)
11
12 %define         ldb_version 1.1.0
13 Summary:        System Security Services Daemon
14 Summary(pl.UTF-8):      System Security Services Daemon - demon usług bezpieczeństwa systemu
15 Name:           sssd
16 Version:        1.13.4
17 Release:        8
18 License:        GPL v3+
19 Group:          Applications/System
20 Source0:        https://fedorahosted.org/released/sssd/%{name}-%{version}.tar.gz
21 # Source0-md5:  d147e0a4f4719d993693c6a99370b350
22 Source1:        %{name}.init
23 Patch0:         %{name}-python.patch
24 Patch1:         %{name}-heimdal.patch
25 Patch2:         %{name}-systemd.patch
26 Patch3:         %{name}-link.patch
27 Patch4:         format.patch
28 Patch5:         array-size.patch
29 URL:            https://fedorahosted.org/sssd/
30 BuildRequires:  augeas-devel >= 1.0.0
31 BuildRequires:  autoconf >= 2.59
32 BuildRequires:  automake
33 # nsupdate utility
34 BuildRequires:  bind-utils
35 BuildRequires:  c-ares-devel
36 BuildRequires:  check-devel >= 0.9.5
37 BuildRequires:  cifs-utils-devel
38 %{?with_tests:BuildRequires:    cmocka-devel >= 1.0.0}
39 BuildRequires:  cyrus-sasl-devel >= 2
40 BuildRequires:  dbus-devel >= 1.0.0
41 BuildRequires:  docbook-dtd44-xml
42 BuildRequires:  docbook-style-xsl
43 BuildRequires:  doxygen
44 %{?with_tests:BuildRequires:    fakeroot}
45 BuildRequires:  gettext-tools >= 0.14.4
46 BuildRequires:  glib2-devel >= 2.0
47 %{!?with_krb5:BuildRequires:    heimdal-devel}
48 BuildRequires:  keyutils-devel
49 %{?with_krb5:BuildRequires:     krb5-devel >= 1.9}
50 BuildRequires:  ldb-devel >= %{ldb_version}
51 BuildRequires:  libcollection-devel >= 0.5.1
52 BuildRequires:  libdhash-devel >= 0.4.2
53 BuildRequires:  libini_config-devel >= 1.1.0
54 BuildRequires:  libltdl-devel
55 BuildRequires:  libnfsidmap-devel
56 BuildRequires:  libnl-devel >= 3.2
57 BuildRequires:  libselinux-devel
58 BuildRequires:  libsemanage-devel
59 BuildRequires:  libsmbclient-devel
60 BuildRequires:  libtool >= 2:2
61 BuildRequires:  libxml2-progs
62 BuildRequires:  libxslt-progs
63 BuildRequires:  m4
64 BuildRequires:  nspr-devel
65 BuildRequires:  nss-devel
66 %{?with_tests:BuildRequires:    nss_wrapper}
67 BuildRequires:  openldap-devel
68 BuildRequires:  pam-devel
69 BuildRequires:  pcre-devel >= 7
70 BuildRequires:  pkgconfig
71 BuildRequires:  po4a
72 BuildRequires:  popt-devel
73 %{?with_python2:BuildRequires:  python-devel >= 1:2.6}
74 %{?with_tests:BuildRequires:    python-pytest}
75 %{?with_python3:BuildRequires:  python3-devel >= 1:3.3}
76 BuildRequires:  rpm-pythonprov
77 BuildRequires:  rpmbuild(macros) >= 1.612
78 # pkgconfig(ndr_nbt), pkgconfig(ndr_krb5pac) if with krb5
79 BuildRequires:  samba-devel >= 4
80 BuildRequires:  systemd-devel >= 1:209
81 BuildRequires:  systemd-units
82 BuildRequires:  talloc-devel
83 BuildRequires:  tdb-devel >= 1.1.3
84 BuildRequires:  tevent-devel
85 %{?with_tests:BuildRequires:    uid_wrapper}
86 Requires(post): /sbin/ldconfig
87 Requires(post,preun):   /sbin/chkconfig
88 Requires:       %{name}-client = %{version}-%{release}
89 Requires:       cyrus-sasl-gssapi
90 Requires:       ldb >= %{ldb_version}
91 Requires:       libcollection >= 0.5.1
92 Requires:       libdhash >= 0.4.2
93 Requires:       libini_config >= 1.1.0
94 Requires:       libsss_idmap = %{version}-%{release}
95 Requires:       pcre >= 7
96 Requires:       rc-scripts >= 0.4.0.10
97 Requires:       tdb >= 1.1.3
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %define         sssdstatedir            %{_localstatedir}/lib/sss
101 %define         dbpath                  %{sssdstatedir}/db
102 %define         pipepath                %{sssdstatedir}/pipes
103 %define         pubconfpath             %{sssdstatedir}/pubconf
104
105 # Determine the location of the LDB modules directory
106 %define         ldb_modulesdir  %(pkg-config --variable=modulesdir ldb)
107
108 %description
109 Provides a set of daemons to manage access to remote directories and
110 authentication mechanisms. It provides an NSS and PAM interface toward
111 the system and a pluggable backend system to connect to multiple
112 different account sources. It is also the basis to provide client
113 auditing and policy services for projects like FreeIPA.
114
115 %description -l pl.UTF-8
116 Ten pakiet dostarcza zbiór demonów do zarządzania dostępem do zdalnych
117 katalogów i mechanizmów uwierzytelniania. Udostępnia interfejsy NSS i
118 PAM dla systemu oraz system backendu z wtyczkami w celu łączenia się z
119 wieloma różnymi źródłami kont. Jest także podstawą zapewniającą audyt
120 klientów oraz usługi polityk dla projektów takich jak FreeIPA.
121
122 %package client
123 Summary:        SSSD Client libraries for NSS and PAM
124 Summary(pl.UTF-8):      Biblioteki klienckie SSSD dla NSS i PAM
125 License:        LGPL v3+
126 Group:          Applications/System
127 Requires:       libsss_idmap = %{version}-%{release}
128 Requires:       libsss_nss_idmap = %{version}-%{release}
129
130 %description client
131 Provides the libraries needed by the PAM and NSS stacks to connect to
132 the SSSD service.
133
134 %description client -l pl.UTF-8
135 Ten pakiet dostarcza biblioteki wymagane przez stosy PAM i NSS w celu
136 łączenia się z usługą SSSD.
137
138 %package tools
139 Summary:        Userspace tools for use with the SSSD
140 Summary(pl.UTF-8):      Narzędzia przestrzeni użytkownika do używania z SSSD
141 License:        GPL v3+
142 Group:          Applications/System
143 Requires:       %{name} = %{version}-%{release}
144
145 %description tools
146 Provides userspace tools for manipulating users, groups, and nested
147 groups in SSSD when using id_provider = local in /etc/sssd/sssd.conf.
148
149 Also provides several other administrative tools:
150  - sss_debuglevel to change the debug level on the fly,
151  - sss_seed which pre-creates a user entry for use in kickstarts,
152  - sss_obfuscate for generating an obfuscated LDAP password.
153
154 %description tools -l pl.UTF-8
155 Ten pakiet dostarcza narzędzia przestrzeni poleceń do operowania na
156 użytkownikach, grupach oraz zagnieżdżonych grupach w SSSD w przypadku
157 używania id_provider = local w /etc/sssd/sssd.conf.
158
159 Pakiet zawiera także kilka innych narzędzi administracyjnych:
160  - sss_debuglevel do zmiany poziomu diagnostyki w locie,
161  - sss_seed tworzący wpis użytkownika do szybkiego rozruchu,
162  - sss_obfuscate do generowania utajnionego hasła LDAP.
163
164 %package -n python-sss
165 Summary:        Python 2 bindings for sssd
166 Summary(pl.UTF-8):      Wiązania Pythona 2 do sssd
167 License:        LGPL v3+
168 Group:          Libraries/Python
169 Requires:       %{name} = %{version}-%{release}
170
171 %description -n python-sss
172 Python 2 module for manipulating users, groups, and nested groups in
173 SSSD when using id_provider = local in /etc/sssd/sssd.conf.
174
175 This module also provides several other useful Python 2 bindings:
176  - function for retrieving list of groups user belongs to.
177  - class for obfuscation of passwords
178
179 %description -n python-sss -l pl.UTF-8
180 Moduł Pythona 2 do operowania na użytkownikach, grupach i
181 zagnieżdżonych grupach w SSSD w przypadku używania id_provider = local
182 w /etc/sssd/sssd.conf.
183
184 Ten moduł dostarcza także kilka innych przydatnych wiązań Pythona 2:
185  - funkcję do użyskiwania list grup, do których należy użytkownik,
186  - klasę do ukrywania haseł.
187
188 %package -n python-sss-murmur
189 Summary:        Python 2 bindings for murmur hash function
190 Summary(pl.UTF-8):      Wiązania Pythona 2 do funkcji mieszającej murmur
191 License:        LGPL v3+
192 Group:          Libraries/Python
193
194 %description -n python-sss-murmur
195 Python 2 module for calculating the murmur hash version 3.
196
197 %description -n python-sss-murmur -l pl.UTF-8
198 Moduł Pythona 2 do obliczania skrótu murmur w wersji 3.
199
200 %package -n python-sssdconfig
201 Summary:        SSSD and IPA configuration file manipulation classes and functions for Python 2
202 Summary(pl.UTF-8):      Klasy i funkcje Pythona 2 do operowania na plikach konfiguracyjnych SSSD oraz IPA
203 License:        GPL v3+
204 Group:          Libraries/Python
205 BuildArch:      noarch
206
207 %description -n python-sssdconfig
208 SSSD and IPA configuration file manipulation classes and functions for
209 Python 2.
210
211 %description -n python-sssdconfig -l pl.UTF-8
212 Klasy i funkcje Pythona 2 do operowania na plikach konfiguracyjnych
213 SSSD oraz IPA.
214
215 %package -n python3-sss
216 Summary:        Python 3 bindings for sssd
217 Summary(pl.UTF-8):      Wiązania Pythona 3 do sssd
218 License:        LGPL v3+
219 Group:          Libraries/Python
220 Requires:       %{name} = %{version}-%{release}
221
222 %description -n python3-sss
223 Python 3 module for manipulating users, groups, and nested groups in
224 SSSD when using id_provider = local in /etc/sssd/sssd.conf.
225
226 This module also provides several other useful Python 3 bindings:
227  - function for retrieving list of groups user belongs to.
228  - class for obfuscation of passwords
229
230 %description -n python3-sss -l pl.UTF-8
231 Moduł Pythona 3 do operowania na użytkownikach, grupach i
232 zagnieżdżonych grupach w SSSD w przypadku używania id_provider = local
233 w /etc/sssd/sssd.conf.
234
235 Ten moduł dostarcza także kilka innych przydatnych wiązań Pythona 3:
236  - funkcję do użyskiwania list grup, do których należy użytkownik,
237  - klasę do ukrywania haseł.
238
239 %package -n python3-sss-murmur
240 Summary:        Python 3 bindings for murmur hash function
241 Summary(pl.UTF-8):      Wiązania Pythona 3 do funkcji mieszającej murmur
242 License:        LGPL v3+
243 Group:          Libraries/Python
244
245 %description -n python3-sss-murmur
246 Python 3 module for calculating the murmur hash version 3.
247
248 %description -n python3-sss-murmur -l pl.UTF-8
249 Moduł Pythona 3 do obliczania skrótu murmur w wersji 3.
250
251 %package -n python3-sssdconfig
252 Summary:        SSSD and IPA configuration file manipulation classes and functions for Python 3
253 Summary(pl.UTF-8):      Klasy i funkcje Pythona 3 do operowania na plikach konfiguracyjnych SSSD oraz IPA
254 License:        GPL v3+
255 Group:          Libraries/Python
256 BuildArch:      noarch
257
258 %description -n python3-sssdconfig
259 SSSD and IPA configuration file manipulation classes and functions for
260 Python 3.
261
262 %description -n python3-sssdconfig -l pl.UTF-8
263 Klasy i funkcje Pythona 3 do operowania na plikach konfiguracyjnych
264 SSSD oraz IPA.
265
266 %package libwbclient
267 Summary:        The SSSD libwbclient implementation
268 Summary(pl.UTF-8):      Implementacja libwbclient oparta na SSSD
269 Group:          Libraries
270 License:        LGPL v3+
271 Requires:       libsss_nss_idmap = %{version}-%{release}
272
273 %description libwbclient
274 The SSSD implementation of Samba wbclient library.
275
276 %description libwbclient -l pl.UTF-8
277 Implementacja biblioteki Samba wbclient oparta na SSSD.
278
279 %package libwbclient-devel
280 Summary:        Development files of the SSSD libwbclient implementation
281 Summary(pl.UTF-8):      Pliki programistyczne implementacja libwbclient oparta na SSSD
282 Group:          Development/Libraries
283 License:        LGPL v3+
284 Requires:       %{name}-libwbclient = %{version}-%{release}
285
286 %description libwbclient-devel
287 Development files for the SSSD implementation of Samba wbclient
288 library.
289
290 %description libwbclient-devel -l pl.UTF-8
291 Pliki programistyczne implementacji biblioteki Samba wbclient opartej
292 na SSSD.
293
294 %package -n libipa_hbac
295 Summary:        FreeIPA HBAC Evaluator library
296 Summary(pl.UTF-8):      Biblioteka oceniająca FreeIPA HBAC
297 License:        LGPL v3+
298 Group:          Libraries
299
300 %description -n libipa_hbac
301 Utility library to validate FreeIPA HBAC rules for authorization
302 requests.
303
304 %description -n libipa_hbac
305 Biblioteka narzędziowa do sprawdzania poprawności reguł FreeIPA HBAC
306 dla żądań autoryzacji.
307
308 %package -n libipa_hbac-devel
309 Summary:        Development files for FreeIPA HBAC Evaluator library
310 Summary(pl.UTF-8):      Pliki programistyczne biblioteki oceniająca FreeIPA HBAC
311 License:        LGPL v3+
312 Group:          Development/Libraries
313 Requires:       libipa_hbac = %{version}-%{release}
314
315 %description -n libipa_hbac-devel
316 Development files for FreeIPA HBAC Evaluator library.
317
318 %description -n libipa_hbac-devel -l pl.UTF-8
319 Pliki programistyczne biblioteki oceniająca FreeIPA HBAC.
320
321 %package -n python-libipa_hbac
322 Summary:        Python 2 bindings for the FreeIPA HBAC Evaluator library
323 Summary(pl.UTF-8):      Wiązania Pythona 2 do biblioteki oceniającej FreeIPA HBAC
324 License:        LGPL v3+
325 Group:          Libraries/Python
326 Requires:       libipa_hbac = %{version}-%{release}
327 Obsoletes:      libipa_hbac-python
328
329 %description -n python-libipa_hbac
330 This package contains the bindings so that libipa_hbac can be used by
331 Python 2 applications.
332
333 %description -n python-libipa_hbac -l pl.UTF-8
334 Ten pakiet zawiera wiązania pozwalające na używanie libipa_hbac w
335 aplikacjach Pythona 2.
336
337 %package -n python3-libipa_hbac
338 Summary:        Python 3 bindings for the FreeIPA HBAC Evaluator library
339 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki oceniającej FreeIPA HBAC
340 License:        LGPL v3+
341 Group:          Libraries/Python
342 Requires:       libipa_hbac = %{version}-%{release}
343
344 %description -n python3-libipa_hbac
345 This package contains the bindings so that libipa_hbac can be used by
346 Python 3 applications.
347
348 %description -n python3-libipa_hbac -l pl.UTF-8
349 Ten pakiet zawiera wiązania pozwalające na używanie libipa_hbac w
350 aplikacjach Pythona 3.
351
352 %package -n libsss_idmap
353 Summary:        FreeIPA Idmap library
354 Summary(pl.UTF-8):      Biblioteka FreeIPA Idmap
355 Group:          Libraries
356 License:        LGPL v3+
357
358 %description -n libsss_idmap
359 Utility library to convert SIDs to Unix uids and gids.
360
361 %description -n libsss_idmap -l pl.UTF-8
362 Biblioteka narzędziowa konwertująca SID-y na uniksowe uidy i gidy.
363
364 %package -n libsss_idmap-devel
365 Summary:        Development files for FreeIPA Idmap library
366 Summary(pl.UTF-8):      Pliki programistyczne biblioteki FreeIPA Idmap
367 Group:          Development/Libraries
368 License:        LGPL v3+
369 Requires:       libsss_idmap = %{version}-%{release}
370
371 %description -n libsss_idmap-devel
372 Development files for FreeIPA Idmap library.
373
374 %description -n libsss_idmap-devel -l pl.UTF-8
375 Pliki programistyczne biblioteki FreeIPA Idmap.
376
377 %package -n libsss_nss_idmap
378 Summary:        Library for SID based lookups
379 Summary(pl.UTF-8):      Biblioteka do wyszukiwań w oparciu o SID
380 Group:          Libraries
381 License:        LGPL v3+
382
383 %description -n libsss_nss_idmap
384 Utility library for SID based lookups.
385
386 %description -n libsss_nss_idmap -l pl.UTF-8
387 Biblioteka do wyszukiwań w oparciu o SID.
388
389 %package -n libsss_nss_idmap-devel
390 Summary:        Development files for sss_nss_idmap library
391 Summary(pl.UTF-8):      Pliki programistyczne biblioteki sss_nss_idmap
392 Group:          Development/Libraries
393 License:        LGPL v3+
394 Requires:       libsss_nss_idmap = %{version}-%{release}
395
396 %description -n libsss_nss_idmap-devel
397 Development files for sss_nss_idmap library.
398
399 %description -n libsss_nss_idmap-devel -l pl.UTF-8
400 Pliki programistyczne biblioteki sss_nss_idmap.
401
402 %package -n python-libsss_nss_idmap
403 Summary:        Python 2 bindings for libsss_nss_idmap
404 Summary(pl.UTF-8):      Wiązania Pythona 2 do biblioteki libsss_nss_idmap
405 Group:          Libraries/Python
406 License:        LGPL v3+
407 Requires:       libsss_nss_idmap = %{version}-%{release}
408
409 %description -n python-libsss_nss_idmap
410 This package contains the bindings so that libsss_nss_idmap can be
411 used by Python 2 applications.
412
413 %description -n python-libsss_nss_idmap -l pl.UTF-8
414 Ten pakiet zawiera wiązania umożliwiające korzystanie z biblioteki
415 libsss_nss_idmap w aplikacjach Pythona 2.
416
417 %package -n python3-libsss_nss_idmap
418 Summary:        Python 3 bindings for libsss_nss_idmap
419 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki libsss_nss_idmap
420 Group:          Libraries/Python
421 License:        LGPL v3+
422 Requires:       libsss_nss_idmap = %{version}-%{release}
423
424 %description -n python3-libsss_nss_idmap
425 This package contains the bindings so that libsss_nss_idmap can be
426 used by Python 3 applications.
427
428 %description -n python3-libsss_nss_idmap -l pl.UTF-8
429 Ten pakiet zawiera wiązania umożliwiające korzystanie z biblioteki
430 libsss_nss_idmap w aplikacjach Pythona 3.
431
432 %package -n libsss_simpleifp
433 Summary:        A library that simplifies work with the InfoPipe responder
434 Summary(pl.UTF-8):      Biblioteka upraszczająca pracę z responderem InfoPipe
435 Group:          Libraries
436 Requires:       dbus-libs >= 1.0.0
437 Requires:       libdhash >= 0.4.2
438
439 %description -n libsss_simpleifp
440 A library that simplifies work with the InfoPipe responder.
441
442 %description -n libsss_simpleifp -l pl.UTF-8
443 Biblioteka upraszczająca pracę z responderem InfoPipe.
444
445 %package -n libsss_simpleifp-devel
446 Summary:        Header files for libsss_simpleifp library
447 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsss_simpleifp
448 Group:          Development/Libraries
449 Requires:       dbus-devel >= 1.0.0
450 Requires:       libdhash-devel >= 0.4.2
451 Requires:       libsss_simpleifp = %{version}-%{release}
452
453 %description -n libsss_simpleifp-devel
454 Header files for libsss_simpleifp library.
455
456 %description -n libsss_simpleifp-devel -l pl.UTF-8
457 Pliki nagłówkowe biblioteki libsss_simpleifp.
458
459 %prep
460 %setup -q
461 %patch0 -p1
462 %patch1 -p1
463 %patch2 -p1
464 %patch3 -p1
465 %patch4 -p1
466 %patch5 -p1
467
468 %build
469 %{__libtoolize}
470 %{__gettextize}
471 %{__aclocal} -I m4
472 %{__autoconf}
473 %{__automake}
474 %configure \
475         NSCD=/usr/sbin/nscd \
476         %{!?with_krb5:--disable-krb5-locator-plugin} \
477         --enable-nfsidmaplibdir=/%{_lib}/libnfsidmap \
478         --enable-nsslibdir=/%{_lib} \
479         %{!?with_krb5:--disable-pac-responder} \
480         --enable-pammoddir=/%{_lib}/security \
481         --disable-rpath \
482         --with-db-path=%{dbpath} \
483         --with-init-dir=/etc/rc.d/init.d \
484         --with-initscript=sysv,systemd \
485         --with-pipe-path=%{pipepath} \
486         --with-pubconf-path=%{pubconfpath} \
487         --with-python2-bindings%{!?with_python2:=no} \
488         --with-python3-bindings%{!?with_python3:=no} \
489         --with-systemdunitdir=%{systemdunitdir} \
490         --with-test-dir=/dev/shm
491
492 %{__make}
493
494 %if %{with tests}
495 export CK_TIMEOUT_MULTIPLIER=10
496 %{__make} check
497 unset CK_TIMEOUT_MULTIPLIER
498 %endif
499
500 %install
501 rm -rf $RPM_BUILD_ROOT
502
503 %{__make} -j1 install \
504         DESTDIR=$RPM_BUILD_ROOT \
505         python3dir=%{py3_sitescriptdir}
506
507 # Prepare language files
508 %find_lang %{name}
509
510 # Copy default sssd.conf file
511 install -d $RPM_BUILD_ROOT%{_sysconfdir}/sssd/sssd.api.d
512 cp -p src/examples/sssd-example.conf $RPM_BUILD_ROOT%{_sysconfdir}/sssd/sssd.conf
513
514 # Copy default logrotate file
515 install -d $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
516 cp -p src/examples/logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/sssd
517
518 # Make sure SSSD is able to run on read-only root
519 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rwtab.d
520 #cp -p src/examples/rwtab $RPM_BUILD_ROOT%{_sysconfdir}/rwtab.d/sssd
521
522 # Remove .la files created by libtool
523 %{__rm} \
524         $RPM_BUILD_ROOT/%{_lib}/libnss_sss.la \
525         $RPM_BUILD_ROOT/%{_lib}/libnfsidmap/sss.la \
526         $RPM_BUILD_ROOT/%{_lib}/security/pam_sss.la \
527         $RPM_BUILD_ROOT%{ldb_modulesdir}/memberof.la \
528         $RPM_BUILD_ROOT%{_libdir}/cifs-utils/*.la \
529         %{?with_krb5:$RPM_BUILD_ROOT%{_libdir}/krb5/plugins/libkrb5/sss*.la} \
530         $RPM_BUILD_ROOT%{_libdir}/sssd/libsss_*.la \
531         $RPM_BUILD_ROOT%{_libdir}/sssd/modules/lib*.la \
532         $RPM_BUILD_ROOT%{_libdir}/lib*.la
533 %if %{with python2}
534 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.la
535 %py_postclean
536 %endif
537 %if %{with python3}
538 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/*.la
539 %endif
540
541 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
542
543 echo '%%defattr(644,root,root,755)' > sssd_client.lang
544 echo '%%defattr(644,root,root,755)' > sssd_tools.lang
545 for man in $(find $RPM_BUILD_ROOT%{_mandir}/??/man? -type f | sed -e "s#$RPM_BUILD_ROOT%{_mandir}/##"); do
546         lang=$(echo $man | cut -c 1-2)
547         case $(basename $man) in
548         pam_sss.8|sssd_krb5_locator_plugin.8)
549                 echo "%lang(${lang}) %{_mandir}/${man}*" >> sssd_client.lang
550                 ;;
551         sss_debuglevel.8|sss_group*.8|sss_obfuscate.8|sss_seed.8|sss_user*.8)
552                 echo "%lang(${lang}) %{_mandir}/${man}*" >> sssd_tools.lang
553                 ;;
554         *)
555                 echo "%lang(${lang}) %{_mandir}/${man}*" >> sssd.lang
556                 ;;
557         esac
558 done
559
560 %clean
561 rm -rf $RPM_BUILD_ROOT
562
563 %post
564 /sbin/ldconfig
565 /sbin/chkconfig --add %{name}
566 %service %{name} restart
567
568 %preun
569 if [ "$1" = "0" ]; then
570         %service -q %{name} stop
571         /sbin/chkconfig --del %{name}
572 fi
573
574 %postun -p /sbin/ldconfig
575
576 %post   client -p /sbin/ldconfig
577 %postun client -p /sbin/ldconfig
578
579 %post   -n libipa_hbac -p /sbin/ldconfig
580 %postun -n libipa_hbac -p /sbin/ldconfig
581
582 %post   -n libsss_idmap -p /sbin/ldconfig
583 %postun -n libsss_idmap -p /sbin/ldconfig
584
585 %post   -n libsss_nss_idmap -p /sbin/ldconfig
586 %postun -n libsss_nss_idmap -p /sbin/ldconfig
587
588 %post   -n libsss_simpleifp -p /sbin/ldconfig
589 %postun -n libsss_simpleifp -p /sbin/ldconfig
590
591 %files -f sssd.lang
592 %defattr(644,root,root,755)
593 %attr(755,root,root) %{_bindir}/sss_ssh_authorizedkeys
594 %attr(755,root,root) %{_bindir}/sss_ssh_knownhostsproxy
595 %attr(755,root,root) %{_sbindir}/sss_cache
596 %attr(755,root,root) %{_sbindir}/sssd
597 # sudo plugin
598 %attr(755,root,root) %{_libdir}/libsss_sudo.so
599 %dir %{_libdir}/sssd
600 # internal shared libraries
601 %attr(755,root,root) %{_libdir}/sssd/libsss_cert.so
602 %attr(755,root,root) %{_libdir}/sssd/libsss_child.so
603 %attr(755,root,root) %{_libdir}/sssd/libsss_config.so
604 %attr(755,root,root) %{_libdir}/sssd/libsss_crypt.so
605 %attr(755,root,root) %{_libdir}/sssd/libsss_debug.so
606 %attr(755,root,root) %{_libdir}/sssd/libsss_krb5_common.so
607 %attr(755,root,root) %{_libdir}/sssd/libsss_ldap_common.so
608 %attr(755,root,root) %{_libdir}/sssd/libsss_semanage.so
609 %attr(755,root,root) %{_libdir}/sssd/libsss_util.so
610 # modules
611 %attr(755,root,root) %{_libdir}/sssd/libsss_simple.so
612 %attr(755,root,root) %{_libdir}/sssd/libsss_ad.so
613 %attr(755,root,root) %{_libdir}/sssd/libsss_ipa.so
614 %attr(755,root,root) %{_libdir}/sssd/libsss_krb5.so
615 %attr(755,root,root) %{_libdir}/sssd/libsss_ldap.so
616 %attr(755,root,root) %{_libdir}/sssd/libsss_proxy.so
617 %dir %{_libdir}/sssd/modules
618 %attr(755,root,root) %{_libdir}/sssd/modules/libsss_autofs.so
619 %if "%{_libdir}" != "%{_libexecdir}"
620 %dir %{_libexecdir}/sssd
621 %endif
622 %attr(755,root,root) %{_libexecdir}/sssd/gpo_child
623 %attr(755,root,root) %{_libexecdir}/sssd/krb5_child
624 %attr(755,root,root) %{_libexecdir}/sssd/ldap_child
625 %attr(755,root,root) %{_libexecdir}/sssd/p11_child
626 %attr(755,root,root) %{_libexecdir}/sssd/proxy_child
627 %attr(755,root,root) %{_libexecdir}/sssd/selinux_child
628 %attr(755,root,root) %{_libexecdir}/sssd/sss_signal
629 %attr(755,root,root) %{_libexecdir}/sssd/sssd_autofs
630 %attr(755,root,root) %{_libexecdir}/sssd/sssd_be
631 %attr(755,root,root) %{_libexecdir}/sssd/sssd_ifp
632 %attr(755,root,root) %{_libexecdir}/sssd/sssd_nss
633 %if %{with krb5}
634 %attr(755,root,root) %{_libexecdir}/sssd/sssd_pac
635 %endif
636 %attr(755,root,root) %{_libexecdir}/sssd/sssd_pam
637 %attr(755,root,root) %{_libexecdir}/sssd/sssd_ssh
638 %attr(755,root,root) %{_libexecdir}/sssd/sssd_sudo
639 %dir %{_datadir}/sssd
640 %{_datadir}/sssd/sssd.api.conf
641 %dir %{_datadir}/sssd/sssd.api.d
642 %{_datadir}/sssd/sssd.api.d/sssd-ad.conf
643 %{_datadir}/sssd/sssd.api.d/sssd-ipa.conf
644 %{_datadir}/sssd/sssd.api.d/sssd-krb5.conf
645 %{_datadir}/sssd/sssd.api.d/sssd-ldap.conf
646 %{_datadir}/sssd/sssd.api.d/sssd-local.conf
647 %{_datadir}/sssd/sssd.api.d/sssd-proxy.conf
648 %{_datadir}/sssd/sssd.api.d/sssd-simple.conf
649 %attr(755,root,root) /%{_lib}/libnfsidmap/sss.so
650 %attr(755,root,root) %{ldb_modulesdir}/memberof.so
651 %dir %{sssdstatedir}
652 %attr(700,root,root) %dir %{dbpath}
653 %dir %{pipepath}
654 %dir %{pubconfpath}
655 %attr(700,root,root) %dir %{pipepath}/private
656 %attr(750,root,root) %dir %{_var}/log/%{name}
657 %attr(700,root,root) %dir %{_sysconfdir}/sssd
658 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sssd/sssd.conf
659 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/sssd
660 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rwtab.d/sssd
661 %attr(754,root,root) /etc/rc.d/init.d/sssd
662 %{systemdunitdir}/sssd.service
663 /etc/dbus-1/system.d/org.freedesktop.sssd.infopipe.conf
664 %{_datadir}/dbus-1/system-services/org.freedesktop.sssd.infopipe.service
665 %{_mandir}/man1/sss_ssh_authorizedkeys.1*
666 %{_mandir}/man1/sss_ssh_knownhostsproxy.1*
667 %{_mandir}/man5/sss_rpcidmapd.5*
668 %{_mandir}/man5/sssd.conf.5*
669 %{_mandir}/man5/sssd-ad.5*
670 %{_mandir}/man5/sssd-ifp.5*
671 %{_mandir}/man5/sssd-ipa.5*
672 %{_mandir}/man5/sssd-krb5.5*
673 %{_mandir}/man5/sssd-ldap.5*
674 %{_mandir}/man5/sssd-simple.5*
675 %{_mandir}/man5/sssd-sudo.5*
676 %{_mandir}/man8/sss_cache.8*
677 %{_mandir}/man8/sssd.8*
678
679 %files client -f sssd_client.lang
680 %defattr(644,root,root,755)
681 %attr(755,root,root) /%{_lib}/libnss_sss.so.2
682 %attr(755,root,root) /%{_lib}/security/pam_sss.so
683 %attr(755,root,root) %{_libdir}/cifs-utils/cifs_idmap_sss.so
684 %if %{with krb5}
685 # XXX: verify locations
686 %attr(755,root,root) %{_libdir}/krb5/plugins/libkrb5/sssd_krb5_localauth_plugin.so
687 %attr(755,root,root) %{_libdir}/krb5/plugins/libkrb5/sssd_krb5_locator_plugin.so
688 %attr(755,root,root) %{_libdir}/krb5/plugins/libkrb5/sssd_pac_plugin.so
689 %endif
690 %{_mandir}/man8/pam_sss.8*
691 %{_mandir}/man8/sssd_krb5_locator_plugin.8*
692
693 %files tools -f sssd_tools.lang
694 %defattr(644,root,root,755)
695 %attr(755,root,root) %{_sbindir}/sss_debuglevel
696 %attr(755,root,root) %{_sbindir}/sss_groupadd
697 %attr(755,root,root) %{_sbindir}/sss_groupdel
698 %attr(755,root,root) %{_sbindir}/sss_groupmod
699 %attr(755,root,root) %{_sbindir}/sss_groupshow
700 %attr(755,root,root) %{_sbindir}/sss_obfuscate
701 %attr(755,root,root) %{_sbindir}/sss_override
702 %attr(755,root,root) %{_sbindir}/sss_seed
703 %attr(755,root,root) %{_sbindir}/sss_useradd
704 %attr(755,root,root) %{_sbindir}/sss_userdel
705 %attr(755,root,root) %{_sbindir}/sss_usermod
706 %{_mandir}/man8/sss_debuglevel.8*
707 %{_mandir}/man8/sss_groupadd.8*
708 %{_mandir}/man8/sss_groupdel.8*
709 %{_mandir}/man8/sss_groupmod.8*
710 %{_mandir}/man8/sss_groupshow.8*
711 %{_mandir}/man8/sss_obfuscate.8*
712 %{_mandir}/man8/sss_override.8*
713 %{_mandir}/man8/sss_seed.8*
714 %{_mandir}/man8/sss_useradd.8*
715 %{_mandir}/man8/sss_userdel.8*
716 %{_mandir}/man8/sss_usermod.8*
717
718 %if %{with python2}
719 %files -n python-sss
720 %defattr(644,root,root,755)
721 %attr(755,root,root) %{py_sitedir}/pysss.so
722
723 %files -n python-sss-murmur
724 %defattr(644,root,root,755)
725 %attr(755,root,root) %{py_sitedir}/pysss_murmur.so
726
727 %files -n python-sssdconfig
728 %defattr(644,root,root,755)
729 %dir %{py_sitescriptdir}/SSSDConfig
730 %{py_sitescriptdir}/SSSDConfig/*.py[co]
731 %{py_sitescriptdir}/SSSDConfig-%{version}-py*.egg-info
732 %endif
733
734 %if %{with python3}
735 %files -n python3-sss
736 %defattr(644,root,root,755)
737 %attr(755,root,root) %{py3_sitedir}/pysss.so
738
739 %files -n python3-sss-murmur
740 %defattr(644,root,root,755)
741 %attr(755,root,root) %{py3_sitedir}/pysss_murmur.so
742
743 %files -n python3-sssdconfig
744 %defattr(644,root,root,755)
745 %dir %{py3_sitescriptdir}/SSSDConfig
746 %{py3_sitescriptdir}/SSSDConfig/*.py
747 %{py3_sitescriptdir}/SSSDConfig/__pycache__
748 %{py3_sitescriptdir}/SSSDConfig-%{version}-py*.egg-info
749 %endif
750
751 %files libwbclient
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_libdir}/sssd/modules/libwbclient.so.*
754
755 %files libwbclient-devel
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_libdir}/sssd/modules/libwbclient.so
758 %{_includedir}/wbclient_sssd.h
759 %{_pkgconfigdir}/wbclient_sssd.pc
760
761 %files -n libipa_hbac
762 %defattr(644,root,root,755)
763 %attr(755,root,root) %{_libdir}/libipa_hbac.so.*.*.*
764 %attr(755,root,root) %ghost %{_libdir}/libipa_hbac.so.0
765
766 %files -n libipa_hbac-devel
767 %defattr(644,root,root,755)
768 %attr(755,root,root) %{_libdir}/libipa_hbac.so
769 %{_includedir}/ipa_hbac.h
770 %{_pkgconfigdir}/ipa_hbac.pc
771
772 %if %{with python2}
773 %files -n python-libipa_hbac
774 %defattr(644,root,root,755)
775 %attr(755,root,root) %{py_sitedir}/pyhbac.so
776 %endif
777
778 %if %{with python3}
779 %files -n python3-libipa_hbac
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{py3_sitedir}/pyhbac.so
782 %endif
783
784 %files -n libsss_idmap
785 %defattr(644,root,root,755)
786 %attr(755,root,root) %{_libdir}/libsss_idmap.so.*.*.*
787 %attr(755,root,root) %ghost %{_libdir}/libsss_idmap.so.0
788
789 %files -n libsss_idmap-devel
790 %defattr(644,root,root,755)
791 %attr(755,root,root) %{_libdir}/libsss_idmap.so
792 %{_includedir}/sss_idmap.h
793 %{_pkgconfigdir}/sss_idmap.pc
794
795 %files -n libsss_nss_idmap
796 %defattr(644,root,root,755)
797 %attr(755,root,root) %{_libdir}/libsss_nss_idmap.so.*.*.*
798 %attr(755,root,root) %ghost %{_libdir}/libsss_nss_idmap.so.0
799
800 %files -n libsss_nss_idmap-devel
801 %defattr(644,root,root,755)
802 %attr(755,root,root) %{_libdir}/libsss_nss_idmap.so
803 %{_includedir}/sss_nss_idmap.h
804 %{_pkgconfigdir}/sss_nss_idmap.pc
805
806 %if %{with python2}
807 %files -n python-libsss_nss_idmap
808 %defattr(644,root,root,755)
809 %attr(755,root,root) %{py_sitedir}/pysss_nss_idmap.so
810 %endif
811
812 %if %{with python3}
813 %files -n python3-libsss_nss_idmap
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{py3_sitedir}/pysss_nss_idmap.so
816 %endif
817
818 %files -n libsss_simpleifp
819 %defattr(644,root,root,755)
820 %attr(755,root,root) %{_libdir}/libsss_simpleifp.so.*.*.*
821 %attr(755,root,root) %ghost %{_libdir}/libsss_simpleifp.so.0
822
823 %files -n libsss_simpleifp-devel
824 %defattr(644,root,root,755)
825 %attr(755,root,root) %{_libdir}/libsss_simpleifp.so
826 %{_includedir}/sss_sifp.h
827 %{_includedir}/sss_sifp_dbus.h
828 %{_pkgconfigdir}/sss_simpleifp.pc
This page took 0.128936 seconds and 3 git commands to generate.